source: projects/specs/trunk/c/ctpl/ctpl-vl.spec @ 4851

Revision 4851, 5.0 KB checked in by kudoh, 13 years ago (diff)

%global ctpl_docdir %{_defaultdocdir}/ctpl-%{version}

Name: ctpl
Version: 0.3.3
Release: 1%{?_dist_release}
Summary: Template engine library written in C
Summary(ja): C で書かれたテンプレートエンジンライブラリ

Group: Development/Tools?
License: GPLv3+
URL:  http://ctpl.tuxfamily.org/
Source0:  http://download.tuxfamily.org/ctpl/releases/ctpl-%{version}.tar.gz
BuildRoot?: %{_tmppath}/%{name}-%{version}-root

BuildRequires?: glib2-devel >= 2.10
Requires: ctpl-libs = %{version}-%{release}

%description
CTPL is a template library written in C. It allows fast and easy parsing of
templates from many sources (including in-memory data and local and remote
streaming, thanks to GIO) and fine control over template parsing environment.

CTPL has following features:

  • It is a library, then it can be easily used from programs
  • Separated lexer and parser
  • It is written in portable C
  • Simple syntax
  • Fast and strict parsing
  • Possible in-memory parsing, allowing non-file data parsing and avoiding I/O-latency, through GIO's GMemoryInputStream and GMemoryOutputStream

%package libs
Summary: Template library written in C
Summary(ja): C で書かれたテンプレートライブラリ
Group: Development/Tools?

%description libs
This package contains the CTPL library.

%post libs -p /sbin/ldconfig
%postun libs -p /sbin/ldconfig

%package devel
Summary: Development headers of the template library written in C
Summary(ja): C で書かれたテンプレートライブラリの開発ヘッダ
Group: Development/Tools?
Requires: ctpl-libs = %{version}-%{release}

%description devel
This package contains the development headers of the CTPL library.

%package doc
Summary: Documentation for the CTPL library
Summary: CTPL ライブラリのドキュメント
Group: Development/Tools?
Requires: ctpl-libs = %{version}-%{release}
Requires: gtk-doc

BuildArch?: noarch

%description doc
This package contains the HTML documentation reference for the CTPL library.

%prep
%setup -q

# remove waf since this isn't needed for the build, we're building the
# package with autotools
rm -f waf
rm -f wscript

%build
%configure --docdir %{ctpl_docdir}
sed -i 's|hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
sed -i 's|
runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
make %{?_smp_mflags}

%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT

# Seems the --docdir flag is not working correctly, working around this here
# for now
install -d $RPM_BUILD_ROOT%{ctpl_docdir}
install -Dpm0644 AUTHORS COPYING NEWS HACKING TODO README THANKS $RPM_BUILD_ROOT%{ctpl_docdir}

rm -f $RPM_BUILD_ROOT%{_libdir}/libctpl.a
rm -f $RPM_BUILD_ROOT%{_libdir}/libctpl.la

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root,-)
%doc %{_mandir}/man1/%{name}.1.*
%{_bindir}/%{name}

%files libs
%defattr(-,root,root,-)
%dir %{ctpl_docdir}
%doc %{ctpl_docdir}/AUTHORS
%doc %{ctpl_docdir}/COPYING
%doc %{ctpl_docdir}/NEWS
%{_libdir}/lib%{name}.so.*

%files devel
%defattr(-,root,root,-)
%doc %{ctpl_docdir}/HACKING
%doc %{ctpl_docdir}/TODO
%{_libdir}/lib%{name}.so
%{_includedir}/%{name}/
%{_libdir}/pkgconfig/%{name}.pc

%files doc
%defattr(-,root,root,-)
%doc %{ctpl_docdir}/README
%doc %{ctpl_docdir}/THANKS
%doc %{_datadir}/gtk-doc/html/%{name}

%changelog

  • Sun Oct 02 2011 Toshiharu Kudoh <toshi.kd2@…> - 0.3.3-1
  • new upstream release
  • Sun Jan 23 2011 Toshiharu Kudoh <toshi.kd2@…> - 0.3.2-1
  • new upstream release
  • Tue Dec 22 2010 Toshiharu Kudoh <toshi.kd2@…> - 0.3.1-1
  • new upstream release
  • Mon Sep 27 2010 Shu KONNO <owa@…> 0.2.2-2
  • rebuilt with rpm-4.8.1 for pkg-config
  • Sun Aug 8 2010 Toshiharu Kudoh <toshi.kd2@…> - 0.2.2-1
  • initial build for VineSeed
  • Sat Jul 17 2010 Dominic Hopf <dmaphy@…> - 0.2.2-4
  • fix rpmlint binary-or-shlib-defines-rpath error
  • fix rpmlint library-without-ldconfig-* errors
  • make the -doc package noarch
  • remove the -bin subpackage, the binary files will now be installed with the main package, thus when typing 'yum install ctpl'
  • require gtk-doc for the -doc package
  • ctpl-libs now owns /usr/share/doc/ctpl-0.2.2
  • fix redundant file listings
  • require -libs package with fully qualified version for the binary package
  • Fri Jul 16 2010 Dominic Hopf <dmaphy@…> - 0.2.2-3
  • move the %%{_libdir}/lib%%{name}.so back to the -devel package where it belongs to
  • Fri Jul 16 2010 Dominic Hopf <dmaphy@…> - 0.2.2-2
  • rename subpackage lib to libs
  • add Requires on the libs package to -bin, -devel and -doc package
  • install %%{_libdir}/lib%%{name}.so with a -static package
  • install manpage only with the binary
  • install HACKING and TODO only with the -devel package
  • install README and THANKS only with the -doc package
  • fix the installation path for documentation files
  • Thu Jul 15 2010 Dominic Hopf <dmaphy@…> - 0.2.2-1
  • initial specfile
Line 
1%global ctpl_docdir %{_defaultdocdir}/ctpl-%{version}
2
3Name:           ctpl
4Version:        0.3.3
5Release:        1%{?_dist_release}
6Summary:        Template engine library written in C
7Summary(ja):    C で書かれたテンプレートエンジンライブラリ
8
9Group:          Development/Tools
10License:        GPLv3+
11URL:            http://ctpl.tuxfamily.org/
12Source0:        http://download.tuxfamily.org/ctpl/releases/ctpl-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires:  glib2-devel >= 2.10
16Requires:       ctpl-libs = %{version}-%{release}
17
18%description
19CTPL is a template library written in C. It allows fast and easy parsing of
20templates from many sources (including in-memory data and local and remote
21streaming, thanks to GIO) and fine control over template parsing environment.
22
23CTPL has following features:
24* It is a library, then it can be easily used from programs
25* Separated lexer and parser
26* It is written in portable C
27* Simple syntax
28* Fast and strict parsing
29* Possible in-memory parsing, allowing non-file data parsing and avoiding
30  I/O-latency, through GIO's GMemoryInputStream and GMemoryOutputStream
31
32
33%package libs
34Summary: Template library written in C
35Summary(ja):  C で書かれたテンプレートライブラリ
36Group:     Development/Tools
37
38%description libs
39This package contains the CTPL library.
40
41%post libs -p /sbin/ldconfig
42%postun libs -p /sbin/ldconfig
43
44
45%package devel
46Summary: Development headers of the template library written in C
47Summary(ja):  C で書かれたテンプレートライブラリの開発ヘッダ
48Group:     Development/Tools
49Requires:  ctpl-libs = %{version}-%{release}
50
51%description devel
52This package contains the development headers of the CTPL library.
53
54
55%package doc
56Summary:   Documentation for the CTPL library
57Summary:   CTPL ライブラリのドキュメント
58Group:     Development/Tools
59Requires:  ctpl-libs = %{version}-%{release}
60Requires:  gtk-doc
61
62BuildArch: noarch
63
64
65%description doc
66This package contains the HTML documentation reference for the CTPL library.
67
68
69%prep
70%setup -q
71
72# remove waf since this isn't needed for the build, we're building the
73# package with autotools
74rm -f waf
75rm -f wscript
76
77
78%build
79%configure --docdir %{ctpl_docdir}
80sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
81sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
82make %{?_smp_mflags}
83
84
85%install
86rm -rf $RPM_BUILD_ROOT
87make install DESTDIR=$RPM_BUILD_ROOT
88
89# Seems the --docdir flag is not working correctly, working around this here
90# for now
91install -d $RPM_BUILD_ROOT%{ctpl_docdir}
92install -Dpm0644 AUTHORS COPYING NEWS HACKING TODO README THANKS $RPM_BUILD_ROOT%{ctpl_docdir}
93
94rm -f $RPM_BUILD_ROOT%{_libdir}/libctpl.a
95rm -f $RPM_BUILD_ROOT%{_libdir}/libctpl.la
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100
101%files
102%defattr(-,root,root,-)
103%doc %{_mandir}/man1/%{name}.1.*
104%{_bindir}/%{name}
105
106
107%files libs
108%defattr(-,root,root,-)
109%dir %{ctpl_docdir}
110%doc %{ctpl_docdir}/AUTHORS
111%doc %{ctpl_docdir}/COPYING
112%doc %{ctpl_docdir}/NEWS
113%{_libdir}/lib%{name}.so.*
114
115
116%files devel
117%defattr(-,root,root,-)
118%doc %{ctpl_docdir}/HACKING
119%doc %{ctpl_docdir}/TODO
120%{_libdir}/lib%{name}.so
121%{_includedir}/%{name}/
122%{_libdir}/pkgconfig/%{name}.pc
123
124
125%files doc
126%defattr(-,root,root,-)
127%doc %{ctpl_docdir}/README
128%doc %{ctpl_docdir}/THANKS
129%doc %{_datadir}/gtk-doc/html/%{name}
130
131
132%changelog
133* Sun Oct 02 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.3-1
134- new upstream release
135
136* Sun Jan 23 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.2-1
137- new upstream release
138
139* Tue Dec 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.1-1
140- new upstream release
141
142* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.2-2
143- rebuilt with rpm-4.8.1 for pkg-config
144
145* Sun Aug 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.2-1
146- initial build for VineSeed
147
148* Sat Jul 17 2010 Dominic Hopf <dmaphy@fedoraproject.org> - 0.2.2-4
149- fix rpmlint binary-or-shlib-defines-rpath error
150- fix rpmlint library-without-ldconfig-* errors
151- make the -doc package noarch
152- remove the -bin subpackage, the binary files will now be installed with the
153  main package, thus when typing 'yum install ctpl'
154- require gtk-doc for the -doc package
155- ctpl-libs now owns /usr/share/doc/ctpl-0.2.2
156- fix redundant file listings
157- require -libs package with fully qualified version for the binary package
158
159* Fri Jul 16 2010 Dominic Hopf <dmaphy@fedoraproject.org> - 0.2.2-3
160- move the %%{_libdir}/lib%%{name}.so back to the -devel package where it
161  belongs to
162
163* Fri Jul 16 2010 Dominic Hopf <dmaphy@fedoraproject.org> - 0.2.2-2
164- rename subpackage lib to libs
165- add Requires on the libs package to -bin, -devel and -doc package
166- install %%{_libdir}/lib%%{name}.so with a -static package
167- install manpage only with the binary
168- install HACKING and TODO only with the -devel package
169- install README and THANKS only with the -doc package
170- fix the installation path for documentation files
171
172* Thu Jul 15 2010 Dominic Hopf <dmaphy@fedoraproject.org> - 0.2.2-1
173- initial specfile
Note: See TracBrowser for help on using the repository browser.