source: projects/specs/trunk/c/ctpl/ctpl-vl.spec @ 9049

Revision 9049, 5.2 KB checked in by inagaki, 9 years ago (diff)

2014-11-01 Ryoichi INAGAKI <ryo1@…>

  • libev, xmlsec1: updated
  • accountsservice, ctpl, poppler-data: changed Group


Line 
1%global ctpl_docdir %{_defaultdocdir}/ctpl-%{version}
2
3Name:           ctpl
4Version:        0.3.3
5Release:        3%{?_dist_release}
6Summary:        Template engine library written in C
7Summary(ja):    C で書かれたテンプレートエンジンライブラリ
8
9Group:          Development/Tools
10License:        GPLv3+
11URL:            http://ctpl.tuxfamily.org/
12Source0:        http://download.tuxfamily.org/ctpl/releases/ctpl-%{version}.tar.gz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  glib2-devel >= 2.10
16Requires:       ctpl-libs = %{version}-%{release}
17
18%description
19CTPL is a template library written in C. It allows fast and easy parsing of
20templates from many sources (including in-memory data and local and remote
21streaming, thanks to GIO) and fine control over template parsing environment.
22
23CTPL has following features:
24* It is a library, then it can be easily used from programs
25* Separated lexer and parser
26* It is written in portable C
27* Simple syntax
28* Fast and strict parsing
29* Possible in-memory parsing, allowing non-file data parsing and avoiding
30  I/O-latency, through GIO's GMemoryInputStream and GMemoryOutputStream
31
32
33%package libs
34Summary: Template library written in C
35Summary(ja): C で書かれたテンプレートライブラリ
36Group: System Environment/Libraries
37
38%description libs
39This package contains the CTPL library.
40
41%post libs -p /sbin/ldconfig
42%postun libs -p /sbin/ldconfig
43
44
45%package devel
46Summary: Development headers of the template library written in C
47Summary(ja): C で書かれたテンプレートライブラリの開発ヘッダ
48Group:  Development/Libraries
49Requires: ctpl-libs = %{version}-%{release}
50
51%description devel
52This package contains the development headers of the CTPL library.
53
54
55%package doc
56Summary:   Documentation for the CTPL library
57Summary:   CTPL ライブラリのドキュメント
58Group:     Documentation
59BuildArch: noarch
60Requires:  ctpl-libs = %{version}-%{release}
61Requires:  gtk-doc
62
63%description doc
64This package contains the HTML documentation reference for the CTPL library.
65
66
67%prep
68%setup -q
69
70# remove waf since this isn't needed for the build, we're building the
71# package with autotools
72rm -f waf
73rm -f wscript
74
75
76%build
77%configure --docdir %{ctpl_docdir}
78sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
79sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
80make %{?_smp_mflags}
81
82
83%install
84rm -rf $RPM_BUILD_ROOT
85make install DESTDIR=$RPM_BUILD_ROOT
86
87# Seems the --docdir flag is not working correctly, working around this here
88# for now
89install -d $RPM_BUILD_ROOT%{ctpl_docdir}
90install -Dpm0644 AUTHORS COPYING NEWS HACKING TODO README THANKS $RPM_BUILD_ROOT%{ctpl_docdir}
91
92rm -f $RPM_BUILD_ROOT%{_libdir}/libctpl.a
93rm -f $RPM_BUILD_ROOT%{_libdir}/libctpl.la
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98
99%files
100%defattr(-,root,root,-)
101%doc %{_mandir}/man1/%{name}.1.*
102%{_bindir}/%{name}
103
104
105%files libs
106%defattr(-,root,root,-)
107%dir %{ctpl_docdir}
108%doc %{ctpl_docdir}/AUTHORS
109%doc %{ctpl_docdir}/COPYING
110%doc %{ctpl_docdir}/NEWS
111%{_libdir}/lib%{name}.so.*
112
113
114%files devel
115%defattr(-,root,root,-)
116%doc %{ctpl_docdir}/HACKING
117%doc %{ctpl_docdir}/TODO
118%{_libdir}/lib%{name}.so
119%{_includedir}/%{name}/
120%{_libdir}/pkgconfig/%{name}.pc
121
122
123%files doc
124%defattr(-,root,root,-)
125%doc %{ctpl_docdir}/README
126%doc %{ctpl_docdir}/THANKS
127%doc %{_datadir}/gtk-doc/html/%{name}
128
129
130%changelog
131* Sat Nov  2 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.3.3-3
132- moved libs to System Environment/Libraries Group
133- moved devel to Development/Libraries Group
134- moved doc to Documentation Group
135
136* Sat May 24 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.3-2
137- rebuild with new toolchain
138
139* Sun Oct 02 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.3-1
140- new upstream release
141
142* Sun Jan 23 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.2-1
143- new upstream release
144
145* Wed Dec 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.1-1
146- new upstream release
147
148* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.2-2
149- rebuilt with rpm-4.8.1 for pkg-config
150
151* Sun Aug 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.2-1
152- initial build for VineSeed
153
154* Sat Jul 17 2010 Dominic Hopf <dmaphy@fedoraproject.org> - 0.2.2-4
155- fix rpmlint binary-or-shlib-defines-rpath error
156- fix rpmlint library-without-ldconfig-* errors
157- make the -doc package noarch
158- remove the -bin subpackage, the binary files will now be installed with the
159  main package, thus when typing 'yum install ctpl'
160- require gtk-doc for the -doc package
161- ctpl-libs now owns /usr/share/doc/ctpl-0.2.2
162- fix redundant file listings
163- require -libs package with fully qualified version for the binary package
164
165* Fri Jul 16 2010 Dominic Hopf <dmaphy@fedoraproject.org> - 0.2.2-3
166- move the %%{_libdir}/lib%%{name}.so back to the -devel package where it
167  belongs to
168
169* Fri Jul 16 2010 Dominic Hopf <dmaphy@fedoraproject.org> - 0.2.2-2
170- rename subpackage lib to libs
171- add Requires on the libs package to -bin, -devel and -doc package
172- install %%{_libdir}/lib%%{name}.so with a -static package
173- install manpage only with the binary
174- install HACKING and TODO only with the -devel package
175- install README and THANKS only with the -doc package
176- fix the installation path for documentation files
177
178* Thu Jul 15 2010 Dominic Hopf <dmaphy@fedoraproject.org> - 0.2.2-1
179- initial specfile
Note: See TracBrowser for help on using the repository browser.