source: projects/specs/trunk/c/cryptsetup/cryptsetup-vl.spec @ 12361

Revision 12361, 13.1 KB checked in by tomop, 4 years ago (diff)

updated 8 packages

cryptsetup-2.3.1-1

gdisk-1.0.5-1

kernel-4.14.174-1

lvm2-2.03.09-1

libblockdev-2.23-1

libmicrohttpd-0.9.70-1

udisks-1.0.5-1

udisks2-2.8.4-1

Line 
1%define _root_sbindir /sbin
2%define upstream_version %{version}
3
4Summary:        A utility for setting up encrypted disks
5Summary(ja):    暗号化ファイルシステム設定用ユーティリティ
6Name:           cryptsetup
7Group:          Applications/System
8
9Version:        2.3.1
10Release:        1%{?_dist_release}
11
12License:        GPLv2 and LGPLv2+
13URL:            https://gitlab.com/cryptsetup/cryptsetup
14%global         shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
15Source0:        https://www.kernel.org/pub/linux/utils/cryptsetup/v%{shortver}/cryptsetup-%{upstream_version}.tar.xz
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires:  popt-devel
19BuildRequires:  device-mapper-devel
20BuildRequires:  json-c-devel
21BuildRequires:  libblkid-devel
22BuildRequires:  libgcrypt-devel
23BuildRequires:  libgpg-error-devel
24BuildRequires:  libuuid-devel
25BuildRequires:  openssl-devel
26Provides:       cryptsetup-luks = %{version}-%{release}
27Obsoletes:      cryptsetup-luks < 1.4.0
28Requires:       cryptsetup-libs = %{version}-%{release}
29Obsoletes:      %{name}-python < 2.0.0
30
31%description
32The cryptsetup package contains a utility for setting up
33disk encryption using dm-crypt kernel module.
34
35%description -l ja
36cryptsetup パッケージには、dm-crypt カーネルモジュールを使って
37ディスクの暗号化を設定するユーティリティが収録されています。
38
39
40%package devel
41Summary: Headers and libraries for using encrypted file systems
42Summary(ja): 暗号化ファイルシステムを使うためのヘッダとライブラリ
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: libgcrypt-devel > 1.1.42
46Requires: device-mapper-devel
47Requires: libuuid-devel
48Requires: pkgconfig
49Provides: cryptsetup-luks-devel = %{version}-%{release}
50Obsoletes: cryptsetup-luks-devel < 1.4.0
51
52%description devel
53The cryptsetup-devel package contains libraries and header files
54used for writing code that makes use of disk encryption.
55
56%description devel -l ja
57cryptsetup-devel パッケージには、ディスクの暗号化を使うコードを
58書くのに使われるライブラリとヘッダファイルが収録されています。
59
60
61%package libs
62Summary: Cryptsetup shared library
63Summary(ja): Cryptsetup 共有ライブラリ
64Group: System Environment/Libraries
65Provides: cryptsetup-luks-libs = %{version}-%{release}
66Obsoletes: cryptsetup-luks-libs < 1.4.0
67
68%description libs
69This package contains the cryptsetup shared library, libcryptsetup.
70
71%description libs -l ja
72このパッケージには、cryptsetup の共有ライブラリ、libcryptsetup が
73収録されています。
74
75
76%prep
77%setup -q -n cryptsetup-%{upstream_version}
78
79
80%build
81export PYTHON=%{__python3}
82
83%configure \
84        --sbindir=%{_root_sbindir} \
85        --libdir=/%{_lib} \
86        --disable-selinux
87# remove rpath
88sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
89sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
90make %{?_smp_mflags}
91
92
93%install
94rm -rf %{buildroot}
95make install DESTDIR=%{buildroot}
96rm -rf  %{buildroot}/%{_lib}/*.la %{buildroot}/%{_lib}/cryptsetup
97
98# move libcryptsetup.so to %%{_libdir}
99pushd %{buildroot}/%{_lib}
100rm libcryptsetup.so
101mkdir -p %{buildroot}/%{_libdir}
102ln -s ../../%{_lib}/$(ls libcryptsetup.so.??.?.?) %{buildroot}/%{_libdir}/libcryptsetup.so
103mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}
104popd
105%find_lang cryptsetup
106
107
108%post -n cryptsetup-libs -p /sbin/ldconfig
109
110
111%postun -n cryptsetup-libs -p /sbin/ldconfig
112
113
114%files -f cryptsetup.lang
115%doc COPYING ChangeLog AUTHORS TODO FAQ
116%{_mandir}/man8/*.8.gz
117%{_root_sbindir}/*
118
119
120%files devel
121%doc docs/examples/*
122%{_includedir}/libcryptsetup.h
123%{_libdir}/libcryptsetup.so
124%{_libdir}/pkgconfig/libcryptsetup.pc
125
126
127%files libs
128%doc COPYING
129/%{_lib}/libcryptsetup.so.*
130
131
132%clean
133rm -rf %{buildroot}
134
135
136%changelog
137* Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.1-1
138- new upstream release.
139
140* Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.5-1
141- updated to 1.7.5.
142
143* Sat Dec  6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.4.1-4
144- rebuilt with libgcrypt 1.6.0
145
146* Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.1-3
147- updated to 1.4.1; spec revamp; Japanese summary & description
148
149  - Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.5-8vl5
150  - applied new versioning policy
151 
152  - Sun Dec  9 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.5-7vl1
153  - initial build for VineSeed
154
155* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.1-2
156- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
157
158* Wed Nov 09 2011 Milan Broz <mbroz@redhat.com> - 1.4.1-1
159- Update to cryptsetup 1.4.1.
160- Add Python cryptsetup bindings.
161- Obsolete separate python-cryptsetup package.
162
163* Wed Oct 26 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-1
164- Update to cryptsetup 1.4.0.
165
166* Mon Oct 10 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-0.1
167- Update to cryptsetup 1.4.0-rc1.
168- Rename package back from cryptsetup-luks to cryptsetup.
169
170* Wed Jun 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-2
171- Fix return code for status command when device doesn't exist.
172
173* Tue May 24 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-1
174- Update to cryptsetup 1.3.1.
175
176* Tue Apr 05 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-1
177- Update to cryptsetup 1.3.0.
178
179* Tue Mar 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.2
180- Update to cryptsetup 1.3.0-rc2
181
182* Mon Mar 14 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.1
183- Update to cryptsetup 1.3.0-rc1
184
185* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
186- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
187
188* Mon Dec 20 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-1
189- Update to cryptsetup 1.2.0
190
191* Thu Nov 25 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.2
192- Fix crypt_activate_by_keyfile() to work with PLAIN devices.
193
194* Tue Nov 16 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.1
195- Add FAQ to documentation.
196- Update to cryptsetup 1.2.0-rc1
197
198* Sat Jul 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.3-1
199- Update to cryptsetup 1.1.3
200
201* Mon Jun 07 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-2
202- Fix alignment ioctl use.
203- Fix API activation calls to handle NULL device name.
204
205* Sun May 30 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-1
206- Update to cryptsetup 1.1.2
207- Fix luksOpen handling of new line char on stdin.
208
209* Sun May 23 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-1
210- Update to cryptsetup 1.1.1
211- Fix luksClose for stacked LUKS/LVM devices.
212
213* Mon May 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.2
214- Update to cryptsetup 1.1.1-rc2.
215
216* Sat May 01 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.1
217- Update to cryptsetup 1.1.1-rc1.
218
219* Sun Jan 17 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-1
220- Update to cryptsetup 1.1.0.
221
222* Fri Jan 15 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-0.6
223- Fix gcrypt initialisation.
224- Fix backward compatibility for hash algorithm (uppercase).
225
226* Wed Dec 30 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.5
227- Update to cryptsetup 1.1.0-rc4
228
229* Mon Nov 16 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.4
230- Update to cryptsetup 1.1.0-rc3
231
232* Thu Oct 01 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.3
233- Update to cryptsetup 1.1.0-rc2
234- Fix libcryptsetup to properly export only versioned symbols.
235
236* Tue Sep 29 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.2
237- Update to cryptsetup 1.1.0-rc1
238- Add luksHeaderBackup and luksHeaderRestore commands.
239
240* Fri Sep 11 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.1
241- Update to new upstream testing version with new API interface.
242- Add luksSuspend and luksResume commands.
243- Introduce pkgconfig.
244
245* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-2
246- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
247
248* Wed Jul 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-1
249- Update to upstream final release.
250- Split libs subpackage.
251- Remove rpath setting from cryptsetup binary.
252
253* Wed Jul 15 2009 Till Maas <opensource@till.name> - 1.0.7-0.2
254- update BR because of libuuid splitout from e2fsprogs
255
256* Mon Jun 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-0.1
257- Update to new upstream 1.0.7-rc1.
258
259- Wipe old fs headers to not confuse blkid (#468062)
260* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-7
261- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
262
263* Thu Oct 30 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-6
264- Wipe old fs headers to not confuse blkid (#468062)
265
266* Tue Sep 23 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-5
267- Change new project home page.
268- Print more descriptive messages for initialization errors.
269- Refresh patches to versions commited upstream.
270
271* Sat Sep 06 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-4
272- Fix close of zero decriptor.
273- Fix udevsettle delays - use temporary crypt device remapping.
274
275* Wed May 28 2008 Till Maas <opensource till name> - 1.0.6-3
276- remove a duplicate sentence from the manpage (RH #448705)
277- add patch metadata about upstream status
278
279* Tue Apr 15 2008 Bill Nottinghm <notting@redhat.com> - 1.0.6-2
280- Add the device to the luksOpen prompt (#433406)
281- Use iconv, not recode (#442574)
282
283* Thu Mar 13 2008 Till Maas <opensource till name> - 1.0.6-1
284- Update to latest version
285- remove patches that have been merged upstream
286
287* Mon Mar 03 2008 Till Maas <opensource till name> - 1.0.6-0.1.pre2
288- Update to new version with several bugfixes
289- remove patches that have been merged upstream
290- add patch from cryptsetup newsgroup
291- fix typo / missing luksRemoveKey in manpage (patch)
292
293* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.5-9
294- Autorebuild for GCC 4.3
295
296* Sat Jan 19 2008 Peter Jones <pjones@redhat.com> - 1.0.5-8
297- Rebuild for broken deps.
298
299* Thu Aug 30 2007 Till Maas <opensource till name> - 1.0.5-7
300- update URL
301- update license tag
302- recode ChangeLog from latin1 to uf8
303- add smp_mflags to make
304
305* Fri Aug 24 2007 Till Maas <opensource till name> - 1.0.5-6
306- cleanup BuildRequires:
307- removed versions, packages in Fedora are new enough
308- changed popt to popt-devel
309
310* Thu Aug 23 2007 Till Maas <opensource till name> - 1.0.5-5
311- fix devel subpackage requires
312- remove empty NEWS README
313- remove uneeded INSTALL
314- remove uneeded ldconfig requires
315- add readonly detection patch
316
317* Wed Aug 08 2007 Till Maas <opensource till name> - 1.0.5-4
318- disable patch2, libsepol is now detected by configure
319- move libcryptsetup.so to %%{_libdir} instead of /%%{_lib}
320
321* Fri Jul 27 2007 Till Maas <opensource till name> - 1.0.5-3
322- Use /%%{_lib} instead of /lib to use /lib64 on 64bit archs
323
324* Thu Jul 26 2007 Till Maas <opensource till name> - 1.0.5-2
325- Use /lib as libdir (#243228)
326- sync header and library (#215349)
327- do not use %%makeinstall (recommended by PackageGuidelines)
328- select sbindir with %%configure instead with make
329- add TODO
330
331* Wed Jun 13 2007 Jeremy Katz <katzj@redhat.com> - 1.0.5-1
332- update to 1.0.5
333
334* Mon Jun 04 2007 Peter Jones <pjones@redhat.com> - 1.0.3-5
335- Don't build static any more.
336
337* Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 1.0.3-4
338- Add build dependency on new device-mapper-devel package.
339- Add preun and post ldconfig requirements.
340- Update BuildRoot.
341
342* Wed Nov  1 2006 Peter Jones <pjones@redhat.com> - 1.0.3-3
343- Require newer libselinux (#213414)
344
345* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.3-2.1
346- rebuild
347
348* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 1.0.3-2
349- put shared libs in the right subpackages
350
351* Fri Apr  7 2006 Bill Nottingham <notting@redhat.com> 1.0.3-1
352- update to final 1.0.3
353
354* Mon Feb 27 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc2
355- update to 1.0.3rc2, fixes bug with HAL & encrypted devices (#182658)
356
357* Wed Feb 22 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc1
358- update to 1.0.3rc1, reverts changes to default encryption type
359
360* Tue Feb 21 2006 Bill Nottingham <notting@redhat.com> 1.0.2-1
361- update to 1.0.2, fix incompatiblity with old cryptsetup (#176726)
362
363* Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-5
364- BuildRequires: libselinux-devel
365
366* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2.1
367- bump again for double-long bug on ppc(64)
368
369* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2
370- rebuilt for new gcc4.1 snapshot and glibc changes
371
372* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
373- rebuilt
374
375* Mon Dec  5 2005 Bill Nottingham <notting@redhat.com> 1.0.1-4
376- rebuild against new libdevmapper
377
378* Thu Oct 13 2005 Florian La Roche <laroche@redhat.com>
379- add -lsepol to rebuild on current fc5
380
381* Mon Aug 22 2005 Karel Zak <kzak@redhat.com> 1.0.1-2
382- fix cryptsetup help for isLuks action
383
384* Fri Jul  1 2005 Bill Nottingham <notting@redhat.com> 1.0.1-1
385- update to 1.0.1 - fixes incompatiblity with previous cryptsetup for
386  piped passwords
387
388* Thu Jun 16 2005 Bill Nottingham <notting@redhat.com> 1.0-2
389- add patch for 32/64 bit compatibility (#160445, <redhat@paukstadt.de>)
390
391* Tue Mar 29 2005 Bill Nottingham <notting@redhat.com> 1.0-1
392- update to 1.0
393
394* Thu Mar 10 2005 Bill Nottingham <notting@redhat.com> 0.993-1
395- switch to cryptsetup-luks, for LUKS support
396
397* Tue Oct 12 2004 Bill Nottingham <notting@redhat.com> 0.1-4
398- oops, make that *everything* static (#129926)
399
400* Tue Aug 31 2004 Bill Nottingham <notting@redhat.com> 0.1-3
401- link some things static, move to /sbin (#129926)
402
403* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
404- rebuilt
405
406* Fri Apr 16 2004 Bill Nottingham <notting@redhat.com> 0.1-1
407- initial packaging
Note: See TracBrowser for help on using the repository browser.