source: projects/specs/trunk/c/cryptsetup/cryptsetup-vl.spec @ 12401

Revision 12401, 13.2 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

cryptsetup-2.3.2-1

device-mapper-multipath-0.8.2-2

gimp-2.10.18-1

json-c-0.14-1

libmypaint-1.6.1-1

strongswan-5.8.4-1

upstart-1.12.1-7

Line 
1%define _root_sbindir /sbin
2%define upstream_version %{version}
3
4Summary:        A utility for setting up encrypted disks
5Summary(ja):    暗号化ファイルシステム設定用ユーティリティ
6Name:           cryptsetup
7Group:          Applications/System
8
9Version:        2.3.2
10Release:        1%{?_dist_release}
11
12License:        GPLv2 and LGPLv2+
13URL:            https://gitlab.com/cryptsetup/cryptsetup
14%global         shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
15Source0:        https://www.kernel.org/pub/linux/utils/cryptsetup/v%{shortver}/cryptsetup-%{upstream_version}.tar.xz
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires:  popt-devel
19BuildRequires:  device-mapper-devel
20BuildRequires:  json-c-devel
21BuildRequires:  libblkid-devel
22BuildRequires:  libgcrypt-devel
23BuildRequires:  libgpg-error-devel
24BuildRequires:  libuuid-devel
25BuildRequires:  openssl-devel
26Provides:       cryptsetup-luks = %{version}-%{release}
27Obsoletes:      cryptsetup-luks < 1.4.0
28Requires:       cryptsetup-libs = %{version}-%{release}
29Obsoletes:      %{name}-python < 2.0.0
30
31%description
32The cryptsetup package contains a utility for setting up
33disk encryption using dm-crypt kernel module.
34
35%description -l ja
36cryptsetup パッケージには、dm-crypt カーネルモジュールを使って
37ディスクの暗号化を設定するユーティリティが収録されています。
38
39
40%package devel
41Summary: Headers and libraries for using encrypted file systems
42Summary(ja): 暗号化ファイルシステムを使うためのヘッダとライブラリ
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: libgcrypt-devel > 1.1.42
46Requires: device-mapper-devel
47Requires: libuuid-devel
48Requires: pkgconfig
49Provides: cryptsetup-luks-devel = %{version}-%{release}
50Obsoletes: cryptsetup-luks-devel < 1.4.0
51
52%description devel
53The cryptsetup-devel package contains libraries and header files
54used for writing code that makes use of disk encryption.
55
56%description devel -l ja
57cryptsetup-devel パッケージには、ディスクの暗号化を使うコードを
58書くのに使われるライブラリとヘッダファイルが収録されています。
59
60
61%package libs
62Summary: Cryptsetup shared library
63Summary(ja): Cryptsetup 共有ライブラリ
64Group: System Environment/Libraries
65Provides: cryptsetup-luks-libs = %{version}-%{release}
66Obsoletes: cryptsetup-luks-libs < 1.4.0
67
68%description libs
69This package contains the cryptsetup shared library, libcryptsetup.
70
71%description libs -l ja
72このパッケージには、cryptsetup の共有ライブラリ、libcryptsetup が
73収録されています。
74
75
76%prep
77%setup -q -n cryptsetup-%{upstream_version}
78
79
80%build
81export PYTHON=%{__python3}
82
83%configure \
84        --sbindir=%{_root_sbindir} \
85        --libdir=/%{_lib} \
86        --disable-selinux
87# remove rpath
88sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
89sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
90make %{?_smp_mflags}
91
92
93%install
94rm -rf %{buildroot}
95make install DESTDIR=%{buildroot}
96rm -rf  %{buildroot}/%{_lib}/*.la %{buildroot}/%{_lib}/cryptsetup
97
98# move libcryptsetup.so to %%{_libdir}
99pushd %{buildroot}/%{_lib}
100rm libcryptsetup.so
101mkdir -p %{buildroot}/%{_libdir}
102ln -s ../../%{_lib}/$(ls libcryptsetup.so.??.?.?) %{buildroot}/%{_libdir}/libcryptsetup.so
103mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}
104popd
105%find_lang cryptsetup
106
107
108%clean
109rm -rf %{buildroot}
110
111
112%post -n cryptsetup-libs -p /sbin/ldconfig
113
114%postun -n cryptsetup-libs -p /sbin/ldconfig
115
116
117%files -f cryptsetup.lang
118%license COPYING
119%doc ChangeLog AUTHORS TODO FAQ
120%{_mandir}/man8/*.8.gz
121%{_root_sbindir}/*
122
123%files devel
124%doc docs/examples/*
125%{_includedir}/libcryptsetup.h
126%{_libdir}/libcryptsetup.so
127%{_libdir}/pkgconfig/libcryptsetup.pc
128
129%files libs
130%license COPYING
131/%{_lib}/libcryptsetup.so.*
132
133
134%changelog
135* Sat May 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.2-1
136- new upstream release.
137
138* Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.1-1
139- new upstream release.
140
141* Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.5-1
142- updated to 1.7.5.
143
144* Sat Dec  6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.4.1-4
145- rebuilt with libgcrypt 1.6.0
146
147* Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.1-3
148- updated to 1.4.1; spec revamp; Japanese summary & description
149
150  - Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.5-8vl5
151  - applied new versioning policy
152 
153  - Sun Dec  9 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.5-7vl1
154  - initial build for VineSeed
155
156* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.1-2
157- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
158
159* Wed Nov 09 2011 Milan Broz <mbroz@redhat.com> - 1.4.1-1
160- Update to cryptsetup 1.4.1.
161- Add Python cryptsetup bindings.
162- Obsolete separate python-cryptsetup package.
163
164* Wed Oct 26 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-1
165- Update to cryptsetup 1.4.0.
166
167* Mon Oct 10 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-0.1
168- Update to cryptsetup 1.4.0-rc1.
169- Rename package back from cryptsetup-luks to cryptsetup.
170
171* Wed Jun 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-2
172- Fix return code for status command when device doesn't exist.
173
174* Tue May 24 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-1
175- Update to cryptsetup 1.3.1.
176
177* Tue Apr 05 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-1
178- Update to cryptsetup 1.3.0.
179
180* Tue Mar 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.2
181- Update to cryptsetup 1.3.0-rc2
182
183* Mon Mar 14 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.1
184- Update to cryptsetup 1.3.0-rc1
185
186* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
187- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
188
189* Mon Dec 20 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-1
190- Update to cryptsetup 1.2.0
191
192* Thu Nov 25 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.2
193- Fix crypt_activate_by_keyfile() to work with PLAIN devices.
194
195* Tue Nov 16 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.1
196- Add FAQ to documentation.
197- Update to cryptsetup 1.2.0-rc1
198
199* Sat Jul 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.3-1
200- Update to cryptsetup 1.1.3
201
202* Mon Jun 07 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-2
203- Fix alignment ioctl use.
204- Fix API activation calls to handle NULL device name.
205
206* Sun May 30 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-1
207- Update to cryptsetup 1.1.2
208- Fix luksOpen handling of new line char on stdin.
209
210* Sun May 23 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-1
211- Update to cryptsetup 1.1.1
212- Fix luksClose for stacked LUKS/LVM devices.
213
214* Mon May 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.2
215- Update to cryptsetup 1.1.1-rc2.
216
217* Sat May 01 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.1
218- Update to cryptsetup 1.1.1-rc1.
219
220* Sun Jan 17 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-1
221- Update to cryptsetup 1.1.0.
222
223* Fri Jan 15 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-0.6
224- Fix gcrypt initialisation.
225- Fix backward compatibility for hash algorithm (uppercase).
226
227* Wed Dec 30 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.5
228- Update to cryptsetup 1.1.0-rc4
229
230* Mon Nov 16 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.4
231- Update to cryptsetup 1.1.0-rc3
232
233* Thu Oct 01 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.3
234- Update to cryptsetup 1.1.0-rc2
235- Fix libcryptsetup to properly export only versioned symbols.
236
237* Tue Sep 29 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.2
238- Update to cryptsetup 1.1.0-rc1
239- Add luksHeaderBackup and luksHeaderRestore commands.
240
241* Fri Sep 11 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.1
242- Update to new upstream testing version with new API interface.
243- Add luksSuspend and luksResume commands.
244- Introduce pkgconfig.
245
246* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-2
247- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
248
249* Wed Jul 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-1
250- Update to upstream final release.
251- Split libs subpackage.
252- Remove rpath setting from cryptsetup binary.
253
254* Wed Jul 15 2009 Till Maas <opensource@till.name> - 1.0.7-0.2
255- update BR because of libuuid splitout from e2fsprogs
256
257* Mon Jun 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-0.1
258- Update to new upstream 1.0.7-rc1.
259
260- Wipe old fs headers to not confuse blkid (#468062)
261* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-7
262- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
263
264* Thu Oct 30 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-6
265- Wipe old fs headers to not confuse blkid (#468062)
266
267* Tue Sep 23 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-5
268- Change new project home page.
269- Print more descriptive messages for initialization errors.
270- Refresh patches to versions commited upstream.
271
272* Sat Sep 06 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-4
273- Fix close of zero decriptor.
274- Fix udevsettle delays - use temporary crypt device remapping.
275
276* Wed May 28 2008 Till Maas <opensource till name> - 1.0.6-3
277- remove a duplicate sentence from the manpage (RH #448705)
278- add patch metadata about upstream status
279
280* Tue Apr 15 2008 Bill Nottinghm <notting@redhat.com> - 1.0.6-2
281- Add the device to the luksOpen prompt (#433406)
282- Use iconv, not recode (#442574)
283
284* Thu Mar 13 2008 Till Maas <opensource till name> - 1.0.6-1
285- Update to latest version
286- remove patches that have been merged upstream
287
288* Mon Mar 03 2008 Till Maas <opensource till name> - 1.0.6-0.1.pre2
289- Update to new version with several bugfixes
290- remove patches that have been merged upstream
291- add patch from cryptsetup newsgroup
292- fix typo / missing luksRemoveKey in manpage (patch)
293
294* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.5-9
295- Autorebuild for GCC 4.3
296
297* Sat Jan 19 2008 Peter Jones <pjones@redhat.com> - 1.0.5-8
298- Rebuild for broken deps.
299
300* Thu Aug 30 2007 Till Maas <opensource till name> - 1.0.5-7
301- update URL
302- update license tag
303- recode ChangeLog from latin1 to uf8
304- add smp_mflags to make
305
306* Fri Aug 24 2007 Till Maas <opensource till name> - 1.0.5-6
307- cleanup BuildRequires:
308- removed versions, packages in Fedora are new enough
309- changed popt to popt-devel
310
311* Thu Aug 23 2007 Till Maas <opensource till name> - 1.0.5-5
312- fix devel subpackage requires
313- remove empty NEWS README
314- remove uneeded INSTALL
315- remove uneeded ldconfig requires
316- add readonly detection patch
317
318* Wed Aug 08 2007 Till Maas <opensource till name> - 1.0.5-4
319- disable patch2, libsepol is now detected by configure
320- move libcryptsetup.so to %%{_libdir} instead of /%%{_lib}
321
322* Fri Jul 27 2007 Till Maas <opensource till name> - 1.0.5-3
323- Use /%%{_lib} instead of /lib to use /lib64 on 64bit archs
324
325* Thu Jul 26 2007 Till Maas <opensource till name> - 1.0.5-2
326- Use /lib as libdir (#243228)
327- sync header and library (#215349)
328- do not use %%makeinstall (recommended by PackageGuidelines)
329- select sbindir with %%configure instead with make
330- add TODO
331
332* Wed Jun 13 2007 Jeremy Katz <katzj@redhat.com> - 1.0.5-1
333- update to 1.0.5
334
335* Mon Jun 04 2007 Peter Jones <pjones@redhat.com> - 1.0.3-5
336- Don't build static any more.
337
338* Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 1.0.3-4
339- Add build dependency on new device-mapper-devel package.
340- Add preun and post ldconfig requirements.
341- Update BuildRoot.
342
343* Wed Nov  1 2006 Peter Jones <pjones@redhat.com> - 1.0.3-3
344- Require newer libselinux (#213414)
345
346* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.3-2.1
347- rebuild
348
349* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 1.0.3-2
350- put shared libs in the right subpackages
351
352* Fri Apr  7 2006 Bill Nottingham <notting@redhat.com> 1.0.3-1
353- update to final 1.0.3
354
355* Mon Feb 27 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc2
356- update to 1.0.3rc2, fixes bug with HAL & encrypted devices (#182658)
357
358* Wed Feb 22 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc1
359- update to 1.0.3rc1, reverts changes to default encryption type
360
361* Tue Feb 21 2006 Bill Nottingham <notting@redhat.com> 1.0.2-1
362- update to 1.0.2, fix incompatiblity with old cryptsetup (#176726)
363
364* Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-5
365- BuildRequires: libselinux-devel
366
367* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2.1
368- bump again for double-long bug on ppc(64)
369
370* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2
371- rebuilt for new gcc4.1 snapshot and glibc changes
372
373* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
374- rebuilt
375
376* Mon Dec  5 2005 Bill Nottingham <notting@redhat.com> 1.0.1-4
377- rebuild against new libdevmapper
378
379* Thu Oct 13 2005 Florian La Roche <laroche@redhat.com>
380- add -lsepol to rebuild on current fc5
381
382* Mon Aug 22 2005 Karel Zak <kzak@redhat.com> 1.0.1-2
383- fix cryptsetup help for isLuks action
384
385* Fri Jul  1 2005 Bill Nottingham <notting@redhat.com> 1.0.1-1
386- update to 1.0.1 - fixes incompatiblity with previous cryptsetup for
387  piped passwords
388
389* Thu Jun 16 2005 Bill Nottingham <notting@redhat.com> 1.0-2
390- add patch for 32/64 bit compatibility (#160445, <redhat@paukstadt.de>)
391
392* Tue Mar 29 2005 Bill Nottingham <notting@redhat.com> 1.0-1
393- update to 1.0
394
395* Thu Mar 10 2005 Bill Nottingham <notting@redhat.com> 0.993-1
396- switch to cryptsetup-luks, for LUKS support
397
398* Tue Oct 12 2004 Bill Nottingham <notting@redhat.com> 0.1-4
399- oops, make that *everything* static (#129926)
400
401* Tue Aug 31 2004 Bill Nottingham <notting@redhat.com> 0.1-3
402- link some things static, move to /sbin (#129926)
403
404* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
405- rebuilt
406
407* Fri Apr 16 2004 Bill Nottingham <notting@redhat.com> 0.1-1
408- initial packaging
Note: See TracBrowser for help on using the repository browser.