source: projects/specs/trunk/c/cryptsetup/cryptsetup-vl.spec @ 11176

Revision 11176, 13.8 KB checked in by tomop, 7 years ago (diff)

cryptsetup-1.7.5-1

Line 
1%define _root_sbindir /sbin
2%define upstream_version %{version}
3
4Summary:        A utility for setting up encrypted disks
5Summary(ja):    暗号化ファイルシステム設定用ユーティリティ
6Name:           cryptsetup
7Version:        1.7.5
8Release:        1%{?_dist_release}
9License:        GPLv2 and LGPLv2+
10Group:          Applications/System
11URL:            http://cryptsetup.googlecode.com/
12
13Source0:        https://www.kernel.org/pub/linux/utils/cryptsetup/v1.7/cryptsetup-%{upstream_version}.tar.xz
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  libgcrypt-devel
17BuildRequires:  popt-devel
18BuildRequires:  device-mapper-devel
19BuildRequires:  libgpg-error-devel
20BuildRequires:  libuuid-devel
21BuildRequires:  python-devel
22Provides:       cryptsetup-luks = %{version}-%{release}
23Obsoletes:      cryptsetup-luks < 1.4.0
24Requires:       cryptsetup-libs = %{version}-%{release}
25
26%description
27The cryptsetup package contains a utility for setting up
28disk encryption using dm-crypt kernel module.
29
30%description -l ja
31cryptsetup パッケージには、dm-crypt カーネルモジュールを使って
32ディスクの暗号化を設定するユーティリティが収録されています。
33
34
35%package devel
36Summary: Headers and libraries for using encrypted file systems
37Summary(ja): 暗号化ファイルシステムを使うためのヘッダとライブラリ
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40Requires: libgcrypt-devel > 1.1.42
41Requires: device-mapper-devel
42Requires: libuuid-devel
43Requires: pkgconfig
44Provides: cryptsetup-luks-devel = %{version}-%{release}
45Obsoletes: cryptsetup-luks-devel < 1.4.0
46
47%description devel
48The cryptsetup-devel package contains libraries and header files
49used for writing code that makes use of disk encryption.
50
51%description devel -l ja
52cryptsetup-devel パッケージには、ディスクの暗号化を使うコードを
53書くのに使われるライブラリとヘッダファイルが収録されています。
54
55
56%package libs
57Summary: Cryptsetup shared library
58Summary(ja): Cryptsetup 共有ライブラリ
59Group: System Environment/Libraries
60Provides: cryptsetup-luks-libs = %{version}-%{release}
61Obsoletes: cryptsetup-luks-libs < 1.4.0
62
63%description libs
64This package contains the cryptsetup shared library, libcryptsetup.
65
66%description libs -l ja
67このパッケージには、cryptsetup の共有ライブラリ、libcryptsetup が
68収録されています。
69
70
71%package python
72Summary: Python bindings for libcryptsetup
73Summary(ja): libcryptsetup の Python バインディング
74Group: System Environment/Libraries
75Requires: %{name}-libs = %{version}-%{release}
76Provides: python-cryptsetup = %{version}-%{release}
77Obsoletes: python-cryptsetup < 1.4.0
78
79%description python
80This package provides Python bindings for libcryptsetup, a library
81for setting up disk encryption using dm-crypt kernel module.
82
83%description python -l ja
84このパッケージには、dm-crypt カーネルモジュールを使って
85ディスクの暗号化を設定するライブラリ libcryptsetup の
86Python バインディングが収録されています。
87
88
89%prep
90%setup -q -n cryptsetup-%{upstream_version}
91chmod -x python/pycryptsetup-test.py
92
93
94%build
95%configure  --sbindir=%{_root_sbindir} --libdir=/%{_lib} \
96        --enable-python \
97        --disable-selinux
98# remove rpath
99sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
100sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
101make %{?_smp_mflags}
102
103
104%install
105rm -rf %{buildroot}
106make install DESTDIR=%{buildroot}
107rm -rf  %{buildroot}/%{_lib}/*.la %{buildroot}/%{_lib}/cryptsetup
108
109# move libcryptsetup.so to %%{_libdir}
110pushd %{buildroot}/%{_lib}
111rm libcryptsetup.so
112mkdir -p %{buildroot}/%{_libdir}
113ln -s ../../%{_lib}/$(ls libcryptsetup.so.?.?.?) %{buildroot}/%{_libdir}/libcryptsetup.so
114mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}
115popd
116%find_lang cryptsetup
117
118
119%post -n cryptsetup-libs -p /sbin/ldconfig
120
121
122%postun -n cryptsetup-libs -p /sbin/ldconfig
123
124
125%files -f cryptsetup.lang
126%doc COPYING ChangeLog AUTHORS TODO FAQ
127%{_mandir}/man8/cryptsetup.8.gz
128%{_mandir}/man8/veritysetup.8.gz
129%{_root_sbindir}/cryptsetup
130%{_root_sbindir}/veritysetup
131
132
133%files devel
134%doc docs/examples/*
135%{_includedir}/libcryptsetup.h
136%{_libdir}/libcryptsetup.so
137%{_libdir}/pkgconfig/libcryptsetup.pc
138
139
140%files libs
141%doc COPYING
142/%{_lib}/libcryptsetup.so.*
143
144
145%files python
146%doc COPYING.LGPL python/pycryptsetup-test.py
147%exclude %{python_sitearch}/pycryptsetup.la
148%{python_sitearch}/pycryptsetup.so
149
150
151%clean
152rm -rf %{buildroot}
153
154
155%changelog
156* Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.5-1
157- updated to 1.7.5.
158
159* Sat Dec  6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.4.1-4
160- rebuilt with libgcrypt 1.6.0
161
162* Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.1-3
163- updated to 1.4.1; spec revamp; Japanese summary & description
164
165  - Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.5-8vl5
166  - applied new versioning policy
167 
168  - Sun Dec  9 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.5-7vl1
169  - initial build for VineSeed
170
171* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.1-2
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
173
174* Wed Nov 09 2011 Milan Broz <mbroz@redhat.com> - 1.4.1-1
175- Update to cryptsetup 1.4.1.
176- Add Python cryptsetup bindings.
177- Obsolete separate python-cryptsetup package.
178
179* Wed Oct 26 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-1
180- Update to cryptsetup 1.4.0.
181
182* Mon Oct 10 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-0.1
183- Update to cryptsetup 1.4.0-rc1.
184- Rename package back from cryptsetup-luks to cryptsetup.
185
186* Wed Jun 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-2
187- Fix return code for status command when device doesn't exist.
188
189* Tue May 24 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-1
190- Update to cryptsetup 1.3.1.
191
192* Tue Apr 05 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-1
193- Update to cryptsetup 1.3.0.
194
195* Tue Mar 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.2
196- Update to cryptsetup 1.3.0-rc2
197
198* Mon Mar 14 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.1
199- Update to cryptsetup 1.3.0-rc1
200
201* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
202- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
203
204* Mon Dec 20 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-1
205- Update to cryptsetup 1.2.0
206
207* Thu Nov 25 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.2
208- Fix crypt_activate_by_keyfile() to work with PLAIN devices.
209
210* Tue Nov 16 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.1
211- Add FAQ to documentation.
212- Update to cryptsetup 1.2.0-rc1
213
214* Sat Jul 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.3-1
215- Update to cryptsetup 1.1.3
216
217* Mon Jun 07 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-2
218- Fix alignment ioctl use.
219- Fix API activation calls to handle NULL device name.
220
221* Sun May 30 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-1
222- Update to cryptsetup 1.1.2
223- Fix luksOpen handling of new line char on stdin.
224
225* Sun May 23 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-1
226- Update to cryptsetup 1.1.1
227- Fix luksClose for stacked LUKS/LVM devices.
228
229* Mon May 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.2
230- Update to cryptsetup 1.1.1-rc2.
231
232* Sat May 01 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.1
233- Update to cryptsetup 1.1.1-rc1.
234
235* Sun Jan 17 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-1
236- Update to cryptsetup 1.1.0.
237
238* Fri Jan 15 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-0.6
239- Fix gcrypt initialisation.
240- Fix backward compatibility for hash algorithm (uppercase).
241
242* Wed Dec 30 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.5
243- Update to cryptsetup 1.1.0-rc4
244
245* Mon Nov 16 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.4
246- Update to cryptsetup 1.1.0-rc3
247
248* Thu Oct 01 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.3
249- Update to cryptsetup 1.1.0-rc2
250- Fix libcryptsetup to properly export only versioned symbols.
251
252* Tue Sep 29 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.2
253- Update to cryptsetup 1.1.0-rc1
254- Add luksHeaderBackup and luksHeaderRestore commands.
255
256* Fri Sep 11 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.1
257- Update to new upstream testing version with new API interface.
258- Add luksSuspend and luksResume commands.
259- Introduce pkgconfig.
260
261* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-2
262- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
263
264* Wed Jul 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-1
265- Update to upstream final release.
266- Split libs subpackage.
267- Remove rpath setting from cryptsetup binary.
268
269* Wed Jul 15 2009 Till Maas <opensource@till.name> - 1.0.7-0.2
270- update BR because of libuuid splitout from e2fsprogs
271
272* Mon Jun 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-0.1
273- Update to new upstream 1.0.7-rc1.
274
275- Wipe old fs headers to not confuse blkid (#468062)
276* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-7
277- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
278
279* Thu Oct 30 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-6
280- Wipe old fs headers to not confuse blkid (#468062)
281
282* Tue Sep 23 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-5
283- Change new project home page.
284- Print more descriptive messages for initialization errors.
285- Refresh patches to versions commited upstream.
286
287* Sat Sep 06 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-4
288- Fix close of zero decriptor.
289- Fix udevsettle delays - use temporary crypt device remapping.
290
291* Wed May 28 2008 Till Maas <opensource till name> - 1.0.6-3
292- remove a duplicate sentence from the manpage (RH #448705)
293- add patch metadata about upstream status
294
295* Tue Apr 15 2008 Bill Nottinghm <notting@redhat.com> - 1.0.6-2
296- Add the device to the luksOpen prompt (#433406)
297- Use iconv, not recode (#442574)
298
299* Thu Mar 13 2008 Till Maas <opensource till name> - 1.0.6-1
300- Update to latest version
301- remove patches that have been merged upstream
302
303* Mon Mar 03 2008 Till Maas <opensource till name> - 1.0.6-0.1.pre2
304- Update to new version with several bugfixes
305- remove patches that have been merged upstream
306- add patch from cryptsetup newsgroup
307- fix typo / missing luksRemoveKey in manpage (patch)
308
309* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.5-9
310- Autorebuild for GCC 4.3
311
312* Sat Jan 19 2008 Peter Jones <pjones@redhat.com> - 1.0.5-8
313- Rebuild for broken deps.
314
315* Thu Aug 30 2007 Till Maas <opensource till name> - 1.0.5-7
316- update URL
317- update license tag
318- recode ChangeLog from latin1 to uf8
319- add smp_mflags to make
320
321* Fri Aug 24 2007 Till Maas <opensource till name> - 1.0.5-6
322- cleanup BuildRequires:
323- removed versions, packages in Fedora are new enough
324- changed popt to popt-devel
325
326* Thu Aug 23 2007 Till Maas <opensource till name> - 1.0.5-5
327- fix devel subpackage requires
328- remove empty NEWS README
329- remove uneeded INSTALL
330- remove uneeded ldconfig requires
331- add readonly detection patch
332
333* Wed Aug 08 2007 Till Maas <opensource till name> - 1.0.5-4
334- disable patch2, libsepol is now detected by configure
335- move libcryptsetup.so to %%{_libdir} instead of /%%{_lib}
336
337* Fri Jul 27 2007 Till Maas <opensource till name> - 1.0.5-3
338- Use /%%{_lib} instead of /lib to use /lib64 on 64bit archs
339
340* Thu Jul 26 2007 Till Maas <opensource till name> - 1.0.5-2
341- Use /lib as libdir (#243228)
342- sync header and library (#215349)
343- do not use %%makeinstall (recommended by PackageGuidelines)
344- select sbindir with %%configure instead with make
345- add TODO
346
347* Wed Jun 13 2007 Jeremy Katz <katzj@redhat.com> - 1.0.5-1
348- update to 1.0.5
349
350* Mon Jun 04 2007 Peter Jones <pjones@redhat.com> - 1.0.3-5
351- Don't build static any more.
352
353* Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 1.0.3-4
354- Add build dependency on new device-mapper-devel package.
355- Add preun and post ldconfig requirements.
356- Update BuildRoot.
357
358* Wed Nov  1 2006 Peter Jones <pjones@redhat.com> - 1.0.3-3
359- Require newer libselinux (#213414)
360
361* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.3-2.1
362- rebuild
363
364* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 1.0.3-2
365- put shared libs in the right subpackages
366
367* Fri Apr  7 2006 Bill Nottingham <notting@redhat.com> 1.0.3-1
368- update to final 1.0.3
369
370* Mon Feb 27 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc2
371- update to 1.0.3rc2, fixes bug with HAL & encrypted devices (#182658)
372
373* Wed Feb 22 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc1
374- update to 1.0.3rc1, reverts changes to default encryption type
375
376* Tue Feb 21 2006 Bill Nottingham <notting@redhat.com> 1.0.2-1
377- update to 1.0.2, fix incompatiblity with old cryptsetup (#176726)
378
379* Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-5
380- BuildRequires: libselinux-devel
381
382* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2.1
383- bump again for double-long bug on ppc(64)
384
385* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2
386- rebuilt for new gcc4.1 snapshot and glibc changes
387
388* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
389- rebuilt
390
391* Mon Dec  5 2005 Bill Nottingham <notting@redhat.com> 1.0.1-4
392- rebuild against new libdevmapper
393
394* Thu Oct 13 2005 Florian La Roche <laroche@redhat.com>
395- add -lsepol to rebuild on current fc5
396
397* Mon Aug 22 2005 Karel Zak <kzak@redhat.com> 1.0.1-2
398- fix cryptsetup help for isLuks action
399
400* Fri Jul  1 2005 Bill Nottingham <notting@redhat.com> 1.0.1-1
401- update to 1.0.1 - fixes incompatiblity with previous cryptsetup for
402  piped passwords
403
404* Thu Jun 16 2005 Bill Nottingham <notting@redhat.com> 1.0-2
405- add patch for 32/64 bit compatibility (#160445, <redhat@paukstadt.de>)
406
407* Tue Mar 29 2005 Bill Nottingham <notting@redhat.com> 1.0-1
408- update to 1.0
409
410* Thu Mar 10 2005 Bill Nottingham <notting@redhat.com> 0.993-1
411- switch to cryptsetup-luks, for LUKS support
412
413* Tue Oct 12 2004 Bill Nottingham <notting@redhat.com> 0.1-4
414- oops, make that *everything* static (#129926)
415
416* Tue Aug 31 2004 Bill Nottingham <notting@redhat.com> 0.1-3
417- link some things static, move to /sbin (#129926)
418
419* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
420- rebuilt
421
422* Fri Apr 16 2004 Bill Nottingham <notting@redhat.com> 0.1-1
423- initial packaging
Note: See TracBrowser for help on using the repository browser.