source: projects/specs/trunk/c/cryptsetup/cryptsetup-vl.spec @ 9144

Revision 9144, 13.6 KB checked in by inagaki, 9 years ago (diff)

2014-12-11 Ryoichi INAGAKI <ryo1@…>

  • cryptsetup, gwenhywfar, vpnc: rebuilt


Line 
1%define _root_sbindir /sbin
2%define upstream_version %{version}
3
4Summary:        A utility for setting up encrypted disks
5Summary(ja):    暗号化ファイルシステム設定用ユーティリティ
6Name:           cryptsetup
7Version:        1.4.1
8Release:        4%{?_dist_release}
9License:        GPLv2 and LGPLv2+
10Group:          Applications/System
11URL:            http://cryptsetup.googlecode.com/
12
13Source0:        http://cryptsetup.googlecode.com/files/cryptsetup-%{upstream_version}.tar.bz2
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  libgcrypt-devel
17BuildRequires:  popt-devel
18BuildRequires:  device-mapper-devel
19BuildRequires:  libgpg-error-devel
20BuildRequires:  libuuid-devel
21BuildRequires:  python-devel
22Provides:       cryptsetup-luks = %{version}-%{release}
23Obsoletes:      cryptsetup-luks < 1.4.0
24Requires:       cryptsetup-libs = %{version}-%{release}
25
26%description
27The cryptsetup package contains a utility for setting up
28disk encryption using dm-crypt kernel module.
29
30%description -l ja
31cryptsetup パッケージには、dm-crypt カーネルモジュールを使って
32ディスクの暗号化を設定するユーティリティが収録されています。
33
34
35%package devel
36Summary: Headers and libraries for using encrypted file systems
37Summary(ja): 暗号化ファイルシステムを使うためのヘッダとライブラリ
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40Requires: libgcrypt-devel > 1.1.42
41Requires: device-mapper-devel
42Requires: libuuid-devel
43Requires: pkgconfig
44Provides: cryptsetup-luks-devel = %{version}-%{release}
45Obsoletes: cryptsetup-luks-devel < 1.4.0
46
47%description devel
48The cryptsetup-devel package contains libraries and header files
49used for writing code that makes use of disk encryption.
50
51%description devel -l ja
52cryptsetup-devel パッケージには、ディスクの暗号化を使うコードを
53書くのに使われるライブラリとヘッダファイルが収録されています。
54
55
56%package libs
57Summary: Cryptsetup shared library
58Summary(ja): Cryptsetup 共有ライブラリ
59Group: System Environment/Libraries
60Provides: cryptsetup-luks-libs = %{version}-%{release}
61Obsoletes: cryptsetup-luks-libs < 1.4.0
62
63%description libs
64This package contains the cryptsetup shared library, libcryptsetup.
65
66%description libs -l ja
67このパッケージには、cryptsetup の共有ライブラリ、libcryptsetup が
68収録されています。
69
70
71%package python
72Summary: Python bindings for libcryptsetup
73Summary(ja): libcryptsetup の Python バインディング
74Group: System Environment/Libraries
75Requires: %{name}-libs = %{version}-%{release}
76Provides: python-cryptsetup = %{version}-%{release}
77Obsoletes: python-cryptsetup < 1.4.0
78
79%description python
80This package provides Python bindings for libcryptsetup, a library
81for setting up disk encryption using dm-crypt kernel module.
82
83%description python -l ja
84このパッケージには、dm-crypt カーネルモジュールを使って
85ディスクの暗号化を設定するライブラリ libcryptsetup の
86Python バインディングが収録されています。
87
88
89%prep
90%setup -q -n cryptsetup-%{upstream_version}
91chmod -x python/pycryptsetup-test.py
92
93
94%build
95%configure  --sbindir=%{_root_sbindir} --libdir=/%{_lib} \
96        --enable-python \
97        --disable-selinux
98# remove rpath
99sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
100sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
101make %{?_smp_mflags}
102
103
104%install
105rm -rf %{buildroot}
106make install DESTDIR=%{buildroot}
107rm -rf  %{buildroot}/%{_lib}/*.la %{buildroot}/%{_lib}/cryptsetup
108
109# move libcryptsetup.so to %%{_libdir}
110pushd %{buildroot}/%{_lib}
111rm libcryptsetup.so
112mkdir -p %{buildroot}/%{_libdir}
113ln -s ../../%{_lib}/$(ls libcryptsetup.so.?.?.?) %{buildroot}/%{_libdir}/libcryptsetup.so
114mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}
115popd
116%find_lang cryptsetup
117
118
119%post -n cryptsetup-libs -p /sbin/ldconfig
120
121
122%postun -n cryptsetup-libs -p /sbin/ldconfig
123
124
125%files -f cryptsetup.lang
126%doc COPYING ChangeLog AUTHORS TODO FAQ
127%{_mandir}/man8/cryptsetup.8.gz
128%{_root_sbindir}/cryptsetup
129
130
131%files devel
132%doc docs/examples/*
133%{_includedir}/libcryptsetup.h
134%{_libdir}/libcryptsetup.so
135%{_libdir}/pkgconfig/libcryptsetup.pc
136
137
138%files libs
139%doc COPYING
140/%{_lib}/libcryptsetup.so.*
141
142
143%files python
144%doc COPYING.LGPL python/pycryptsetup-test.py
145%exclude %{python_sitearch}/pycryptsetup.la
146%{python_sitearch}/pycryptsetup.so
147
148
149%clean
150rm -rf %{buildroot}
151
152
153%changelog
154* Sat Dec  6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.4.1-4
155- rebuilt with libgcrypt 1.6.0
156
157* Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.1-3
158- updated to 1.4.1; spec revamp; Japanese summary & description
159
160  - Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.5-8vl5
161  - applied new versioning policy
162 
163  - Sun Dec  9 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.5-7vl1
164  - initial build for VineSeed
165
166* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.1-2
167- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
168
169* Wed Nov 09 2011 Milan Broz <mbroz@redhat.com> - 1.4.1-1
170- Update to cryptsetup 1.4.1.
171- Add Python cryptsetup bindings.
172- Obsolete separate python-cryptsetup package.
173
174* Wed Oct 26 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-1
175- Update to cryptsetup 1.4.0.
176
177* Mon Oct 10 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-0.1
178- Update to cryptsetup 1.4.0-rc1.
179- Rename package back from cryptsetup-luks to cryptsetup.
180
181* Wed Jun 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-2
182- Fix return code for status command when device doesn't exist.
183
184* Tue May 24 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-1
185- Update to cryptsetup 1.3.1.
186
187* Tue Apr 05 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-1
188- Update to cryptsetup 1.3.0.
189
190* Tue Mar 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.2
191- Update to cryptsetup 1.3.0-rc2
192
193* Mon Mar 14 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.1
194- Update to cryptsetup 1.3.0-rc1
195
196* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
197- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
198
199* Mon Dec 20 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-1
200- Update to cryptsetup 1.2.0
201
202* Thu Nov 25 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.2
203- Fix crypt_activate_by_keyfile() to work with PLAIN devices.
204
205* Tue Nov 16 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.1
206- Add FAQ to documentation.
207- Update to cryptsetup 1.2.0-rc1
208
209* Sat Jul 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.3-1
210- Update to cryptsetup 1.1.3
211
212* Mon Jun 07 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-2
213- Fix alignment ioctl use.
214- Fix API activation calls to handle NULL device name.
215
216* Sun May 30 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-1
217- Update to cryptsetup 1.1.2
218- Fix luksOpen handling of new line char on stdin.
219
220* Sun May 23 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-1
221- Update to cryptsetup 1.1.1
222- Fix luksClose for stacked LUKS/LVM devices.
223
224* Mon May 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.2
225- Update to cryptsetup 1.1.1-rc2.
226
227* Sat May 01 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.1
228- Update to cryptsetup 1.1.1-rc1.
229
230* Sun Jan 17 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-1
231- Update to cryptsetup 1.1.0.
232
233* Fri Jan 15 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-0.6
234- Fix gcrypt initialisation.
235- Fix backward compatibility for hash algorithm (uppercase).
236
237* Wed Dec 30 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.5
238- Update to cryptsetup 1.1.0-rc4
239
240* Mon Nov 16 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.4
241- Update to cryptsetup 1.1.0-rc3
242
243* Thu Oct 01 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.3
244- Update to cryptsetup 1.1.0-rc2
245- Fix libcryptsetup to properly export only versioned symbols.
246
247* Tue Sep 29 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.2
248- Update to cryptsetup 1.1.0-rc1
249- Add luksHeaderBackup and luksHeaderRestore commands.
250
251* Thu Sep 11 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.1
252- Update to new upstream testing version with new API interface.
253- Add luksSuspend and luksResume commands.
254- Introduce pkgconfig.
255
256* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-2
257- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
258
259* Wed Jul 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-1
260- Update to upstream final release.
261- Split libs subpackage.
262- Remove rpath setting from cryptsetup binary.
263
264* Wed Jul 15 2009 Till Maas <opensource@till.name> - 1.0.7-0.2
265- update BR because of libuuid splitout from e2fsprogs
266
267* Mon Jun 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-0.1
268- Update to new upstream 1.0.7-rc1.
269
270- Wipe old fs headers to not confuse blkid (#468062)
271* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-7
272- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
273
274* Thu Oct 30 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-6
275- Wipe old fs headers to not confuse blkid (#468062)
276
277* Tue Sep 23 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-5
278- Change new project home page.
279- Print more descriptive messages for initialization errors.
280- Refresh patches to versions commited upstream.
281
282* Sat Sep 06 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-4
283- Fix close of zero decriptor.
284- Fix udevsettle delays - use temporary crypt device remapping.
285
286* Wed May 28 2008 Till Maas <opensource till name> - 1.0.6-3
287- remove a duplicate sentence from the manpage (RH #448705)
288- add patch metadata about upstream status
289
290* Tue Apr 15 2008 Bill Nottinghm <notting@redhat.com> - 1.0.6-2
291- Add the device to the luksOpen prompt (#433406)
292- Use iconv, not recode (#442574)
293
294* Thu Mar 13 2008 Till Maas <opensource till name> - 1.0.6-1
295- Update to latest version
296- remove patches that have been merged upstream
297
298* Mon Mar 03 2008 Till Maas <opensource till name> - 1.0.6-0.1.pre2
299- Update to new version with several bugfixes
300- remove patches that have been merged upstream
301- add patch from cryptsetup newsgroup
302- fix typo / missing luksRemoveKey in manpage (patch)
303
304* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.5-9
305- Autorebuild for GCC 4.3
306
307* Sat Jan 19 2008 Peter Jones <pjones@redhat.com> - 1.0.5-8
308- Rebuild for broken deps.
309
310* Thu Aug 30 2007 Till Maas <opensource till name> - 1.0.5-7
311- update URL
312- update license tag
313- recode ChangeLog from latin1 to uf8
314- add smp_mflags to make
315
316* Fri Aug 24 2007 Till Maas <opensource till name> - 1.0.5-6
317- cleanup BuildRequires:
318- removed versions, packages in Fedora are new enough
319- changed popt to popt-devel
320
321* Thu Aug 23 2007 Till Maas <opensource till name> - 1.0.5-5
322- fix devel subpackage requires
323- remove empty NEWS README
324- remove uneeded INSTALL
325- remove uneeded ldconfig requires
326- add readonly detection patch
327
328* Wed Aug 08 2007 Till Maas <opensource till name> - 1.0.5-4
329- disable patch2, libsepol is now detected by configure
330- move libcryptsetup.so to %%{_libdir} instead of /%%{_lib}
331
332* Fri Jul 27 2007 Till Maas <opensource till name> - 1.0.5-3
333- Use /%%{_lib} instead of /lib to use /lib64 on 64bit archs
334
335* Thu Jul 26 2007 Till Maas <opensource till name> - 1.0.5-2
336- Use /lib as libdir (#243228)
337- sync header and library (#215349)
338- do not use %%makeinstall (recommended by PackageGuidelines)
339- select sbindir with %%configure instead with make
340- add TODO
341
342* Wed Jun 13 2007 Jeremy Katz <katzj@redhat.com> - 1.0.5-1
343- update to 1.0.5
344
345* Mon Jun 04 2007 Peter Jones <pjones@redhat.com> - 1.0.3-5
346- Don't build static any more.
347
348* Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 1.0.3-4
349- Add build dependency on new device-mapper-devel package.
350- Add preun and post ldconfig requirements.
351- Update BuildRoot.
352
353* Wed Nov  1 2006 Peter Jones <pjones@redhat.com> - 1.0.3-3
354- Require newer libselinux (#213414)
355
356* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.3-2.1
357- rebuild
358
359* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 1.0.3-2
360- put shared libs in the right subpackages
361
362* Fri Apr  7 2006 Bill Nottingham <notting@redhat.com> 1.0.3-1
363- update to final 1.0.3
364
365* Wed Feb 27 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc2
366- update to 1.0.3rc2, fixes bug with HAL & encrypted devices (#182658)
367
368* Wed Feb 22 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc1
369- update to 1.0.3rc1, reverts changes to default encryption type
370
371* Tue Feb 21 2006 Bill Nottingham <notting@redhat.com> 1.0.2-1
372- update to 1.0.2, fix incompatiblity with old cryptsetup (#176726)
373
374* Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-5
375- BuildRequires: libselinux-devel
376
377* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2.1
378- bump again for double-long bug on ppc(64)
379
380* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2
381- rebuilt for new gcc4.1 snapshot and glibc changes
382
383* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
384- rebuilt
385
386* Mon Dec  5 2005 Bill Nottingham <notting@redhat.com> 1.0.1-4
387- rebuild against new libdevmapper
388
389* Thu Oct 13 2005 Florian La Roche <laroche@redhat.com>
390- add -lsepol to rebuild on current fc5
391
392* Mon Aug 22 2005 Karel Zak <kzak@redhat.com> 1.0.1-2
393- fix cryptsetup help for isLuks action
394
395* Fri Jul  1 2005 Bill Nottingham <notting@redhat.com> 1.0.1-1
396- update to 1.0.1 - fixes incompatiblity with previous cryptsetup for
397  piped passwords
398
399* Thu Jun 16 2005 Bill Nottingham <notting@redhat.com> 1.0-2
400- add patch for 32/64 bit compatibility (#160445, <redhat@paukstadt.de>)
401
402* Tue Mar 29 2005 Bill Nottingham <notting@redhat.com> 1.0-1
403- update to 1.0
404
405* Thu Mar 10 2005 Bill Nottingham <notting@redhat.com> 0.993-1
406- switch to cryptsetup-luks, for LUKS support
407
408* Tue Oct 12 2004 Bill Nottingham <notting@redhat.com> 0.1-4
409- oops, make that *everything* static (#129926)
410
411* Tue Aug 31 2004 Bill Nottingham <notting@redhat.com> 0.1-3
412- link some things static, move to /sbin (#129926)
413
414* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
415- rebuilt
416
417* Fri Apr 16 2004 Bill Nottingham <notting@redhat.com> 0.1-1
418- initial packaging
Note: See TracBrowser for help on using the repository browser.