source: projects/specs/trunk/c/cronie/cronie-vl.spec @ 8616

Revision 8616, 15.6 KB checked in by iwaim, 10 years ago (diff)

cronie 1.4.11-2

Line 
1%bcond_with selinux
2%bcond_without pam
3%bcond_without audit
4%bcond_without inotify
5
6%define ver 1.4.11
7%define rel 2
8
9Summary:   Cron daemon for executing programs at set times
10Name:      cronie
11Version:   %{ver}
12Release:   %{rel}%{?_dist_release}
13License:   MIT and BSD and ISC and GPLv2+
14Group:     System Environment/Base
15URL:       https://fedorahosted.org/cronie
16Source0:   https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
17# from cronie 1.4.8 tarball
18Source1:   cronie.init
19#Patch0:    cronie-systemd.patch
20Patch1:    cronie-1.4.11-fcntl_locking.patch
21Patch2:    cronie-1.4.11-pamenv.patch
22Patch3:    cronie-1.4.11-man-debug.patch
23Patch4:    cronie-check-config-param.patch
24
25Requires:  dailyjobs
26Conflicts: vixie-cron
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager: iwaim
31
32%if %{with selinux}
33Requires:      libselinux >= 2.0.64
34Buildrequires: libselinux-devel >= 2.0.64
35%endif
36%if %{with pam}
37Requires:      pam >= 1.0.1
38Buildrequires: pam-devel >= 1.0.1
39%endif
40%if %{with audit}
41Buildrequires: audit-libs-devel >= 1.4.1
42%endif
43
44Requires(post): coreutils sed
45Requires(post): chkconfig
46Requires(preun): chkconfig
47
48%description
49Cronie contains the standard UNIX daemon crond that runs specified programs at
50scheduled times and related tools. It is a fork of the original vixie-cron and
51has security and configuration enhancements like the ability to use pam and
52SELinux.
53
54%package anacron
55Summary:   Utility for running regular jobs
56Requires:  crontabs
57Group:     System Environment/Base
58Provides:  dailyjobs
59Provides:  anacron = 2.4
60Obsoletes: anacron <= 2.3
61Requires(post): coreutils
62Requires:  %{name} = %{version}-%{release}
63
64%description anacron
65Anacron is part of cronie that is used for running jobs with regular
66periodicity which do not have exact time of day of execution.
67
68The default settings of anacron execute the daily, weekly, and monthly
69jobs, but anacron allows setting arbitrary periodicity of jobs.
70
71Using anacron allows running the periodic jobs even if the system is often
72powered off and it also allows randomizing the time of the job execution
73for better utilization of resources shared among multiple systems.
74
75%package noanacron
76Summary:   Utility for running simple regular jobs in old cron style
77Group:     System Environment/Base
78Provides:  dailyjobs
79Requires:  crontabs
80Requires:  %{name} = %{version}-%{release}
81
82%description noanacron
83Old style of running {hourly,daily,weekly,monthly}.jobs without anacron. No
84extra features.
85
86%prep
87%setup -q
88#%patch0 -p1
89%patch1 -p1
90%patch2 -p1
91%patch3 -p1
92%patch4 -p1
93
94%build
95%configure \
96%if %{with pam}
97--with-pam \
98%endif
99%if %{with selinux}
100--with-selinux \
101%endif
102%if %{with audit}
103--with-audit \
104%endif
105%if %{with inotify}
106--with-inotify \
107%endif
108--enable-anacron \
109--enable-pie \
110--enable-relro
111
112make %{?_smp_mflags}
113
114%install
115make install DESTDIR=$RPM_BUILD_ROOT DESTMAN=$RPM_BUILD_ROOT%{_mandir}
116mkdir -pm700 $RPM_BUILD_ROOT%{_localstatedir}/spool/cron
117mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
118mkdir -pm755 $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/
119%if ! %{with pam}
120    rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/crond
121%endif
122install -m 600 crond.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/crond
123touch $RPM_BUILD_ROOT%{_sysconfdir}/cron.deny
124install -m 600 contrib/anacrontab $RPM_BUILD_ROOT%{_sysconfdir}/anacrontab
125install -c -m755 contrib/0hourly $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/0hourly
126mkdir -pm 700 $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly
127install -c -m755 contrib/0anacron $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly/0anacron
128mkdir -p $RPM_BUILD_ROOT/var/spool/anacron
129touch $RPM_BUILD_ROOT/var/spool/anacron/cron.daily
130touch $RPM_BUILD_ROOT/var/spool/anacron/cron.weekly
131touch $RPM_BUILD_ROOT/var/spool/anacron/cron.monthly
132
133# noanacron package
134install -m 644 contrib/dailyjobs $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/dailyjobs
135
136# install initscript
137mkdir -p $RPM_BUILD_ROOT%{_initddir}
138install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initddir}/crond
139
140%post
141# run after an installation
142/sbin/chkconfig --add crond
143
144%post anacron
145[ -e /var/spool/anacron/cron.daily ] || touch /var/spool/anacron/cron.daily
146[ -e /var/spool/anacron/cron.weekly ] || touch /var/spool/anacron/cron.weekly
147[ -e /var/spool/anacron/cron.monthly ] || touch /var/spool/anacron/cron.monthly
148
149%preun
150# run before a package is removed
151if [ "$1" -eq 0 ]; then
152        /sbin/service crond stop >/dev/null 2>&1
153        /sbin/chkconfig --del crond
154fi
155
156%postun
157# run after a package is removed
158if [ "$1" -ge "1" ]; then
159  /sbin/service crond condrestart >/dev/null 2>&1 || :
160fi
161
162%triggerpostun -- vixie-cron
163/sbin/chkconfig --add crond
164
165%files
166%doc AUTHORS COPYING INSTALL README ChangeLog
167%attr(755,root,root) %{_sbindir}/crond
168%attr(4755,root,root) %{_bindir}/crontab
169%{_mandir}/man8/crond.*
170%{_mandir}/man8/cron.*
171%{_mandir}/man5/crontab.*
172%{_mandir}/man1/crontab.*
173%dir %{_localstatedir}/spool/cron
174%dir %{_sysconfdir}/cron.d
175%if %{with pam}
176%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/pam.d/crond
177%endif
178%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/crond
179%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/cron.deny
180%attr(0644,root,root) %{_sysconfdir}/cron.d/0hourly
181%attr(0755,root,root) %{_initddir}/crond
182
183%files anacron
184%{_sbindir}/anacron
185%attr(0755,root,root) %{_sysconfdir}/cron.hourly/0anacron
186%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/anacrontab
187%dir /var/spool/anacron
188%ghost %verify(not md5 size mtime) /var/spool/anacron/cron.daily
189%ghost %verify(not md5 size mtime) /var/spool/anacron/cron.weekly
190%ghost %verify(not md5 size mtime) /var/spool/anacron/cron.monthly
191%{_mandir}/man5/anacrontab.*
192%{_mandir}/man8/anacron.*
193
194%files noanacron
195%attr(0644,root,root) %{_sysconfdir}/cron.d/dailyjobs
196
197%changelog
198* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.11-2
199- run chkconfig for vixie-cron in triggerpostun script
200
201* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.11-1
202- initial build for Vine Linux
203
204* Mon Jan 27 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-11
205- now it's work even on ppc64, all checks working correctly
206- Related: rhbz#1031384
207
208* Fri Jan 24 2014 Daniel Mach <dmach@redhat.com> - 1.4.11-10
209- Mass rebuild 2014-01-24
210
211* Wed Jan 22 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-9
212- fix coverity warnings about dead code. Incorrect checking of values.
213- Related: rhbz#1031384
214
215* Mon Jan 20 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-8
216- anacron do not execute jobs run from command line
217- Related: rhbz#1031384
218
219* Wed Jan 08 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-7
220- anacron segfaults with certain config data
221- Resolves: rhbz#1031384
222
223* Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 1.4.11-6
224- Mass rebuild 2013-12-27
225
226* Tue Oct 15 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-5
227- Cronie doesn't work when is executed as stand alone without systemd (for
228  debuging issues)
229- Fix another permission, hopefully all now.
230- Resolves: rhbz#1012420, rhbz#1015567
231
232* Fri Sep 13 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-4
233- fix permission on configuration files, same as rhbz#706979
234
235* Fri Aug 30 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-3
236- 919290 systemd script use "KillMode=process"
237- Fcntl locking has different semantics than flock. Prefer flock.
238  - 49225e172d156531ca142518d2638350752e373a
239- Pull PAM environment variables also from session modules.
240  - c8e7d1b43c86a85441cb09cf7e08090f3ec1f384
241
242* Mon Jul 22 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-2
243- scriptlets are not created correctly if systemd is not in BR 986698
244- remove sub-package sysvinit, which is not needed anymore
245- update license, anacron is under GPLv2+
246
247* Thu Jul 18 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-1
248- new release 1.4.11 (contains previous bug fixes from 1.4.10-5)
249
250* Tue Jun 11 2013 Tomáš Mráz <tmraz@redhat.com> - 1.4.10-5
251- add support for RANDOM_DELAY - delaying job startups
252- pass some environment variables to processes (LANG, etc.) (#969761)
253- do not use putenv() with string literals (#971516)
254
255* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.10-4
256- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
257
258* Wed Jan  2 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.10-3
259- change configuration files to 644
260- change 6755 to 4755 for crontab binary
261
262* Tue Nov 27 2012 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.10-1
263- New release 1.4.10
264
265* Thu Nov 22 2012 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.9-1
266- New release 1.4.9
267
268* Wed Sep 05 2012 Václav Pavlín <vpavlin@redhat.com> - 1.4.8-13
269- Scriptlets replaced with new systemd macros (#850070)
270
271* Fri Jul 27 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-12
272- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
273
274* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-11
275- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
276
277* Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-10
278- Rebuilt for glibc bug#747377
279
280* Tue Oct 25 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-9
281- make crond run a little bit later in the boot process (#747759)
282
283* Mon Oct 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-8
284- change triggerun to fix 735802 during upgrade
285
286* Wed Jul 27 2011 Karsten Hopp <karsten@redhat.com> 1.4.8-7
287- rebuild again, ppc still had the broken rpm in the buildroots
288
289* Thu Jul 21 2011 Rex Dieter <rdieter@fedoraproject.org> 1.4.8-6
290- rebuild (broken rpm in buildroot)
291
292* Thu Jul 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-5
293- fix permission of init.d/crond
294
295* Thu Jun 30 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-4
296- drop the without systemd build condition
297- add the chkconfig readding trigger to the sysvinit subpackage
298
299* Wed Jun 29 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-3
300- start crond after auditd
301
302* Wed Jun 29 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-2
303- fix inotify support to not leak fds (#717505)
304
305* Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-1
306- update to 1.4.8
307- create sub-package sysvinit for initscript
308
309* Mon May  9 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.7-3
310- missing requirement on systemd-sysv for scriptlets
311
312* Thu May 05 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.7-2
313- use only systemd units with systemd
314- add trigger for restart on glibc, libselinux or pam upgrades (#699189)
315
316* Tue Mar 15 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.7-1
317- new release 1.4.7
318
319* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.6-9
320- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
321
322* Mon Jan 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-8
323- enable crond even with systemctl
324
325* Thu Dec 16 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-7
326- 663193 rewritten selinux support
327
328* Wed Dec 15 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-6
329- apply selinux patch from dwalsh
330
331* Fri Dec 10 2010 Tomas Mraz <tmraz@redhat.com> - 1.4.6-5
332- do not lock jobs that fall out of allowed range - 661966
333
334* Thu Dec 02 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-4
335- fix post (thanks plautrba for review)
336
337* Tue Nov 30 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-3
338- systemd init script 617320
339
340* Tue Nov 30 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-2
341- fix typos in man pages
342
343* Fri Oct 22 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-1
344- update to 1.4.6
345
346* Fri Aug 13 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-4
347- 623908 fix fd leak in anacron, which caused denail of prelink
348  and others
349
350* Mon Aug  9 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-2
351- remove sendmail from requirements. If it's not installed, it will
352 log into (r)syslog.
353
354* Mon Aug  2 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-1
355- update to new release
356
357* Fri Feb 19 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.4-1
358- update to new release
359
360* Mon Feb 15 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-3
361- 564894 FTBFS DSOLinking
362
363* Thu Nov  5 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-2
364- 533189 pam needs add a line and selinux needs defined one function
365
366* Fri Oct 30 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-1
367- 531963 and 532482 creating noanacron package
368
369* Mon Oct 19 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.2-2
370- 529632 service crond stop returns appropriate value
371
372* Mon Oct 12 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.2-1
373- new release
374
375* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.1-3
376- rebuilt with new audit
377
378* Fri Aug 14 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.1-2
379- create the anacron timestamps in correct post script
380
381* Fri Aug 14 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.1-1
382- update to 1.4.1
383- create and own /var/spool/anacron/cron.{daily,weekly,monthly} to
384 remove false warning about non existent files
385- Resolves: 517398
386
387* Wed Aug  5 2009 Tomas Mraz <tmraz@redhat.com> - 1.4-4
388- 515762 move anacron provides and obsoletes to the anacron subpackage
389
390* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-3
391- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
392
393* Mon Jul 20 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4-2
394- merge cronie and anacron in new release of cronie
395- obsolete/provide anacron in spec
396
397* Thu Jun 18 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.3-2
398- 506560 check return value of access
399
400* Mon Apr 27 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.3-1
401- new release
402
403* Fri Apr 24 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-8
404- 496973 close file descriptors after exec
405
406* Mon Mar  9 2009 Tomas Mraz <tmraz@redhat.com> - 1.2-7
407- rebuild
408
409* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-6
410- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
411
412* Tue Dec 23 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-5
413- 477100 NO_FOLLOW was removed, reload after change in symlinked
414  crontab is needed, man updated.
415
416* Fri Oct 24 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-4
417- update init script
418
419* Thu Sep 25 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-3
420- add sendmail file into requirement, cause it's needed some MTA
421
422* Thu Sep 18 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-2
423- 462252  /etc/sysconfig/crond does not need to be executable
424
425* Thu Jun 26 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-1
426- update to 1.2
427
428* Tue Jun 17 2008 Tomas Mraz <tmraz@redhat.com> - 1.1-3
429- fix setting keycreate context
430- unify logging a bit
431- cleanup some warnings and fix a typo in TZ code
432- 450993 improve and fix inotify support
433
434* Wed Jun  4 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.1-2
435- 49864 upgrade/update problem. Syntax error in spec.
436
437* Wed May 28 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.1-1
438- release 1.1
439
440* Tue May 20 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-6
441- 446360 check for lock didn't call chkconfig
442
443* Tue Feb 12 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-5
444- upgrade from less than cronie-1.0-4 didn't add chkconfig
445
446* Wed Feb  6 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-4
447- 431366 after reboot wasn't cron in chkconfig
448
449* Tue Feb  5 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-3
450- 431366 trigger part => after update from vixie-cron on cronie will
451        be daemon running.
452
453* Wed Jan 30 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-2
454- change the provides on higher version than obsoletes
455
456* Tue Jan  8 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-1
457- packaging cronie
458- thank's for help with packaging to my reviewers
Note: See TracBrowser for help on using the repository browser.