source: projects/specs/trunk/c/cronie/cronie-vl.spec @ 12458

Revision 12458, 16.6 KB checked in by tomop, 4 years ago (diff)

updated 4 packages

cronie-1.5.5-2

geoclue2-2.5.6-1

kernel-5.4.57-1

rng-tools-6.10-5

Line 
1%bcond_with systemd
2%bcond_with selinux
3%bcond_without pam
4%bcond_without audit
5%bcond_without inotify
6
7Summary:        Cron daemon for executing programs at set times
8Name:           cronie
9Version:        1.5.5
10Release:        2%{?_dist_release}%{?with_systemd:.systemd}
11Group:          system
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       iwaim
15
16License:        MIT and BSD and ISC and GPLv2+
17URL:            https://github.com/cronie-crond/cronie
18Source0:        https://github.com/cronie-crond/cronie/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
19# from cronie 1.4.8 tarball
20Source1:        cronie.init
21
22Requires:       dailyjobs
23Conflicts:      vixie-cron
24
25%if %{with selinux}
26Requires:       libselinux >= 2.0.64
27BuildRequires:  libselinux-devel >= 2.0.64
28%endif
29%if %{with pam}
30Requires:       pam >= 1.0.1
31BuildRequires:  pam-devel >= 1.0.1
32%endif
33%if %{with audit}
34BuildRequires:  audit-libs-devel >= 1.4.1
35%endif
36%if %{with systemd}
37BuildRequires:  systemd
38%{?systemd_requires}
39%else
40Requires(post): chkconfig
41Requires(preun): chkconfig
42%endif
43
44Requires(post): coreutils sed
45
46Obsoletes:      vixie-cron <= 3.0.1
47
48%description
49Cronie contains the standard UNIX daemon crond that runs specified programs at
50scheduled times and related tools. It is a fork of the original vixie-cron and
51has security and configuration enhancements like the ability to use pam and
52SELinux.
53
54
55%package anacron
56Summary:   Utility for running regular jobs
57Requires:  crontabs
58Group:     system
59Provides:  dailyjobs
60Provides:  anacron = 2.4
61Obsoletes: anacron <= 2.3
62Requires(post): coreutils
63Requires:  %{name} = %{version}-%{release}
64
65%description anacron
66Anacron is part of cronie that is used for running jobs with regular
67periodicity which do not have exact time of day of execution.
68
69The default settings of anacron execute the daily, weekly, and monthly
70jobs, but anacron allows setting arbitrary periodicity of jobs.
71
72Using anacron allows running the periodic jobs even if the system is often
73powered off and it also allows randomizing the time of the job execution
74for better utilization of resources shared among multiple systems.
75
76
77%package noanacron
78Summary:   Utility for running simple regular jobs in old cron style
79Group:     system
80Provides:  dailyjobs
81Requires:  crontabs
82Requires:  %{name} = %{version}-%{release}
83
84%description noanacron
85Old style of running {hourly,daily,weekly,monthly}.jobs without anacron. No
86extra features.
87
88
89%prep
90%setup -q
91
92
93%build
94%configure \
95%if %{with pam}
96--with-pam \
97%endif
98%if %{with selinux}
99--with-selinux \
100%endif
101%if %{with audit}
102--with-audit \
103%endif
104%if %{with inotify}
105--with-inotify \
106%endif
107--enable-anacron \
108--enable-pie \
109--enable-relro
110
111make %{?_smp_mflags}
112
113
114%install
115make install DESTDIR=$RPM_BUILD_ROOT DESTMAN=$RPM_BUILD_ROOT%{_mandir}
116mkdir -pm700 $RPM_BUILD_ROOT%{_localstatedir}/spool/cron
117mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
118mkdir -pm755 $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/
119%if ! %{with pam}
120    rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/crond
121%endif
122install -m 600 crond.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/crond
123touch $RPM_BUILD_ROOT%{_sysconfdir}/cron.deny
124install -m 600 contrib/anacrontab $RPM_BUILD_ROOT%{_sysconfdir}/anacrontab
125install -c -m755 contrib/0hourly $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/0hourly
126mkdir -pm 700 $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly
127install -c -m755 contrib/0anacron $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly/0anacron
128mkdir -p $RPM_BUILD_ROOT/var/spool/anacron
129touch $RPM_BUILD_ROOT/var/spool/anacron/cron.daily
130touch $RPM_BUILD_ROOT/var/spool/anacron/cron.weekly
131touch $RPM_BUILD_ROOT/var/spool/anacron/cron.monthly
132
133# noanacron package
134install -m 644 contrib/dailyjobs $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/dailyjobs
135
136
137%if %{with systemd}
138# install systemd initscript
139mkdir -p $RPM_BUILD_ROOT%{_unitdir}
140install -m 644 contrib/cronie.systemd $RPM_BUILD_ROOT%{_unitdir}/crond.service
141%else
142# install initscript
143mkdir -p $RPM_BUILD_ROOT%{_initddir}
144install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initddir}/crond
145%endif
146
147
148%post
149# run after an installation
150%if %{with systemd}
151%systemd_post crond.service
152%else
153/sbin/chkconfig --add crond
154%endif
155
156%post anacron
157[ -e /var/spool/anacron/cron.daily ] || touch /var/spool/anacron/cron.daily
158[ -e /var/spool/anacron/cron.weekly ] || touch /var/spool/anacron/cron.weekly
159[ -e /var/spool/anacron/cron.monthly ] || touch /var/spool/anacron/cron.monthly
160
161%preun
162# run before a package is removed
163%if %{with systemd}
164%systemd_preun crond.service
165%else
166if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
167        /sbin/service crond stop >/dev/null 2>&1
168        /sbin/chkconfig --del crond
169fi
170%endif
171
172%postun
173# run after a package is removed
174%if %{with systemd}
175%systemd_postun_with_restart crond.service
176%else
177if [ "$1" -ge "1" ]; then
178  /sbin/service crond condrestart >/dev/null 2>&1 || :
179fi
180%endif
181
182%triggerpostun -- vixie-cron
183%if %{with systemd}
184%systemd_postun_with_restart crond.service
185%else
186/sbin/chkconfig --add crond
187%endif
188
189
190%files
191%license COPYING*
192%doc AUTHORS INSTALL README ChangeLog
193%attr(755,root,root) %{_sbindir}/crond
194%attr(4755,root,root) %{_bindir}/crontab
195%attr(755,root,root) %{_bindir}/cronnext
196%{_mandir}/man8/crond.*
197%{_mandir}/man8/cron.*
198%{_mandir}/man5/crontab.*
199%{_mandir}/man1/crontab.*
200%{_mandir}/man1/cronnext.*
201%dir %{_localstatedir}/spool/cron
202%dir %{_sysconfdir}/cron.d
203%if %{with pam}
204%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/pam.d/crond
205%endif
206%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/crond
207%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/cron.deny
208%attr(0644,root,root) %{_sysconfdir}/cron.d/0hourly
209%if %{with systemd}
210%{_unitdir}/crond.service
211%else
212%attr(0755,root,root) %{_initddir}/crond
213%endif
214
215%files anacron
216%{_sbindir}/anacron
217%attr(0755,root,root) %{_sysconfdir}/cron.hourly/0anacron
218%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/anacrontab
219%dir /var/spool/anacron
220%ghost %verify(not md5 size mtime) /var/spool/anacron/cron.daily
221%ghost %verify(not md5 size mtime) /var/spool/anacron/cron.weekly
222%ghost %verify(not md5 size mtime) /var/spool/anacron/cron.monthly
223%{_mandir}/man5/anacrontab.*
224%{_mandir}/man8/anacron.*
225
226%files noanacron
227%attr(0644,root,root) %{_sysconfdir}/cron.d/dailyjobs
228
229
230%changelog
231* Sun Aug 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.5-2
232- added systemd support (disabled as default).
233
234* Wed Mar 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.5-1
235- new upstream release.
236- dropped all patches.
237
238* Mon Sep 11 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.1-1
239- new upstream release.
240- dropped Patch0.
241- imported Patch0 and Patch1 from rawhide.
242
243* Sat Jul 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.0-1
244- new upstream release.
245- dropped all patches.
246- imported Patch0 from rawhide.
247- added O:vixie-cron.
248
249* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.11-2
250- run chkconfig for vixie-cron in triggerpostun script
251
252* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.11-1
253- initial build for Vine Linux
254
255* Mon Jan 27 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-11
256- now it's work even on ppc64, all checks working correctly
257- Related: rhbz#1031384
258
259* Fri Jan 24 2014 Daniel Mach <dmach@redhat.com> - 1.4.11-10
260- Mass rebuild 2014-01-24
261
262* Wed Jan 22 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-9
263- fix coverity warnings about dead code. Incorrect checking of values.
264- Related: rhbz#1031384
265
266* Mon Jan 20 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-8
267- anacron do not execute jobs run from command line
268- Related: rhbz#1031384
269
270* Wed Jan 08 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-7
271- anacron segfaults with certain config data
272- Resolves: rhbz#1031384
273
274* Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 1.4.11-6
275- Mass rebuild 2013-12-27
276
277* Tue Oct 15 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-5
278- Cronie doesn't work when is executed as stand alone without systemd (for
279  debuging issues)
280- Fix another permission, hopefully all now.
281- Resolves: rhbz#1012420, rhbz#1015567
282
283* Fri Sep 13 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-4
284- fix permission on configuration files, same as rhbz#706979
285
286* Fri Aug 30 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-3
287- 919290 systemd script use "KillMode=process"
288- Fcntl locking has different semantics than flock. Prefer flock.
289  - 49225e172d156531ca142518d2638350752e373a
290- Pull PAM environment variables also from session modules.
291  - c8e7d1b43c86a85441cb09cf7e08090f3ec1f384
292
293* Mon Jul 22 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-2
294- scriptlets are not created correctly if systemd is not in BR 986698
295- remove sub-package sysvinit, which is not needed anymore
296- update license, anacron is under GPLv2+
297
298* Thu Jul 18 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-1
299- new release 1.4.11 (contains previous bug fixes from 1.4.10-5)
300
301* Tue Jun 11 2013 Tomáš Mráz <tmraz@redhat.com> - 1.4.10-5
302- add support for RANDOM_DELAY - delaying job startups
303- pass some environment variables to processes (LANG, etc.) (#969761)
304- do not use putenv() with string literals (#971516)
305
306* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.10-4
307- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
308
309* Wed Jan  2 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.10-3
310- change configuration files to 644
311- change 6755 to 4755 for crontab binary
312
313* Tue Nov 27 2012 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.10-1
314- New release 1.4.10
315
316* Thu Nov 22 2012 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.9-1
317- New release 1.4.9
318
319* Wed Sep 05 2012 Václav Pavlín <vpavlin@redhat.com> - 1.4.8-13
320- Scriptlets replaced with new systemd macros (#850070)
321
322* Fri Jul 27 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-12
323- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
324
325* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-11
326- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
327
328* Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-10
329- Rebuilt for glibc bug#747377
330
331* Tue Oct 25 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-9
332- make crond run a little bit later in the boot process (#747759)
333
334* Mon Oct 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-8
335- change triggerun to fix 735802 during upgrade
336
337* Wed Jul 27 2011 Karsten Hopp <karsten@redhat.com> 1.4.8-7
338- rebuild again, ppc still had the broken rpm in the buildroots
339
340* Thu Jul 21 2011 Rex Dieter <rdieter@fedoraproject.org> 1.4.8-6
341- rebuild (broken rpm in buildroot)
342
343* Thu Jul 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-5
344- fix permission of init.d/crond
345
346* Thu Jun 30 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-4
347- drop the without systemd build condition
348- add the chkconfig readding trigger to the sysvinit subpackage
349
350* Wed Jun 29 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-3
351- start crond after auditd
352
353* Wed Jun 29 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-2
354- fix inotify support to not leak fds (#717505)
355
356* Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-1
357- update to 1.4.8
358- create sub-package sysvinit for initscript
359
360* Mon May  9 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.7-3
361- missing requirement on systemd-sysv for scriptlets
362
363* Thu May 05 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.7-2
364- use only systemd units with systemd
365- add trigger for restart on glibc, libselinux or pam upgrades (#699189)
366
367* Tue Mar 15 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.7-1
368- new release 1.4.7
369
370* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.6-9
371- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
372
373* Mon Jan 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-8
374- enable crond even with systemctl
375
376* Thu Dec 16 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-7
377- 663193 rewritten selinux support
378
379* Wed Dec 15 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-6
380- apply selinux patch from dwalsh
381
382* Fri Dec 10 2010 Tomas Mraz <tmraz@redhat.com> - 1.4.6-5
383- do not lock jobs that fall out of allowed range - 661966
384
385* Thu Dec 02 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-4
386- fix post (thanks plautrba for review)
387
388* Tue Nov 30 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-3
389- systemd init script 617320
390
391* Tue Nov 30 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-2
392- fix typos in man pages
393
394* Fri Oct 22 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-1
395- update to 1.4.6
396
397* Fri Aug 13 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-4
398- 623908 fix fd leak in anacron, which caused denail of prelink
399  and others
400
401* Mon Aug  9 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-2
402- remove sendmail from requirements. If it's not installed, it will
403 log into (r)syslog.
404
405* Mon Aug  2 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-1
406- update to new release
407
408* Fri Feb 19 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.4-1
409- update to new release
410
411* Mon Feb 15 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-3
412- 564894 FTBFS DSOLinking
413
414* Thu Nov  5 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-2
415- 533189 pam needs add a line and selinux needs defined one function
416
417* Fri Oct 30 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-1
418- 531963 and 532482 creating noanacron package
419
420* Mon Oct 19 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.2-2
421- 529632 service crond stop returns appropriate value
422
423* Mon Oct 12 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.2-1
424- new release
425
426* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.1-3
427- rebuilt with new audit
428
429* Fri Aug 14 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.1-2
430- create the anacron timestamps in correct post script
431
432* Fri Aug 14 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.1-1
433- update to 1.4.1
434- create and own /var/spool/anacron/cron.{daily,weekly,monthly} to
435 remove false warning about non existent files
436- Resolves: 517398
437
438* Wed Aug  5 2009 Tomas Mraz <tmraz@redhat.com> - 1.4-4
439- 515762 move anacron provides and obsoletes to the anacron subpackage
440
441* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-3
442- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
443
444* Mon Jul 20 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4-2
445- merge cronie and anacron in new release of cronie
446- obsolete/provide anacron in spec
447
448* Thu Jun 18 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.3-2
449- 506560 check return value of access
450
451* Mon Apr 27 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.3-1
452- new release
453
454* Fri Apr 24 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-8
455- 496973 close file descriptors after exec
456
457* Mon Mar  9 2009 Tomas Mraz <tmraz@redhat.com> - 1.2-7
458- rebuild
459
460* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-6
461- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
462
463* Tue Dec 23 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-5
464- 477100 NO_FOLLOW was removed, reload after change in symlinked
465  crontab is needed, man updated.
466
467* Fri Oct 24 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-4
468- update init script
469
470* Thu Sep 25 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-3
471- add sendmail file into requirement, cause it's needed some MTA
472
473* Thu Sep 18 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-2
474- 462252  /etc/sysconfig/crond does not need to be executable
475
476* Thu Jun 26 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-1
477- update to 1.2
478
479* Tue Jun 17 2008 Tomas Mraz <tmraz@redhat.com> - 1.1-3
480- fix setting keycreate context
481- unify logging a bit
482- cleanup some warnings and fix a typo in TZ code
483- 450993 improve and fix inotify support
484
485* Wed Jun  4 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.1-2
486- 49864 upgrade/update problem. Syntax error in spec.
487
488* Wed May 28 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.1-1
489- release 1.1
490
491* Tue May 20 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-6
492- 446360 check for lock didn't call chkconfig
493
494* Tue Feb 12 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-5
495- upgrade from less than cronie-1.0-4 didn't add chkconfig
496
497* Wed Feb  6 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-4
498- 431366 after reboot wasn't cron in chkconfig
499
500* Tue Feb  5 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-3
501- 431366 trigger part => after update from vixie-cron on cronie will
502        be daemon running.
503
504* Wed Jan 30 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-2
505- change the provides on higher version than obsoletes
506
507* Tue Jan  8 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-1
508- packaging cronie
509- thank's for help with packaging to my reviewers
Note: See TracBrowser for help on using the repository browser.