source: projects/specs/trunk/c/cronie/cronie-vl.spec @ 12351

Revision 12351, 15.9 KB checked in by tomop, 4 years ago (diff)

updated 2 packages

chrony-3.5-1

cronie-1.5.5-1

Line 
1%bcond_with selinux
2%bcond_without pam
3%bcond_without audit
4%bcond_without inotify
5
6Summary:        Cron daemon for executing programs at set times
7Name:           cronie
8Version:        1.5.5
9Release:        1%{?_dist_release}
10Group:          System Environment/Base
11Vendor:         Project Vine
12Distribution:   Vine Linux
13Packager:       iwaim
14License:        MIT and BSD and ISC and GPLv2+
15URL:            https://github.com/cronie-crond/cronie
16Source0:        https://github.com/cronie-crond/cronie/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
17# from cronie 1.4.8 tarball
18Source1:        cronie.init
19
20Requires:       dailyjobs
21Conflicts:      vixie-cron
22
23%if %{with selinux}
24Requires:       libselinux >= 2.0.64
25BuildRequires:  libselinux-devel >= 2.0.64
26%endif
27%if %{with pam}
28Requires:       pam >= 1.0.1
29BuildRequires:  pam-devel >= 1.0.1
30%endif
31%if %{with audit}
32BuildRequires:  audit-libs-devel >= 1.4.1
33%endif
34
35Requires(post): coreutils sed
36Requires(post): chkconfig
37Requires(preun): chkconfig
38
39Obsoletes:      vixie-cron <= 3.0.1
40
41%description
42Cronie contains the standard UNIX daemon crond that runs specified programs at
43scheduled times and related tools. It is a fork of the original vixie-cron and
44has security and configuration enhancements like the ability to use pam and
45SELinux.
46
47%package anacron
48Summary:   Utility for running regular jobs
49Requires:  crontabs
50Group:     System Environment/Base
51Provides:  dailyjobs
52Provides:  anacron = 2.4
53Obsoletes: anacron <= 2.3
54Requires(post): coreutils
55Requires:  %{name} = %{version}-%{release}
56
57%description anacron
58Anacron is part of cronie that is used for running jobs with regular
59periodicity which do not have exact time of day of execution.
60
61The default settings of anacron execute the daily, weekly, and monthly
62jobs, but anacron allows setting arbitrary periodicity of jobs.
63
64Using anacron allows running the periodic jobs even if the system is often
65powered off and it also allows randomizing the time of the job execution
66for better utilization of resources shared among multiple systems.
67
68%package noanacron
69Summary:   Utility for running simple regular jobs in old cron style
70Group:     System Environment/Base
71Provides:  dailyjobs
72Requires:  crontabs
73Requires:  %{name} = %{version}-%{release}
74
75%description noanacron
76Old style of running {hourly,daily,weekly,monthly}.jobs without anacron. No
77extra features.
78
79%prep
80%setup -q
81
82
83%build
84%configure \
85%if %{with pam}
86--with-pam \
87%endif
88%if %{with selinux}
89--with-selinux \
90%endif
91%if %{with audit}
92--with-audit \
93%endif
94%if %{with inotify}
95--with-inotify \
96%endif
97--enable-anacron \
98--enable-pie \
99--enable-relro
100
101make %{?_smp_mflags}
102
103%install
104make install DESTDIR=$RPM_BUILD_ROOT DESTMAN=$RPM_BUILD_ROOT%{_mandir}
105mkdir -pm700 $RPM_BUILD_ROOT%{_localstatedir}/spool/cron
106mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
107mkdir -pm755 $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/
108%if ! %{with pam}
109    rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/crond
110%endif
111install -m 600 crond.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/crond
112touch $RPM_BUILD_ROOT%{_sysconfdir}/cron.deny
113install -m 600 contrib/anacrontab $RPM_BUILD_ROOT%{_sysconfdir}/anacrontab
114install -c -m755 contrib/0hourly $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/0hourly
115mkdir -pm 700 $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly
116install -c -m755 contrib/0anacron $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly/0anacron
117mkdir -p $RPM_BUILD_ROOT/var/spool/anacron
118touch $RPM_BUILD_ROOT/var/spool/anacron/cron.daily
119touch $RPM_BUILD_ROOT/var/spool/anacron/cron.weekly
120touch $RPM_BUILD_ROOT/var/spool/anacron/cron.monthly
121
122# noanacron package
123install -m 644 contrib/dailyjobs $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/dailyjobs
124
125# install initscript
126mkdir -p $RPM_BUILD_ROOT%{_initddir}
127install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initddir}/crond
128
129%post
130# run after an installation
131/sbin/chkconfig --add crond
132
133%post anacron
134[ -e /var/spool/anacron/cron.daily ] || touch /var/spool/anacron/cron.daily
135[ -e /var/spool/anacron/cron.weekly ] || touch /var/spool/anacron/cron.weekly
136[ -e /var/spool/anacron/cron.monthly ] || touch /var/spool/anacron/cron.monthly
137
138%preun
139# run before a package is removed
140if [ "$1" -eq 0 ]; then
141        /sbin/service crond stop >/dev/null 2>&1
142        /sbin/chkconfig --del crond
143fi
144
145%postun
146# run after a package is removed
147if [ "$1" -ge "1" ]; then
148  /sbin/service crond condrestart >/dev/null 2>&1 || :
149fi
150
151%triggerpostun -- vixie-cron
152/sbin/chkconfig --add crond
153
154%files
155%license COPYING*
156%doc AUTHORS INSTALL README ChangeLog
157%attr(755,root,root) %{_sbindir}/crond
158%attr(4755,root,root) %{_bindir}/crontab
159%attr(755,root,root) %{_bindir}/cronnext
160%{_mandir}/man8/crond.*
161%{_mandir}/man8/cron.*
162%{_mandir}/man5/crontab.*
163%{_mandir}/man1/crontab.*
164%{_mandir}/man1/cronnext.*
165%dir %{_localstatedir}/spool/cron
166%dir %{_sysconfdir}/cron.d
167%if %{with pam}
168%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/pam.d/crond
169%endif
170%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/crond
171%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/cron.deny
172%attr(0644,root,root) %{_sysconfdir}/cron.d/0hourly
173%attr(0755,root,root) %{_initddir}/crond
174
175%files anacron
176%{_sbindir}/anacron
177%attr(0755,root,root) %{_sysconfdir}/cron.hourly/0anacron
178%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/anacrontab
179%dir /var/spool/anacron
180%ghost %verify(not md5 size mtime) /var/spool/anacron/cron.daily
181%ghost %verify(not md5 size mtime) /var/spool/anacron/cron.weekly
182%ghost %verify(not md5 size mtime) /var/spool/anacron/cron.monthly
183%{_mandir}/man5/anacrontab.*
184%{_mandir}/man8/anacron.*
185
186%files noanacron
187%attr(0644,root,root) %{_sysconfdir}/cron.d/dailyjobs
188
189%changelog
190* Wed Mar 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.5-1
191- new upstream release.
192- dropped all patches.
193
194* Mon Sep 11 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.1-1
195- new upstream release.
196- dropped Patch0.
197- imported Patch0 and Patch1 from rawhide.
198
199* Sat Jul 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.0-1
200- new upstream release.
201- dropped all patches.
202- imported Patch0 from rawhide.
203- added O:vixie-cron.
204
205* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.11-2
206- run chkconfig for vixie-cron in triggerpostun script
207
208* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.11-1
209- initial build for Vine Linux
210
211* Mon Jan 27 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-11
212- now it's work even on ppc64, all checks working correctly
213- Related: rhbz#1031384
214
215* Fri Jan 24 2014 Daniel Mach <dmach@redhat.com> - 1.4.11-10
216- Mass rebuild 2014-01-24
217
218* Wed Jan 22 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-9
219- fix coverity warnings about dead code. Incorrect checking of values.
220- Related: rhbz#1031384
221
222* Mon Jan 20 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-8
223- anacron do not execute jobs run from command line
224- Related: rhbz#1031384
225
226* Wed Jan 08 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-7
227- anacron segfaults with certain config data
228- Resolves: rhbz#1031384
229
230* Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 1.4.11-6
231- Mass rebuild 2013-12-27
232
233* Tue Oct 15 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-5
234- Cronie doesn't work when is executed as stand alone without systemd (for
235  debuging issues)
236- Fix another permission, hopefully all now.
237- Resolves: rhbz#1012420, rhbz#1015567
238
239* Fri Sep 13 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-4
240- fix permission on configuration files, same as rhbz#706979
241
242* Fri Aug 30 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-3
243- 919290 systemd script use "KillMode=process"
244- Fcntl locking has different semantics than flock. Prefer flock.
245  - 49225e172d156531ca142518d2638350752e373a
246- Pull PAM environment variables also from session modules.
247  - c8e7d1b43c86a85441cb09cf7e08090f3ec1f384
248
249* Mon Jul 22 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-2
250- scriptlets are not created correctly if systemd is not in BR 986698
251- remove sub-package sysvinit, which is not needed anymore
252- update license, anacron is under GPLv2+
253
254* Thu Jul 18 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-1
255- new release 1.4.11 (contains previous bug fixes from 1.4.10-5)
256
257* Tue Jun 11 2013 Tomáš Mráz <tmraz@redhat.com> - 1.4.10-5
258- add support for RANDOM_DELAY - delaying job startups
259- pass some environment variables to processes (LANG, etc.) (#969761)
260- do not use putenv() with string literals (#971516)
261
262* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.10-4
263- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
264
265* Wed Jan  2 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.10-3
266- change configuration files to 644
267- change 6755 to 4755 for crontab binary
268
269* Tue Nov 27 2012 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.10-1
270- New release 1.4.10
271
272* Thu Nov 22 2012 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.9-1
273- New release 1.4.9
274
275* Wed Sep 05 2012 Václav Pavlín <vpavlin@redhat.com> - 1.4.8-13
276- Scriptlets replaced with new systemd macros (#850070)
277
278* Fri Jul 27 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-12
279- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
280
281* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-11
282- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
283
284* Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-10
285- Rebuilt for glibc bug#747377
286
287* Tue Oct 25 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-9
288- make crond run a little bit later in the boot process (#747759)
289
290* Mon Oct 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-8
291- change triggerun to fix 735802 during upgrade
292
293* Wed Jul 27 2011 Karsten Hopp <karsten@redhat.com> 1.4.8-7
294- rebuild again, ppc still had the broken rpm in the buildroots
295
296* Thu Jul 21 2011 Rex Dieter <rdieter@fedoraproject.org> 1.4.8-6
297- rebuild (broken rpm in buildroot)
298
299* Thu Jul 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-5
300- fix permission of init.d/crond
301
302* Thu Jun 30 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-4
303- drop the without systemd build condition
304- add the chkconfig readding trigger to the sysvinit subpackage
305
306* Wed Jun 29 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-3
307- start crond after auditd
308
309* Wed Jun 29 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-2
310- fix inotify support to not leak fds (#717505)
311
312* Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-1
313- update to 1.4.8
314- create sub-package sysvinit for initscript
315
316* Mon May  9 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.7-3
317- missing requirement on systemd-sysv for scriptlets
318
319* Thu May 05 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.7-2
320- use only systemd units with systemd
321- add trigger for restart on glibc, libselinux or pam upgrades (#699189)
322
323* Tue Mar 15 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.7-1
324- new release 1.4.7
325
326* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.6-9
327- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
328
329* Mon Jan 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-8
330- enable crond even with systemctl
331
332* Thu Dec 16 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-7
333- 663193 rewritten selinux support
334
335* Wed Dec 15 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-6
336- apply selinux patch from dwalsh
337
338* Fri Dec 10 2010 Tomas Mraz <tmraz@redhat.com> - 1.4.6-5
339- do not lock jobs that fall out of allowed range - 661966
340
341* Thu Dec 02 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-4
342- fix post (thanks plautrba for review)
343
344* Tue Nov 30 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-3
345- systemd init script 617320
346
347* Tue Nov 30 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-2
348- fix typos in man pages
349
350* Fri Oct 22 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-1
351- update to 1.4.6
352
353* Fri Aug 13 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-4
354- 623908 fix fd leak in anacron, which caused denail of prelink
355  and others
356
357* Mon Aug  9 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-2
358- remove sendmail from requirements. If it's not installed, it will
359 log into (r)syslog.
360
361* Mon Aug  2 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-1
362- update to new release
363
364* Fri Feb 19 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.4-1
365- update to new release
366
367* Mon Feb 15 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-3
368- 564894 FTBFS DSOLinking
369
370* Thu Nov  5 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-2
371- 533189 pam needs add a line and selinux needs defined one function
372
373* Fri Oct 30 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-1
374- 531963 and 532482 creating noanacron package
375
376* Mon Oct 19 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.2-2
377- 529632 service crond stop returns appropriate value
378
379* Mon Oct 12 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.2-1
380- new release
381
382* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.1-3
383- rebuilt with new audit
384
385* Fri Aug 14 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.1-2
386- create the anacron timestamps in correct post script
387
388* Fri Aug 14 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.1-1
389- update to 1.4.1
390- create and own /var/spool/anacron/cron.{daily,weekly,monthly} to
391 remove false warning about non existent files
392- Resolves: 517398
393
394* Wed Aug  5 2009 Tomas Mraz <tmraz@redhat.com> - 1.4-4
395- 515762 move anacron provides and obsoletes to the anacron subpackage
396
397* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-3
398- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
399
400* Mon Jul 20 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4-2
401- merge cronie and anacron in new release of cronie
402- obsolete/provide anacron in spec
403
404* Thu Jun 18 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.3-2
405- 506560 check return value of access
406
407* Mon Apr 27 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.3-1
408- new release
409
410* Fri Apr 24 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-8
411- 496973 close file descriptors after exec
412
413* Mon Mar  9 2009 Tomas Mraz <tmraz@redhat.com> - 1.2-7
414- rebuild
415
416* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-6
417- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
418
419* Tue Dec 23 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-5
420- 477100 NO_FOLLOW was removed, reload after change in symlinked
421  crontab is needed, man updated.
422
423* Fri Oct 24 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-4
424- update init script
425
426* Thu Sep 25 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-3
427- add sendmail file into requirement, cause it's needed some MTA
428
429* Thu Sep 18 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-2
430- 462252  /etc/sysconfig/crond does not need to be executable
431
432* Thu Jun 26 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-1
433- update to 1.2
434
435* Tue Jun 17 2008 Tomas Mraz <tmraz@redhat.com> - 1.1-3
436- fix setting keycreate context
437- unify logging a bit
438- cleanup some warnings and fix a typo in TZ code
439- 450993 improve and fix inotify support
440
441* Wed Jun  4 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.1-2
442- 49864 upgrade/update problem. Syntax error in spec.
443
444* Wed May 28 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.1-1
445- release 1.1
446
447* Tue May 20 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-6
448- 446360 check for lock didn't call chkconfig
449
450* Tue Feb 12 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-5
451- upgrade from less than cronie-1.0-4 didn't add chkconfig
452
453* Wed Feb  6 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-4
454- 431366 after reboot wasn't cron in chkconfig
455
456* Tue Feb  5 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-3
457- 431366 trigger part => after update from vixie-cron on cronie will
458        be daemon running.
459
460* Wed Jan 30 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-2
461- change the provides on higher version than obsoletes
462
463* Tue Jan  8 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-1
464- packaging cronie
465- thank's for help with packaging to my reviewers
Note: See TracBrowser for help on using the repository browser.