source: projects/specs/trunk/c/cronie/cronie-vl.spec @ 11184

Revision 11184, 15.8 KB checked in by tomop, 7 years ago (diff)

cronie-1.5.1-1

Line 
1%bcond_with selinux
2%bcond_without pam
3%bcond_without audit
4%bcond_without inotify
5
6%define ver 1.5.1
7%define rel 1
8
9Summary:   Cron daemon for executing programs at set times
10Name:      cronie
11Version:   %{ver}
12Release:   %{rel}%{?_dist_release}
13License:   MIT and BSD and ISC and GPLv2+
14Group:     System Environment/Base
15URL:       https://fedorahosted.org/cronie
16Source0:   https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
17# from cronie 1.4.8 tarball
18Source1:   cronie.init
19
20Patch0:    cronie-1.5.1-power.patch
21Patch1:    cronie-1.5.1-y2038.patch
22
23Requires:  dailyjobs
24Conflicts: vixie-cron
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: iwaim
29
30%if %{with selinux}
31Requires:      libselinux >= 2.0.64
32Buildrequires: libselinux-devel >= 2.0.64
33%endif
34%if %{with pam}
35Requires:      pam >= 1.0.1
36Buildrequires: pam-devel >= 1.0.1
37%endif
38%if %{with audit}
39Buildrequires: audit-libs-devel >= 1.4.1
40%endif
41
42Requires(post): coreutils sed
43Requires(post): chkconfig
44Requires(preun): chkconfig
45
46Obsoletes: vixie-cron <= 3.0.1
47
48%description
49Cronie contains the standard UNIX daemon crond that runs specified programs at
50scheduled times and related tools. It is a fork of the original vixie-cron and
51has security and configuration enhancements like the ability to use pam and
52SELinux.
53
54%package anacron
55Summary:   Utility for running regular jobs
56Requires:  crontabs
57Group:     System Environment/Base
58Provides:  dailyjobs
59Provides:  anacron = 2.4
60Obsoletes: anacron <= 2.3
61Requires(post): coreutils
62Requires:  %{name} = %{version}-%{release}
63
64%description anacron
65Anacron is part of cronie that is used for running jobs with regular
66periodicity which do not have exact time of day of execution.
67
68The default settings of anacron execute the daily, weekly, and monthly
69jobs, but anacron allows setting arbitrary periodicity of jobs.
70
71Using anacron allows running the periodic jobs even if the system is often
72powered off and it also allows randomizing the time of the job execution
73for better utilization of resources shared among multiple systems.
74
75%package noanacron
76Summary:   Utility for running simple regular jobs in old cron style
77Group:     System Environment/Base
78Provides:  dailyjobs
79Requires:  crontabs
80Requires:  %{name} = %{version}-%{release}
81
82%description noanacron
83Old style of running {hourly,daily,weekly,monthly}.jobs without anacron. No
84extra features.
85
86%prep
87%setup -q
88
89%patch0 -p1 -b .power
90%patch1 -p1 -b .y2038
91
92%build
93%configure \
94%if %{with pam}
95--with-pam \
96%endif
97%if %{with selinux}
98--with-selinux \
99%endif
100%if %{with audit}
101--with-audit \
102%endif
103%if %{with inotify}
104--with-inotify \
105%endif
106--enable-anacron \
107--enable-pie \
108--enable-relro
109
110make %{?_smp_mflags}
111
112%install
113make install DESTDIR=$RPM_BUILD_ROOT DESTMAN=$RPM_BUILD_ROOT%{_mandir}
114mkdir -pm700 $RPM_BUILD_ROOT%{_localstatedir}/spool/cron
115mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
116mkdir -pm755 $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/
117%if ! %{with pam}
118    rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/crond
119%endif
120install -m 600 crond.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/crond
121touch $RPM_BUILD_ROOT%{_sysconfdir}/cron.deny
122install -m 600 contrib/anacrontab $RPM_BUILD_ROOT%{_sysconfdir}/anacrontab
123install -c -m755 contrib/0hourly $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/0hourly
124mkdir -pm 700 $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly
125install -c -m755 contrib/0anacron $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly/0anacron
126mkdir -p $RPM_BUILD_ROOT/var/spool/anacron
127touch $RPM_BUILD_ROOT/var/spool/anacron/cron.daily
128touch $RPM_BUILD_ROOT/var/spool/anacron/cron.weekly
129touch $RPM_BUILD_ROOT/var/spool/anacron/cron.monthly
130
131# noanacron package
132install -m 644 contrib/dailyjobs $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/dailyjobs
133
134# install initscript
135mkdir -p $RPM_BUILD_ROOT%{_initddir}
136install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initddir}/crond
137
138%post
139# run after an installation
140/sbin/chkconfig --add crond
141
142%post anacron
143[ -e /var/spool/anacron/cron.daily ] || touch /var/spool/anacron/cron.daily
144[ -e /var/spool/anacron/cron.weekly ] || touch /var/spool/anacron/cron.weekly
145[ -e /var/spool/anacron/cron.monthly ] || touch /var/spool/anacron/cron.monthly
146
147%preun
148# run before a package is removed
149if [ "$1" -eq 0 ]; then
150        /sbin/service crond stop >/dev/null 2>&1
151        /sbin/chkconfig --del crond
152fi
153
154%postun
155# run after a package is removed
156if [ "$1" -ge "1" ]; then
157  /sbin/service crond condrestart >/dev/null 2>&1 || :
158fi
159
160%triggerpostun -- vixie-cron
161/sbin/chkconfig --add crond
162
163%files
164%doc AUTHORS COPYING INSTALL README ChangeLog
165%attr(755,root,root) %{_sbindir}/crond
166%attr(4755,root,root) %{_bindir}/crontab
167%{_mandir}/man8/crond.*
168%{_mandir}/man8/cron.*
169%{_mandir}/man5/crontab.*
170%{_mandir}/man1/crontab.*
171%dir %{_localstatedir}/spool/cron
172%dir %{_sysconfdir}/cron.d
173%if %{with pam}
174%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/pam.d/crond
175%endif
176%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/crond
177%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/cron.deny
178%attr(0644,root,root) %{_sysconfdir}/cron.d/0hourly
179%attr(0755,root,root) %{_initddir}/crond
180
181%files anacron
182%{_sbindir}/anacron
183%attr(0755,root,root) %{_sysconfdir}/cron.hourly/0anacron
184%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/anacrontab
185%dir /var/spool/anacron
186%ghost %verify(not md5 size mtime) /var/spool/anacron/cron.daily
187%ghost %verify(not md5 size mtime) /var/spool/anacron/cron.weekly
188%ghost %verify(not md5 size mtime) /var/spool/anacron/cron.monthly
189%{_mandir}/man5/anacrontab.*
190%{_mandir}/man8/anacron.*
191
192%files noanacron
193%attr(0644,root,root) %{_sysconfdir}/cron.d/dailyjobs
194
195%changelog
196* Mon Sep 11 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.1-1
197- new upstream release.
198- dropped Patch0.
199- imported Patch0 and Patch1 from rawhide.
200
201* Sat Jul 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.0-1
202- new upstream release.
203- dropped all patches.
204- imported Patch0 from rawhide.
205- added O:vixie-cron.
206
207* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.11-2
208- run chkconfig for vixie-cron in triggerpostun script
209
210* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.11-1
211- initial build for Vine Linux
212
213* Mon Jan 27 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-11
214- now it's work even on ppc64, all checks working correctly
215- Related: rhbz#1031384
216
217* Fri Jan 24 2014 Daniel Mach <dmach@redhat.com> - 1.4.11-10
218- Mass rebuild 2014-01-24
219
220* Wed Jan 22 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-9
221- fix coverity warnings about dead code. Incorrect checking of values.
222- Related: rhbz#1031384
223
224* Mon Jan 20 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-8
225- anacron do not execute jobs run from command line
226- Related: rhbz#1031384
227
228* Wed Jan 08 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-7
229- anacron segfaults with certain config data
230- Resolves: rhbz#1031384
231
232* Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 1.4.11-6
233- Mass rebuild 2013-12-27
234
235* Tue Oct 15 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-5
236- Cronie doesn't work when is executed as stand alone without systemd (for
237  debuging issues)
238- Fix another permission, hopefully all now.
239- Resolves: rhbz#1012420, rhbz#1015567
240
241* Fri Sep 13 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-4
242- fix permission on configuration files, same as rhbz#706979
243
244* Fri Aug 30 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-3
245- 919290 systemd script use "KillMode=process"
246- Fcntl locking has different semantics than flock. Prefer flock.
247  - 49225e172d156531ca142518d2638350752e373a
248- Pull PAM environment variables also from session modules.
249  - c8e7d1b43c86a85441cb09cf7e08090f3ec1f384
250
251* Mon Jul 22 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-2
252- scriptlets are not created correctly if systemd is not in BR 986698
253- remove sub-package sysvinit, which is not needed anymore
254- update license, anacron is under GPLv2+
255
256* Thu Jul 18 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-1
257- new release 1.4.11 (contains previous bug fixes from 1.4.10-5)
258
259* Tue Jun 11 2013 Tomáš Mráz <tmraz@redhat.com> - 1.4.10-5
260- add support for RANDOM_DELAY - delaying job startups
261- pass some environment variables to processes (LANG, etc.) (#969761)
262- do not use putenv() with string literals (#971516)
263
264* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.10-4
265- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
266
267* Wed Jan  2 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.10-3
268- change configuration files to 644
269- change 6755 to 4755 for crontab binary
270
271* Tue Nov 27 2012 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.10-1
272- New release 1.4.10
273
274* Thu Nov 22 2012 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.9-1
275- New release 1.4.9
276
277* Wed Sep 05 2012 Václav Pavlín <vpavlin@redhat.com> - 1.4.8-13
278- Scriptlets replaced with new systemd macros (#850070)
279
280* Fri Jul 27 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-12
281- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
282
283* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-11
284- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
285
286* Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-10
287- Rebuilt for glibc bug#747377
288
289* Tue Oct 25 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-9
290- make crond run a little bit later in the boot process (#747759)
291
292* Mon Oct 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-8
293- change triggerun to fix 735802 during upgrade
294
295* Wed Jul 27 2011 Karsten Hopp <karsten@redhat.com> 1.4.8-7
296- rebuild again, ppc still had the broken rpm in the buildroots
297
298* Thu Jul 21 2011 Rex Dieter <rdieter@fedoraproject.org> 1.4.8-6
299- rebuild (broken rpm in buildroot)
300
301* Thu Jul 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-5
302- fix permission of init.d/crond
303
304* Thu Jun 30 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-4
305- drop the without systemd build condition
306- add the chkconfig readding trigger to the sysvinit subpackage
307
308* Wed Jun 29 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-3
309- start crond after auditd
310
311* Wed Jun 29 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-2
312- fix inotify support to not leak fds (#717505)
313
314* Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-1
315- update to 1.4.8
316- create sub-package sysvinit for initscript
317
318* Mon May  9 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.7-3
319- missing requirement on systemd-sysv for scriptlets
320
321* Thu May 05 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.7-2
322- use only systemd units with systemd
323- add trigger for restart on glibc, libselinux or pam upgrades (#699189)
324
325* Tue Mar 15 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.7-1
326- new release 1.4.7
327
328* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.6-9
329- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
330
331* Mon Jan 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-8
332- enable crond even with systemctl
333
334* Thu Dec 16 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-7
335- 663193 rewritten selinux support
336
337* Wed Dec 15 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-6
338- apply selinux patch from dwalsh
339
340* Fri Dec 10 2010 Tomas Mraz <tmraz@redhat.com> - 1.4.6-5
341- do not lock jobs that fall out of allowed range - 661966
342
343* Thu Dec 02 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-4
344- fix post (thanks plautrba for review)
345
346* Tue Nov 30 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-3
347- systemd init script 617320
348
349* Tue Nov 30 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-2
350- fix typos in man pages
351
352* Fri Oct 22 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-1
353- update to 1.4.6
354
355* Fri Aug 13 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-4
356- 623908 fix fd leak in anacron, which caused denail of prelink
357  and others
358
359* Mon Aug  9 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-2
360- remove sendmail from requirements. If it's not installed, it will
361 log into (r)syslog.
362
363* Mon Aug  2 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-1
364- update to new release
365
366* Fri Feb 19 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.4-1
367- update to new release
368
369* Mon Feb 15 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-3
370- 564894 FTBFS DSOLinking
371
372* Thu Nov  5 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-2
373- 533189 pam needs add a line and selinux needs defined one function
374
375* Fri Oct 30 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-1
376- 531963 and 532482 creating noanacron package
377
378* Mon Oct 19 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.2-2
379- 529632 service crond stop returns appropriate value
380
381* Mon Oct 12 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.2-1
382- new release
383
384* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.1-3
385- rebuilt with new audit
386
387* Fri Aug 14 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.1-2
388- create the anacron timestamps in correct post script
389
390* Fri Aug 14 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.1-1
391- update to 1.4.1
392- create and own /var/spool/anacron/cron.{daily,weekly,monthly} to
393 remove false warning about non existent files
394- Resolves: 517398
395
396* Wed Aug  5 2009 Tomas Mraz <tmraz@redhat.com> - 1.4-4
397- 515762 move anacron provides and obsoletes to the anacron subpackage
398
399* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-3
400- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
401
402* Mon Jul 20 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4-2
403- merge cronie and anacron in new release of cronie
404- obsolete/provide anacron in spec
405
406* Thu Jun 18 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.3-2
407- 506560 check return value of access
408
409* Mon Apr 27 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.3-1
410- new release
411
412* Fri Apr 24 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-8
413- 496973 close file descriptors after exec
414
415* Mon Mar  9 2009 Tomas Mraz <tmraz@redhat.com> - 1.2-7
416- rebuild
417
418* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-6
419- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
420
421* Tue Dec 23 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-5
422- 477100 NO_FOLLOW was removed, reload after change in symlinked
423  crontab is needed, man updated.
424
425* Fri Oct 24 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-4
426- update init script
427
428* Thu Sep 25 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-3
429- add sendmail file into requirement, cause it's needed some MTA
430
431* Thu Sep 18 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-2
432- 462252  /etc/sysconfig/crond does not need to be executable
433
434* Thu Jun 26 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-1
435- update to 1.2
436
437* Tue Jun 17 2008 Tomas Mraz <tmraz@redhat.com> - 1.1-3
438- fix setting keycreate context
439- unify logging a bit
440- cleanup some warnings and fix a typo in TZ code
441- 450993 improve and fix inotify support
442
443* Wed Jun  4 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.1-2
444- 49864 upgrade/update problem. Syntax error in spec.
445
446* Wed May 28 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.1-1
447- release 1.1
448
449* Tue May 20 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-6
450- 446360 check for lock didn't call chkconfig
451
452* Tue Feb 12 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-5
453- upgrade from less than cronie-1.0-4 didn't add chkconfig
454
455* Wed Feb  6 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-4
456- 431366 after reboot wasn't cron in chkconfig
457
458* Tue Feb  5 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-3
459- 431366 trigger part => after update from vixie-cron on cronie will
460        be daemon running.
461
462* Wed Jan 30 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-2
463- change the provides on higher version than obsoletes
464
465* Tue Jan  8 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-1
466- packaging cronie
467- thank's for help with packaging to my reviewers
Note: See TracBrowser for help on using the repository browser.