source: projects/specs/trunk/c/cppunit/cppunit-vl.spec @ 10462

Revision 10462, 4.2 KB checked in by tomop, 8 years ago (diff)

cppunit-1.12.1-5

Line 
1Name: cppunit
2Version: 1.12.1
3Release: 5%{?_dist_release}
4
5Vendor: Project Vine
6Distribution: Vine Linux
7
8Summary: C++ unit testing framework
9Summary(ja): C++ 単体テストフレームワーク
10License: LGPL
11Group: Development/Tools
12Url: http://cppunit.sourceforge.net/
13#Source: http://download.sf.net/cppunit/cppunit-%{version}.tar.gz
14Source: http://downloads.sourceforge.net/cppunit/cppunit-%{version}.tar.gz
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: doxygen, graphviz
18
19%description
20CppUnit is the C++ port of the famous JUnit framework for unit testing.
21Test output is in XML for automatic testing and GUI based for supervised tests.
22
23%package devel
24Summary: Libraries and headers for cppunit development
25Summary(ja): cppunit 開発用ファイル
26Group: Development/Libraries
27Requires: pkgconfig, automake
28Requires: %{name} = %{version}-%{release}
29
30%description devel
31This package contains the libraries and headers necessary for developing
32programs that use cppunit.
33
34%package doc
35Summary: HTML formatted API documention for cppunit
36Summary(ja): cppunit の API ドキュメント (HTMLフォーマット)
37Group: Applications/Documentation
38Requires: %{name} = %{version}-%{release}
39
40%description doc
41The cppunit-doc package contains HTML formatted API documention generated by
42the popular doxygen documentation generation tool.
43
44
45%prep
46%setup -q
47
48%build
49%configure --enable-doxygen --disable-static
50make %{?_smp_mflags}
51
52%install
53rm -rf $RPM_BUILD_ROOT
54make install DESTDIR=$RPM_BUILD_ROOT
55rm $RPM_BUILD_ROOT%{_libdir}/*.la
56# remove double of doc
57rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/cppunit
58
59# clean up examples
60rm -rf dist-examples dist-examples-dir
61cp -a examples dist-examples
62make -C dist-examples distclean
63# Makefile.am files are left as documentation
64find dist-examples \( -name Makefile.in -o -name .cvsignore \) -exec rm {} \;
65mkdir dist-examples-dir
66mv dist-examples dist-examples-dir/examples
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%post -p /sbin/ldconfig
72
73%postun -p /sbin/ldconfig
74
75%files
76%defattr(-,root,root,-)
77%doc AUTHORS COPYING NEWS README THANKS ChangeLog TODO BUGS doc/FAQ
78%{_bindir}/DllPlugInTester
79%{_libdir}/libcppunit*.so.*
80
81%files devel
82%defattr(-,root,root,-)
83%{_bindir}/cppunit-config
84%{_includedir}/cppunit
85%{_libdir}/libcppunit.so
86%{_datadir}/aclocal/cppunit.m4
87%{_mandir}/man1/cppunit-config.1*
88%{_libdir}/pkgconfig/cppunit.pc
89
90%files doc
91%defattr(-,root,root,-)
92%doc dist-examples-dir/examples/
93%doc doc/html/
94
95%changelog
96* Fri Jul  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.1-5
97- rebuilt with new toolchain.
98
99* Mon Jan 13 2014 NAKAMURA Kenta <kenta@vinelinux.org> 1.12.1-4
100- rebuilt with the current environment
101
102* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 1.12.1-3
103- rebuilt with rpm-4.8.1 for pkg-config
104
105* Tue Mar 23 2010 Shu KONNO <owa@bg.wakwak.com> 1.12.1-2
106- built with new toolchain
107- changed source url
108
109* Sat Nov  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.1-1
110- new upstream release
111- applied new versioning policy
112- spec in UTF-8
113
114* Tue Jul 31 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.0-3vl3
115- rebuilt fot VineSeed
116
117* Tue Jul 31 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.0-3vl2
118- changed Group to Development/Tools
119- changed doc Group to Applications/Documentation
120- rebuilt fot VinePlus/4.0
121
122* Thu May 31 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.12.0-3vl1
123- updated to 1.12.0 release based on FC package
124
125  - Fri Aug  1 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.8.0-0vl2
126  - Rebuild for new Vine.
127
128  - Mon Jun 23 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 1.8.0-0vl1
129  - Initial build.
130
131
132* Mon Jan 29 2007 Patrice Dumas <pertusus@free.fr> 1.12.0-3
133- add rightly files to -devel (#224106)
134- add necessary requires for -devel (#224106)
135- ship examples
136
137* Sun Sep 10 2006 Patrice Dumas <pertusus@free.fr> 1.12.0-2
138- rebuild for FC6
139
140* Wed Jul  5 2006 Patrice Dumas <pertusus@free.fr> 1.12.0-1
141- update to 1.12
142
143* Sun May 21 2006 Patrice Dumas <pertusus@free.fr> 1.11.6-1
144- update to 1.11.6
145
146* Wed Dec 21 2005 Patrice Dumas <pertusus@free.fr> 1.11.4-1
147- update
148
149* Mon Aug 15 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.11.0-2
150- various cleanups
151
152* Mon Jul  4 2005 Patrice Dumas <pertusus@free.fr> 1.11.0-1
153- update using the fedora template
154 
155* Sat Apr 14 2001 Bastiaan Bakker <bastiaan.bakker@lifeline.nl>
156- Initial release
Note: See TracBrowser for help on using the repository browser.