source: projects/specs/trunk/c/cppunit/cppunit-vl.spec @ 10653

Revision 10653, 4.3 KB checked in by takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1Name: cppunit
2Version: 1.13.2
3Release: 1%{?_dist_release}
4
5Vendor: Project Vine
6Distribution: Vine Linux
7
8Summary: C++ unit testing framework
9Summary(ja): C++ 単体テストフレームワーク
10License: LGPL
11Group: Development/Tools
12Url: https://www.freedesktop.org/wiki/Software/cppunit/
13Source: http://dev-www.libreoffice.org/src/%{name}-%{version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: doxygen, graphviz
17
18%description
19CppUnit is the C++ port of the famous JUnit framework for unit testing.
20Test output is in XML for automatic testing and GUI based for supervised tests.
21
22%package devel
23Summary: Libraries and headers for cppunit development
24Summary(ja): cppunit 開発用ファイル
25Group: Development/Libraries
26Requires: pkgconfig, automake
27Requires: %{name} = %{version}-%{release}
28
29%description devel
30This package contains the libraries and headers necessary for developing
31programs that use cppunit.
32
33%package doc
34Summary: HTML formatted API documention for cppunit
35Summary(ja): cppunit の API ドキュメント (HTMLフォーマット)
36Group: Applications/Documentation
37Requires: %{name} = %{version}-%{release}
38
39%description doc
40The cppunit-doc package contains HTML formatted API documention generated by
41the popular doxygen documentation generation tool.
42
43
44%prep
45%setup -q
46
47%build
48%configure --enable-doxygen --disable-static
49make %{?_smp_mflags}
50
51%install
52rm -rf $RPM_BUILD_ROOT
53make install DESTDIR=$RPM_BUILD_ROOT
54rm $RPM_BUILD_ROOT%{_libdir}/*.la
55# remove double of doc
56rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/cppunit
57
58# clean up examples
59rm -rf dist-examples dist-examples-dir
60cp -a examples dist-examples
61make -C dist-examples distclean
62# Makefile.am files are left as documentation
63find dist-examples \( -name Makefile.in -o -name .cvsignore \) -exec rm {} \;
64mkdir dist-examples-dir
65mv dist-examples dist-examples-dir/examples
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%post -p /sbin/ldconfig
71
72%postun -p /sbin/ldconfig
73
74%files
75%defattr(-,root,root,-)
76%doc AUTHORS COPYING NEWS README THANKS ChangeLog TODO BUGS doc/FAQ
77%{_bindir}/DllPlugInTester
78%{_libdir}/libcppunit*.so.*
79
80%files devel
81%defattr(-,root,root,-)
82%{_bindir}/cppunit-config
83%{_includedir}/cppunit
84%{_libdir}/libcppunit.so
85%{_datadir}/aclocal/cppunit.m4
86%{_mandir}/man1/cppunit-config.1*
87%{_libdir}/pkgconfig/cppunit.pc
88
89%files doc
90%defattr(-,root,root,-)
91%doc dist-examples-dir/examples/
92%doc doc/html/
93%{_datadir}/%{name}/html/
94
95%changelog
96* Thu Jul 21 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.13.2-1
97- new upstream release
98
99* Fri Jul  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.1-5
100- rebuilt with new toolchain.
101
102* Mon Jan 13 2014 NAKAMURA Kenta <kenta@vinelinux.org> 1.12.1-4
103- rebuilt with the current environment
104
105* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 1.12.1-3
106- rebuilt with rpm-4.8.1 for pkg-config
107
108* Tue Mar 23 2010 Shu KONNO <owa@bg.wakwak.com> 1.12.1-2
109- built with new toolchain
110- changed source url
111
112* Sat Nov  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.1-1
113- new upstream release
114- applied new versioning policy
115- spec in UTF-8
116
117* Tue Jul 31 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.0-3vl3
118- rebuilt fot VineSeed
119
120* Tue Jul 31 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.0-3vl2
121- changed Group to Development/Tools
122- changed doc Group to Applications/Documentation
123- rebuilt fot VinePlus/4.0
124
125* Thu May 31 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.12.0-3vl1
126- updated to 1.12.0 release based on FC package
127
128  - Fri Aug  1 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.8.0-0vl2
129  - Rebuild for new Vine.
130
131  - Mon Jun 23 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 1.8.0-0vl1
132  - Initial build.
133
134
135* Mon Jan 29 2007 Patrice Dumas <pertusus@free.fr> 1.12.0-3
136- add rightly files to -devel (#224106)
137- add necessary requires for -devel (#224106)
138- ship examples
139
140* Sun Sep 10 2006 Patrice Dumas <pertusus@free.fr> 1.12.0-2
141- rebuild for FC6
142
143* Wed Jul  5 2006 Patrice Dumas <pertusus@free.fr> 1.12.0-1
144- update to 1.12
145
146* Sun May 21 2006 Patrice Dumas <pertusus@free.fr> 1.11.6-1
147- update to 1.11.6
148
149* Wed Dec 21 2005 Patrice Dumas <pertusus@free.fr> 1.11.4-1
150- update
151
152* Mon Aug 15 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.11.0-2
153- various cleanups
154
155* Mon Jul  4 2005 Patrice Dumas <pertusus@free.fr> 1.11.0-1
156- update using the fedora template
157 
158* Sat Apr 14 2001 Bastiaan Bakker <bastiaan.bakker@lifeline.nl>
159- Initial release
Note: See TracBrowser for help on using the repository browser.