source: projects/specs/trunk/c/cppunit/cppunit-vl.spec @ 521

Revision 521, 3.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: cppunit
2Version: 1.12.1
3Release: 1%{?_dist_release}
4
5Summary: C++ unit testing framework
6Summary(ja): C++ 単体テストフレームワーク
7License: LGPL
8Group: Development/Tools
9Url: http://cppunit.sourceforge.net/
10Source: http://download.sf.net/cppunit/cppunit-%{version}.tar.gz
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: doxygen, graphviz
14
15%description
16CppUnit is the C++ port of the famous JUnit framework for unit testing.
17Test output is in XML for automatic testing and GUI based for supervised tests.
18
19%package devel
20Summary: Libraries and headers for cppunit development
21Summary(ja): cppunit 開発用ファイル
22Group: Development/Libraries
23Requires: pkgconfig, automake
24Requires: %{name} = %{version}-%{release}
25
26%description devel
27This package contains the libraries and headers necessary for developing
28programs that use cppunit.
29
30%package doc
31Summary: HTML formatted API documention for cppunit
32Summary(ja): cppunit の API ドキュメント (HTMLフォーマット)
33Group: Applications/Documentation
34Requires: %{name} = %{version}-%{release}
35
36%description doc
37The cppunit-doc package contains HTML formatted API documention generated by
38the popular doxygen documentation generation tool.
39
40
41%prep
42%setup -q
43
44%build
45%configure --enable-doxygen --disable-static
46make %{?_smp_mflags}
47
48%install
49rm -rf $RPM_BUILD_ROOT
50make install DESTDIR=$RPM_BUILD_ROOT
51rm $RPM_BUILD_ROOT%{_libdir}/*.la
52# remove double of doc
53rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/cppunit
54
55# clean up examples
56rm -rf dist-examples dist-examples-dir
57cp -a examples dist-examples
58make -C dist-examples distclean
59# Makefile.am files are left as documentation
60find dist-examples \( -name Makefile.in -o -name .cvsignore \) -exec rm {} \;
61mkdir dist-examples-dir
62mv dist-examples dist-examples-dir/examples
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%post -p /sbin/ldconfig
68
69%postun -p /sbin/ldconfig
70
71%files
72%defattr(-,root,root,-)
73%doc AUTHORS COPYING NEWS README THANKS ChangeLog TODO BUGS doc/FAQ
74%{_bindir}/DllPlugInTester
75%{_libdir}/libcppunit*.so.*
76
77%files devel
78%defattr(-,root,root,-)
79%{_bindir}/cppunit-config
80%{_includedir}/cppunit
81%{_libdir}/libcppunit.so
82%{_datadir}/aclocal/cppunit.m4
83%{_mandir}/man1/cppunit-config.1*
84%{_libdir}/pkgconfig/cppunit.pc
85
86%files doc
87%defattr(-,root,root,-)
88%doc dist-examples-dir/examples/
89%doc doc/html/
90
91%changelog
92* Sat Nov  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.1-1
93- new upstream release
94- applied new versioning policy
95- spec in UTF-8
96
97* Tue Jul 31 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.0-3vl3
98- rebuilt fot VineSeed
99
100* Tue Jul 31 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.0-3vl2
101- changed Group to Development/Tools
102- changed doc Group to Applications/Documentation
103- rebuilt fot VinePlus/4.0
104
105* Thu May 31 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.12.0-3vl1
106- updated to 1.12.0 release based on FC package
107
108  - Fri Aug  1 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.8.0-0vl2
109  - Rebuild for new Vine.
110
111  - Mon Jun 23 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 1.8.0-0vl1
112  - Initial build.
113
114
115* Mon Jan 29 2007 Patrice Dumas <pertusus@free.fr> 1.12.0-3
116- add rightly files to -devel (#224106)
117- add necessary requires for -devel (#224106)
118- ship examples
119
120* Sun Sep 10 2006 Patrice Dumas <pertusus@free.fr> 1.12.0-2
121- rebuild for FC6
122
123* Wed Jul  5 2006 Patrice Dumas <pertusus@free.fr> 1.12.0-1
124- update to 1.12
125
126* Sun May 21 2006 Patrice Dumas <pertusus@free.fr> 1.11.6-1
127- update to 1.11.6
128
129* Wed Dec 21 2005 Patrice Dumas <pertusus@free.fr> 1.11.4-1
130- update
131
132* Mon Aug 15 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.11.0-2
133- various cleanups
134
135* Mon Jul  4 2005 Patrice Dumas <pertusus@free.fr> 1.11.0-1
136- update using the fedora template
137 
138* Sat Apr 14 2001 Bastiaan Bakker <bastiaan.bakker@lifeline.nl>
139- Initial release
Note: See TracBrowser for help on using the repository browser.