source: projects/specs/trunk/c/cpdf/cpdf-vl.spec @ 11618

Revision 11618, 2.6 KB checked in by ara_t, 6 years ago (diff)

cpdf: initial build

Line 
1%define pkg_name    cpdf
2%define pkg_version 2.2
3%define patchlevel  1
4%define pkg_release 1%{?_dist_release}
5
6Summary: Command Line Tools allow you to manipulate existing PDF files
7Name:    %{pkg_name}
8Version: %{pkg_version}.p%{patchlevel}
9Release: %{pkg_release}
10
11License: Coherent Graphics Ltd Non-Commercial Use License Agreement
12Group:   Applications/Publishing
13URL:     http://community.coherentpdf.com/
14
15Source0: cpdf-source-%{pkg_version}-patchlevel%{patchlevel}.tar.gz
16# Source0: camlpdf-%{version}.tar.gz
17
18BuildRequires: readline-devel
19BuildRequires: ocaml
20BuildRequires: ocaml-findlib
21BuildRequires: ocaml-camlpdf
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26
27%description
28The Coherent PDF Command Line Tools allow you to manipulate
29existing PDF files in a variety of ways.
30For example:
31 - Merge PDF files together, or split them apart Encrypt and decrypt
32 - Scale, crop and rotate pages
33 - Read and set document info and metadata
34 - Copy, add or remove bookmarks
35 - Stamp logos, text, dates, page numbers
36 - Add or remove attachments
37 - Losslessly compress PDF files
38
39[caution]
40Now we're releasing them for free, under a special not-for-commercial-use
41license If you like the tools and want to use them commercially,
42or need support, licenses are available from Coherent Graphics Ltd.
43#'
44
45%description -l ja
46Coherent PDF は PDF ファイルを操作するためのコマンドラインツールです。
47
48[注意1]
49このアプリケーションは「非商用に限り」フリーで使用できます。
50詳しくは LICENCE を参照して下さい。
51
52%package libs
53Summary: OCaml library for Coherent PDF
54Group:   Development/Languages
55Requires: ocaml
56Requires: ocaml-findlib
57Requires: ocaml-camlpdf
58
59%description libs
60%{summary}
61
62
63%prep
64%{__rm} -rf ${RPM_BUILD_ROOT}
65%setup -q -n %{name}-source-%{pkg_version}-patchlevel%{patchlevel}
66
67%build
68LDFLAGS="-ltinfo" %{__make}
69
70%install
71# for binary
72%{__mkdir_p} ${RPM_BUILD_ROOT}%{_bindir}
73%{__mkdir_p} ${RPM_BUILD_ROOT}%{_mandir}/man1
74%{__cp} cpdf ${RPM_BUILD_ROOT}%{_bindir}
75%{__cp} cpdf.1 ${RPM_BUILD_ROOT}%{_mandir}/man1
76
77# for libs
78INSTALLDIR=${RPM_BUILD_ROOT}%{_libdir}/ocaml
79%{__mkdir_p} ${INSTALLDIR}
80%{__make} install \
81 OCAMLFIND_INSTFLAGS="-destdir ${INSTALLDIR}"
82
83%clean
84%{__rm} -rf ${RPM_BUILD_ROOT}
85
86%post libs
87echo "%{_libdir}/ocaml/%{pkg_name}" >> %{_libdir}/ocaml/ld.conf
88
89%preun libs
90%{__perl} -pi -e "s|^%{_libdir}/ocaml/%{pkg_name}\n$||" \
91 %{_libdir}/ocaml/ld.conf
92
93
94%files
95%doc doc/cpdf/html
96%doc Changes LICENSE cpdfmanual.pdf
97%{_bindir}/cpdf
98%{_mandir}/man1/*
99
100%files libs
101%{_libdir}/ocaml/cpdf
102
103
104%changelog
105* Sun Apr 15 2018 Toshiaki Ara <ara_t@384.jp> 2.2-pachlevel1
106- initial build for Vine Linux
107
Note: See TracBrowser for help on using the repository browser.