source: projects/specs/trunk/c/cpdf/cpdf-vl.spec @ 12245

Revision 12245, 2.8 KB checked in by ara_t, 5 years ago (diff)

cpdf: update to 2.3

Line 
1%define pkg_name    cpdf
2%define pkg_version 2.3
3# %define patchlevel  1
4%define pkg_release 1%{?_dist_release}
5
6Summary: Command Line Tools allow you to manipulate existing PDF files
7Name:    %{pkg_name}
8Version: %{pkg_version}
9# Version: %{pkg_version}.p%{patchlevel}
10Release: %{pkg_release}
11
12License: Coherent Graphics Ltd Non-Commercial Use License Agreement
13Group:   Applications/Publishing
14URL:     http://community.coherentpdf.com/
15
16Source0: cpdf-source-%{pkg_version}.tar.gz
17# Source0: cpdf-source-%{pkg_version}-patchlevel%{patchlevel}.tar.gz
18
19BuildRequires: readline-devel
20BuildRequires: ocaml
21BuildRequires: ocaml-findlib
22BuildRequires: ocaml-camlpdf = %{pkg_version}
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27
28%description
29The Coherent PDF Command Line Tools allow you to manipulate
30existing PDF files in a variety of ways.
31For example:
32 - Merge PDF files together, or split them apart Encrypt and decrypt
33 - Scale, crop and rotate pages
34 - Read and set document info and metadata
35 - Copy, add or remove bookmarks
36 - Stamp logos, text, dates, page numbers
37 - Add or remove attachments
38 - Losslessly compress PDF files
39
40[caution]
41Now we're releasing them for free, under a special not-for-commercial-use
42license If you like the tools and want to use them commercially,
43or need support, licenses are available from Coherent Graphics Ltd.
44#'
45
46%description -l ja
47Coherent PDF は PDF ファイルを操作するためのコマンドラインツールです。
48
49[注意1]
50このアプリケーションは「非商用に限り」フリーで使用できます。
51詳しくは LICENCE を参照して下さい。
52
53%package libs
54Summary: OCaml library for Coherent PDF
55Group:   Development/Languages
56Requires: ocaml
57Requires: ocaml-findlib
58Requires: ocaml-camlpdf = %{pkg_version}
59
60%description libs
61%{summary}
62
63
64%prep
65%{__rm} -rf ${RPM_BUILD_ROOT}
66%setup -q -n %{name}-source-%{pkg_version}
67# %setup -q -n %{name}-source-%{pkg_version}-patchlevel%{patchlevel}
68
69%build
70LDFLAGS="-ltinfo" %{__make}
71
72%install
73# for binary
74%{__mkdir_p} ${RPM_BUILD_ROOT}%{_bindir}
75%{__mkdir_p} ${RPM_BUILD_ROOT}%{_mandir}/man1
76%{__cp} cpdf ${RPM_BUILD_ROOT}%{_bindir}
77%{__cp} cpdf.1 ${RPM_BUILD_ROOT}%{_mandir}/man1
78
79# for libs
80INSTALLDIR=${RPM_BUILD_ROOT}%{_libdir}/ocaml
81%{__mkdir_p} ${INSTALLDIR}
82%{__make} install \
83 OCAMLFIND_INSTFLAGS="-destdir ${INSTALLDIR}"
84
85%clean
86%{__rm} -rf ${RPM_BUILD_ROOT}
87
88%post libs
89echo "%{_libdir}/ocaml/%{pkg_name}" >> %{_libdir}/ocaml/ld.conf
90
91%preun libs
92%{__perl} -pi -e "s|^%{_libdir}/ocaml/%{pkg_name}\n$||" \
93 %{_libdir}/ocaml/ld.conf
94
95
96%files
97%doc doc/cpdf/html
98%doc Changes LICENSE cpdfmanual.pdf
99%{_bindir}/cpdf
100%{_mandir}/man1/*
101
102%files libs
103%{_libdir}/ocaml/cpdf
104
105
106%changelog
107* Sun Oct 06 2019 Toshiaki Ara <ara_t@384.jp> 2.3-1
108- update to 2.3
109
110* Sun Apr 15 2018 Toshiaki Ara <ara_t@384.jp> 2.2-pachlevel1
111- initial build for Vine Linux
112
Note: See TracBrowser for help on using the repository browser.