source: projects/specs/trunk/c/courier-authlib/courier-authlib-vl.spec @ 521

Revision 521, 7.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Courier authentication library.
2Summary(ja): Courier 認証ライブラリ
3Name: courier-authlib
4Version: 0.63.0
5Release: 1%{?_dist_release}
6License: GPL
7Group: System Environment/Daemons
8URL: http://www.courier-mta.org
9Source0: %{name}-%{version}.tar.bz2
10Patch: %{name}-apop.patch
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: libtool
13BuildRequires: openldap-devel
14BuildRequires: MySQL-devel zlib-devel
15BuildRequires: postgresql-devel
16BuildRequires: gdbm-devel
17BuildRequires: pam-devel
18BuildRequires: expect
19
20Requires(post): /sbin/chkconfig
21Requires(preun): /sbin/chkconfig
22
23%description
24The Courier authentication library provides authentication services for
25other Courier applications.
26
27%description -l ja
28Courier 認証ライブラリは他の Courier アプリケーションへ認証サービスを
29提供します。
30
31
32%package devel
33Summary: Development libraries for the Courier authentication library.
34Summary(ja): Courier 認証ライブラリの開発ライブラリ
35Group: Development/Libraries
36Requires: courier-authlib = %{version}-%{release}
37
38%description devel
39This package contains the development libraries and files needed to compile
40Courier packages that use this authentication library.  Install this
41package in order to build the rest of the Courier packages.  After they are
42built and installed this package can be removed.  Files in this package
43are not needed at runtime.
44
45%description -l ja devel
46認証ライブラリを必要とする Courier パッケージのコンパイルに必要な開発
47ライブラリです。他の Courier パッケージを作成するならインストールして
48ください。作成したパッケージのインストール後は不要ですので削除しても構
49いません。このパッケージに含まれるファイルは実行時には必要ありません。
50
51
52%package ldap
53Summary: LDAP support for the Courier authentication library.
54Summary(ja): Courier 認証ライブラリの LDAP サポート
55Group: System Environment/Daemons
56Requires: courier-authlib = %{version}-%{release}
57Requires: openldap
58
59%description ldap
60This package installs LDAP support for the Courier authentication library.
61Install this package in order to be able to authenticate using LDAP.
62
63%description -l ja ldap
64Courier 認証ライブラリの LDAP サポートパッケージです。LDAP を使った認証を
65行なう場合にインストールしてください。
66
67
68%package pgsql
69Summary: PostgreSQL support for the Courier authentication library.
70Summary(ja): Courier 認証ライブラリの PostgreSQL サポート
71Group: System Environment/Daemons
72Requires: courier-authlib = %{version}-%{release}
73Requires: postgresql-libs, postgresql
74
75%description pgsql
76This package installs PostgreSQL support for the Courier authentication
77library.
78Install this package in order to be able to authenticate using PostgreSQL.
79
80%description -l ja pgsql
81Courier 認証ライブラリの PostgreSQL サポートパッケージです。PostgreSQL を
82使った認証を行なう場合にインストールしてください。
83
84
85%package mysql
86Summary: MySQL support for the Courier authentication library.
87Summary(ja): Courier 認証ライブラリの MySQL サポート
88Group: System Environment/Daemons
89Requires: courier-authlib = %{version}-%{release}
90
91%description mysql
92This package installs MySQL support for the Courier authentication library.
93Install this package in order to be able to authenticate using MySQL.
94
95%description -l ja mysql
96Courier 認証ライブラリの MySQL サポートパッケージです。MySQL を使った認証を
97行なう場合にインストールしてください。
98
99%prep
100%setup -q
101%patch -p1 -b .orig
102
103%build
104#%configure --without-authldap --without-authpgsql
105%configure
106make
107
108%install
109rm -rf %{buildroot}
110make install DESTDIR=%{buildroot}
111rm -f %{buildroot}/%{_libdir}/%{name}/*.a
112install -m 555 sysconftool %{buildroot}/%{_libexecdir}/%{name}
113install -m 555 authmigrate %{buildroot}/%{_libexecdir}/%{name}
114
115#./courierauthconfig --configfiles >configtmp
116#. configtmp
117
118./authmksock %{buildroot}/%{_localstatedir}/spool/authdaemon/socket || exit 1
119touch %{buildroot}/%{_localstatedir}/spool/authdaemon/pid.lock || exit 1
120touch %{buildroot}/%{_localstatedir}/spool/authdaemon/pid || exit 1
121chmod 777 %{buildroot}/%{_localstatedir}/spool/authdaemon/socket || exit 1
122
123mkdir -p %{buildroot}/%{_initdir}
124install -m 555 courier-authlib.sysvinit %{buildroot}/%{_initdir}/courier-authlib
125
126%post
127%{_libexecdir}/%{name}/authmigrate >/dev/null
128%{_libexecdir}/%{name}/sysconftool %{_sysconfdir}/authlib/*.dist >/dev/null
129
130/sbin/chkconfig --del courier-authlib
131/sbin/chkconfig --add courier-authlib
132
133%preun
134if test -x %{_sbindir}/authdaemond
135then
136        %{_sbindir}/authdaemond >/dev/null 2>&1 || /bin/true
137fi
138
139if test "$1" = "0"
140then
141        /sbin/chkconfig --del courier-authlib
142fi
143
144%clean
145rm -rf %{buildroot}
146
147%files
148%defattr(-,root,root)
149%doc README README*html README.authmysql.myownquery README.ldap
150%doc NEWS COPYING* AUTHORS ChangeLog authldap.schema
151%doc README.apop
152/etc/rc.d/init.d/*
153%ghost %attr(600,root,root) %{_localstatedir}/spool/authdaemon/pid.lock
154%ghost %attr(644,root,root) %{_localstatedir}/spool/authdaemon/pid
155%ghost %attr(-,root,root) %{_localstatedir}/spool/authdaemon/socket
156%{_mandir}/man1/*
157%{_mandir}/man8/*
158%defattr(-,daemon,daemon)
159%dir %{_sysconfdir}/authlib
160%{_sysconfdir}/authlib/authdaemonrc.dist
161%{_libexecdir}/%{name}
162%dir %{_libdir}/%{name}
163%{_libdir}/%{name}/libauthcustom*
164%{_libdir}/%{name}/libauthpam*
165%{_libdir}/%{name}/libauthpipe*
166%{_libdir}/%{name}/libauthuser*
167%{_libdir}/%{name}/libcourierauth*
168%dir %attr(750,daemon,daemon) %{_localstatedir}/spool/authdaemon
169%{_sbindir}/*
170
171%files devel
172%defattr(-,root,root)
173%{_bindir}/courierauthconfig
174%{_includedir}/*
175%{_mandir}/man3/*
176%doc authlib.html auth_*.html
177
178%files ldap
179%defattr(-,root,root)
180%{_sysconfdir}/authlib/authldaprc.dist
181%{_libdir}/%{name}/libauthldap*
182
183%files pgsql
184%defattr(-,root,root)
185%{_sysconfdir}/authlib/authpgsqlrc.dist
186%{_libdir}/%{name}/libauthpgsql*
187
188%files mysql
189%defattr(-,root,root)
190%{_sysconfdir}/authlib/authmysqlrc.dist
191%{_libdir}/%{name}/libauthmysql*
192
193
194%changelog
195* Sun Feb 07 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.63.0-1
196- new upstream release.
197- replaced "BuildPreReq:" with "BuilldRequires:".
198
199* Sun Nov 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.62.4-1
200- new upstream release.
201- removed "Requires: MySQL-shared".
202- updated APOP patch.
203
204* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.59.3-2
205- rebuilt with MySQL-shared-5.1.34.
206
207* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-1vl5
208- applied new versioning policy, and spec in utf-8
209- rebuilt with postgresql-8.3.3
210
211* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-0vl3
212- rebuilt
213
214* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-0vl2
215- rebuilt with postgresql-8.2.6
216
217* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.59.3-0vl1
218- new upstream release
219- rebuilt with postgresql 8.2.5
220
221* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.56-0vl4
222- rebuilt with MySQL 5.0.27
223- included /usr/lib/courier-authlib/libauthpipe.*
224
225* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.56-0vl3
226- rebuilt with openldap-2.3.27-0vl1
227
228* Sun May 22 2005 UECHI Yasumasa <uechi@potaway.net> 0.56-0vl2
229- new upstream release
230
231* Mon Mar 28 2005 UECHI Yasumasa <uechi@potaway.net> 0.55-0vl4
232- add ldap, postgresql, mysql packages
233
234* Thu Mar 17 2005 UECHI Yasumasa <uechi@potaway.net> 0.55-0vl1
235- new upstream release
236
237* Thu Feb 17 2005 UECHI Yasumasa <uechi@potaway.net> 0.54-0vl1
238- new upstream release
239
240* Wed Jan 12 2005 UECHI Yasumasa <uechi@potaway.net> 0.53-0vl1
241- new upstream release
242
243* Wed Jan 12 2005 UECHI Yasumasa <uechi@potaway.net> 0.52-0vl1
244- simplify a spec for Vine
245- add apop patch
246
247* Sun Oct  3 2004 Mr. Sam <sam@email-scan.com> - 0.50-1
248- Initial build.
Note: See TracBrowser for help on using the repository browser.