source: projects/specs/trunk/c/courier-authlib/courier-authlib-vl.spec @ 10876

Revision 10876, 8.9 KB checked in by iwaim, 7 years ago (diff)

courier-authlib 0.66.4-4

Line 
1Summary: Courier authentication library.
2Summary(ja): Courier 認証ライブラリ
3Name: courier-authlib
4Version: 0.66.4
5Release: 4%{?_dist_release}
6License: GPLv3
7Group: System Environment/Daemons
8URL: http://www.courier-mta.org
9Source0: %{name}-%{version}.tar.bz2
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildRequires: libtool
12BuildRequires: libtool-ltdl-devel
13BuildRequires: zlib-devel
14BuildRequires: gdbm-devel
15BuildRequires: pam-devel
16BuildRequires: expect
17BuildRequires: courier-unicode-devel > 1.2
18
19Requires(post): /sbin/chkconfig
20Requires(preun): /sbin/chkconfig
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: tomop, iwaim
25
26%description
27The Courier authentication library provides authentication services for
28other Courier applications.
29
30%description -l ja
31Courier 認証ライブラリは他の Courier アプリケーションへ認証サービスを
32提供します。
33
34
35%package devel
36Summary: Development libraries for the Courier authentication library.
37Summary(ja): Courier 認証ライブラリの開発ライブラリ
38Group: Development/Libraries
39Requires: courier-authlib = %{version}-%{release}
40
41%description devel
42This package contains the development libraries and files needed to compile
43Courier packages that use this authentication library.  Install this
44package in order to build the rest of the Courier packages.  After they are
45built and installed this package can be removed.  Files in this package
46are not needed at runtime.
47
48%description -l ja devel
49認証ライブラリを必要とする Courier パッケージのコンパイルに必要な開発
50ライブラリです。他の Courier パッケージを作成するならインストールして
51ください。作成したパッケージのインストール後は不要ですので削除しても構
52いません。このパッケージに含まれるファイルは実行時には必要ありません。
53
54
55%package ldap
56Summary: LDAP support for the Courier authentication library.
57Summary(ja): Courier 認証ライブラリの LDAP サポート
58Group: System Environment/Daemons
59Requires: courier-authlib = %{version}-%{release}
60Requires: openldap
61BuildRequires: openldap-devel
62
63%description ldap
64This package installs LDAP support for the Courier authentication library.
65Install this package in order to be able to authenticate using LDAP.
66
67%description -l ja ldap
68Courier 認証ライブラリの LDAP サポートパッケージです。LDAP を使った認証を
69行なう場合にインストールしてください。
70
71
72%package pgsql
73Summary: PostgreSQL support for the Courier authentication library.
74Summary(ja): Courier 認証ライブラリの PostgreSQL サポート
75Group: System Environment/Daemons
76Requires: courier-authlib = %{version}-%{release}
77%if "%{?_dist_release}" == "vl6"
78BuildRequires: postgresql-devel
79%else
80BuildRequires: libpq-devel
81%endif
82
83%description pgsql
84This package installs PostgreSQL support for the Courier authentication
85library.
86Install this package in order to be able to authenticate using PostgreSQL.
87
88%description -l ja pgsql
89Courier 認証ライブラリの PostgreSQL サポートパッケージです。PostgreSQL を
90使った認証を行なう場合にインストールしてください。
91
92
93%package mysql
94Summary: MySQL support for the Courier authentication library.
95Summary(ja): Courier 認証ライブラリの MySQL サポート
96Group: System Environment/Daemons
97Requires: courier-authlib = %{version}-%{release}
98%if "%{?_dist_release}" == "vl6"
99BuildRequires: MySQL-devel
100%else
101BuildRequires: libmysqlclient-devel
102%endif
103
104%description mysql
105This package installs MySQL support for the Courier authentication library.
106Install this package in order to be able to authenticate using MySQL.
107
108%description -l ja mysql
109Courier 認証ライブラリの MySQL サポートパッケージです。MySQL を使った認証を
110行なう場合にインストールしてください。
111
112%prep
113%setup -q
114
115%build
116#%configure --without-authldap --without-authpgsql
117%configure
118make
119
120%install
121rm -rf %{buildroot}
122make install DESTDIR=%{buildroot}
123rm -f %{buildroot}/%{_libdir}/%{name}/*.a
124install -m 555 sysconftool %{buildroot}/%{_libexecdir}/%{name}
125install -m 555 authmigrate %{buildroot}/%{_libexecdir}/%{name}
126
127#./courierauthconfig --configfiles >configtmp
128#. configtmp
129
130./authmksock %{buildroot}/%{_localstatedir}/spool/authdaemon/socket || exit 1
131touch %{buildroot}/%{_localstatedir}/spool/authdaemon/pid.lock || exit 1
132touch %{buildroot}/%{_localstatedir}/spool/authdaemon/pid || exit 1
133chmod 777 %{buildroot}/%{_localstatedir}/spool/authdaemon/socket || exit 1
134
135mkdir -p %{buildroot}/%{_initdir}
136install -m 555 courier-authlib.sysvinit %{buildroot}/%{_initdir}/courier-authlib
137
138%post
139%{_libexecdir}/%{name}/authmigrate >/dev/null
140%{_libexecdir}/%{name}/sysconftool %{_sysconfdir}/authlib/*.dist >/dev/null
141
142/sbin/chkconfig --del courier-authlib
143/sbin/chkconfig --add courier-authlib
144
145%preun
146if test -x %{_sbindir}/authdaemond
147then
148        %{_sbindir}/authdaemond >/dev/null 2>&1 || /bin/true
149fi
150
151if test "$1" = "0"
152then
153        /sbin/chkconfig --del courier-authlib
154fi
155
156%clean
157rm -rf %{buildroot}
158
159%files
160%defattr(-,root,root)
161%doc README README*html README.authmysql.myownquery README.ldap
162%doc NEWS COPYING* AUTHORS ChangeLog authldap.schema
163/etc/rc.d/init.d/*
164%ghost %attr(600,root,root) %{_localstatedir}/spool/authdaemon/pid.lock
165%ghost %attr(644,root,root) %{_localstatedir}/spool/authdaemon/pid
166%ghost %attr(-,root,root) %{_localstatedir}/spool/authdaemon/socket
167%{_mandir}/man1/*
168%{_mandir}/man8/*
169%defattr(-,daemon,daemon)
170%dir %{_sysconfdir}/authlib
171%{_sysconfdir}/authlib/authdaemonrc.dist
172%{_libexecdir}/%{name}
173%dir %{_libdir}/%{name}
174%{_libdir}/%{name}/libauthcustom*
175%{_libdir}/%{name}/libauthpam*
176%{_libdir}/%{name}/libauthpipe*
177%{_libdir}/%{name}/libauthuser*
178%{_libdir}/%{name}/libcourierauth*
179%dir %attr(750,daemon,daemon) %{_localstatedir}/spool/authdaemon
180%{_sbindir}/*
181
182%files devel
183%defattr(-,root,root)
184%{_bindir}/courierauthconfig
185%{_includedir}/*
186%{_mandir}/man3/*
187%doc authlib.html auth_*.html
188
189%files ldap
190%defattr(-,root,root)
191%{_sysconfdir}/authlib/authldaprc.dist
192%{_libdir}/%{name}/libauthldap*
193
194%files pgsql
195%defattr(-,root,root)
196%{_sysconfdir}/authlib/authpgsqlrc.dist
197%{_libdir}/%{name}/libauthpgsql*
198
199%files mysql
200%defattr(-,root,root)
201%{_sysconfdir}/authlib/authmysqlrc.dist
202%{_libdir}/%{name}/libauthmysql*
203
204
205%changelog
206* Thu Jan  5 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 0.66.4-4
207- fix typo for VineSeed
208
209* Thu Jan  5 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 0.66.4-3
210- build for Vine Linux 6
211
212* Fri May  6 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 0.66.4-2
213- build with openssl 1.0.2 for courier-authlib-mysql
214
215* Tue Dec 29 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 0.66.4-1
216- update to 0.66.4
217- add BuildRequires: courier-unicode-devel > 1.2
218- update License tag
219- add Packager: iwaim
220
221* Sun Jul 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.66.1-2
222- rebuilt with current environment.
223- replaced BR:MySQL-devel to BR:libmysqlclient-devel.
224- replaced BR:postgresql-devel to BR:libpq-devel.
225- dropped R:postgresql-libs (detected by autoreq).
226- dropped R:postgresql.
227
228* Sat Jan  4 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.66.1-1
229- update to 0.66.1
230- drop APOP patch (Patch0)
231- add BuildRequires: libtool-ltdl-devel
232
233* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.63.0-2
234- Rebuilt with new toolchain.
235
236* Sun Feb 07 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.63.0-1
237- new upstream release.
238- replaced "BuildPreReq:" with "BuilldRequires:".
239
240* Sun Nov 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.62.4-1
241- new upstream release.
242- removed "Requires: MySQL-shared".
243- updated APOP patch.
244
245* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.59.3-2
246- rebuilt with MySQL-shared-5.1.34.
247
248* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-1vl5
249- applied new versioning policy, and spec in utf-8
250- rebuilt with postgresql-8.3.3
251
252* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-0vl3
253- rebuilt
254
255* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-0vl2
256- rebuilt with postgresql-8.2.6
257
258* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.59.3-0vl1
259- new upstream release
260- rebuilt with postgresql 8.2.5
261
262* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.56-0vl4
263- rebuilt with MySQL 5.0.27
264- included /usr/lib/courier-authlib/libauthpipe.*
265
266* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.56-0vl3
267- rebuilt with openldap-2.3.27-0vl1
268
269* Sun May 22 2005 UECHI Yasumasa <uechi@potaway.net> 0.56-0vl2
270- new upstream release
271
272* Mon Mar 28 2005 UECHI Yasumasa <uechi@potaway.net> 0.55-0vl4
273- add ldap, postgresql, mysql packages
274
275* Thu Mar 17 2005 UECHI Yasumasa <uechi@potaway.net> 0.55-0vl1
276- new upstream release
277
278* Thu Feb 17 2005 UECHI Yasumasa <uechi@potaway.net> 0.54-0vl1
279- new upstream release
280
281* Wed Jan 12 2005 UECHI Yasumasa <uechi@potaway.net> 0.53-0vl1
282- new upstream release
283
284* Wed Jan 12 2005 UECHI Yasumasa <uechi@potaway.net> 0.52-0vl1
285- simplify a spec for Vine
286- add apop patch
287
288* Sun Oct  3 2004 Mr. Sam <sam@email-scan.com> - 0.50-1
289- Initial build.
Note: See TracBrowser for help on using the repository browser.