source: projects/specs/trunk/c/courier-authlib/courier-authlib-vl.spec @ 9923

Revision 9923, 8.5 KB checked in by iwaim, 8 years ago (diff)

courier-authlib-0.66.4-1

Line 
1Summary: Courier authentication library.
2Summary(ja): Courier 認証ライブラリ
3Name: courier-authlib
4Version: 0.66.4
5Release: 1%{?_dist_release}
6License: GPLv3
7Group: System Environment/Daemons
8URL: http://www.courier-mta.org
9Source0: %{name}-%{version}.tar.bz2
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildRequires: libtool
12BuildRequires: libtool-ltdl-devel
13BuildRequires: openldap-devel
14BuildRequires: libmysqlclient-devel zlib-devel
15BuildRequires: libpq-devel
16BuildRequires: gdbm-devel
17BuildRequires: pam-devel
18BuildRequires: expect
19BuildRequires: courier-unicode-devel > 1.2
20
21Requires(post): /sbin/chkconfig
22Requires(preun): /sbin/chkconfig
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: tomop, iwaim
27
28%description
29The Courier authentication library provides authentication services for
30other Courier applications.
31
32%description -l ja
33Courier 認証ライブラリは他の Courier アプリケーションへ認証サービスを
34提供します。
35
36
37%package devel
38Summary: Development libraries for the Courier authentication library.
39Summary(ja): Courier 認証ライブラリの開発ライブラリ
40Group: Development/Libraries
41Requires: courier-authlib = %{version}-%{release}
42
43%description devel
44This package contains the development libraries and files needed to compile
45Courier packages that use this authentication library.  Install this
46package in order to build the rest of the Courier packages.  After they are
47built and installed this package can be removed.  Files in this package
48are not needed at runtime.
49
50%description -l ja devel
51認証ライブラリを必要とする Courier パッケージのコンパイルに必要な開発
52ライブラリです。他の Courier パッケージを作成するならインストールして
53ください。作成したパッケージのインストール後は不要ですので削除しても構
54いません。このパッケージに含まれるファイルは実行時には必要ありません。
55
56
57%package ldap
58Summary: LDAP support for the Courier authentication library.
59Summary(ja): Courier 認証ライブラリの LDAP サポート
60Group: System Environment/Daemons
61Requires: courier-authlib = %{version}-%{release}
62Requires: openldap
63
64%description ldap
65This package installs LDAP support for the Courier authentication library.
66Install this package in order to be able to authenticate using LDAP.
67
68%description -l ja ldap
69Courier 認証ライブラリの LDAP サポートパッケージです。LDAP を使った認証を
70行なう場合にインストールしてください。
71
72
73%package pgsql
74Summary: PostgreSQL support for the Courier authentication library.
75Summary(ja): Courier 認証ライブラリの PostgreSQL サポート
76Group: System Environment/Daemons
77Requires: courier-authlib = %{version}-%{release}
78
79%description pgsql
80This package installs PostgreSQL support for the Courier authentication
81library.
82Install this package in order to be able to authenticate using PostgreSQL.
83
84%description -l ja pgsql
85Courier 認証ライブラリの PostgreSQL サポートパッケージです。PostgreSQL を
86使った認証を行なう場合にインストールしてください。
87
88
89%package mysql
90Summary: MySQL support for the Courier authentication library.
91Summary(ja): Courier 認証ライブラリの MySQL サポート
92Group: System Environment/Daemons
93Requires: courier-authlib = %{version}-%{release}
94
95%description mysql
96This package installs MySQL support for the Courier authentication library.
97Install this package in order to be able to authenticate using MySQL.
98
99%description -l ja mysql
100Courier 認証ライブラリの MySQL サポートパッケージです。MySQL を使った認証を
101行なう場合にインストールしてください。
102
103%prep
104%setup -q
105
106%build
107#%configure --without-authldap --without-authpgsql
108%configure
109make
110
111%install
112rm -rf %{buildroot}
113make install DESTDIR=%{buildroot}
114rm -f %{buildroot}/%{_libdir}/%{name}/*.a
115install -m 555 sysconftool %{buildroot}/%{_libexecdir}/%{name}
116install -m 555 authmigrate %{buildroot}/%{_libexecdir}/%{name}
117
118#./courierauthconfig --configfiles >configtmp
119#. configtmp
120
121./authmksock %{buildroot}/%{_localstatedir}/spool/authdaemon/socket || exit 1
122touch %{buildroot}/%{_localstatedir}/spool/authdaemon/pid.lock || exit 1
123touch %{buildroot}/%{_localstatedir}/spool/authdaemon/pid || exit 1
124chmod 777 %{buildroot}/%{_localstatedir}/spool/authdaemon/socket || exit 1
125
126mkdir -p %{buildroot}/%{_initdir}
127install -m 555 courier-authlib.sysvinit %{buildroot}/%{_initdir}/courier-authlib
128
129%post
130%{_libexecdir}/%{name}/authmigrate >/dev/null
131%{_libexecdir}/%{name}/sysconftool %{_sysconfdir}/authlib/*.dist >/dev/null
132
133/sbin/chkconfig --del courier-authlib
134/sbin/chkconfig --add courier-authlib
135
136%preun
137if test -x %{_sbindir}/authdaemond
138then
139        %{_sbindir}/authdaemond >/dev/null 2>&1 || /bin/true
140fi
141
142if test "$1" = "0"
143then
144        /sbin/chkconfig --del courier-authlib
145fi
146
147%clean
148rm -rf %{buildroot}
149
150%files
151%defattr(-,root,root)
152%doc README README*html README.authmysql.myownquery README.ldap
153%doc NEWS COPYING* AUTHORS ChangeLog authldap.schema
154/etc/rc.d/init.d/*
155%ghost %attr(600,root,root) %{_localstatedir}/spool/authdaemon/pid.lock
156%ghost %attr(644,root,root) %{_localstatedir}/spool/authdaemon/pid
157%ghost %attr(-,root,root) %{_localstatedir}/spool/authdaemon/socket
158%{_mandir}/man1/*
159%{_mandir}/man8/*
160%defattr(-,daemon,daemon)
161%dir %{_sysconfdir}/authlib
162%{_sysconfdir}/authlib/authdaemonrc.dist
163%{_libexecdir}/%{name}
164%dir %{_libdir}/%{name}
165%{_libdir}/%{name}/libauthcustom*
166%{_libdir}/%{name}/libauthpam*
167%{_libdir}/%{name}/libauthpipe*
168%{_libdir}/%{name}/libauthuser*
169%{_libdir}/%{name}/libcourierauth*
170%dir %attr(750,daemon,daemon) %{_localstatedir}/spool/authdaemon
171%{_sbindir}/*
172
173%files devel
174%defattr(-,root,root)
175%{_bindir}/courierauthconfig
176%{_includedir}/*
177%{_mandir}/man3/*
178%doc authlib.html auth_*.html
179
180%files ldap
181%defattr(-,root,root)
182%{_sysconfdir}/authlib/authldaprc.dist
183%{_libdir}/%{name}/libauthldap*
184
185%files pgsql
186%defattr(-,root,root)
187%{_sysconfdir}/authlib/authpgsqlrc.dist
188%{_libdir}/%{name}/libauthpgsql*
189
190%files mysql
191%defattr(-,root,root)
192%{_sysconfdir}/authlib/authmysqlrc.dist
193%{_libdir}/%{name}/libauthmysql*
194
195
196%changelog
197* Tue Dec 29 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 0.66.4-1
198- update to 0.66.4
199- add BuildRequires: courier-unicode-devel > 1.2
200- update License tag
201- add Packager: iwaim
202
203* Sun Jul 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.66.1-2
204- rebuilt with current environment.
205- replaced BR:MySQL-devel to BR:libmysqlclient-devel.
206- replaced BR:postgresql-devel to BR:libpq-devel.
207- dropped R:postgresql-libs (detected by autoreq).
208- dropped R:postgresql.
209
210* Sat Jan  4 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.66.1-1
211- update to 0.66.1
212- drop APOP patch (Patch0)
213- add BuildRequires: libtool-ltdl-devel
214
215* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.63.0-2
216- Rebuilt with new toolchain.
217
218* Sun Feb 07 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.63.0-1
219- new upstream release.
220- replaced "BuildPreReq:" with "BuilldRequires:".
221
222* Sun Nov 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.62.4-1
223- new upstream release.
224- removed "Requires: MySQL-shared".
225- updated APOP patch.
226
227* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.59.3-2
228- rebuilt with MySQL-shared-5.1.34.
229
230* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-1vl5
231- applied new versioning policy, and spec in utf-8
232- rebuilt with postgresql-8.3.3
233
234* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-0vl3
235- rebuilt
236
237* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-0vl2
238- rebuilt with postgresql-8.2.6
239
240* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.59.3-0vl1
241- new upstream release
242- rebuilt with postgresql 8.2.5
243
244* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.56-0vl4
245- rebuilt with MySQL 5.0.27
246- included /usr/lib/courier-authlib/libauthpipe.*
247
248* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.56-0vl3
249- rebuilt with openldap-2.3.27-0vl1
250
251* Sun May 22 2005 UECHI Yasumasa <uechi@potaway.net> 0.56-0vl2
252- new upstream release
253
254* Mon Mar 28 2005 UECHI Yasumasa <uechi@potaway.net> 0.55-0vl4
255- add ldap, postgresql, mysql packages
256
257* Thu Mar 17 2005 UECHI Yasumasa <uechi@potaway.net> 0.55-0vl1
258- new upstream release
259
260* Thu Feb 17 2005 UECHI Yasumasa <uechi@potaway.net> 0.54-0vl1
261- new upstream release
262
263* Wed Jan 12 2005 UECHI Yasumasa <uechi@potaway.net> 0.53-0vl1
264- new upstream release
265
266* Wed Jan 12 2005 UECHI Yasumasa <uechi@potaway.net> 0.52-0vl1
267- simplify a spec for Vine
268- add apop patch
269
270* Sun Oct  3 2004 Mr. Sam <sam@email-scan.com> - 0.50-1
271- Initial build.
Note: See TracBrowser for help on using the repository browser.