source: projects/specs/trunk/c/corosync/corosync-vl.spec @ 6424

Revision 6424, 14.1 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1Name: corosync
2Summary: The Corosync Cluster Engine and Application Programming Interfaces
3Summary(ja): Corosyncクラスタエンジンおよびアプリケーションプログラミングインタフェース
4Version: 1.4.3
5Release: 1%{?_dist_release}
6License: BSD
7Group: System Environment/Base
8URL: http://ftp.corosync.org
9Source0: ftp://ftp:downloads@ftp.corosync.org/downloads/%{name}-%{version}/%{name}-%{version}.tar.gz
10
11# Runtime bits
12Requires: corosynclib = %{version}-%{release}
13Requires(pre): shadow-utils
14Requires(post): chkconfig
15Requires(preun): chkconfig
16
17# Build bits
18
19%define buildtrunk 0
20%{?_with_buildtrunk: %define buildtrunk 1}
21%define enablerdma 0
22%{?_with_rdma: %define enablerdma 1}
23
24%if %{buildtrunk}
25BuildRequires: autoconf automake
26%endif
27BuildRequires: nss-devel
28%if %{enablerdma}
29BuildRequires: libibverbs-devel librdmacm-devel
30%endif
31
32BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
33
34%prep
35%setup -q -n %{name}-%{version}
36
37%build
38%if %{buildtrunk}
39./autogen.sh
40%endif
41
42%if %{enablerdma}
43export ibverbs_CFLAGS=-I/usr/include/infiniband \
44export ibverbs_LIBS=-libverbs \
45export rdmacm_CFLAGS=-I/usr/include/rdma \
46export rdmacm_LIBS=-lrdmacm \
47%endif
48%{configure} \
49        --enable-nss \
50%if %{enablerdma}
51        --enable-rdma \
52%endif
53        --with-initddir=%{_initrddir}
54
55make %{_smp_mflags}
56
57%install
58rm -rf %{buildroot}
59
60make install DESTDIR=%{buildroot}
61
62## tree fixup
63# drop static libs
64rm -f %{buildroot}%{_libdir}/*.a
65# drop docs and html docs for now
66rm -rf %{buildroot}%{_docdir}/*
67
68%clean
69rm -rf %{buildroot}
70
71%description
72This package contains the Corosync Cluster Engine Executive, several default
73APIs and libraries, default configuration files, and an init script.
74
75%post
76if [ $1 -eq 1 ]; then
77        /sbin/chkconfig --add corosync || :
78fi
79
80%preun
81if [ $1 -eq 0 ]; then
82        /sbin/service corosync stop &>/dev/null || :
83        /sbin/chkconfig --del corosync || :
84fi
85
86%files
87%defattr(-,root,root,-)
88%doc LICENSE SECURITY
89%{_bindir}/corosync-blackbox
90%{_sbindir}/corosync
91%{_sbindir}/corosync-keygen
92%{_sbindir}/corosync-objctl
93%{_sbindir}/corosync-cfgtool
94%{_sbindir}/corosync-fplay
95%{_sbindir}/corosync-pload
96%{_sbindir}/corosync-cpgtool
97%{_sbindir}/corosync-quorumtool
98%{_sbindir}/corosync-notifyd
99%dir %{_sysconfdir}/corosync
100%dir %{_sysconfdir}/corosync/service.d
101%dir %{_sysconfdir}/corosync/uidgid.d
102%config(noreplace) %{_sysconfdir}/corosync/corosync.conf.example
103%config(noreplace) %{_sysconfdir}/corosync/corosync.conf.example.udpu
104%{_initrddir}/corosync
105%{_initrddir}/corosync-notifyd
106%dir %{_libexecdir}/lcrso
107%{_libexecdir}/lcrso/coroparse.lcrso
108%{_libexecdir}/lcrso/objdb.lcrso
109%{_libexecdir}/lcrso/service_cfg.lcrso
110%{_libexecdir}/lcrso/service_cpg.lcrso
111%{_libexecdir}/lcrso/service_evs.lcrso
112%{_libexecdir}/lcrso/service_confdb.lcrso
113%{_libexecdir}/lcrso/service_pload.lcrso
114%{_libexecdir}/lcrso/quorum_votequorum.lcrso
115%{_libexecdir}/lcrso/quorum_testquorum.lcrso
116%{_libexecdir}/lcrso/vsf_quorum.lcrso
117%{_libexecdir}/lcrso/vsf_ykd.lcrso
118%dir %{_localstatedir}/lib/corosync
119%dir %{_localstatedir}/log/cluster
120%{_mandir}/man8/corosync_overview.8*
121%{_mandir}/man8/corosync.8*
122%{_mandir}/man8/corosync-blackbox.8*
123%{_mandir}/man8/corosync-objctl.8*
124%{_mandir}/man8/corosync-keygen.8*
125%{_mandir}/man8/corosync-cfgtool.8*
126%{_mandir}/man8/corosync-cpgtool.8*
127%{_mandir}/man8/corosync-fplay.8*
128%{_mandir}/man8/corosync-pload.8*
129%{_mandir}/man8/corosync-quorumtool.8*
130%{_mandir}/man8/corosync-notifyd.8*
131%{_mandir}/man5/corosync.conf.5*
132
133%package -n corosynclib
134Summary: The Corosync Cluster Engine Libraries
135Summary(ja): The Corosync Cluster Engine Libraries
136Group: System Environment/Libraries
137Requires: %{name} = %{version}-%{release}
138
139%description -n corosynclib
140This package contains corosync libraries.
141
142%files -n corosynclib
143%defattr(-,root,root,-)
144%doc LICENSE
145%{_libdir}/libcfg.so.*
146%{_libdir}/libcpg.so.*
147%{_libdir}/libconfdb.so.*
148%{_libdir}/libevs.so.*
149%{_libdir}/libtotem_pg.so.*
150%{_libdir}/liblogsys.so.*
151%{_libdir}/libcoroipcc.so.*
152%{_libdir}/libcoroipcs.so.*
153%{_libdir}/libquorum.so.*
154%{_libdir}/libvotequorum.so.*
155%{_libdir}/libpload.so.*
156%{_libdir}/libsam.so.*
157
158%post -n corosynclib -p /sbin/ldconfig
159
160%postun -n corosynclib -p /sbin/ldconfig
161
162%package -n corosynclib-devel
163Summary: The Corosync Cluster Engine Development Kit
164Summary(ja): The Corosync Cluster Engine Development Kit
165Group: Development/Libraries
166Requires: corosynclib = %{version}-%{release}
167Requires: pkgconfig
168Provides: corosync-devel = %{version}
169Obsoletes: corosync-devel < 0.92-7
170
171%description -n corosynclib-devel
172This package contains include files and man pages used to develop using
173The Corosync Cluster Engine APIs.
174
175%files -n corosynclib-devel
176%defattr(-,root,root,-)
177%doc LICENSE README.devmap
178%dir %{_includedir}/corosync/
179%{_includedir}/corosync/cs_config.h
180%{_includedir}/corosync/corodefs.h
181%{_includedir}/corosync/coroipc_types.h
182%{_includedir}/corosync/coroipcs.h
183%{_includedir}/corosync/coroipcc.h
184%{_includedir}/corosync/cfg.h
185%{_includedir}/corosync/confdb.h
186%{_includedir}/corosync/corotypes.h
187%{_includedir}/corosync/cpg.h
188%{_includedir}/corosync/evs.h
189%{_includedir}/corosync/hdb.h
190%{_includedir}/corosync/list.h
191%{_includedir}/corosync/mar_gen.h
192%{_includedir}/corosync/sam.h
193%{_includedir}/corosync/swab.h
194%{_includedir}/corosync/quorum.h
195%{_includedir}/corosync/votequorum.h
196%dir %{_includedir}/corosync/totem/
197%{_includedir}/corosync/totem/coropoll.h
198%{_includedir}/corosync/totem/totem.h
199%{_includedir}/corosync/totem/totemip.h
200%{_includedir}/corosync/totem/totempg.h
201%dir %{_includedir}/corosync/lcr/
202%{_includedir}/corosync/lcr/lcr_ckpt.h
203%{_includedir}/corosync/lcr/lcr_comp.h
204%{_includedir}/corosync/lcr/lcr_ifact.h
205%dir %{_includedir}/corosync/engine
206%{_includedir}/corosync/engine/config.h
207%{_includedir}/corosync/engine/coroapi.h
208%{_includedir}/corosync/engine/logsys.h
209%{_includedir}/corosync/engine/objdb.h
210%{_includedir}/corosync/engine/quorum.h
211%{_libdir}/libcfg.so
212%{_libdir}/libcpg.so
213%{_libdir}/libconfdb.so
214%{_libdir}/libevs.so
215%{_libdir}/libtotem_pg.so
216%{_libdir}/liblogsys.so
217%{_libdir}/libcoroipcc.so
218%{_libdir}/libcoroipcs.so
219%{_libdir}/libquorum.so
220%{_libdir}/libvotequorum.so
221%{_libdir}/libpload.so
222%{_libdir}/libsam.so
223%{_libdir}/pkgconfig/*.pc
224%{_mandir}/man3/cpg_*3*
225%{_mandir}/man3/evs_*3*
226%{_mandir}/man3/confdb_*3*
227%{_mandir}/man3/votequorum_*3*
228%{_mandir}/man3/sam_*3*
229%{_mandir}/man8/cpg_overview.8*
230%{_mandir}/man8/evs_overview.8*
231%{_mandir}/man8/confdb_overview.8*
232%{_mandir}/man8/logsys_overview.8*
233%{_mandir}/man8/votequorum_overview.8*
234%{_mandir}/man8/coroipc_overview.8*
235%{_mandir}/man8/sam_overview.8*
236
237%changelog
238* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
239- new upstream release
240
241* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-1
242- initial build for Vine Linux
243
244* Mon Jul  5 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.6-1
245- New upstream release
246- Resync spec file with upstream changes
247
248* Tue May 25 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.3-1
249- New upstream release
250- Rediff revision 2770 patch
251
252* Mon May 17 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.2-1
253- New upstream release
254- Add upstream trunk revision 2770 to add cpg_model_initialize api.
255- Fix URL and Source0 entries.
256- Add workaround to broken 1.2.2 Makefile with make -j.
257
258* Wed Mar 24 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.1-1
259- New upstream release
260
261* Tue Dec  8 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.0-1
262- New upstream release
263- Use global instead of define
264- Update Source0 url
265- Use more %name macro around
266- Cleanup install section. Init script is now installed by upstream
267- Cleanup whitespace
268- Don't deadlock between package upgrade and corosync condrestart
269- Ship service.d config directory
270- Fix Conflicts vs Requires
271- Ship new sam library and man pages
272
273* Fri Oct 23 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.1.2-1
274- New upstream release fixes major regression on specific loads
275
276* Wed Oct 21 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.1.1-1
277- New upstream release
278
279* Fri Sep 25 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.1.0-1
280- New upstream release
281- spec file updates:
282  * enable IB support
283  * explicitly define built-in features at configure time
284
285* Tue Sep 22 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.1-1
286- New upstream release
287- spec file updates:
288  * use proper configure macro
289
290* Tue Jul 28 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.0-3
291- spec file updates:
292  * more consistent use of macros across the board
293  * fix directory ownership
294
295* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
296- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
297
298* Wed Jul  8 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.0-1
299- New upstream release
300
301* Thu Jul  2 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.100-1
302- New upstream release
303
304* Sat Jun 20 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.98-1
305- New upstream release
306- spec file updates:
307  * Drop corosync-trunk patch and alpha tag.
308  * Fix alphatag vs buildtrunk handling.
309  * Drop requirement on ais user/group and stop creating them.
310  * New config file locations from upstream: /etc/corosync/corosync.conf.
311
312* Wed Jun 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.97-1.svn2233
313- spec file updates:
314  * Update to svn version 2233 to include library linking fixes
315
316* Wed Jun 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.97-1.svn2232
317- New upstream release
318- spec file updates:
319  * Drop pkgconfig fix that's now upstream
320  * Update to svn version 2232
321  * Define buildtrunk if we are using svn snapshots
322  * BuildRequires: nss-devel to enable nss crypto for network communication
323  * Force autogen invokation if buildtrunk is defined
324  * Whitespace cleanup
325  * Stop shipping corosync.conf in favour of a generic example
326  * Update file list
327
328* Mon Mar 30 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.95-2
329- Backport svn commit 1913 to fix pkgconfig files generation
330  and unbreak lvm2 build.
331
332* Tue Mar 24 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.95-1
333- New upstream release
334- spec file updates:
335  * Drop alpha tag
336  * Drop local patches (no longer required)
337  * Allow to build from svn trunk by supporting rpmbuild --with buildtrunk
338  * BuildRequires autoconf automake if building from trunk
339  * Execute autogen.sh if building from trunk and if no configure is available
340  * Switch to use rpm configure macro and set standard install paths
341  * Build invokation now supports _smp_mflags
342  * Remove install section for docs and use proper doc macro instead
343  * Add tree fixup bits to drop static libs and html docs (only for now)
344  * Add LICENSE file to all subpackages
345  * libraries have moved to libdir. Drop ld.so.conf.d corosync file
346  * Update BuildRoot usage to preferred versions/names
347
348* Tue Mar 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-5.svn1797
349- Update the corosync-trunk patch for real this time.
350
351* Tue Mar 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-4.svn1797
352- Import fixes from upstream:
353  * Cleanup logsys format init around to use default settings (1795)
354  * logsys_format_set should use its own internal copy of format_buffer (1796)
355  * Add logsys_format_get to logsys API (1797)
356- Cherry pick svn1807 to unbreak CPG.
357
358* Mon Mar  9 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-3.svn1794
359- Import fixes from upstream:
360  * Add reserve/release feature to totem message queue space (1793)
361  * Fix CG shutdown (1794)
362
363* Fri Mar  6 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-2.svn1792
364- Import fixes from upstream:
365  * Fix uninitialized memory. Spotted by valgrind (1788)
366  * Fix logsys_set_format by updating the right bits (1789)
367  * logsys: re-add support for timestamp  (1790)
368  * Fix cpg crash (1791)
369  * Allow logsys_format_set to reset to default (1792)
370
371* Tue Mar  3 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-1
372- New upstream release.
373- Drop obsolete patches.
374- Add soname bump patch that was missing from upstream.
375
376* Wed Feb 25 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.93-4
377- Add Makefile fix to install all corosync tools (commit r1780)
378
379* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
380- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
381
382* Mon Feb 23 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.93-2
383- Rename gcc-4.4 patch to match svn commit (r1767).
384- Backport patch from trunk (commit r1774) to fix quorum engine.
385
386* Thu Feb 19 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.93-1
387- New upstream release.
388- Drop alphatag from spec file.
389- Drop trunk patch.
390- Update Provides for corosynclib-devel.
391- Backport gcc-4.4 build fix from trunk.
392
393* Mon Feb  2 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-7.svn1756
394- Update to svn trunk at revision 1756 from upstream.
395- Add support pkgconfig to devel package.
396- Tidy up spec files by re-organazing sections according to packages.
397- Split libraries from corosync to corosynclib.
398- Rename corosync-devel to corosynclib-devel.
399- Comply with multiarch requirements (libraries).
400
401* Tue Jan 27 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-6.svn1750
402- Update to svn trunk at revision 1750 from upstream.
403- Include new quorum service in the packaging.
404
405* Mon Dec 15 2008 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-5.svn1709
406- Update to svn trunk at revision 1709 from upstream.
407- Update spec file to include new include files.
408
409* Wed Dec 10 2008 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-4.svn1707
410- Update to svn trunk at revision 1707 from upstream.
411- Update spec file to include new lcrso services and include file.
412
413* Mon Oct 13 2008 Dennis Gilmore <dennis@ausil.us> - 0.92-3
414- remove ExclusiveArch line
415
416* Fri Sep 24 2008 Steven Dake <sdake@redhat.com> - 0.92-2
417- Add conflicts for openais and openais-devel packages older then 0.90.
418
419* Wed Sep 24 2008 Steven Dake <sdake@redhat.com> - 0.92-1
420- New upstream release corosync-0.92.
421
422* Sun Aug 24 2008 Steven Dake <sdake@redhat.com> - 0.91-3
423- move logsys_overview.8.* to devel package.
424- move shared libs to main package.
425
426* Wed Aug 20 2008 Steven Dake <sdake@redhat.com> - 0.91-2
427- use /sbin/service instead of calling init script directly.
428- put corosync-objctl man page in the main package.
429- change all initrddir to initddir for fedora 10 guidelines.
430
431* Thu Aug 14 2008 Steven Dake <sdake@redhat.com> - 0.91-1
432- First upstream packaged version of corosync for rawhide review.
Note: See TracBrowser for help on using the repository browser.