source: projects/specs/trunk/c/corosync/corosync-vl.spec @ 9394

Revision 9394, 16.2 KB checked in by inagaki, 9 years ago (diff)

2015-02-28 Ryoichi INAGAKI <ryo1@…>

  • corosync, pacemaker, resoure-agents: updated
  • libqb, perl-Net-IAMP-Simple-SSL: new


Line 
1# Conditionals
2# Invoke "rpmbuild --without <feature>" or "rpmbuild --with <feature>"
3# to disable or enable specific features
4%bcond_with testagents
5%bcond_with watchdog
6%bcond_with monitoring
7%bcond_without snmp
8%bcond_without dbus
9# no InfiniBand stack on s390(x)
10#ifnarch s390 s390x
11%bcond_with    rdma
12#endif
13%bcond_with    systemd
14%bcond_without upstart
15%bcond_without xmlconf
16%bcond_without runautogen
17
18Name: corosync
19Summary: The Corosync Cluster Engine and Application Programming Interfaces
20Summary(ja): Corosync クラスタエンジン及びその API
21Version: 2.3.4
22Release: 1%{?_dist_release}
23License: BSD
24Group: System Environment/Base
25URL: http://www.corosync.org/
26
27Source0: http://corosync.org/download/%{name}-%{version}.tar.gz
28
29ExclusiveArch: i686 x86_64
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31# Build bits
32BuildRequires: groff
33BuildRequires: libqb-devel >= 0.14.2
34BuildRequires: nss-devel
35%if %{with runautogen}
36BuildRequires: autoconf automake libtool
37%endif
38%if %{with monitoring}
39BuildRequires: libstatgrab-devel
40%endif
41%if %{with rdma}
42BuildRequires: libibverbs-devel librdmacm-devel
43%endif
44%if %{with snmp}
45BuildRequires: net-snmp-devel
46%endif
47%if %{with dbus}
48BuildRequires: dbus-devel
49%endif
50%if %{with systemd}
51BuildRequires: systemd-units
52Requires(post): systemd
53Requires(preun): systemd
54Requires(postun): systemd
55%endif
56%if %{with xmlconf}
57Requires: libxslt
58%endif
59
60# Runtime bits
61Requires: corosynclib = %{version}-%{release}
62Requires(pre): /usr/sbin/useradd
63Requires(post): /sbin/chkconfig
64Requires(preun): /sbin/chkconfig
65Obsoletes: openais, openais-devel, openaislib, openaislib-devel
66Obsoletes: cman, clusterlib, clusterlib-devel
67
68%description
69This package contains the Corosync Cluster Engine Executive, several default
70APIs and libraries, default configuration files, and an init script.
71
72# optional testagent rpm
73#
74%if %{with testagents}
75%package -n corosync-testagents
76Summary: The Corosync Cluster Engine Test Agents
77Group: Development/Libraries
78Requires: %{name} = %{version}-%{release}
79Requires: libqb >= 0.14.2
80
81%description -n corosync-testagents
82This package contains corosync test agents.
83%endif
84
85# library
86#
87%package -n corosynclib
88Summary: The Corosync Cluster Engine Libraries
89Summary(ja): Corosync クラスタエンジンのライブラリ
90Group: System Environment/Libraries
91Requires: %{name} = %{version}-%{release}
92
93%description -n corosynclib
94This package contains corosync libraries.
95
96%package -n corosynclib-devel
97Summary: The Corosync Cluster Engine Development Kit
98Summary(ja): Corosync クラスタエンジン開発キット
99Group: Development/Libraries
100Requires: corosynclib = %{version}-%{release}
101Requires: pkgconfig
102Provides: corosync-devel = %{version}
103Obsoletes: corosync-devel < 0.92-7
104
105%description -n corosynclib-devel
106This package contains include files and man pages used to develop using
107The Corosync Cluster Engine APIs.
108
109
110%prep
111%setup -q -n %{name}-%{version}
112
113%build
114%if %{with runautogen}
115./autogen.sh
116%endif
117
118%if %{with rdma}
119export ibverbs_CFLAGS=-I%{_includedir}/infiniband \
120export ibverbs_LIBS=-libverbs \
121export rdmacm_CFLAGS=-I%{_includedir}/rdma \
122export rdmacm_LIBS=-lrdmacm \
123%endif
124%{configure} \
125%if %{with testagents}
126        --enable-testagents \
127%endif
128%if %{with watchdog}
129        --enable-watchdog \
130%endif
131%if %{with monitoring}
132        --enable-monitoring \
133%endif
134%if %{with snmp}
135        --enable-snmp \
136%endif
137%if %{with dbus}
138        --enable-dbus \
139%endif
140%if %{with rdma}
141        --enable-rdma \
142%endif
143%if %{with systemd}
144        --enable-systemd \
145%endif
146%if %{with upstart}
147        --enable-upstart \
148%endif
149%if %{with xmlconf}
150        --enable-xmlconf \
151%endif
152        --with-initddir=%{_initrddir} \
153        --with-systemddir=%{_unitdir} \
154        --with-upstartdir=%{_sysconfdir}/init
155
156make %{_smp_mflags}
157
158%install
159rm -rf %{buildroot}
160
161make install DESTDIR=%{buildroot}
162
163%if %{with dbus}
164mkdir -p -m 0700 %{buildroot}/%{_sysconfdir}/dbus-1/system.d
165install -m 644 %{_builddir}/%{name}-%{version}%{?gittarver}/conf/corosync-signals.conf %{buildroot}/%{_sysconfdir}/dbus-1/system.d/corosync-signals.conf
166%endif
167
168## tree fixup
169# drop static libs
170rm -f %{buildroot}%{_libdir}/*.a
171rm -f %{buildroot}%{_libdir}/*.la
172# drop docs and html docs for now
173rm -rf %{buildroot}%{_docdir}/*
174# /etc/sysconfig/corosync-notifyd
175mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
176install -m 644 tools/corosync-notifyd.sysconfig.example \
177   %{buildroot}%{_sysconfdir}/sysconfig/corosync-notifyd
178# /etc/sysconfig/corosync
179install -m 644 init/corosync.sysconfig.example \
180   %{buildroot}%{_sysconfdir}/sysconfig/corosync
181
182%clean
183rm -rf %{buildroot}
184
185%post
186%if %{with systemd} && 0%{?systemd_post:1}
187%systemd_post corosync.service
188%else
189if [ $1 -eq 1 ]; then
190        /sbin/chkconfig --add corosync || :
191fi
192%endif
193
194%preun
195%if %{with systemd} && 0%{?systemd_preun:1}
196%systemd_preun corosync.service
197%else
198if [ $1 -eq 0 ]; then
199        /sbin/service corosync stop &>/dev/null || :
200        /sbin/chkconfig --del corosync || :
201fi
202%endif
203
204%postun
205%if %{with systemd} && 0%{?systemd_postun:1}
206%systemd_postun
207%endif
208
209%post -n corosynclib -p /sbin/ldconfig
210
211%postun -n corosynclib -p /sbin/ldconfig
212
213%files
214%defattr(-,root,root,-)
215%doc LICENSE SECURITY
216%{_sbindir}/corosync
217%{_sbindir}/corosync-keygen
218%{_sbindir}/corosync-cmapctl
219%{_sbindir}/corosync-cfgtool
220%{_sbindir}/corosync-cpgtool
221%{_sbindir}/corosync-quorumtool
222%{_sbindir}/corosync-notifyd
223%{_bindir}/corosync-blackbox
224%if %{with xmlconf}
225%{_bindir}/corosync-xmlproc
226%config(noreplace) %{_sysconfdir}/corosync/corosync.xml.example
227%dir %{_datadir}/corosync
228%{_datadir}/corosync/xml2conf.xsl
229%{_mandir}/man8/corosync-xmlproc.8*
230%{_mandir}/man5/corosync.xml.5*
231%endif
232%dir %{_sysconfdir}/corosync
233%dir %{_sysconfdir}/corosync/uidgid.d
234%config(noreplace) %{_sysconfdir}/corosync/corosync.conf.example
235%config(noreplace) %{_sysconfdir}/corosync/corosync.conf.example.udpu
236%config(noreplace) %{_sysconfdir}/sysconfig/corosync-notifyd
237%config(noreplace) %{_sysconfdir}/sysconfig/corosync
238%if %{with dbus}
239%{_sysconfdir}/dbus-1/system.d/corosync-signals.conf
240%endif
241%if %{with snmp}
242%{_datadir}/snmp/mibs/COROSYNC-MIB.txt
243%endif
244%if %{with systemd}
245%{_unitdir}/corosync.service
246%{_unitdir}/corosync-notifyd.service
247%dir %{_datadir}/corosync
248%{_datadir}/corosync/corosync
249%{_datadir}/corosync/corosync-notifyd
250%else
251%{_initrddir}/corosync
252%{_initrddir}/corosync-notifyd
253%endif
254%if %{with upstart}
255%{_sysconfdir}/init/corosync.conf
256%{_sysconfdir}/init/corosync-notifyd.conf
257%endif
258%dir %{_localstatedir}/lib/corosync
259%dir %{_localstatedir}/log/cluster
260%{_mandir}/man8/corosync_overview.8*
261%{_mandir}/man8/corosync.8*
262%{_mandir}/man8/corosync-blackbox.8*
263%{_mandir}/man8/corosync-cmapctl.8*
264%{_mandir}/man8/corosync-keygen.8*
265%{_mandir}/man8/corosync-cfgtool.8*
266%{_mandir}/man8/corosync-cpgtool.8*
267%{_mandir}/man8/corosync-notifyd.8*
268%{_mandir}/man8/corosync-quorumtool.8*
269%{_mandir}/man5/corosync.conf.5*
270%{_mandir}/man5/votequorum.5*
271%{_mandir}/man8/cmap_keys.8*
272
273%if %{with testagents}
274%files -n corosync-testagents
275%defattr(755,root,root,-)
276%{_datadir}/corosync/tests/mem_leak_test.sh
277%{_datadir}/corosync/tests/net_breaker.sh
278%{_datadir}/corosync/tests/cmap-dispatch-deadlock.sh
279%{_datadir}/corosync/tests/shm_leak_audit.sh
280%{_bindir}/cpg_test_agent
281%{_bindir}/sam_test_agent
282%{_bindir}/votequorum_test_agent
283%endif
284
285%files -n corosynclib
286%defattr(-,root,root,-)
287%doc LICENSE
288%{_libdir}/libcfg.so.*
289%{_libdir}/libcpg.so.*
290%{_libdir}/libcmap.so.*
291%{_libdir}/libtotem_pg.so.*
292%{_libdir}/libquorum.so.*
293%{_libdir}/libvotequorum.so.*
294%{_libdir}/libsam.so.*
295%{_libdir}/libcorosync_common.so.*
296
297%files -n corosynclib-devel
298%defattr(-,root,root,-)
299%doc LICENSE
300%dir %{_includedir}/corosync/
301%{_includedir}/corosync/corodefs.h
302%{_includedir}/corosync/cfg.h
303%{_includedir}/corosync/cmap.h
304%{_includedir}/corosync/corotypes.h
305%{_includedir}/corosync/cpg.h
306%{_includedir}/corosync/hdb.h
307%{_includedir}/corosync/sam.h
308%{_includedir}/corosync/quorum.h
309%{_includedir}/corosync/votequorum.h
310%dir %{_includedir}/corosync/totem/
311%{_includedir}/corosync/totem/totem.h
312%{_includedir}/corosync/totem/totemip.h
313%{_includedir}/corosync/totem/totempg.h
314%{_libdir}/libcfg.so
315%{_libdir}/libcpg.so
316%{_libdir}/libcmap.so
317%{_libdir}/libtotem_pg.so
318%{_libdir}/libquorum.so
319%{_libdir}/libvotequorum.so
320%{_libdir}/libsam.so
321%{_libdir}/libcorosync_common.so
322%{_libdir}/pkgconfig/*.pc
323%{_mandir}/man3/cpg_*3*
324%{_mandir}/man3/quorum_*3*
325%{_mandir}/man3/votequorum_*3*
326%{_mandir}/man3/sam_*3*
327%{_mandir}/man8/cpg_overview.8*
328%{_mandir}/man8/votequorum_overview.8*
329%{_mandir}/man8/sam_overview.8*
330%{_mandir}/man3/cmap_*3*
331%{_mandir}/man8/cmap_overview.8*
332%{_mandir}/man8/quorum_overview.8*
333
334%changelog
335* Thu Feb 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.4-1
336- updated to 2.3.4
337- added BR: libqb-devel
338
339* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
340- new upstream release
341
342* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-1
343- initial build for Vine Linux
344
345* Mon Jul  5 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.6-1
346- New upstream release
347- Resync spec file with upstream changes
348
349* Tue May 25 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.3-1
350- New upstream release
351- Rediff revision 2770 patch
352
353* Mon May 17 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.2-1
354- New upstream release
355- Add upstream trunk revision 2770 to add cpg_model_initialize api.
356- Fix URL and Source0 entries.
357- Add workaround to broken 1.2.2 Makefile with make -j.
358
359* Wed Mar 24 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.1-1
360- New upstream release
361
362* Tue Dec  8 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.0-1
363- New upstream release
364- Use global instead of define
365- Update Source0 url
366- Use more %name macro around
367- Cleanup install section. Init script is now installed by upstream
368- Cleanup whitespace
369- Don't deadlock between package upgrade and corosync condrestart
370- Ship service.d config directory
371- Fix Conflicts vs Requires
372- Ship new sam library and man pages
373
374* Fri Oct 23 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.1.2-1
375- New upstream release fixes major regression on specific loads
376
377* Wed Oct 21 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.1.1-1
378- New upstream release
379
380* Fri Sep 25 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.1.0-1
381- New upstream release
382- spec file updates:
383  * enable IB support
384  * explicitly define built-in features at configure time
385
386* Tue Sep 22 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.1-1
387- New upstream release
388- spec file updates:
389  * use proper configure macro
390
391* Tue Jul 28 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.0-3
392- spec file updates:
393  * more consistent use of macros across the board
394  * fix directory ownership
395
396* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
397- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
398
399* Wed Jul  8 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.0-1
400- New upstream release
401
402* Thu Jul  2 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.100-1
403- New upstream release
404
405* Sat Jun 20 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.98-1
406- New upstream release
407- spec file updates:
408  * Drop corosync-trunk patch and alpha tag.
409  * Fix alphatag vs buildtrunk handling.
410  * Drop requirement on ais user/group and stop creating them.
411  * New config file locations from upstream: /etc/corosync/corosync.conf.
412
413* Wed Jun 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.97-1.svn2233
414- spec file updates:
415  * Update to svn version 2233 to include library linking fixes
416
417* Wed Jun 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.97-1.svn2232
418- New upstream release
419- spec file updates:
420  * Drop pkgconfig fix that's now upstream
421  * Update to svn version 2232
422  * Define buildtrunk if we are using svn snapshots
423  * BuildRequires: nss-devel to enable nss crypto for network communication
424  * Force autogen invokation if buildtrunk is defined
425  * Whitespace cleanup
426  * Stop shipping corosync.conf in favour of a generic example
427  * Update file list
428
429* Mon Mar 30 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.95-2
430- Backport svn commit 1913 to fix pkgconfig files generation
431  and unbreak lvm2 build.
432
433* Tue Mar 24 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.95-1
434- New upstream release
435- spec file updates:
436  * Drop alpha tag
437  * Drop local patches (no longer required)
438  * Allow to build from svn trunk by supporting rpmbuild --with buildtrunk
439  * BuildRequires autoconf automake if building from trunk
440  * Execute autogen.sh if building from trunk and if no configure is available
441  * Switch to use rpm configure macro and set standard install paths
442  * Build invokation now supports _smp_mflags
443  * Remove install section for docs and use proper doc macro instead
444  * Add tree fixup bits to drop static libs and html docs (only for now)
445  * Add LICENSE file to all subpackages
446  * libraries have moved to libdir. Drop ld.so.conf.d corosync file
447  * Update BuildRoot usage to preferred versions/names
448
449* Tue Mar 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-5.svn1797
450- Update the corosync-trunk patch for real this time.
451
452* Tue Mar 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-4.svn1797
453- Import fixes from upstream:
454  * Cleanup logsys format init around to use default settings (1795)
455  * logsys_format_set should use its own internal copy of format_buffer (1796)
456  * Add logsys_format_get to logsys API (1797)
457- Cherry pick svn1807 to unbreak CPG.
458
459* Mon Mar  9 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-3.svn1794
460- Import fixes from upstream:
461  * Add reserve/release feature to totem message queue space (1793)
462  * Fix CG shutdown (1794)
463
464* Fri Mar  6 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-2.svn1792
465- Import fixes from upstream:
466  * Fix uninitialized memory. Spotted by valgrind (1788)
467  * Fix logsys_set_format by updating the right bits (1789)
468  * logsys: re-add support for timestamp  (1790)
469  * Fix cpg crash (1791)
470  * Allow logsys_format_set to reset to default (1792)
471
472* Tue Mar  3 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-1
473- New upstream release.
474- Drop obsolete patches.
475- Add soname bump patch that was missing from upstream.
476
477* Wed Feb 25 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.93-4
478- Add Makefile fix to install all corosync tools (commit r1780)
479
480* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
481- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
482
483* Mon Feb 23 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.93-2
484- Rename gcc-4.4 patch to match svn commit (r1767).
485- Backport patch from trunk (commit r1774) to fix quorum engine.
486
487* Thu Feb 19 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.93-1
488- New upstream release.
489- Drop alphatag from spec file.
490- Drop trunk patch.
491- Update Provides for corosynclib-devel.
492- Backport gcc-4.4 build fix from trunk.
493
494* Mon Feb  2 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-7.svn1756
495- Update to svn trunk at revision 1756 from upstream.
496- Add support pkgconfig to devel package.
497- Tidy up spec files by re-organazing sections according to packages.
498- Split libraries from corosync to corosynclib.
499- Rename corosync-devel to corosynclib-devel.
500- Comply with multiarch requirements (libraries).
501
502* Tue Jan 27 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-6.svn1750
503- Update to svn trunk at revision 1750 from upstream.
504- Include new quorum service in the packaging.
505
506* Mon Dec 15 2008 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-5.svn1709
507- Update to svn trunk at revision 1709 from upstream.
508- Update spec file to include new include files.
509
510* Wed Dec 10 2008 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-4.svn1707
511- Update to svn trunk at revision 1707 from upstream.
512- Update spec file to include new lcrso services and include file.
513
514* Mon Oct 13 2008 Dennis Gilmore <dennis@ausil.us> - 0.92-3
515- remove ExclusiveArch line
516
517* Fri Sep 24 2008 Steven Dake <sdake@redhat.com> - 0.92-2
518- Add conflicts for openais and openais-devel packages older then 0.90.
519
520* Wed Sep 24 2008 Steven Dake <sdake@redhat.com> - 0.92-1
521- New upstream release corosync-0.92.
522
523* Sun Aug 24 2008 Steven Dake <sdake@redhat.com> - 0.91-3
524- move logsys_overview.8.* to devel package.
525- move shared libs to main package.
526
527* Wed Aug 20 2008 Steven Dake <sdake@redhat.com> - 0.91-2
528- use /sbin/service instead of calling init script directly.
529- put corosync-objctl man page in the main package.
530- change all initrddir to initddir for fedora 10 guidelines.
531
532* Thu Aug 14 2008 Steven Dake <sdake@redhat.com> - 0.91-1
533- First upstream packaged version of corosync for rawhide review.
Note: See TracBrowser for help on using the repository browser.