source: projects/specs/trunk/c/control-center/control-center-vl.spec @ 8447

Revision 8447, 32.3 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.2

Line 
1%define pango_version 1.36.3
2%define gtk3_version 3.12.0
3%define gnome_desktop3_version 3.12.0
4%define libgnomekbd_version 3.6.0
5%define desktop_file_utils_version 0.3
6%define startup_notification_version 0.7
7%define libxklavier_version 5.0
8%define gnome_doc_utils_version 0.20
9%define gnome_menus_version 3.8.0
10%define vine_menus_version 3.0
11%define evolution_data_server_version 2.32.0
12%define libcanberra_version 0.9
13%define usermode_version 1.83
14%define libnotify_version 0.7.3
15%define nm_version 0.9.8
16%define mm_version 0.7.0
17
18Summary: GNOME Control Center.
19Summary(ja): GNOME コントロールセンター
20Name: control-center
21Version: 3.12.1
22Release: 2%{?_dist_release}
23License: GPLv2+ and GFDL+
24Group: User Interface/Desktops
25URL: http://www.gnome.org
26
27Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-control-center/3.12/gnome-control-center-%{version}.tar.xz
28
29Patch1: control-center-3.8.1-gpermission.patch
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: inagaki, daisuke, Takemikaduchi
34
35BuildRoot: %{_tmppath}/%{name}-%{version}-root
36
37Obsoletes: gnome, control-center-devel < 2.0
38Obsoletes: fontilus, themus
39
40Provides: gnome-volume-manager < 2.25
41Obsoletes: gnome-volume-manager < 2.25
42
43Requires: usermode >= %{usermode_version}
44Requires: gnome-settings-daemon
45Requires: gnome-icon-theme
46Requires: gnome-desktop3 >= %{gnome_desktop_version}
47Requires: dbus-x11
48Requires: apg
49Requires(post,postun): desktop-file-utils shared-mime-info gtk3
50
51BuildRequires: gnome-common
52BuildRequires: pango-devel >= %{pango_version}
53BuildRequires: gtk3-devel >= %{gtk3_version}
54BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
55BuildRequires: libgnomekbd-devel >= %{libgnomekbd_version}
56BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
57BuildRequires: startup-notification-devel >= %{startup_notification_version}
58BuildRequires: libxklavier-devel >= %{libxklavier_version}
59BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
60BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
61BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
62BuildRequires: gnome-settings-daemon-devel
63BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
64BuildRequires: nautilus-devel
65BuildRequires: alsa-lib-devel
66BuildRequires: autoconf
67BuildRequires: gettext-devel
68BuildRequires: librsvg2-devel
69BuildRequires: libXScrnSaver-devel
70BuildRequires: libXxf86misc-devel
71BuildRequires: libSM-devel
72BuildRequires: unique3-devel
73BuildRequires: polkit-devel
74BuildRequires: libgtop2-devel
75BuildRequires: upower-devel
76BuildRequires: pulseaudio-libs-devel
77BuildRequires: cups-devel
78BuildRequires: cheese-devel
79BuildRequires: grilo-devel
80BuildRequires: gstreamer-plugins-base-devel
81BuildRequires: gnome-online-accounts-devel
82BuildRequires: colord-devel
83BuildRequires: colord-gtk-devel
84BuildRequires: libnm-gtk-devel >= %{nm_version}
85BuildRequires: NetworkManager-glib-devel >= %{nm_version}
86BuildRequires: ModemManager-glib-devel >= %{mm_version}
87BuildRequires: libnotify-devel >= %{libnotify_version}
88BuildRequires: libwacom-devel
89BuildRequires: libpwquality-devel
90BuildRequires: ibus-devel
91BuildRequires: accountsservice-devel
92BuildRequires: gnome-online-accounts-devel
93BuildRequires: libsmbclient-devel
94
95%description
96GNOME (the GNU Network Object Model Environment) is an attractive and
97easy-to-use GUI desktop environment. The control-center package
98provides the GNOME Control Center utilities that allow you to setup
99and configure your system's GNOME environment (things like the desktop
100background and theme, the screensaver, the window manager, system
101sounds, and mouse behavior).
102
103If you install GNOME, you need to install control-center.
104
105%description -l ja
106GNOME (the GNU Network Object Model Environment) は、魅力的で使いやすい
107GUI デスクトップ環境です。 control-center パッケージには、あなたの GNOME
108環境の設定に使う GNOME コントロールセンター・ユーティリティが含まれていま
109す。(これを使うと、デスクトップの壁紙や、テーマ、スクリーンセーバ、ウィン
110ドウマネージャ、サウンド、マウス、その他いろいろな設定を行えます。)
111
112%package devel
113Summary: Development files for GNOME Control Center
114Summary(ja): GNOME コントロールセンターの開発用ファイル
115Group: Development/Libraries
116Requires: %{name} = %{version}-%{release}
117
118%description devel
119Development tool for GNOME Control Center
120
121%descriotion -l ja devel
122GNOME コントロールセンターの開発用ファイルが含まれています。
123
124%prep
125%setup -q -n gnome-control-center-%{version}
126%patch1 -p1
127
128%build
129autoreconf -if
130%configure --disable-static  \
131    --disable-update-mimedb \
132    --enable-ibus \
133        --with-libsocialweb=no
134    CFLAGS="$RPM_OPT_FLAGS -Wno-error"
135
136# drop unneeded direct library deps with --as-needed
137# libtool doesn't make this easy, so we do it the hard way
138sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/    if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/      func_append compile_command " -Wl,-O1,--as-needed"\n      func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
139
140make %{?_smp_mflags}
141
142%install
143rm -rf $RPM_BUILD_ROOT
144
145make install DESTDIR=$RPM_BUILD_ROOT
146
147desktop-file-install --delete-original                  \
148  --dir $RPM_BUILD_ROOT%{_datadir}/applications         \
149  --add-only-show-in GNOME                              \
150  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
151
152# we do want this
153mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
154
155# We don't want these
156rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
157rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/cursor-fonts
158
159# remove useless libtool archive files
160find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
161
162# don't package mime caches
163rm -f $RPM_BUILD_ROOT%{_datadir}/mime/XMLnamespaces
164rm -f $RPM_BUILD_ROOT%{_datadir}/mime/aliases
165rm -f $RPM_BUILD_ROOT%{_datadir}/mime/application/x-gnome-theme-package.xml
166rm -f $RPM_BUILD_ROOT%{_datadir}/mime/globs
167rm -f $RPM_BUILD_ROOT%{_datadir}/mime/magic
168rm -f $RPM_BUILD_ROOT%{_datadir}/mime/subclasses
169rm -f $RPM_BUILD_ROOT%{_datadir}/mime/mime.cache
170rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
171
172rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/fdl
173rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/lgpl
174
175%find_lang gnome-control-center-2.0
176%find_lang gnome-control-center-2.0-timezones
177
178%clean
179rm -rf $RPM_BUILD_ROOT
180
181%post
182/sbin/ldconfig
183
184update-desktop-database %{_datadir}/applications >& /dev/null ||:
185update-mime-database %{_datadir}/mime > /dev/null
186touch --no-create %{_datadir}/icons/hicolor
187if [ -x /usr/bin/gtk-update-icon-cache ]; then
188  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
189fi
190
191%postun
192/sbin/ldconfig
193update-desktop-database %{_datadir}/applications >& /dev/null ||:
194update-mime-database %{_datadir}/mime > /dev/null
195touch --no-create %{_datadir}/icons/hicolor
196if [ -x /usr/bin/gtk-update-icon-cache ]; then
197  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
198fi
199
200%files -f gnome-control-center-2.0.lang -f gnome-control-center-2.0-timezones.lang
201%defattr(-, root, root)
202%doc AUTHORS COPYING ChangeLog NEWS README
203%{_bindir}/gnome-control-center
204%{_libexecdir}/cc-remote-login-helper
205%{_libexecdir}/gnome-control-center-search-provider
206%dir %{_datadir}/gnome/wm-properties
207%dir %{_datadir}/gnome-control-center
208%{_datadir}/applications/*
209%{_datadir}/bash-completion/completions/gnome-control-center
210%{_datadir}/dbus-1/services/org.gnome.ControlCenter.SearchProvider.service
211%{_datadir}/dbus-1/services/org.gnome.ControlCenter.service
212%{_datadir}/gnome-control-center/datetime
213%{_datadir}/gnome-control-center/icons
214%{_datadir}/gnome-control-center/keybindings
215%{_datadir}/gnome-control-center/pixmaps
216%{_datadir}/gnome-control-center/sounds
217%{_datadir}/gnome-shell/search-providers/gnome-control-center-search-provider.ini
218%{_datadir}/icons/*
219%{_datadir}/pixmaps/*
220%{_datadir}/polkit-1/actions/org.gnome.controlcenter.datetime.policy
221%{_datadir}/polkit-1/actions/org.gnome.controlcenter.remote-login-helper.policy
222%{_datadir}/polkit-1/actions/org.gnome.controlcenter.user-accounts.policy
223%{_datadir}/polkit-1/rules.d/gnome-control-center.rules
224%{_datadir}/sounds/*
225%{_mandir}/man1/gnome-control-center.1.gz
226
227%files devel
228%defattr(-, root, root)
229%{_datadir}/pkgconfig/*
230
231
232%changelog
233* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-2
234- rebuild with libgtop2-2.30.0
235
236* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
237- new upstream release
238
239* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
240- new upstream release
241- add BuildRequires: grilo-devel
242
243* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
244- new upstream release
245- remove Patch0 (gnome-control-center-3.10.1-test-chooser-dialog.patch)
246
247* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
248- new upstream release
249- add BuildRequires: NetworkManager-glib-devel, ModemManager-glib-devel, libsmbclient-devel
250- add Patch0 (gnome-control-center-3.10.1-test-chooser-dialog.patch)
251
252* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4.1-1
253- new upstream release
254
255* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
256- new upstream release
257
258* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
259- new upstream release
260- remove Patch0 (control-center-3.8.1-git20130424.patch)
261
262* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-2
263- add Patch1 (control-center-3.8.1-gpermission.patch)
264
265* Wed Apr 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
266- new upstream release
267- remove BuildRequires: gnome-panel-devel, metacity-devel
268- change BuildRequires: libnm-gtk-devel instead of NetworkManager-gtk-devel
269- add BuildRequires: colord-gtk-devel, accountsservice-devel, gnome-online-accounts-devel
270- add Patch0 (control-center-3.8.1-git20130424.patch)
271
272* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
273- new upstream release
274
275* Tue Oct 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
276- new upstream release
277
278* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
279- new upstream release
280
281* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
282- new upstream release
283- add BuildRequires: libpwquality-devel
284
285* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
286- new upstream release
287
288* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
289- new upstream release
290- remove BuildRequires: GConf2-devel, libbonobo-devel
291- add BuildRequires: libwacom-devel
292
293* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
294- new upstream release
295
296* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
297- new upstream release
298
299* Mon Oct 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-2
300- rebuild with NetworkManager-0.9
301- change BuildRequires: NetworkManager-gtk-devel instead of NetworkManager-glib-devel
302
303* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
304- new upstream release
305
306* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
307- new upstream release
308
309* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
310- new upstream release
311- remove Patch0
312
313* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
314- new upstream release
315- add BuildRequires: libnotify-devel
316- add Patch0 (control-center-3.1.5-crash-layout.patch)
317
318* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
319- new upstream release
320- change BuildRequires: gtk3-devel instead of gtk2-devel
321- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
322- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
323- change BuildRequires: unique3-devel instead of unique-devel
324- add BuildRequires: libXxf86misc-devel, libSM-devel, polkit-devel, libgtop2-devel, upower-devel,
325                     pulseaudio-libs-devel, cups-devel, cheese-devel, gstreamer-plugins-base-devel,
326                     gnome-online-accounts-devel, colord-devel, NetworkManager-glib-devel
327- add Requires: apg
328- drop all Patches
329- add Provides: and Obsoletes: gnome-volume-manager
330
331* Mon Mar 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
332- update desktop-effect-integration patch
333  - fix freeze on changing metacity to compiz
334  - run compiz directly instead of compiz-gtk
335  - drop use of jockey-gtk
336- update ja.po
337
338* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
339- new upstream release
340
341* Sat Nov 06 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-4
342- update translation.
343
344* Fri Nov 05 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-3
345- update translation.
346
347* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
348- update Source21(gnome-control-center-2.32.0-vine.ja.po)
349
350* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
351- new upstream release
352- drop Patch22, Patch30, Patch52
353- fix %files
354
355* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-4
356- rebuilt with rpm-4.8.1 for pkg-config (too)
357
358* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
359- rebuild with rpm-4.8.1 for pkg-config file
360- add Requires: %{name}=%{version}-%{release}
361
362* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
363- rebuild with evolution-data-server-2.30.2
364
365* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
366- new upstream release
367
368* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
369- new upstream release
370- drop Patch3, Patch46, Patch50, Patch51, Patch53, Patch54, Patch112
371- add BuildRequires: gnome-common, unique-devel
372
373* Thu Dec 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-2
374- enable Patch101,110-112 and 500
375
376* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
377- new upstream release
378- disabled Patch101, 110-112 and 500
379
380* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-9
381- update notification-theme.patch
382  - use vine theme if NotificationTheme is not set in meta-theme.
383
384* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-8
385- add Patch510: use Sans for font-properties sample font.
386- add BR: librsvg2-devel, libXScrnSaver-devel
387- remove BR: esound
388
389* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-7
390- add Patch37: Don't rely on _BACKUP property for xkb initialization
391
392* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-6
393- renumber patch10 to patch1010
394  - do not check gdm fprint plugin
395- add Patch101: show aspect in drop down menu
396- add Patch110: modify gnome-mouse-properties to fit smaller screen
397- add Patch111: modify gnome-about-me to fit smaller screen
398- add Patch112: modify gnome-display-properties to fit smaller screen
399
400* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-5
401- update Patch100 to use compiz-gtk instead of compiz
402
403* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
404- update ja.po
405
406* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
407- import upstream patchs (10,22,3[0-6])
408
409* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
410- add nautilus-devel to BR: not Requires:
411
412* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
413- new upstream release
414- update ja.po
415- add BR: nautilus-devel
416
417* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-3
418- drop Patch20 which need new XInput API
419- update Patch23
420
421* Sat Oct 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
422- add Patch20,22.23 from ubuntu
423  - patch20 to add touchpad configuration
424  - patch22 to add aspect setting in randr capplet
425  - patch23 to integrate desktop setting into appearance-properties
426
427* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
428- new upstream release
429
430* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
431- new upstream release
432
433* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-3
434- add gnome-typing-monitor to %%files
435
436* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
437- add Patch100 for new RandR capplet. (fc)
438
439* Sat Jun  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2.1-1
440- new upstream release
441- dropped Patch8 (merged into upstream)
442
443* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
444- new upstream release
445- added Patch7 and Patch8 from Fedora
446  * Mon Mar 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
447  - Fix warnings in the keybindings capplet when in non-UTF-8 locale
448  - Fix Esc/Backspace being bindable when CapsLock is on (#427123)
449  * Tue Apr  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-2
450  - Remove a nonfunctional button from the a11y preferences
451- added BuildRequires: gnome-settings-daemon, gnome-panel
452- added Requires: gnome-icon-theme, gnome-desktop, dbus-x11
453- removed Requires: xscreensaver
454
455* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
456- new upstream release based on Fedora
457- added BuildRequires: gnome-settings-daemon
458
459* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
460- new upstream release based on Fedora
461  * Wed Oct 24 2007  Matthias Clasen <mclasen@redhat.com> - 2.20.1-5
462  - Fix the orca command in the default applications capplet (#351471)
463
464* Sat Jul 14 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl4
465- add BuildReq: libgnomekbd-devel
466
467* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
468- rebuilt with evolution-data-server-devel-1.10.1
469
470* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl2
471- add BuildReq: evolution-data-server-devel
472
473* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
474- new upstream release
475- remove unneeded? patch10
476
477* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.2-0vl2
478- added Patch10 to supress /dev/pmu warning messages on some ppc models
479
480* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
481- new upstream release
482
483* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
484- new upstream release
485
486* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
487- run gtk-update-icon-cache in %%post script.
488
489* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
490- new upstream release
491- drop Patch10,it is merged in upstream
492
493* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl2
494- add Patch10 for correct textdomain name in
495  default-applications-properties(Bug332833)
496- add Patch100 for change default-applications settings for vine
497
498* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
499- new upstream release
500
501* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
502- new upstream release
503
504* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
505- new upstream release
506
507* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
508- new upstream release
509- enable alsa support
510
511* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
512- new upstream release
513
514* Thu Mar 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl4
515- fixed type in %%post script
516
517* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl3
518- clear the old defaults of xkb
519
520* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
521- remove bonobo-activation dependency
522
523* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
524- new upstream version
525
526* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
527- new upstream release
528- add Japanese summay to devel package
529
530* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
531- new upstream release
532
533* Sat Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
534- modify patch11 to use NeoVine theme instead of BeCool.
535
536* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
537- rebuild with new toolchain
538
539* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
540- new upstream release
541- remove obsolete ja.po
542
543* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 2.3.6-0vl2
544- change required version of metacity to 2.4.34 on alpha
545
546* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
547- new upstream release
548
549* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl1
550- new upstream release
551
552* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl3
553- add more missing files and schemas...
554
555* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
556- add missing file in %{_libdir}/gnome-vfs-2.0/
557
558* Sat May 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl1
559- new upstream release
560- this is experimental version
561- remove sr@Latn locale from desktop files to build with desktop-file-utils-0.3
562
563* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
564- new upstream release
565
566* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl3
567- import patch6 (upstream paches) from rawhide package.
568
569* Tue Feb 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl2
570- import patch1-5 (upstream paches) from rawhide package.
571
572* Sun Feb 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
573- new upstream release
574
575* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
576- rebuild
577
578* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
579- new upstream release
580
581* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
582- new upstream release
583
584* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
585- new upstream release
586
587* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl7
588- change default gtk1 theme from Raleigh to BeCool.
589
590* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl6
591- add BuildRequires/Requires.
592- fixed kanjicode of specfile
593
594* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
595- remove bogus message in %%post scripts.
596
597* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
598- add patch10 to modify some desktop files
599- update ja.po
600
601* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
602- update ja.po
603
604* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
605- update ja.po
606
607* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
608- new upstream release
609
610* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl3
611- add devel package
612- add window-manager-settings files.
613
614* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl2
615- modify dependancies.
616
617* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
618- build for Vine Linux
619- new upstream release from gnome-2.1.4
620
621* Thu Sep  5 2002 Jonathan Blandford <jrb@redhat.com>
622- Allow setting custom mime handlers
623
624* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
625- make desktop file symlinks absolute #71991
626- add po files from cvs.gnome.org
627
628* Fri Aug 23 2002 Jonathan Blandford <jrb@redhat.com>
629- Fix up keyboard handling
630
631* Wed Aug 21 2002 Jonathan Blandford <jrb@redhat.com>
632- Fixes for #68735
633
634* Wed Aug  7 2002 Jonathan Blandford <jrb@redhat.com>
635- New version.  Fix up metacity theme locations
636
637* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
638- Switch the gtk1 theme along with the gtk2 theme
639- Add the ability to switch the window manager theme through the theme capplet
640- Add two more font options to the font property dialog
641- Add a bunch of missing unrefs of the result of gconf_client_get_default()
642
643* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
644- fix desktop files more
645- copy icons to /usr/share/pixmaps
646
647* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
648- munge the desktop files correctly
649- obsolete control-center-devel, #69168
650- replace gnomecc.desktop with a file from redhat-menus
651
652* Tue Jul 23 2002 Owen Taylor <otaylor@redhat.com>
653- Fix crasher bug in xftprefs patch
654
655* Tue Jul 16 2002 Owen Taylor <otaylor@redhat.com>
656- Change the default rendering style to be "Best Shapes", not "Best Contrast"
657
658* Tue Jul  9 2002 Owen Taylor <otaylor@redhat.com>
659- Add Xft / XSETTINGS support
660
661* Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 2.0.0-2
662- fix %%post so schemas get installed
663 
664* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
665- 2.0.0
666- add new default editor schemas
667- fix find_lang
668
669* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
670- rebuild for new libraries
671- remove a no-longer-existing schemas file from post
672- use desktop-file-install
673
674* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
675- rebuild in different environment
676
677* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
678- rebuild with new dependent libs
679
680* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
681- rebuild in different environment
682
683* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
684- rebuild in different environment
685- build requires bonobo-activation
686
687* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
688- 1.99.10
689
690* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
691- 1.99.9
692
693* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
694- Move to GNOME 2 version
695
696* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
697- merge in translations
698
699* Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
700- Make the theme selector write fontsets, not fonts (#62413)
701
702* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
703- really put screensaver capplet back (I think)
704
705* Wed Mar 27 2002 Bill Nottingham <notting@redhat.com>
706- revert xscreensaver change
707
708* Wed Mar 27 2002 Havoc Pennington <hp@redhat.com>
709- init "Scaled" radio button correctly #61913
710
711* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
712- change path to windowmaker config tool again, #61824
713
714* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com>
715- rather than keep patching and patching it, use xscreensaver's own
716  capplet
717
718* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
719- rebuild in Hampton
720
721* Wed Jan 30 2002 Jonathan Blandford <jrb@redhat.com>
722- Rebuild package.
723
724* Thu Jan 24 2002 Tim Powers <timp@redhat.com>
725- rebuilt against new openssl
726
727* Fri Jan 18 2002 Havoc Pennington <hp@redhat.com>
728- automake14
729- don't run auto* again in ccsingle subdir, not sure why we did that
730
731* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
732- rebuild with new gnome-libs so that libcapplet has right cflags/libs
733- pixbufflags patch to make the rebuild work
734- compileflags patch to make control-center-single work
735
736* Wed Aug 29 2001 Havoc Pennington <hp@redhat.com>
737- fix #52831 (UI properties in Programs menu)
738
739* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
740- Add po files from sources.redhat.com
741
742* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
743- set the _XROOTCOLOR_PIXEL property, should fix
744  bug #52141
745
746* Wed Aug 22 2001 Yukihiro Nakai <ynakai@redhat.com>
747- Update translation.
748- Add CJK fontset patch
749
750* Thu Aug 16 2001 Jonathan Blandford <jrb@redhat.com>
751- New control-center-single to handle exiting, #51665
752
753* Wed Aug 01 2001 Havoc Pennington <hp@redhat.com>
754- remove .desktop file for gnomecc, so it won't appear
755  in panel menu, #49653
756
757* Mon Jul 30 2001 Jonathan Blandford <jrb@redhat.com>
758- allow to build without depending on control-center-devel
759
760* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
761- Add BuildRequires
762
763* Mon Jul 16 2001 Jonathan Blandford <jrb@redhat.com>
764- New version of control-center-single
765
766* Thu Jul 12 2001 Alexander Larsson <alexl@redhat.com>
767- Change default background to the same as the nautilus one
768
769* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
770- add hack to default to standalone control panels
771
772* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
773- Bump release + rebuild.
774
775* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
776- putting in tree for David
777
778* Tue May 22 2001 David Sainty <dsainty@redhat.com>
779- improve DPMS patch for the try case, and enable patch
780
781* Wed May  2 2001 Bill Nottingham <notting@redhat.com>
782- add patch to use xscreensaver's DPMS stuff, require that version
783
784* Fri Apr 20 2001  <jrb@redhat.com>
785- New Version (1.4.0.1)
786
787* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
788- kick the mixer once on startup if we aren't running esd
789
790* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
791- translations
792
793* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
794- Rebuild for GTK+-1.2.9 include paths
795
796* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
797- langify
798- don't define and use "ver" at the top of the file
799- move changelog to sane location
800
801* Thu Feb 08 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-4
802- Apply patch from bug #23782 to see how it works
803
804* Fri Feb 02 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-3
805- Include fvwm2.desktop in WM's
806
807* Sat Jan 27 2001 Akira TAGOH <tagoh@redhat.com>
808- Added Japanese patch.
809
810* Mon Dec 04 2000 Jonathan Blandford <jrb@redhat.com>
811- Update release.
812
813* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
814- Again, fix problem with solid backgrounds in bg-properties capplet
815  (patch got lost somewhere)
816
817* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
818- Up Epoch and release
819
820* Thu Aug 10 2000 Owen Taylor <otaylor@redhat.com>
821- Handle unreadable desktop files without crashing
822
823* Mon Aug 07 2000 Owen Taylor <otaylor@redhat.com>
824- Fix problem with backgrounds bigger than screen.
825
826* Tue Aug 01 2000 Owen Taylor <otaylor@redhat.com>
827- Fix problem when ~/.gtkrc does not already exist.
828- Fix problem with solid backgrounds in bg-properties capplet
829
830* Tue Jul 18 2000 Owen Taylor <otaylor@redhat.com>
831- Sort of fix problem with people hitting OK while the
832  "Save Session" dialog is still up. (Session won't be saved,
833  but at least the selected entry will be correctly kept.)
834- Fix history list in background properties capplet
835- Fix problems with temporary files in theme-selector capplet
836
837* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
838- automatic rebuild
839
840* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
841- Require redhat-logos
842- Some spec file and FHS fixes
843- reposition embedded logo a bit
844
845* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
846- Add big change to use gdk-pixbuf for backgrounds and add
847  the ability to emboss the background with a logo
848
849* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
850- revert .so strip
851
852* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
853- strip .so lib
854- use configure macro
855
856* Mon Sep 20 1999 Jonathan Blandford <jrb@redhat.com>
857- changed to work with 1.0.40
858
859* Fri Sep 17 1999 Jonathan Blandford <jrb@redhat.com>
860- Added fixrevert bug to fix bug in theme selector.
861
862* Sun Jun 13 1999 Jonathan Blandford <jrb@redhat.com>
863- updated RPM to use new control-center.
864
865* Wed Apr 07 1999 Michael Fulbright <drmike@redhat.com>
866- fixed sound-properties to only disable sound when run with --init-settings-..
867- removed debugging output from several capplets, fixed try behaviour of sm and
868  gnome-edit capplets
869- fixed bug in screensaver and background props
870- added new icons
871
872* Mon Apr 05 1999 Jonathan Blandford <jrb@redhat.com>
873- added a patch to fix the close dialog
874- added a patch to limit the number of bg's in the history.
875
876* Fri Apr 02 1999 Jonathan Blandford <jrb@redhat.com>
877- vesion 1.0.5
878- removed all patches >10 other then dontstartesd.
879
880* Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
881- removed UI props till it works better
882
883* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
884- make sure we DONT inadvertantly start esd by calling esd_open_...
885
886* Tue Mar 30 1999 Michael Fulbright <drmike@redhat.com>
887- changed default bg color to '#356390'
888
889* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
890- prime file selector path for browse in background-props if
891  "/usr/share/pixmaps/backgrounds/" exists.
892- fix behavior of file selector when you delete/cancel/ok it
893
894* Wed Mar 24 1999 Michael Fulbright <drmike@redhat.com>
895- added patch to fix trying in theme selector
896- disabled crystal screensaver, it does evil things to preview in capplet
897
898* Mon Mar 22 1999 Michael Fulbright <drmike@redhat.com>
899- version 1.0.4, fixes problems with sndprops and theme props among
900  other things.
901
902* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
903- fix sound-properties capplet so Try/Revert doesnt come on unless user
904  changes something
905- fixed theme-selector to not leave processes behind on Linux 2.2 kernels
906- strip binaries
907
908* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
909- version 1.0.3
910- added patch to make esd release after 30 sec of inactivity
911
912* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
913- version 1.0.2
914- turned off sound by default
915
916* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
917- version 1.0.1
918
919* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
920- version 0.99.8.1
921- added etc/CORBA/servers/* to file list
922
923* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
924- update to 0.99.8
925- added /usr/lib/cappletConf.sh
926
927* Mon Feb 08 1999 The Rasterman <raster@redhat.com>
928- update to 0.99.5.1
929
930* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
931- update to 0.99.5
932
933* Wed Jan 20 1999 Michael Fulbright <drmike@redhat.com>
934- update to 0.99.3.1
935
936* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
937- update to 0.99.3
938- seems like patch for non-standard xscreensaver placement was already in
939  prestine sources(?)
940
941* Wed Jan 06 1999 Jonathan Blandford <jrb@redhat.com>
942- updated to 0.99.1
943- temporary hack patch to get path to work to non-standard placement
944  of xscreensaver binaries in RH 5.2
945
946* Wed Dec 16 1998 Jonathan Blandford <jrb@redhat.com>
947- Created for the new control-center branch
948
Note: See TracBrowser for help on using the repository browser.