source: projects/specs/trunk/c/control-center/control-center-vl.spec @ 8369

Revision 8369, 32.3 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.1

Line 
1%define pango_version 1.36.3
2%define gtk3_version 3.12.0
3%define gnome_desktop3_version 3.12.0
4%define libgnomekbd_version 3.6.0
5%define desktop_file_utils_version 0.3
6%define startup_notification_version 0.7
7%define libxklavier_version 5.0
8%define gnome_doc_utils_version 0.20
9%define gnome_menus_version 3.8.0
10%define vine_menus_version 3.0
11%define evolution_data_server_version 2.32.0
12%define libcanberra_version 0.9
13%define usermode_version 1.83
14%define libnotify_version 0.7.3
15%define nm_version 0.9.8
16%define mm_version 0.7.0
17
18Summary: GNOME Control Center.
19Summary(ja): GNOME コントロールセンター
20Name: control-center
21Version: 3.12.1
22Release: 1%{?_dist_release}
23License: GPLv2+ and GFDL+
24Group: User Interface/Desktops
25URL: http://www.gnome.org
26
27Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-control-center/3.12/gnome-control-center-%{version}.tar.xz
28
29Patch1: control-center-3.8.1-gpermission.patch
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: inagaki, daisuke, Takemikaduchi
34
35BuildRoot: %{_tmppath}/%{name}-%{version}-root
36
37Obsoletes: gnome, control-center-devel < 2.0
38Obsoletes: fontilus, themus
39
40Provides: gnome-volume-manager < 2.25
41Obsoletes: gnome-volume-manager < 2.25
42
43Requires: usermode >= %{usermode_version}
44Requires: gnome-settings-daemon
45Requires: gnome-icon-theme
46Requires: gnome-desktop3 >= %{gnome_desktop_version}
47Requires: dbus-x11
48Requires: apg
49Requires(post,postun): desktop-file-utils shared-mime-info gtk3
50
51BuildRequires: gnome-common
52BuildRequires: pango-devel >= %{pango_version}
53BuildRequires: gtk3-devel >= %{gtk3_version}
54BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
55BuildRequires: libgnomekbd-devel >= %{libgnomekbd_version}
56BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
57BuildRequires: startup-notification-devel >= %{startup_notification_version}
58BuildRequires: libxklavier-devel >= %{libxklavier_version}
59BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
60BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
61BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
62BuildRequires: gnome-settings-daemon-devel
63BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
64BuildRequires: nautilus-devel
65BuildRequires: alsa-lib-devel
66BuildRequires: autoconf
67BuildRequires: gettext-devel
68BuildRequires: librsvg2-devel
69BuildRequires: libXScrnSaver-devel
70BuildRequires: libXxf86misc-devel
71BuildRequires: libSM-devel
72BuildRequires: unique3-devel
73BuildRequires: polkit-devel
74BuildRequires: libgtop2-devel
75BuildRequires: upower-devel
76BuildRequires: pulseaudio-libs-devel
77BuildRequires: cups-devel
78BuildRequires: cheese-devel
79BuildRequires: grilo-devel
80BuildRequires: gstreamer-plugins-base-devel
81BuildRequires: gnome-online-accounts-devel
82BuildRequires: colord-devel
83BuildRequires: colord-gtk-devel
84BuildRequires: libnm-gtk-devel >= %{nm_version}
85BuildRequires: NetworkManager-glib-devel >= %{nm_version}
86BuildRequires: ModemManager-glib-devel >= %{mm_version}
87BuildRequires: libnotify-devel >= %{libnotify_version}
88BuildRequires: libwacom-devel
89BuildRequires: libpwquality-devel
90BuildRequires: ibus-devel
91BuildRequires: accountsservice-devel
92BuildRequires: gnome-online-accounts-devel
93BuildRequires: libsmbclient-devel
94
95%description
96GNOME (the GNU Network Object Model Environment) is an attractive and
97easy-to-use GUI desktop environment. The control-center package
98provides the GNOME Control Center utilities that allow you to setup
99and configure your system's GNOME environment (things like the desktop
100background and theme, the screensaver, the window manager, system
101sounds, and mouse behavior).
102
103If you install GNOME, you need to install control-center.
104
105%description -l ja
106GNOME (the GNU Network Object Model Environment) は、魅力的で使いやすい
107GUI デスクトップ環境です。 control-center パッケージには、あなたの GNOME
108環境の設定に使う GNOME コントロールセンター・ユーティリティが含まれていま
109す。(これを使うと、デスクトップの壁紙や、テーマ、スクリーンセーバ、ウィン
110ドウマネージャ、サウンド、マウス、その他いろいろな設定を行えます。)
111
112%package devel
113Summary: Development files for GNOME Control Center
114Summary(ja): GNOME コントロールセンターの開発用ファイル
115Group: Development/Libraries
116Requires: %{name} = %{version}-%{release}
117
118%description devel
119Development tool for GNOME Control Center
120
121%descriotion -l ja devel
122GNOME コントロールセンターの開発用ファイルが含まれています。
123
124%prep
125%setup -q -n gnome-control-center-%{version}
126%patch1 -p1
127
128%build
129autoreconf -if
130%configure --disable-static  \
131    --disable-update-mimedb \
132    --enable-ibus \
133        --with-libsocialweb=no
134    CFLAGS="$RPM_OPT_FLAGS -Wno-error"
135
136# drop unneeded direct library deps with --as-needed
137# libtool doesn't make this easy, so we do it the hard way
138sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/    if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/      func_append compile_command " -Wl,-O1,--as-needed"\n      func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
139
140make %{?_smp_mflags}
141
142%install
143rm -rf $RPM_BUILD_ROOT
144
145make install DESTDIR=$RPM_BUILD_ROOT
146
147desktop-file-install --delete-original                  \
148  --dir $RPM_BUILD_ROOT%{_datadir}/applications         \
149  --add-only-show-in GNOME                              \
150  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
151
152# we do want this
153mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
154
155# We don't want these
156rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
157rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/cursor-fonts
158
159# remove useless libtool archive files
160find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
161
162# don't package mime caches
163rm -f $RPM_BUILD_ROOT%{_datadir}/mime/XMLnamespaces
164rm -f $RPM_BUILD_ROOT%{_datadir}/mime/aliases
165rm -f $RPM_BUILD_ROOT%{_datadir}/mime/application/x-gnome-theme-package.xml
166rm -f $RPM_BUILD_ROOT%{_datadir}/mime/globs
167rm -f $RPM_BUILD_ROOT%{_datadir}/mime/magic
168rm -f $RPM_BUILD_ROOT%{_datadir}/mime/subclasses
169rm -f $RPM_BUILD_ROOT%{_datadir}/mime/mime.cache
170rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
171
172rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/fdl
173rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/lgpl
174
175%find_lang gnome-control-center-2.0
176%find_lang gnome-control-center-2.0-timezones
177
178%clean
179rm -rf $RPM_BUILD_ROOT
180
181%post
182/sbin/ldconfig
183
184update-desktop-database %{_datadir}/applications >& /dev/null ||:
185update-mime-database %{_datadir}/mime > /dev/null
186touch --no-create %{_datadir}/icons/hicolor
187if [ -x /usr/bin/gtk-update-icon-cache ]; then
188  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
189fi
190
191%postun
192/sbin/ldconfig
193update-desktop-database %{_datadir}/applications >& /dev/null ||:
194update-mime-database %{_datadir}/mime > /dev/null
195touch --no-create %{_datadir}/icons/hicolor
196if [ -x /usr/bin/gtk-update-icon-cache ]; then
197  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
198fi
199
200%files -f gnome-control-center-2.0.lang -f gnome-control-center-2.0-timezones.lang
201%defattr(-, root, root)
202%doc AUTHORS COPYING ChangeLog NEWS README
203%{_bindir}/gnome-control-center
204%{_libexecdir}/cc-remote-login-helper
205%{_libexecdir}/gnome-control-center-search-provider
206%dir %{_datadir}/gnome/wm-properties
207%dir %{_datadir}/gnome-control-center
208%{_datadir}/applications/*
209%{_datadir}/bash-completion/completions/gnome-control-center
210%{_datadir}/dbus-1/services/org.gnome.ControlCenter.SearchProvider.service
211%{_datadir}/dbus-1/services/org.gnome.ControlCenter.service
212%{_datadir}/gnome-control-center/datetime
213%{_datadir}/gnome-control-center/icons
214%{_datadir}/gnome-control-center/keybindings
215%{_datadir}/gnome-control-center/pixmaps
216%{_datadir}/gnome-control-center/sounds
217%{_datadir}/gnome-shell/search-providers/gnome-control-center-search-provider.ini
218%{_datadir}/icons/*
219%{_datadir}/pixmaps/*
220%{_datadir}/polkit-1/actions/org.gnome.controlcenter.datetime.policy
221%{_datadir}/polkit-1/actions/org.gnome.controlcenter.remote-login-helper.policy
222%{_datadir}/polkit-1/actions/org.gnome.controlcenter.user-accounts.policy
223%{_datadir}/polkit-1/rules.d/gnome-control-center.rules
224%{_datadir}/sounds/*
225%{_mandir}/man1/gnome-control-center.1.gz
226
227%files devel
228%defattr(-, root, root)
229%{_datadir}/pkgconfig/*
230
231
232%changelog
233* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
234- new upstream release
235
236* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
237- new upstream release
238- add BuildRequires: grilo-devel
239
240* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
241- new upstream release
242- remove Patch0 (gnome-control-center-3.10.1-test-chooser-dialog.patch)
243
244* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
245- new upstream release
246- add BuildRequires: NetworkManager-glib-devel, ModemManager-glib-devel, libsmbclient-devel
247- add Patch0 (gnome-control-center-3.10.1-test-chooser-dialog.patch)
248
249* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4.1-1
250- new upstream release
251
252* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
253- new upstream release
254
255* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
256- new upstream release
257- remove Patch0 (control-center-3.8.1-git20130424.patch)
258
259* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-2
260- add Patch1 (control-center-3.8.1-gpermission.patch)
261
262* Wed Apr 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
263- new upstream release
264- remove BuildRequires: gnome-panel-devel, metacity-devel
265- change BuildRequires: libnm-gtk-devel instead of NetworkManager-gtk-devel
266- add BuildRequires: colord-gtk-devel, accountsservice-devel, gnome-online-accounts-devel
267- add Patch0 (control-center-3.8.1-git20130424.patch)
268
269* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
270- new upstream release
271
272* Tue Oct 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
273- new upstream release
274
275* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
276- new upstream release
277
278* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
279- new upstream release
280- add BuildRequires: libpwquality-devel
281
282* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
283- new upstream release
284
285* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
286- new upstream release
287- remove BuildRequires: GConf2-devel, libbonobo-devel
288- add BuildRequires: libwacom-devel
289
290* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
291- new upstream release
292
293* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
294- new upstream release
295
296* Mon Oct 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-2
297- rebuild with NetworkManager-0.9
298- change BuildRequires: NetworkManager-gtk-devel instead of NetworkManager-glib-devel
299
300* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
301- new upstream release
302
303* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
304- new upstream release
305
306* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
307- new upstream release
308- remove Patch0
309
310* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
311- new upstream release
312- add BuildRequires: libnotify-devel
313- add Patch0 (control-center-3.1.5-crash-layout.patch)
314
315* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
316- new upstream release
317- change BuildRequires: gtk3-devel instead of gtk2-devel
318- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
319- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
320- change BuildRequires: unique3-devel instead of unique-devel
321- add BuildRequires: libXxf86misc-devel, libSM-devel, polkit-devel, libgtop2-devel, upower-devel,
322                     pulseaudio-libs-devel, cups-devel, cheese-devel, gstreamer-plugins-base-devel,
323                     gnome-online-accounts-devel, colord-devel, NetworkManager-glib-devel
324- add Requires: apg
325- drop all Patches
326- add Provides: and Obsoletes: gnome-volume-manager
327
328* Mon Mar 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
329- update desktop-effect-integration patch
330  - fix freeze on changing metacity to compiz
331  - run compiz directly instead of compiz-gtk
332  - drop use of jockey-gtk
333- update ja.po
334
335* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
336- new upstream release
337
338* Sat Nov 06 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-4
339- update translation.
340
341* Fri Nov 05 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-3
342- update translation.
343
344* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
345- update Source21(gnome-control-center-2.32.0-vine.ja.po)
346
347* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
348- new upstream release
349- drop Patch22, Patch30, Patch52
350- fix %files
351
352* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-4
353- rebuilt with rpm-4.8.1 for pkg-config (too)
354
355* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
356- rebuild with rpm-4.8.1 for pkg-config file
357- add Requires: %{name}=%{version}-%{release}
358
359* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
360- rebuild with evolution-data-server-2.30.2
361
362* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
363- new upstream release
364
365* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
366- new upstream release
367- drop Patch3, Patch46, Patch50, Patch51, Patch53, Patch54, Patch112
368- add BuildRequires: gnome-common, unique-devel
369
370* Thu Dec 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-2
371- enable Patch101,110-112 and 500
372
373* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
374- new upstream release
375- disabled Patch101, 110-112 and 500
376
377* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-9
378- update notification-theme.patch
379  - use vine theme if NotificationTheme is not set in meta-theme.
380
381* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-8
382- add Patch510: use Sans for font-properties sample font.
383- add BR: librsvg2-devel, libXScrnSaver-devel
384- remove BR: esound
385
386* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-7
387- add Patch37: Don't rely on _BACKUP property for xkb initialization
388
389* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-6
390- renumber patch10 to patch1010
391  - do not check gdm fprint plugin
392- add Patch101: show aspect in drop down menu
393- add Patch110: modify gnome-mouse-properties to fit smaller screen
394- add Patch111: modify gnome-about-me to fit smaller screen
395- add Patch112: modify gnome-display-properties to fit smaller screen
396
397* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-5
398- update Patch100 to use compiz-gtk instead of compiz
399
400* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
401- update ja.po
402
403* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
404- import upstream patchs (10,22,3[0-6])
405
406* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
407- add nautilus-devel to BR: not Requires:
408
409* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
410- new upstream release
411- update ja.po
412- add BR: nautilus-devel
413
414* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-3
415- drop Patch20 which need new XInput API
416- update Patch23
417
418* Sat Oct 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
419- add Patch20,22.23 from ubuntu
420  - patch20 to add touchpad configuration
421  - patch22 to add aspect setting in randr capplet
422  - patch23 to integrate desktop setting into appearance-properties
423
424* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
425- new upstream release
426
427* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
428- new upstream release
429
430* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-3
431- add gnome-typing-monitor to %%files
432
433* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
434- add Patch100 for new RandR capplet. (fc)
435
436* Sat Jun  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2.1-1
437- new upstream release
438- dropped Patch8 (merged into upstream)
439
440* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
441- new upstream release
442- added Patch7 and Patch8 from Fedora
443  * Mon Mar 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
444  - Fix warnings in the keybindings capplet when in non-UTF-8 locale
445  - Fix Esc/Backspace being bindable when CapsLock is on (#427123)
446  * Tue Apr  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-2
447  - Remove a nonfunctional button from the a11y preferences
448- added BuildRequires: gnome-settings-daemon, gnome-panel
449- added Requires: gnome-icon-theme, gnome-desktop, dbus-x11
450- removed Requires: xscreensaver
451
452* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
453- new upstream release based on Fedora
454- added BuildRequires: gnome-settings-daemon
455
456* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
457- new upstream release based on Fedora
458  * Wed Oct 24 2007  Matthias Clasen <mclasen@redhat.com> - 2.20.1-5
459  - Fix the orca command in the default applications capplet (#351471)
460
461* Sat Jul 14 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl4
462- add BuildReq: libgnomekbd-devel
463
464* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
465- rebuilt with evolution-data-server-devel-1.10.1
466
467* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl2
468- add BuildReq: evolution-data-server-devel
469
470* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
471- new upstream release
472- remove unneeded? patch10
473
474* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.2-0vl2
475- added Patch10 to supress /dev/pmu warning messages on some ppc models
476
477* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
478- new upstream release
479
480* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
481- new upstream release
482
483* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
484- run gtk-update-icon-cache in %%post script.
485
486* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
487- new upstream release
488- drop Patch10,it is merged in upstream
489
490* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl2
491- add Patch10 for correct textdomain name in
492  default-applications-properties(Bug332833)
493- add Patch100 for change default-applications settings for vine
494
495* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
496- new upstream release
497
498* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
499- new upstream release
500
501* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
502- new upstream release
503
504* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
505- new upstream release
506- enable alsa support
507
508* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
509- new upstream release
510
511* Thu Mar 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl4
512- fixed type in %%post script
513
514* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl3
515- clear the old defaults of xkb
516
517* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
518- remove bonobo-activation dependency
519
520* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
521- new upstream version
522
523* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
524- new upstream release
525- add Japanese summay to devel package
526
527* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
528- new upstream release
529
530* Sat Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
531- modify patch11 to use NeoVine theme instead of BeCool.
532
533* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
534- rebuild with new toolchain
535
536* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
537- new upstream release
538- remove obsolete ja.po
539
540* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 2.3.6-0vl2
541- change required version of metacity to 2.4.34 on alpha
542
543* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
544- new upstream release
545
546* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl1
547- new upstream release
548
549* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl3
550- add more missing files and schemas...
551
552* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
553- add missing file in %{_libdir}/gnome-vfs-2.0/
554
555* Sat May 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl1
556- new upstream release
557- this is experimental version
558- remove sr@Latn locale from desktop files to build with desktop-file-utils-0.3
559
560* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
561- new upstream release
562
563* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl3
564- import patch6 (upstream paches) from rawhide package.
565
566* Tue Feb 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl2
567- import patch1-5 (upstream paches) from rawhide package.
568
569* Sun Feb 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
570- new upstream release
571
572* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
573- rebuild
574
575* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
576- new upstream release
577
578* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
579- new upstream release
580
581* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
582- new upstream release
583
584* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl7
585- change default gtk1 theme from Raleigh to BeCool.
586
587* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl6
588- add BuildRequires/Requires.
589- fixed kanjicode of specfile
590
591* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
592- remove bogus message in %%post scripts.
593
594* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
595- add patch10 to modify some desktop files
596- update ja.po
597
598* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
599- update ja.po
600
601* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
602- update ja.po
603
604* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
605- new upstream release
606
607* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl3
608- add devel package
609- add window-manager-settings files.
610
611* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl2
612- modify dependancies.
613
614* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
615- build for Vine Linux
616- new upstream release from gnome-2.1.4
617
618* Thu Sep  5 2002 Jonathan Blandford <jrb@redhat.com>
619- Allow setting custom mime handlers
620
621* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
622- make desktop file symlinks absolute #71991
623- add po files from cvs.gnome.org
624
625* Fri Aug 23 2002 Jonathan Blandford <jrb@redhat.com>
626- Fix up keyboard handling
627
628* Wed Aug 21 2002 Jonathan Blandford <jrb@redhat.com>
629- Fixes for #68735
630
631* Wed Aug  7 2002 Jonathan Blandford <jrb@redhat.com>
632- New version.  Fix up metacity theme locations
633
634* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
635- Switch the gtk1 theme along with the gtk2 theme
636- Add the ability to switch the window manager theme through the theme capplet
637- Add two more font options to the font property dialog
638- Add a bunch of missing unrefs of the result of gconf_client_get_default()
639
640* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
641- fix desktop files more
642- copy icons to /usr/share/pixmaps
643
644* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
645- munge the desktop files correctly
646- obsolete control-center-devel, #69168
647- replace gnomecc.desktop with a file from redhat-menus
648
649* Tue Jul 23 2002 Owen Taylor <otaylor@redhat.com>
650- Fix crasher bug in xftprefs patch
651
652* Tue Jul 16 2002 Owen Taylor <otaylor@redhat.com>
653- Change the default rendering style to be "Best Shapes", not "Best Contrast"
654
655* Tue Jul  9 2002 Owen Taylor <otaylor@redhat.com>
656- Add Xft / XSETTINGS support
657
658* Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 2.0.0-2
659- fix %%post so schemas get installed
660 
661* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
662- 2.0.0
663- add new default editor schemas
664- fix find_lang
665
666* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
667- rebuild for new libraries
668- remove a no-longer-existing schemas file from post
669- use desktop-file-install
670
671* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
672- rebuild in different environment
673
674* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
675- rebuild with new dependent libs
676
677* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
678- rebuild in different environment
679
680* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
681- rebuild in different environment
682- build requires bonobo-activation
683
684* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
685- 1.99.10
686
687* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
688- 1.99.9
689
690* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
691- Move to GNOME 2 version
692
693* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
694- merge in translations
695
696* Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
697- Make the theme selector write fontsets, not fonts (#62413)
698
699* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
700- really put screensaver capplet back (I think)
701
702* Wed Mar 27 2002 Bill Nottingham <notting@redhat.com>
703- revert xscreensaver change
704
705* Wed Mar 27 2002 Havoc Pennington <hp@redhat.com>
706- init "Scaled" radio button correctly #61913
707
708* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
709- change path to windowmaker config tool again, #61824
710
711* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com>
712- rather than keep patching and patching it, use xscreensaver's own
713  capplet
714
715* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
716- rebuild in Hampton
717
718* Wed Jan 30 2002 Jonathan Blandford <jrb@redhat.com>
719- Rebuild package.
720
721* Thu Jan 24 2002 Tim Powers <timp@redhat.com>
722- rebuilt against new openssl
723
724* Fri Jan 18 2002 Havoc Pennington <hp@redhat.com>
725- automake14
726- don't run auto* again in ccsingle subdir, not sure why we did that
727
728* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
729- rebuild with new gnome-libs so that libcapplet has right cflags/libs
730- pixbufflags patch to make the rebuild work
731- compileflags patch to make control-center-single work
732
733* Wed Aug 29 2001 Havoc Pennington <hp@redhat.com>
734- fix #52831 (UI properties in Programs menu)
735
736* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
737- Add po files from sources.redhat.com
738
739* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
740- set the _XROOTCOLOR_PIXEL property, should fix
741  bug #52141
742
743* Wed Aug 22 2001 Yukihiro Nakai <ynakai@redhat.com>
744- Update translation.
745- Add CJK fontset patch
746
747* Thu Aug 16 2001 Jonathan Blandford <jrb@redhat.com>
748- New control-center-single to handle exiting, #51665
749
750* Wed Aug 01 2001 Havoc Pennington <hp@redhat.com>
751- remove .desktop file for gnomecc, so it won't appear
752  in panel menu, #49653
753
754* Mon Jul 30 2001 Jonathan Blandford <jrb@redhat.com>
755- allow to build without depending on control-center-devel
756
757* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
758- Add BuildRequires
759
760* Mon Jul 16 2001 Jonathan Blandford <jrb@redhat.com>
761- New version of control-center-single
762
763* Thu Jul 12 2001 Alexander Larsson <alexl@redhat.com>
764- Change default background to the same as the nautilus one
765
766* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
767- add hack to default to standalone control panels
768
769* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
770- Bump release + rebuild.
771
772* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
773- putting in tree for David
774
775* Tue May 22 2001 David Sainty <dsainty@redhat.com>
776- improve DPMS patch for the try case, and enable patch
777
778* Wed May  2 2001 Bill Nottingham <notting@redhat.com>
779- add patch to use xscreensaver's DPMS stuff, require that version
780
781* Fri Apr 20 2001  <jrb@redhat.com>
782- New Version (1.4.0.1)
783
784* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
785- kick the mixer once on startup if we aren't running esd
786
787* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
788- translations
789
790* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
791- Rebuild for GTK+-1.2.9 include paths
792
793* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
794- langify
795- don't define and use "ver" at the top of the file
796- move changelog to sane location
797
798* Thu Feb 08 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-4
799- Apply patch from bug #23782 to see how it works
800
801* Fri Feb 02 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-3
802- Include fvwm2.desktop in WM's
803
804* Sat Jan 27 2001 Akira TAGOH <tagoh@redhat.com>
805- Added Japanese patch.
806
807* Mon Dec 04 2000 Jonathan Blandford <jrb@redhat.com>
808- Update release.
809
810* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
811- Again, fix problem with solid backgrounds in bg-properties capplet
812  (patch got lost somewhere)
813
814* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
815- Up Epoch and release
816
817* Thu Aug 10 2000 Owen Taylor <otaylor@redhat.com>
818- Handle unreadable desktop files without crashing
819
820* Mon Aug 07 2000 Owen Taylor <otaylor@redhat.com>
821- Fix problem with backgrounds bigger than screen.
822
823* Tue Aug 01 2000 Owen Taylor <otaylor@redhat.com>
824- Fix problem when ~/.gtkrc does not already exist.
825- Fix problem with solid backgrounds in bg-properties capplet
826
827* Tue Jul 18 2000 Owen Taylor <otaylor@redhat.com>
828- Sort of fix problem with people hitting OK while the
829  "Save Session" dialog is still up. (Session won't be saved,
830  but at least the selected entry will be correctly kept.)
831- Fix history list in background properties capplet
832- Fix problems with temporary files in theme-selector capplet
833
834* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
835- automatic rebuild
836
837* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
838- Require redhat-logos
839- Some spec file and FHS fixes
840- reposition embedded logo a bit
841
842* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
843- Add big change to use gdk-pixbuf for backgrounds and add
844  the ability to emboss the background with a logo
845
846* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
847- revert .so strip
848
849* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
850- strip .so lib
851- use configure macro
852
853* Mon Sep 20 1999 Jonathan Blandford <jrb@redhat.com>
854- changed to work with 1.0.40
855
856* Fri Sep 17 1999 Jonathan Blandford <jrb@redhat.com>
857- Added fixrevert bug to fix bug in theme selector.
858
859* Sun Jun 13 1999 Jonathan Blandford <jrb@redhat.com>
860- updated RPM to use new control-center.
861
862* Wed Apr 07 1999 Michael Fulbright <drmike@redhat.com>
863- fixed sound-properties to only disable sound when run with --init-settings-..
864- removed debugging output from several capplets, fixed try behaviour of sm and
865  gnome-edit capplets
866- fixed bug in screensaver and background props
867- added new icons
868
869* Mon Apr 05 1999 Jonathan Blandford <jrb@redhat.com>
870- added a patch to fix the close dialog
871- added a patch to limit the number of bg's in the history.
872
873* Fri Apr 02 1999 Jonathan Blandford <jrb@redhat.com>
874- vesion 1.0.5
875- removed all patches >10 other then dontstartesd.
876
877* Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
878- removed UI props till it works better
879
880* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
881- make sure we DONT inadvertantly start esd by calling esd_open_...
882
883* Tue Mar 30 1999 Michael Fulbright <drmike@redhat.com>
884- changed default bg color to '#356390'
885
886* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
887- prime file selector path for browse in background-props if
888  "/usr/share/pixmaps/backgrounds/" exists.
889- fix behavior of file selector when you delete/cancel/ok it
890
891* Wed Mar 24 1999 Michael Fulbright <drmike@redhat.com>
892- added patch to fix trying in theme selector
893- disabled crystal screensaver, it does evil things to preview in capplet
894
895* Mon Mar 22 1999 Michael Fulbright <drmike@redhat.com>
896- version 1.0.4, fixes problems with sndprops and theme props among
897  other things.
898
899* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
900- fix sound-properties capplet so Try/Revert doesnt come on unless user
901  changes something
902- fixed theme-selector to not leave processes behind on Linux 2.2 kernels
903- strip binaries
904
905* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
906- version 1.0.3
907- added patch to make esd release after 30 sec of inactivity
908
909* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
910- version 1.0.2
911- turned off sound by default
912
913* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
914- version 1.0.1
915
916* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
917- version 0.99.8.1
918- added etc/CORBA/servers/* to file list
919
920* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
921- update to 0.99.8
922- added /usr/lib/cappletConf.sh
923
924* Mon Feb 08 1999 The Rasterman <raster@redhat.com>
925- update to 0.99.5.1
926
927* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
928- update to 0.99.5
929
930* Wed Jan 20 1999 Michael Fulbright <drmike@redhat.com>
931- update to 0.99.3.1
932
933* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
934- update to 0.99.3
935- seems like patch for non-standard xscreensaver placement was already in
936  prestine sources(?)
937
938* Wed Jan 06 1999 Jonathan Blandford <jrb@redhat.com>
939- updated to 0.99.1
940- temporary hack patch to get path to work to non-standard placement
941  of xscreensaver binaries in RH 5.2
942
943* Wed Dec 16 1998 Jonathan Blandford <jrb@redhat.com>
944- Created for the new control-center branch
945
Note: See TracBrowser for help on using the repository browser.