source: projects/specs/trunk/c/control-center/control-center-vl.spec @ 8353

Revision 8353, 32.2 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.0

Line 
1%define pango_version 1.36.3
2%define gtk3_version 3.12.0
3%define gnome_desktop3_version 3.12.0
4%define libgnomekbd_version 3.6.0
5%define desktop_file_utils_version 0.3
6%define startup_notification_version 0.7
7%define libxklavier_version 5.0
8%define gnome_doc_utils_version 0.20
9%define gnome_menus_version 3.8.0
10%define vine_menus_version 3.0
11%define evolution_data_server_version 2.32.0
12%define libcanberra_version 0.9
13%define usermode_version 1.83
14%define libnotify_version 0.7.3
15%define nm_version 0.9.8
16%define mm_version 0.7.0
17
18Summary: GNOME Control Center.
19Summary(ja): GNOME コントロールセンター
20Name: control-center
21Version: 3.12.0
22Release: 1%{?_dist_release}
23License: GPLv2+ and GFDL+
24Group: User Interface/Desktops
25URL: http://www.gnome.org
26
27Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-control-center/3.12/gnome-control-center-%{version}.tar.xz
28
29Patch1: control-center-3.8.1-gpermission.patch
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: inagaki, daisuke, Takemikaduchi
34
35BuildRoot: %{_tmppath}/%{name}-%{version}-root
36
37Obsoletes: gnome, control-center-devel < 2.0
38Obsoletes: fontilus, themus
39
40Provides: gnome-volume-manager < 2.25
41Obsoletes: gnome-volume-manager < 2.25
42
43Requires: usermode >= %{usermode_version}
44Requires: gnome-settings-daemon
45Requires: gnome-icon-theme
46Requires: gnome-desktop3 >= %{gnome_desktop_version}
47Requires: dbus-x11
48Requires: apg
49Requires(post,postun): desktop-file-utils shared-mime-info gtk3
50
51BuildRequires: gnome-common
52BuildRequires: pango-devel >= %{pango_version}
53BuildRequires: gtk3-devel >= %{gtk3_version}
54BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
55BuildRequires: libgnomekbd-devel >= %{libgnomekbd_version}
56BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
57BuildRequires: startup-notification-devel >= %{startup_notification_version}
58BuildRequires: libxklavier-devel >= %{libxklavier_version}
59BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
60BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
61BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
62BuildRequires: gnome-settings-daemon-devel
63BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
64BuildRequires: nautilus-devel
65BuildRequires: alsa-lib-devel
66BuildRequires: autoconf
67BuildRequires: gettext-devel
68BuildRequires: librsvg2-devel
69BuildRequires: libXScrnSaver-devel
70BuildRequires: libXxf86misc-devel
71BuildRequires: libSM-devel
72BuildRequires: unique3-devel
73BuildRequires: polkit-devel
74BuildRequires: libgtop2-devel
75BuildRequires: upower-devel
76BuildRequires: pulseaudio-libs-devel
77BuildRequires: cups-devel
78BuildRequires: cheese-devel
79BuildRequires: grilo-devel
80BuildRequires: gstreamer-plugins-base-devel
81BuildRequires: gnome-online-accounts-devel
82BuildRequires: colord-devel
83BuildRequires: colord-gtk-devel
84BuildRequires: libnm-gtk-devel >= %{nm_version}
85BuildRequires: NetworkManager-glib-devel >= %{nm_version}
86BuildRequires: ModemManager-glib-devel >= %{mm_version}
87BuildRequires: libnotify-devel >= %{libnotify_version}
88BuildRequires: libwacom-devel
89BuildRequires: libpwquality-devel
90BuildRequires: ibus-devel
91BuildRequires: accountsservice-devel
92BuildRequires: gnome-online-accounts-devel
93BuildRequires: libsmbclient-devel
94
95%description
96GNOME (the GNU Network Object Model Environment) is an attractive and
97easy-to-use GUI desktop environment. The control-center package
98provides the GNOME Control Center utilities that allow you to setup
99and configure your system's GNOME environment (things like the desktop
100background and theme, the screensaver, the window manager, system
101sounds, and mouse behavior).
102
103If you install GNOME, you need to install control-center.
104
105%description -l ja
106GNOME (the GNU Network Object Model Environment) は、魅力的で使いやすい
107GUI デスクトップ環境です。 control-center パッケージには、あなたの GNOME
108環境の設定に使う GNOME コントロールセンター・ユーティリティが含まれていま
109す。(これを使うと、デスクトップの壁紙や、テーマ、スクリーンセーバ、ウィン
110ドウマネージャ、サウンド、マウス、その他いろいろな設定を行えます。)
111
112%package devel
113Summary: Development files for GNOME Control Center
114Summary(ja): GNOME コントロールセンターの開発用ファイル
115Group: Development/Libraries
116Requires: %{name} = %{version}-%{release}
117
118%description devel
119Development tool for GNOME Control Center
120
121%descriotion -l ja devel
122GNOME コントロールセンターの開発用ファイルが含まれています。
123
124%prep
125%setup -q -n gnome-control-center-%{version}
126%patch1 -p1
127
128%build
129autoreconf -if
130%configure --disable-static  \
131    --disable-update-mimedb \
132    --enable-ibus \
133        --with-libsocialweb=no
134    CFLAGS="$RPM_OPT_FLAGS -Wno-error"
135
136# drop unneeded direct library deps with --as-needed
137# libtool doesn't make this easy, so we do it the hard way
138sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/    if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/      func_append compile_command " -Wl,-O1,--as-needed"\n      func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
139
140make %{?_smp_mflags}
141
142%install
143rm -rf $RPM_BUILD_ROOT
144
145make install DESTDIR=$RPM_BUILD_ROOT
146
147desktop-file-install --delete-original                  \
148  --dir $RPM_BUILD_ROOT%{_datadir}/applications         \
149  --add-only-show-in GNOME                              \
150  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
151
152# we do want this
153mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
154
155# We don't want these
156rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
157rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/cursor-fonts
158
159# remove useless libtool archive files
160find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
161
162# don't package mime caches
163rm -f $RPM_BUILD_ROOT%{_datadir}/mime/XMLnamespaces
164rm -f $RPM_BUILD_ROOT%{_datadir}/mime/aliases
165rm -f $RPM_BUILD_ROOT%{_datadir}/mime/application/x-gnome-theme-package.xml
166rm -f $RPM_BUILD_ROOT%{_datadir}/mime/globs
167rm -f $RPM_BUILD_ROOT%{_datadir}/mime/magic
168rm -f $RPM_BUILD_ROOT%{_datadir}/mime/subclasses
169rm -f $RPM_BUILD_ROOT%{_datadir}/mime/mime.cache
170rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
171
172rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/fdl
173rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/lgpl
174
175%find_lang gnome-control-center-2.0
176%find_lang gnome-control-center-2.0-timezones
177
178%clean
179rm -rf $RPM_BUILD_ROOT
180
181%post
182/sbin/ldconfig
183
184update-desktop-database %{_datadir}/applications >& /dev/null ||:
185update-mime-database %{_datadir}/mime > /dev/null
186touch --no-create %{_datadir}/icons/hicolor
187if [ -x /usr/bin/gtk-update-icon-cache ]; then
188  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
189fi
190
191%postun
192/sbin/ldconfig
193update-desktop-database %{_datadir}/applications >& /dev/null ||:
194update-mime-database %{_datadir}/mime > /dev/null
195touch --no-create %{_datadir}/icons/hicolor
196if [ -x /usr/bin/gtk-update-icon-cache ]; then
197  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
198fi
199
200%files -f gnome-control-center-2.0.lang -f gnome-control-center-2.0-timezones.lang
201%defattr(-, root, root)
202%doc AUTHORS COPYING ChangeLog NEWS README
203%{_bindir}/gnome-control-center
204%{_libexecdir}/cc-remote-login-helper
205%{_libexecdir}/gnome-control-center-search-provider
206%dir %{_datadir}/gnome/wm-properties
207%dir %{_datadir}/gnome-control-center
208%{_datadir}/applications/*
209%{_datadir}/bash-completion/completions/gnome-control-center
210%{_datadir}/dbus-1/services/org.gnome.ControlCenter.SearchProvider.service
211%{_datadir}/dbus-1/services/org.gnome.ControlCenter.service
212%{_datadir}/gnome-control-center/datetime
213%{_datadir}/gnome-control-center/icons
214%{_datadir}/gnome-control-center/keybindings
215%{_datadir}/gnome-control-center/pixmaps
216%{_datadir}/gnome-control-center/sounds
217%{_datadir}/gnome-shell/search-providers/gnome-control-center-search-provider.ini
218%{_datadir}/icons/*
219%{_datadir}/pixmaps/*
220%{_datadir}/polkit-1/actions/org.gnome.controlcenter.datetime.policy
221%{_datadir}/polkit-1/actions/org.gnome.controlcenter.remote-login-helper.policy
222%{_datadir}/polkit-1/actions/org.gnome.controlcenter.user-accounts.policy
223%{_datadir}/polkit-1/rules.d/gnome-control-center.rules
224%{_datadir}/sounds/*
225%{_mandir}/man1/gnome-control-center.1.gz
226
227%files devel
228%defattr(-, root, root)
229%{_datadir}/pkgconfig/*
230
231
232%changelog
233* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
234- new upstream release
235- add BuildRequires: grilo-devel
236
237* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
238- new upstream release
239- remove Patch0 (gnome-control-center-3.10.1-test-chooser-dialog.patch)
240
241* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
242- new upstream release
243- add BuildRequires: NetworkManager-glib-devel, ModemManager-glib-devel, libsmbclient-devel
244- add Patch0 (gnome-control-center-3.10.1-test-chooser-dialog.patch)
245
246* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4.1-1
247- new upstream release
248
249* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
250- new upstream release
251
252* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
253- new upstream release
254- remove Patch0 (control-center-3.8.1-git20130424.patch)
255
256* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-2
257- add Patch1 (control-center-3.8.1-gpermission.patch)
258
259* Wed Apr 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
260- new upstream release
261- remove BuildRequires: gnome-panel-devel, metacity-devel
262- change BuildRequires: libnm-gtk-devel instead of NetworkManager-gtk-devel
263- add BuildRequires: colord-gtk-devel, accountsservice-devel, gnome-online-accounts-devel
264- add Patch0 (control-center-3.8.1-git20130424.patch)
265
266* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
267- new upstream release
268
269* Tue Oct 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
270- new upstream release
271
272* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
273- new upstream release
274
275* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
276- new upstream release
277- add BuildRequires: libpwquality-devel
278
279* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
280- new upstream release
281
282* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
283- new upstream release
284- remove BuildRequires: GConf2-devel, libbonobo-devel
285- add BuildRequires: libwacom-devel
286
287* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
288- new upstream release
289
290* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
291- new upstream release
292
293* Mon Oct 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-2
294- rebuild with NetworkManager-0.9
295- change BuildRequires: NetworkManager-gtk-devel instead of NetworkManager-glib-devel
296
297* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
298- new upstream release
299
300* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
301- new upstream release
302
303* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
304- new upstream release
305- remove Patch0
306
307* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
308- new upstream release
309- add BuildRequires: libnotify-devel
310- add Patch0 (control-center-3.1.5-crash-layout.patch)
311
312* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
313- new upstream release
314- change BuildRequires: gtk3-devel instead of gtk2-devel
315- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
316- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
317- change BuildRequires: unique3-devel instead of unique-devel
318- add BuildRequires: libXxf86misc-devel, libSM-devel, polkit-devel, libgtop2-devel, upower-devel,
319                     pulseaudio-libs-devel, cups-devel, cheese-devel, gstreamer-plugins-base-devel,
320                     gnome-online-accounts-devel, colord-devel, NetworkManager-glib-devel
321- add Requires: apg
322- drop all Patches
323- add Provides: and Obsoletes: gnome-volume-manager
324
325* Mon Mar 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
326- update desktop-effect-integration patch
327  - fix freeze on changing metacity to compiz
328  - run compiz directly instead of compiz-gtk
329  - drop use of jockey-gtk
330- update ja.po
331
332* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
333- new upstream release
334
335* Sat Nov 06 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-4
336- update translation.
337
338* Fri Nov 05 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-3
339- update translation.
340
341* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
342- update Source21(gnome-control-center-2.32.0-vine.ja.po)
343
344* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
345- new upstream release
346- drop Patch22, Patch30, Patch52
347- fix %files
348
349* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-4
350- rebuilt with rpm-4.8.1 for pkg-config (too)
351
352* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
353- rebuild with rpm-4.8.1 for pkg-config file
354- add Requires: %{name}=%{version}-%{release}
355
356* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
357- rebuild with evolution-data-server-2.30.2
358
359* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
360- new upstream release
361
362* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
363- new upstream release
364- drop Patch3, Patch46, Patch50, Patch51, Patch53, Patch54, Patch112
365- add BuildRequires: gnome-common, unique-devel
366
367* Thu Dec 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-2
368- enable Patch101,110-112 and 500
369
370* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
371- new upstream release
372- disabled Patch101, 110-112 and 500
373
374* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-9
375- update notification-theme.patch
376  - use vine theme if NotificationTheme is not set in meta-theme.
377
378* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-8
379- add Patch510: use Sans for font-properties sample font.
380- add BR: librsvg2-devel, libXScrnSaver-devel
381- remove BR: esound
382
383* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-7
384- add Patch37: Don't rely on _BACKUP property for xkb initialization
385
386* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-6
387- renumber patch10 to patch1010
388  - do not check gdm fprint plugin
389- add Patch101: show aspect in drop down menu
390- add Patch110: modify gnome-mouse-properties to fit smaller screen
391- add Patch111: modify gnome-about-me to fit smaller screen
392- add Patch112: modify gnome-display-properties to fit smaller screen
393
394* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-5
395- update Patch100 to use compiz-gtk instead of compiz
396
397* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
398- update ja.po
399
400* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
401- import upstream patchs (10,22,3[0-6])
402
403* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
404- add nautilus-devel to BR: not Requires:
405
406* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
407- new upstream release
408- update ja.po
409- add BR: nautilus-devel
410
411* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-3
412- drop Patch20 which need new XInput API
413- update Patch23
414
415* Sat Oct 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
416- add Patch20,22.23 from ubuntu
417  - patch20 to add touchpad configuration
418  - patch22 to add aspect setting in randr capplet
419  - patch23 to integrate desktop setting into appearance-properties
420
421* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
422- new upstream release
423
424* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
425- new upstream release
426
427* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-3
428- add gnome-typing-monitor to %%files
429
430* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
431- add Patch100 for new RandR capplet. (fc)
432
433* Sat Jun  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2.1-1
434- new upstream release
435- dropped Patch8 (merged into upstream)
436
437* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
438- new upstream release
439- added Patch7 and Patch8 from Fedora
440  * Mon Mar 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
441  - Fix warnings in the keybindings capplet when in non-UTF-8 locale
442  - Fix Esc/Backspace being bindable when CapsLock is on (#427123)
443  * Tue Apr  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-2
444  - Remove a nonfunctional button from the a11y preferences
445- added BuildRequires: gnome-settings-daemon, gnome-panel
446- added Requires: gnome-icon-theme, gnome-desktop, dbus-x11
447- removed Requires: xscreensaver
448
449* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
450- new upstream release based on Fedora
451- added BuildRequires: gnome-settings-daemon
452
453* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
454- new upstream release based on Fedora
455  * Wed Oct 24 2007  Matthias Clasen <mclasen@redhat.com> - 2.20.1-5
456  - Fix the orca command in the default applications capplet (#351471)
457
458* Sat Jul 14 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl4
459- add BuildReq: libgnomekbd-devel
460
461* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
462- rebuilt with evolution-data-server-devel-1.10.1
463
464* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl2
465- add BuildReq: evolution-data-server-devel
466
467* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
468- new upstream release
469- remove unneeded? patch10
470
471* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.2-0vl2
472- added Patch10 to supress /dev/pmu warning messages on some ppc models
473
474* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
475- new upstream release
476
477* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
478- new upstream release
479
480* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
481- run gtk-update-icon-cache in %%post script.
482
483* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
484- new upstream release
485- drop Patch10,it is merged in upstream
486
487* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl2
488- add Patch10 for correct textdomain name in
489  default-applications-properties(Bug332833)
490- add Patch100 for change default-applications settings for vine
491
492* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
493- new upstream release
494
495* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
496- new upstream release
497
498* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
499- new upstream release
500
501* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
502- new upstream release
503- enable alsa support
504
505* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
506- new upstream release
507
508* Thu Mar 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl4
509- fixed type in %%post script
510
511* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl3
512- clear the old defaults of xkb
513
514* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
515- remove bonobo-activation dependency
516
517* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
518- new upstream version
519
520* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
521- new upstream release
522- add Japanese summay to devel package
523
524* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
525- new upstream release
526
527* Sat Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
528- modify patch11 to use NeoVine theme instead of BeCool.
529
530* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
531- rebuild with new toolchain
532
533* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
534- new upstream release
535- remove obsolete ja.po
536
537* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 2.3.6-0vl2
538- change required version of metacity to 2.4.34 on alpha
539
540* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
541- new upstream release
542
543* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl1
544- new upstream release
545
546* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl3
547- add more missing files and schemas...
548
549* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
550- add missing file in %{_libdir}/gnome-vfs-2.0/
551
552* Sat May 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl1
553- new upstream release
554- this is experimental version
555- remove sr@Latn locale from desktop files to build with desktop-file-utils-0.3
556
557* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
558- new upstream release
559
560* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl3
561- import patch6 (upstream paches) from rawhide package.
562
563* Tue Feb 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl2
564- import patch1-5 (upstream paches) from rawhide package.
565
566* Sun Feb 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
567- new upstream release
568
569* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
570- rebuild
571
572* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
573- new upstream release
574
575* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
576- new upstream release
577
578* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
579- new upstream release
580
581* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl7
582- change default gtk1 theme from Raleigh to BeCool.
583
584* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl6
585- add BuildRequires/Requires.
586- fixed kanjicode of specfile
587
588* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
589- remove bogus message in %%post scripts.
590
591* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
592- add patch10 to modify some desktop files
593- update ja.po
594
595* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
596- update ja.po
597
598* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
599- update ja.po
600
601* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
602- new upstream release
603
604* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl3
605- add devel package
606- add window-manager-settings files.
607
608* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl2
609- modify dependancies.
610
611* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
612- build for Vine Linux
613- new upstream release from gnome-2.1.4
614
615* Thu Sep  5 2002 Jonathan Blandford <jrb@redhat.com>
616- Allow setting custom mime handlers
617
618* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
619- make desktop file symlinks absolute #71991
620- add po files from cvs.gnome.org
621
622* Fri Aug 23 2002 Jonathan Blandford <jrb@redhat.com>
623- Fix up keyboard handling
624
625* Wed Aug 21 2002 Jonathan Blandford <jrb@redhat.com>
626- Fixes for #68735
627
628* Wed Aug  7 2002 Jonathan Blandford <jrb@redhat.com>
629- New version.  Fix up metacity theme locations
630
631* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
632- Switch the gtk1 theme along with the gtk2 theme
633- Add the ability to switch the window manager theme through the theme capplet
634- Add two more font options to the font property dialog
635- Add a bunch of missing unrefs of the result of gconf_client_get_default()
636
637* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
638- fix desktop files more
639- copy icons to /usr/share/pixmaps
640
641* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
642- munge the desktop files correctly
643- obsolete control-center-devel, #69168
644- replace gnomecc.desktop with a file from redhat-menus
645
646* Tue Jul 23 2002 Owen Taylor <otaylor@redhat.com>
647- Fix crasher bug in xftprefs patch
648
649* Tue Jul 16 2002 Owen Taylor <otaylor@redhat.com>
650- Change the default rendering style to be "Best Shapes", not "Best Contrast"
651
652* Tue Jul  9 2002 Owen Taylor <otaylor@redhat.com>
653- Add Xft / XSETTINGS support
654
655* Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 2.0.0-2
656- fix %%post so schemas get installed
657 
658* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
659- 2.0.0
660- add new default editor schemas
661- fix find_lang
662
663* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
664- rebuild for new libraries
665- remove a no-longer-existing schemas file from post
666- use desktop-file-install
667
668* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
669- rebuild in different environment
670
671* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
672- rebuild with new dependent libs
673
674* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
675- rebuild in different environment
676
677* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
678- rebuild in different environment
679- build requires bonobo-activation
680
681* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
682- 1.99.10
683
684* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
685- 1.99.9
686
687* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
688- Move to GNOME 2 version
689
690* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
691- merge in translations
692
693* Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
694- Make the theme selector write fontsets, not fonts (#62413)
695
696* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
697- really put screensaver capplet back (I think)
698
699* Wed Mar 27 2002 Bill Nottingham <notting@redhat.com>
700- revert xscreensaver change
701
702* Wed Mar 27 2002 Havoc Pennington <hp@redhat.com>
703- init "Scaled" radio button correctly #61913
704
705* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
706- change path to windowmaker config tool again, #61824
707
708* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com>
709- rather than keep patching and patching it, use xscreensaver's own
710  capplet
711
712* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
713- rebuild in Hampton
714
715* Wed Jan 30 2002 Jonathan Blandford <jrb@redhat.com>
716- Rebuild package.
717
718* Thu Jan 24 2002 Tim Powers <timp@redhat.com>
719- rebuilt against new openssl
720
721* Fri Jan 18 2002 Havoc Pennington <hp@redhat.com>
722- automake14
723- don't run auto* again in ccsingle subdir, not sure why we did that
724
725* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
726- rebuild with new gnome-libs so that libcapplet has right cflags/libs
727- pixbufflags patch to make the rebuild work
728- compileflags patch to make control-center-single work
729
730* Wed Aug 29 2001 Havoc Pennington <hp@redhat.com>
731- fix #52831 (UI properties in Programs menu)
732
733* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
734- Add po files from sources.redhat.com
735
736* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
737- set the _XROOTCOLOR_PIXEL property, should fix
738  bug #52141
739
740* Wed Aug 22 2001 Yukihiro Nakai <ynakai@redhat.com>
741- Update translation.
742- Add CJK fontset patch
743
744* Thu Aug 16 2001 Jonathan Blandford <jrb@redhat.com>
745- New control-center-single to handle exiting, #51665
746
747* Wed Aug 01 2001 Havoc Pennington <hp@redhat.com>
748- remove .desktop file for gnomecc, so it won't appear
749  in panel menu, #49653
750
751* Mon Jul 30 2001 Jonathan Blandford <jrb@redhat.com>
752- allow to build without depending on control-center-devel
753
754* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
755- Add BuildRequires
756
757* Mon Jul 16 2001 Jonathan Blandford <jrb@redhat.com>
758- New version of control-center-single
759
760* Thu Jul 12 2001 Alexander Larsson <alexl@redhat.com>
761- Change default background to the same as the nautilus one
762
763* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
764- add hack to default to standalone control panels
765
766* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
767- Bump release + rebuild.
768
769* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
770- putting in tree for David
771
772* Tue May 22 2001 David Sainty <dsainty@redhat.com>
773- improve DPMS patch for the try case, and enable patch
774
775* Wed May  2 2001 Bill Nottingham <notting@redhat.com>
776- add patch to use xscreensaver's DPMS stuff, require that version
777
778* Fri Apr 20 2001  <jrb@redhat.com>
779- New Version (1.4.0.1)
780
781* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
782- kick the mixer once on startup if we aren't running esd
783
784* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
785- translations
786
787* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
788- Rebuild for GTK+-1.2.9 include paths
789
790* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
791- langify
792- don't define and use "ver" at the top of the file
793- move changelog to sane location
794
795* Thu Feb 08 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-4
796- Apply patch from bug #23782 to see how it works
797
798* Fri Feb 02 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-3
799- Include fvwm2.desktop in WM's
800
801* Sat Jan 27 2001 Akira TAGOH <tagoh@redhat.com>
802- Added Japanese patch.
803
804* Mon Dec 04 2000 Jonathan Blandford <jrb@redhat.com>
805- Update release.
806
807* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
808- Again, fix problem with solid backgrounds in bg-properties capplet
809  (patch got lost somewhere)
810
811* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
812- Up Epoch and release
813
814* Thu Aug 10 2000 Owen Taylor <otaylor@redhat.com>
815- Handle unreadable desktop files without crashing
816
817* Mon Aug 07 2000 Owen Taylor <otaylor@redhat.com>
818- Fix problem with backgrounds bigger than screen.
819
820* Tue Aug 01 2000 Owen Taylor <otaylor@redhat.com>
821- Fix problem when ~/.gtkrc does not already exist.
822- Fix problem with solid backgrounds in bg-properties capplet
823
824* Tue Jul 18 2000 Owen Taylor <otaylor@redhat.com>
825- Sort of fix problem with people hitting OK while the
826  "Save Session" dialog is still up. (Session won't be saved,
827  but at least the selected entry will be correctly kept.)
828- Fix history list in background properties capplet
829- Fix problems with temporary files in theme-selector capplet
830
831* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
832- automatic rebuild
833
834* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
835- Require redhat-logos
836- Some spec file and FHS fixes
837- reposition embedded logo a bit
838
839* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
840- Add big change to use gdk-pixbuf for backgrounds and add
841  the ability to emboss the background with a logo
842
843* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
844- revert .so strip
845
846* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
847- strip .so lib
848- use configure macro
849
850* Mon Sep 20 1999 Jonathan Blandford <jrb@redhat.com>
851- changed to work with 1.0.40
852
853* Fri Sep 17 1999 Jonathan Blandford <jrb@redhat.com>
854- Added fixrevert bug to fix bug in theme selector.
855
856* Sun Jun 13 1999 Jonathan Blandford <jrb@redhat.com>
857- updated RPM to use new control-center.
858
859* Wed Apr 07 1999 Michael Fulbright <drmike@redhat.com>
860- fixed sound-properties to only disable sound when run with --init-settings-..
861- removed debugging output from several capplets, fixed try behaviour of sm and
862  gnome-edit capplets
863- fixed bug in screensaver and background props
864- added new icons
865
866* Mon Apr 05 1999 Jonathan Blandford <jrb@redhat.com>
867- added a patch to fix the close dialog
868- added a patch to limit the number of bg's in the history.
869
870* Fri Apr 02 1999 Jonathan Blandford <jrb@redhat.com>
871- vesion 1.0.5
872- removed all patches >10 other then dontstartesd.
873
874* Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
875- removed UI props till it works better
876
877* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
878- make sure we DONT inadvertantly start esd by calling esd_open_...
879
880* Tue Mar 30 1999 Michael Fulbright <drmike@redhat.com>
881- changed default bg color to '#356390'
882
883* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
884- prime file selector path for browse in background-props if
885  "/usr/share/pixmaps/backgrounds/" exists.
886- fix behavior of file selector when you delete/cancel/ok it
887
888* Wed Mar 24 1999 Michael Fulbright <drmike@redhat.com>
889- added patch to fix trying in theme selector
890- disabled crystal screensaver, it does evil things to preview in capplet
891
892* Mon Mar 22 1999 Michael Fulbright <drmike@redhat.com>
893- version 1.0.4, fixes problems with sndprops and theme props among
894  other things.
895
896* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
897- fix sound-properties capplet so Try/Revert doesnt come on unless user
898  changes something
899- fixed theme-selector to not leave processes behind on Linux 2.2 kernels
900- strip binaries
901
902* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
903- version 1.0.3
904- added patch to make esd release after 30 sec of inactivity
905
906* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
907- version 1.0.2
908- turned off sound by default
909
910* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
911- version 1.0.1
912
913* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
914- version 0.99.8.1
915- added etc/CORBA/servers/* to file list
916
917* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
918- update to 0.99.8
919- added /usr/lib/cappletConf.sh
920
921* Mon Feb 08 1999 The Rasterman <raster@redhat.com>
922- update to 0.99.5.1
923
924* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
925- update to 0.99.5
926
927* Wed Jan 20 1999 Michael Fulbright <drmike@redhat.com>
928- update to 0.99.3.1
929
930* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
931- update to 0.99.3
932- seems like patch for non-standard xscreensaver placement was already in
933  prestine sources(?)
934
935* Wed Jan 06 1999 Jonathan Blandford <jrb@redhat.com>
936- updated to 0.99.1
937- temporary hack patch to get path to work to non-standard placement
938  of xscreensaver binaries in RH 5.2
939
940* Wed Dec 16 1998 Jonathan Blandford <jrb@redhat.com>
941- Created for the new control-center branch
942
Note: See TracBrowser for help on using the repository browser.