source: projects/specs/trunk/c/control-center/control-center-vl.spec @ 7756

Revision 7756, 31.4 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%define pango_version 1.34.0
2%define gtk3_version 3.8.0
3%define gnome_desktop3_version 3.8.0
4%define libgnomekbd_version 3.6.0
5%define desktop_file_utils_version 0.3
6%define startup_notification_version 0.7
7%define libxklavier_version 5.0
8%define gnome_doc_utils_version 0.20
9%define gnome_menus_version 3.8.0
10%define vine_menus_version 3.0
11%define evolution_data_server_version 2.32.0
12%define libcanberra_version 0.9
13%define usermode_version 1.83
14%define libnotify_version 0.7.3
15%define nm_version 0.9.0
16
17Summary: GNOME Control Center.
18Summary(ja): GNOME コントロールセンター
19Name: control-center
20Version: 3.8.4.1
21Release: 1%{?_dist_release}
22License: GPLv2+ and GFDL+
23Group: User Interface/Desktops
24URL: http://www.gnome.org
25
26Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-control-center/3.8/gnome-control-center-%{version}.tar.xz
27
28Patch1: control-center-3.8.1-gpermission.patch
29
30Vendor: Project Vine
31Distribution: Vine Linux
32Packager: inagaki, daisuke, Takemikaduchi
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36Obsoletes: gnome, control-center-devel < 2.0
37Obsoletes: fontilus, themus
38
39Provides: gnome-volume-manager < 2.25
40Obsoletes: gnome-volume-manager < 2.25
41
42Requires: usermode >= %{usermode_version}
43Requires: gnome-settings-daemon
44Requires: gnome-icon-theme
45Requires: gnome-desktop3 >= %{gnome_desktop_version}
46Requires: dbus-x11
47Requires: apg
48Requires(post,postun): desktop-file-utils shared-mime-info gtk3
49
50BuildRequires: gnome-common
51BuildRequires: pango-devel >= %{pango_version}
52BuildRequires: gtk3-devel >= %{gtk3_version}
53BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
54BuildRequires: libgnomekbd-devel >= %{libgnomekbd_version}
55BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
56BuildRequires: startup-notification-devel >= %{startup_notification_version}
57BuildRequires: libxklavier-devel >= %{libxklavier_version}
58BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
59BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
60BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
61BuildRequires: gnome-settings-daemon-devel
62BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
63BuildRequires: nautilus-devel
64BuildRequires: alsa-lib-devel
65BuildRequires: autoconf
66BuildRequires: gettext-devel
67BuildRequires: librsvg2-devel
68BuildRequires: libXScrnSaver-devel
69BuildRequires: libXxf86misc-devel
70BuildRequires: libSM-devel
71BuildRequires: unique3-devel
72BuildRequires: polkit-devel
73BuildRequires: libgtop2-devel
74BuildRequires: upower-devel
75BuildRequires: pulseaudio-libs-devel
76BuildRequires: cups-devel
77BuildRequires: cheese-devel
78BuildRequires: gstreamer-plugins-base-devel
79BuildRequires: gnome-online-accounts-devel
80BuildRequires: colord-devel
81BuildRequires: colord-gtk-devel
82BuildRequires: libnm-gtk-devel >= %{nm_version}
83BuildRequires: libnotify-devel >= %{libnotify_version}
84BuildRequires: libwacom-devel
85BuildRequires: libpwquality-devel
86BuildRequires: ibus-devel
87BuildRequires: accountsservice-devel
88BuildRequires: gnome-online-accounts-devel
89
90%description
91GNOME (the GNU Network Object Model Environment) is an attractive and
92easy-to-use GUI desktop environment. The control-center package
93provides the GNOME Control Center utilities that allow you to setup
94and configure your system's GNOME environment (things like the desktop
95background and theme, the screensaver, the window manager, system
96sounds, and mouse behavior).
97
98If you install GNOME, you need to install control-center.
99
100%description -l ja
101GNOME (the GNU Network Object Model Environment) は、魅力的で使いやすい
102GUI デスクトップ環境です。 control-center パッケージには、あなたの GNOME
103環境の設定に使う GNOME コントロールセンター・ユーティリティが含まれていま
104す。(これを使うと、デスクトップの壁紙や、テーマ、スクリーンセーバ、ウィン
105ドウマネージャ、サウンド、マウス、その他いろいろな設定を行えます。)
106
107%package devel
108Summary: Development files for GNOME Control Center
109Summary(ja): GNOME コントロールセンターの開発用ファイル
110Group: Development/Libraries
111Requires: %{name} = %{version}-%{release}
112
113%description devel
114Development tool for GNOME Control Center
115
116%descriotion -l ja devel
117GNOME コントロールセンターの開発用ファイルが含まれています。
118
119%prep
120%setup -q -n gnome-control-center-%{version}
121%patch1 -p1
122
123%build
124%configure --disable-static  \
125    --disable-update-mimedb \
126    --enable-ibus \
127        --with-libsocialweb=no
128    CFLAGS="$RPM_OPT_FLAGS -Wno-error"
129
130# drop unneeded direct library deps with --as-needed
131# libtool doesn't make this easy, so we do it the hard way
132sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/    if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/      func_append compile_command " -Wl,-O1,--as-needed"\n      func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
133
134make %{?_smp_mflags}
135
136%install
137rm -rf $RPM_BUILD_ROOT
138
139make install DESTDIR=$RPM_BUILD_ROOT
140
141desktop-file-install --delete-original                  \
142  --dir $RPM_BUILD_ROOT%{_datadir}/applications         \
143  --add-only-show-in GNOME                              \
144  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
145
146# we do want this
147mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
148
149# We don't want these
150rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
151rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/cursor-fonts
152
153# remove useless libtool archive files
154find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
155
156# don't package mime caches
157rm -f $RPM_BUILD_ROOT%{_datadir}/mime/XMLnamespaces
158rm -f $RPM_BUILD_ROOT%{_datadir}/mime/aliases
159rm -f $RPM_BUILD_ROOT%{_datadir}/mime/application/x-gnome-theme-package.xml
160rm -f $RPM_BUILD_ROOT%{_datadir}/mime/globs
161rm -f $RPM_BUILD_ROOT%{_datadir}/mime/magic
162rm -f $RPM_BUILD_ROOT%{_datadir}/mime/subclasses
163rm -f $RPM_BUILD_ROOT%{_datadir}/mime/mime.cache
164rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
165
166rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/fdl
167rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/lgpl
168
169%find_lang gnome-control-center-2.0
170%find_lang gnome-control-center-2.0-timezones
171
172%clean
173rm -rf $RPM_BUILD_ROOT
174
175%post
176/sbin/ldconfig
177
178update-desktop-database %{_datadir}/applications >& /dev/null ||:
179update-mime-database %{_datadir}/mime > /dev/null
180touch --no-create %{_datadir}/icons/hicolor
181if [ -x /usr/bin/gtk-update-icon-cache ]; then
182  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
183fi
184
185%postun
186/sbin/ldconfig
187update-desktop-database %{_datadir}/applications >& /dev/null ||:
188update-mime-database %{_datadir}/mime > /dev/null
189touch --no-create %{_datadir}/icons/hicolor
190if [ -x /usr/bin/gtk-update-icon-cache ]; then
191  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
192fi
193
194%files -f gnome-control-center-2.0.lang -f gnome-control-center-2.0-timezones.lang
195%defattr(-, root, root)
196%doc AUTHORS COPYING ChangeLog NEWS README
197%{_bindir}/gnome-control-center
198%{_libexecdir}/cc-remote-login-helper
199%{_libexecdir}/gnome-control-center-search-provider
200%dir %{_datadir}/gnome/wm-properties
201%dir %{_datadir}/gnome-control-center
202%{_datadir}/applications/*
203%{_datadir}/bash-completion/completions/gnome-control-center
204%{_datadir}/dbus-1/services/org.gnome.ControlCenter.SearchProvider.service
205%{_datadir}/gnome-control-center/datetime
206%{_datadir}/gnome-control-center/icons
207%{_datadir}/gnome-control-center/keybindings
208%{_datadir}/gnome-control-center/pixmaps
209%{_datadir}/gnome-control-center/sounds
210%{_datadir}/gnome-shell/search-providers/gnome-control-center-search-provider.ini
211%{_datadir}/icons/*
212%{_datadir}/pixmaps/*
213%{_datadir}/polkit-1/actions/org.gnome.controlcenter.datetime.policy
214%{_datadir}/polkit-1/actions/org.gnome.controlcenter.remote-login-helper.policy
215%{_datadir}/polkit-1/actions/org.gnome.controlcenter.user-accounts.policy
216%{_datadir}/polkit-1/rules.d/gnome-control-center.rules
217%{_datadir}/sounds/*
218%{_mandir}/man1/gnome-control-center.1.gz
219
220%files devel
221%defattr(-, root, root)
222%{_datadir}/pkgconfig/*
223
224
225%changelog
226* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4.1-1
227- new upstream release
228
229* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
230- new upstream release
231
232* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
233- new upstream release
234- remove Patch0 (control-center-3.8.1-git20130424.patch)
235
236* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-2
237- add Patch1 (control-center-3.8.1-gpermission.patch)
238
239* Wed Apr 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
240- new upstream release
241- remove BuildRequires: gnome-panel-devel, metacity-devel
242- change BuildRequires: libnm-gtk-devel instead of NetworkManager-gtk-devel
243- add BuildRequires: colord-gtk-devel, accountsservice-devel, gnome-online-accounts-devel
244- add Patch0 (control-center-3.8.1-git20130424.patch)
245
246* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
247- new upstream release
248
249* Tue Oct 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
250- new upstream release
251
252* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
253- new upstream release
254
255* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
256- new upstream release
257- add BuildRequires: libpwquality-devel
258
259* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
260- new upstream release
261
262* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
263- new upstream release
264- remove BuildRequires: GConf2-devel, libbonobo-devel
265- add BuildRequires: libwacom-devel
266
267* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
268- new upstream release
269
270* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
271- new upstream release
272
273* Mon Oct 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-2
274- rebuild with NetworkManager-0.9
275- change BuildRequires: NetworkManager-gtk-devel instead of NetworkManager-glib-devel
276
277* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
278- new upstream release
279
280* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
281- new upstream release
282
283* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
284- new upstream release
285- remove Patch0
286
287* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
288- new upstream release
289- add BuildRequires: libnotify-devel
290- add Patch0 (control-center-3.1.5-crash-layout.patch)
291
292* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
293- new upstream release
294- change BuildRequires: gtk3-devel instead of gtk2-devel
295- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
296- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
297- change BuildRequires: unique3-devel instead of unique-devel
298- add BuildRequires: libXxf86misc-devel, libSM-devel, polkit-devel, libgtop2-devel, upower-devel,
299                     pulseaudio-libs-devel, cups-devel, cheese-devel, gstreamer-plugins-base-devel,
300                     gnome-online-accounts-devel, colord-devel, NetworkManager-glib-devel
301- add Requires: apg
302- drop all Patches
303- add Provides: and Obsoletes: gnome-volume-manager
304
305* Mon Mar 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
306- update desktop-effect-integration patch
307  - fix freeze on changing metacity to compiz
308  - run compiz directly instead of compiz-gtk
309  - drop use of jockey-gtk
310- update ja.po
311
312* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
313- new upstream release
314
315* Sat Nov 06 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-4
316- update translation.
317
318* Fri Nov 05 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-3
319- update translation.
320
321* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
322- update Source21(gnome-control-center-2.32.0-vine.ja.po)
323
324* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
325- new upstream release
326- drop Patch22, Patch30, Patch52
327- fix %files
328
329* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-4
330- rebuilt with rpm-4.8.1 for pkg-config (too)
331
332* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
333- rebuild with rpm-4.8.1 for pkg-config file
334- add Requires: %{name}=%{version}-%{release}
335
336* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
337- rebuild with evolution-data-server-2.30.2
338
339* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
340- new upstream release
341
342* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
343- new upstream release
344- drop Patch3, Patch46, Patch50, Patch51, Patch53, Patch54, Patch112
345- add BuildRequires: gnome-common, unique-devel
346
347* Thu Dec 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-2
348- enable Patch101,110-112 and 500
349
350* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
351- new upstream release
352- disabled Patch101, 110-112 and 500
353
354* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-9
355- update notification-theme.patch
356  - use vine theme if NotificationTheme is not set in meta-theme.
357
358* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-8
359- add Patch510: use Sans for font-properties sample font.
360- add BR: librsvg2-devel, libXScrnSaver-devel
361- remove BR: esound
362
363* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-7
364- add Patch37: Don't rely on _BACKUP property for xkb initialization
365
366* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-6
367- renumber patch10 to patch1010
368  - do not check gdm fprint plugin
369- add Patch101: show aspect in drop down menu
370- add Patch110: modify gnome-mouse-properties to fit smaller screen
371- add Patch111: modify gnome-about-me to fit smaller screen
372- add Patch112: modify gnome-display-properties to fit smaller screen
373
374* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-5
375- update Patch100 to use compiz-gtk instead of compiz
376
377* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
378- update ja.po
379
380* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
381- import upstream patchs (10,22,3[0-6])
382
383* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
384- add nautilus-devel to BR: not Requires:
385
386* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
387- new upstream release
388- update ja.po
389- add BR: nautilus-devel
390
391* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-3
392- drop Patch20 which need new XInput API
393- update Patch23
394
395* Sat Oct 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
396- add Patch20,22.23 from ubuntu
397  - patch20 to add touchpad configuration
398  - patch22 to add aspect setting in randr capplet
399  - patch23 to integrate desktop setting into appearance-properties
400
401* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
402- new upstream release
403
404* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
405- new upstream release
406
407* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-3
408- add gnome-typing-monitor to %%files
409
410* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
411- add Patch100 for new RandR capplet. (fc)
412
413* Sat Jun  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2.1-1
414- new upstream release
415- dropped Patch8 (merged into upstream)
416
417* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
418- new upstream release
419- added Patch7 and Patch8 from Fedora
420  * Mon Mar 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
421  - Fix warnings in the keybindings capplet when in non-UTF-8 locale
422  - Fix Esc/Backspace being bindable when CapsLock is on (#427123)
423  * Tue Apr  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-2
424  - Remove a nonfunctional button from the a11y preferences
425- added BuildRequires: gnome-settings-daemon, gnome-panel
426- added Requires: gnome-icon-theme, gnome-desktop, dbus-x11
427- removed Requires: xscreensaver
428
429* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
430- new upstream release based on Fedora
431- added BuildRequires: gnome-settings-daemon
432
433* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
434- new upstream release based on Fedora
435  * Wed Oct 24 2007  Matthias Clasen <mclasen@redhat.com> - 2.20.1-5
436  - Fix the orca command in the default applications capplet (#351471)
437
438* Sat Jul 14 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl4
439- add BuildReq: libgnomekbd-devel
440
441* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
442- rebuilt with evolution-data-server-devel-1.10.1
443
444* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl2
445- add BuildReq: evolution-data-server-devel
446
447* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
448- new upstream release
449- remove unneeded? patch10
450
451* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.2-0vl2
452- added Patch10 to supress /dev/pmu warning messages on some ppc models
453
454* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
455- new upstream release
456
457* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
458- new upstream release
459
460* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
461- run gtk-update-icon-cache in %%post script.
462
463* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
464- new upstream release
465- drop Patch10,it is merged in upstream
466
467* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl2
468- add Patch10 for correct textdomain name in
469  default-applications-properties(Bug332833)
470- add Patch100 for change default-applications settings for vine
471
472* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
473- new upstream release
474
475* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
476- new upstream release
477
478* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
479- new upstream release
480
481* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
482- new upstream release
483- enable alsa support
484
485* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
486- new upstream release
487
488* Thu Mar 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl4
489- fixed type in %%post script
490
491* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl3
492- clear the old defaults of xkb
493
494* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
495- remove bonobo-activation dependency
496
497* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
498- new upstream version
499
500* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
501- new upstream release
502- add Japanese summay to devel package
503
504* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
505- new upstream release
506
507* Sat Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
508- modify patch11 to use NeoVine theme instead of BeCool.
509
510* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
511- rebuild with new toolchain
512
513* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
514- new upstream release
515- remove obsolete ja.po
516
517* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 2.3.6-0vl2
518- change required version of metacity to 2.4.34 on alpha
519
520* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
521- new upstream release
522
523* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl1
524- new upstream release
525
526* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl3
527- add more missing files and schemas...
528
529* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
530- add missing file in %{_libdir}/gnome-vfs-2.0/
531
532* Sat May 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl1
533- new upstream release
534- this is experimental version
535- remove sr@Latn locale from desktop files to build with desktop-file-utils-0.3
536
537* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
538- new upstream release
539
540* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl3
541- import patch6 (upstream paches) from rawhide package.
542
543* Tue Feb 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl2
544- import patch1-5 (upstream paches) from rawhide package.
545
546* Sun Feb 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
547- new upstream release
548
549* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
550- rebuild
551
552* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
553- new upstream release
554
555* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
556- new upstream release
557
558* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
559- new upstream release
560
561* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl7
562- change default gtk1 theme from Raleigh to BeCool.
563
564* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl6
565- add BuildRequires/Requires.
566- fixed kanjicode of specfile
567
568* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
569- remove bogus message in %%post scripts.
570
571* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
572- add patch10 to modify some desktop files
573- update ja.po
574
575* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
576- update ja.po
577
578* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
579- update ja.po
580
581* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
582- new upstream release
583
584* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl3
585- add devel package
586- add window-manager-settings files.
587
588* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl2
589- modify dependancies.
590
591* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
592- build for Vine Linux
593- new upstream release from gnome-2.1.4
594
595* Thu Sep  5 2002 Jonathan Blandford <jrb@redhat.com>
596- Allow setting custom mime handlers
597
598* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
599- make desktop file symlinks absolute #71991
600- add po files from cvs.gnome.org
601
602* Fri Aug 23 2002 Jonathan Blandford <jrb@redhat.com>
603- Fix up keyboard handling
604
605* Wed Aug 21 2002 Jonathan Blandford <jrb@redhat.com>
606- Fixes for #68735
607
608* Wed Aug  7 2002 Jonathan Blandford <jrb@redhat.com>
609- New version.  Fix up metacity theme locations
610
611* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
612- Switch the gtk1 theme along with the gtk2 theme
613- Add the ability to switch the window manager theme through the theme capplet
614- Add two more font options to the font property dialog
615- Add a bunch of missing unrefs of the result of gconf_client_get_default()
616
617* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
618- fix desktop files more
619- copy icons to /usr/share/pixmaps
620
621* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
622- munge the desktop files correctly
623- obsolete control-center-devel, #69168
624- replace gnomecc.desktop with a file from redhat-menus
625
626* Tue Jul 23 2002 Owen Taylor <otaylor@redhat.com>
627- Fix crasher bug in xftprefs patch
628
629* Tue Jul 16 2002 Owen Taylor <otaylor@redhat.com>
630- Change the default rendering style to be "Best Shapes", not "Best Contrast"
631
632* Tue Jul  9 2002 Owen Taylor <otaylor@redhat.com>
633- Add Xft / XSETTINGS support
634
635* Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 2.0.0-2
636- fix %%post so schemas get installed
637 
638* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
639- 2.0.0
640- add new default editor schemas
641- fix find_lang
642
643* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
644- rebuild for new libraries
645- remove a no-longer-existing schemas file from post
646- use desktop-file-install
647
648* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
649- rebuild in different environment
650
651* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
652- rebuild with new dependent libs
653
654* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
655- rebuild in different environment
656
657* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
658- rebuild in different environment
659- build requires bonobo-activation
660
661* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
662- 1.99.10
663
664* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
665- 1.99.9
666
667* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
668- Move to GNOME 2 version
669
670* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
671- merge in translations
672
673* Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
674- Make the theme selector write fontsets, not fonts (#62413)
675
676* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
677- really put screensaver capplet back (I think)
678
679* Wed Mar 27 2002 Bill Nottingham <notting@redhat.com>
680- revert xscreensaver change
681
682* Wed Mar 27 2002 Havoc Pennington <hp@redhat.com>
683- init "Scaled" radio button correctly #61913
684
685* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
686- change path to windowmaker config tool again, #61824
687
688* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com>
689- rather than keep patching and patching it, use xscreensaver's own
690  capplet
691
692* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
693- rebuild in Hampton
694
695* Wed Jan 30 2002 Jonathan Blandford <jrb@redhat.com>
696- Rebuild package.
697
698* Thu Jan 24 2002 Tim Powers <timp@redhat.com>
699- rebuilt against new openssl
700
701* Fri Jan 18 2002 Havoc Pennington <hp@redhat.com>
702- automake14
703- don't run auto* again in ccsingle subdir, not sure why we did that
704
705* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
706- rebuild with new gnome-libs so that libcapplet has right cflags/libs
707- pixbufflags patch to make the rebuild work
708- compileflags patch to make control-center-single work
709
710* Wed Aug 29 2001 Havoc Pennington <hp@redhat.com>
711- fix #52831 (UI properties in Programs menu)
712
713* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
714- Add po files from sources.redhat.com
715
716* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
717- set the _XROOTCOLOR_PIXEL property, should fix
718  bug #52141
719
720* Wed Aug 22 2001 Yukihiro Nakai <ynakai@redhat.com>
721- Update translation.
722- Add CJK fontset patch
723
724* Thu Aug 16 2001 Jonathan Blandford <jrb@redhat.com>
725- New control-center-single to handle exiting, #51665
726
727* Wed Aug 01 2001 Havoc Pennington <hp@redhat.com>
728- remove .desktop file for gnomecc, so it won't appear
729  in panel menu, #49653
730
731* Mon Jul 30 2001 Jonathan Blandford <jrb@redhat.com>
732- allow to build without depending on control-center-devel
733
734* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
735- Add BuildRequires
736
737* Mon Jul 16 2001 Jonathan Blandford <jrb@redhat.com>
738- New version of control-center-single
739
740* Thu Jul 12 2001 Alexander Larsson <alexl@redhat.com>
741- Change default background to the same as the nautilus one
742
743* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
744- add hack to default to standalone control panels
745
746* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
747- Bump release + rebuild.
748
749* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
750- putting in tree for David
751
752* Tue May 22 2001 David Sainty <dsainty@redhat.com>
753- improve DPMS patch for the try case, and enable patch
754
755* Wed May  2 2001 Bill Nottingham <notting@redhat.com>
756- add patch to use xscreensaver's DPMS stuff, require that version
757
758* Fri Apr 20 2001  <jrb@redhat.com>
759- New Version (1.4.0.1)
760
761* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
762- kick the mixer once on startup if we aren't running esd
763
764* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
765- translations
766
767* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
768- Rebuild for GTK+-1.2.9 include paths
769
770* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
771- langify
772- don't define and use "ver" at the top of the file
773- move changelog to sane location
774
775* Thu Feb 08 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-4
776- Apply patch from bug #23782 to see how it works
777
778* Fri Feb 02 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-3
779- Include fvwm2.desktop in WM's
780
781* Sat Jan 27 2001 Akira TAGOH <tagoh@redhat.com>
782- Added Japanese patch.
783
784* Mon Dec 04 2000 Jonathan Blandford <jrb@redhat.com>
785- Update release.
786
787* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
788- Again, fix problem with solid backgrounds in bg-properties capplet
789  (patch got lost somewhere)
790
791* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
792- Up Epoch and release
793
794* Thu Aug 10 2000 Owen Taylor <otaylor@redhat.com>
795- Handle unreadable desktop files without crashing
796
797* Mon Aug 07 2000 Owen Taylor <otaylor@redhat.com>
798- Fix problem with backgrounds bigger than screen.
799
800* Tue Aug 01 2000 Owen Taylor <otaylor@redhat.com>
801- Fix problem when ~/.gtkrc does not already exist.
802- Fix problem with solid backgrounds in bg-properties capplet
803
804* Tue Jul 18 2000 Owen Taylor <otaylor@redhat.com>
805- Sort of fix problem with people hitting OK while the
806  "Save Session" dialog is still up. (Session won't be saved,
807  but at least the selected entry will be correctly kept.)
808- Fix history list in background properties capplet
809- Fix problems with temporary files in theme-selector capplet
810
811* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
812- automatic rebuild
813
814* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
815- Require redhat-logos
816- Some spec file and FHS fixes
817- reposition embedded logo a bit
818
819* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
820- Add big change to use gdk-pixbuf for backgrounds and add
821  the ability to emboss the background with a logo
822
823* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
824- revert .so strip
825
826* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
827- strip .so lib
828- use configure macro
829
830* Mon Sep 20 1999 Jonathan Blandford <jrb@redhat.com>
831- changed to work with 1.0.40
832
833* Fri Sep 17 1999 Jonathan Blandford <jrb@redhat.com>
834- Added fixrevert bug to fix bug in theme selector.
835
836* Sun Jun 13 1999 Jonathan Blandford <jrb@redhat.com>
837- updated RPM to use new control-center.
838
839* Wed Apr 07 1999 Michael Fulbright <drmike@redhat.com>
840- fixed sound-properties to only disable sound when run with --init-settings-..
841- removed debugging output from several capplets, fixed try behaviour of sm and
842  gnome-edit capplets
843- fixed bug in screensaver and background props
844- added new icons
845
846* Mon Apr 05 1999 Jonathan Blandford <jrb@redhat.com>
847- added a patch to fix the close dialog
848- added a patch to limit the number of bg's in the history.
849
850* Fri Apr 02 1999 Jonathan Blandford <jrb@redhat.com>
851- vesion 1.0.5
852- removed all patches >10 other then dontstartesd.
853
854* Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
855- removed UI props till it works better
856
857* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
858- make sure we DONT inadvertantly start esd by calling esd_open_...
859
860* Tue Mar 30 1999 Michael Fulbright <drmike@redhat.com>
861- changed default bg color to '#356390'
862
863* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
864- prime file selector path for browse in background-props if
865  "/usr/share/pixmaps/backgrounds/" exists.
866- fix behavior of file selector when you delete/cancel/ok it
867
868* Wed Mar 24 1999 Michael Fulbright <drmike@redhat.com>
869- added patch to fix trying in theme selector
870- disabled crystal screensaver, it does evil things to preview in capplet
871
872* Mon Mar 22 1999 Michael Fulbright <drmike@redhat.com>
873- version 1.0.4, fixes problems with sndprops and theme props among
874  other things.
875
876* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
877- fix sound-properties capplet so Try/Revert doesnt come on unless user
878  changes something
879- fixed theme-selector to not leave processes behind on Linux 2.2 kernels
880- strip binaries
881
882* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
883- version 1.0.3
884- added patch to make esd release after 30 sec of inactivity
885
886* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
887- version 1.0.2
888- turned off sound by default
889
890* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
891- version 1.0.1
892
893* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
894- version 0.99.8.1
895- added etc/CORBA/servers/* to file list
896
897* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
898- update to 0.99.8
899- added /usr/lib/cappletConf.sh
900
901* Mon Feb 08 1999 The Rasterman <raster@redhat.com>
902- update to 0.99.5.1
903
904* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
905- update to 0.99.5
906
907* Wed Jan 20 1999 Michael Fulbright <drmike@redhat.com>
908- update to 0.99.3.1
909
910* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
911- update to 0.99.3
912- seems like patch for non-standard xscreensaver placement was already in
913  prestine sources(?)
914
915* Wed Jan 06 1999 Jonathan Blandford <jrb@redhat.com>
916- updated to 0.99.1
917- temporary hack patch to get path to work to non-standard placement
918  of xscreensaver binaries in RH 5.2
919
920* Wed Dec 16 1998 Jonathan Blandford <jrb@redhat.com>
921- Created for the new control-center branch
922
Note: See TracBrowser for help on using the repository browser.