source: projects/specs/trunk/c/control-center/control-center-vl.spec @ 7938

Revision 7938, 31.9 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.10.1

Line 
1%define pango_version 1.36.0
2%define gtk3_version 3.10.0
3%define gnome_desktop3_version 3.10.0
4%define libgnomekbd_version 3.6.0
5%define desktop_file_utils_version 0.3
6%define startup_notification_version 0.7
7%define libxklavier_version 5.0
8%define gnome_doc_utils_version 0.20
9%define gnome_menus_version 3.8.0
10%define vine_menus_version 3.0
11%define evolution_data_server_version 2.32.0
12%define libcanberra_version 0.9
13%define usermode_version 1.83
14%define libnotify_version 0.7.3
15%define nm_version 0.9.8
16%define mm_version 0.7.0
17
18Summary: GNOME Control Center.
19Summary(ja): GNOME コントロールセンター
20Name: control-center
21Version: 3.10.1
22Release: 1%{?_dist_release}
23License: GPLv2+ and GFDL+
24Group: User Interface/Desktops
25URL: http://www.gnome.org
26
27Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-control-center/3.10/gnome-control-center-%{version}.tar.xz
28
29Patch0: gnome-control-center-3.10.1-test-chooser-dialog.patch
30Patch1: control-center-3.8.1-gpermission.patch
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: inagaki, daisuke, Takemikaduchi
35
36BuildRoot: %{_tmppath}/%{name}-%{version}-root
37
38Obsoletes: gnome, control-center-devel < 2.0
39Obsoletes: fontilus, themus
40
41Provides: gnome-volume-manager < 2.25
42Obsoletes: gnome-volume-manager < 2.25
43
44Requires: usermode >= %{usermode_version}
45Requires: gnome-settings-daemon
46Requires: gnome-icon-theme
47Requires: gnome-desktop3 >= %{gnome_desktop_version}
48Requires: dbus-x11
49Requires: apg
50Requires(post,postun): desktop-file-utils shared-mime-info gtk3
51
52BuildRequires: gnome-common
53BuildRequires: pango-devel >= %{pango_version}
54BuildRequires: gtk3-devel >= %{gtk3_version}
55BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
56BuildRequires: libgnomekbd-devel >= %{libgnomekbd_version}
57BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
58BuildRequires: startup-notification-devel >= %{startup_notification_version}
59BuildRequires: libxklavier-devel >= %{libxklavier_version}
60BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
61BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
62BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
63BuildRequires: gnome-settings-daemon-devel
64BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
65BuildRequires: nautilus-devel
66BuildRequires: alsa-lib-devel
67BuildRequires: autoconf
68BuildRequires: gettext-devel
69BuildRequires: librsvg2-devel
70BuildRequires: libXScrnSaver-devel
71BuildRequires: libXxf86misc-devel
72BuildRequires: libSM-devel
73BuildRequires: unique3-devel
74BuildRequires: polkit-devel
75BuildRequires: libgtop2-devel
76BuildRequires: upower-devel
77BuildRequires: pulseaudio-libs-devel
78BuildRequires: cups-devel
79BuildRequires: cheese-devel
80BuildRequires: gstreamer-plugins-base-devel
81BuildRequires: gnome-online-accounts-devel
82BuildRequires: colord-devel
83BuildRequires: colord-gtk-devel
84BuildRequires: libnm-gtk-devel >= %{nm_version}
85BuildRequires: NetworkManager-glib-devel >= %{nm_version}
86BuildRequires: ModemManager-glib-devel >= %{mm_version}
87BuildRequires: libnotify-devel >= %{libnotify_version}
88BuildRequires: libwacom-devel
89BuildRequires: libpwquality-devel
90BuildRequires: ibus-devel
91BuildRequires: accountsservice-devel
92BuildRequires: gnome-online-accounts-devel
93BuildRequires: libsmbclient-devel
94
95%description
96GNOME (the GNU Network Object Model Environment) is an attractive and
97easy-to-use GUI desktop environment. The control-center package
98provides the GNOME Control Center utilities that allow you to setup
99and configure your system's GNOME environment (things like the desktop
100background and theme, the screensaver, the window manager, system
101sounds, and mouse behavior).
102
103If you install GNOME, you need to install control-center.
104
105%description -l ja
106GNOME (the GNU Network Object Model Environment) は、魅力的で使いやすい
107GUI デスクトップ環境です。 control-center パッケージには、あなたの GNOME
108環境の設定に使う GNOME コントロールセンター・ユーティリティが含まれていま
109す。(これを使うと、デスクトップの壁紙や、テーマ、スクリーンセーバ、ウィン
110ドウマネージャ、サウンド、マウス、その他いろいろな設定を行えます。)
111
112%package devel
113Summary: Development files for GNOME Control Center
114Summary(ja): GNOME コントロールセンターの開発用ファイル
115Group: Development/Libraries
116Requires: %{name} = %{version}-%{release}
117
118%description devel
119Development tool for GNOME Control Center
120
121%descriotion -l ja devel
122GNOME コントロールセンターの開発用ファイルが含まれています。
123
124%prep
125%setup -q -n gnome-control-center-%{version}
126%patch0 -p1
127%patch1 -p1
128
129%build
130autoreconf -if
131%configure --disable-static  \
132    --disable-update-mimedb \
133    --enable-ibus \
134        --with-libsocialweb=no
135    CFLAGS="$RPM_OPT_FLAGS -Wno-error"
136
137# drop unneeded direct library deps with --as-needed
138# libtool doesn't make this easy, so we do it the hard way
139sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/    if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/      func_append compile_command " -Wl,-O1,--as-needed"\n      func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
140
141make %{?_smp_mflags}
142
143%install
144rm -rf $RPM_BUILD_ROOT
145
146make install DESTDIR=$RPM_BUILD_ROOT
147
148desktop-file-install --delete-original                  \
149  --dir $RPM_BUILD_ROOT%{_datadir}/applications         \
150  --add-only-show-in GNOME                              \
151  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
152
153# we do want this
154mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
155
156# We don't want these
157rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
158rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/cursor-fonts
159
160# remove useless libtool archive files
161find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
162
163# don't package mime caches
164rm -f $RPM_BUILD_ROOT%{_datadir}/mime/XMLnamespaces
165rm -f $RPM_BUILD_ROOT%{_datadir}/mime/aliases
166rm -f $RPM_BUILD_ROOT%{_datadir}/mime/application/x-gnome-theme-package.xml
167rm -f $RPM_BUILD_ROOT%{_datadir}/mime/globs
168rm -f $RPM_BUILD_ROOT%{_datadir}/mime/magic
169rm -f $RPM_BUILD_ROOT%{_datadir}/mime/subclasses
170rm -f $RPM_BUILD_ROOT%{_datadir}/mime/mime.cache
171rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
172
173rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/fdl
174rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/lgpl
175
176%find_lang gnome-control-center-2.0
177%find_lang gnome-control-center-2.0-timezones
178
179%clean
180rm -rf $RPM_BUILD_ROOT
181
182%post
183/sbin/ldconfig
184
185update-desktop-database %{_datadir}/applications >& /dev/null ||:
186update-mime-database %{_datadir}/mime > /dev/null
187touch --no-create %{_datadir}/icons/hicolor
188if [ -x /usr/bin/gtk-update-icon-cache ]; then
189  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
190fi
191
192%postun
193/sbin/ldconfig
194update-desktop-database %{_datadir}/applications >& /dev/null ||:
195update-mime-database %{_datadir}/mime > /dev/null
196touch --no-create %{_datadir}/icons/hicolor
197if [ -x /usr/bin/gtk-update-icon-cache ]; then
198  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
199fi
200
201%files -f gnome-control-center-2.0.lang -f gnome-control-center-2.0-timezones.lang
202%defattr(-, root, root)
203%doc AUTHORS COPYING ChangeLog NEWS README
204%{_bindir}/gnome-control-center
205%{_libexecdir}/cc-remote-login-helper
206%{_libexecdir}/gnome-control-center-search-provider
207%dir %{_datadir}/gnome/wm-properties
208%dir %{_datadir}/gnome-control-center
209%{_datadir}/applications/*
210%{_datadir}/bash-completion/completions/gnome-control-center
211%{_datadir}/dbus-1/services/org.gnome.ControlCenter.SearchProvider.service
212%{_datadir}/dbus-1/services/org.gnome.ControlCenter.service
213%{_datadir}/gnome-control-center/datetime
214%{_datadir}/gnome-control-center/icons
215%{_datadir}/gnome-control-center/keybindings
216%{_datadir}/gnome-control-center/pixmaps
217%{_datadir}/gnome-control-center/sounds
218%{_datadir}/gnome-shell/search-providers/gnome-control-center-search-provider.ini
219%{_datadir}/icons/*
220%{_datadir}/pixmaps/*
221%{_datadir}/polkit-1/actions/org.gnome.controlcenter.datetime.policy
222%{_datadir}/polkit-1/actions/org.gnome.controlcenter.remote-login-helper.policy
223%{_datadir}/polkit-1/actions/org.gnome.controlcenter.user-accounts.policy
224%{_datadir}/polkit-1/rules.d/gnome-control-center.rules
225%{_datadir}/sounds/*
226%{_mandir}/man1/gnome-control-center.1.gz
227
228%files devel
229%defattr(-, root, root)
230%{_datadir}/pkgconfig/*
231
232
233%changelog
234* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
235- new upstream release
236- add BuildRequires: NetworkManager-glib-devel, ModemManager-glib-devel, libsmbclient-devel
237- add Patch0 (gnome-control-center-3.10.1-test-chooser-dialog.patch)
238
239* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4.1-1
240- new upstream release
241
242* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
243- new upstream release
244
245* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
246- new upstream release
247- remove Patch0 (control-center-3.8.1-git20130424.patch)
248
249* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-2
250- add Patch1 (control-center-3.8.1-gpermission.patch)
251
252* Wed Apr 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
253- new upstream release
254- remove BuildRequires: gnome-panel-devel, metacity-devel
255- change BuildRequires: libnm-gtk-devel instead of NetworkManager-gtk-devel
256- add BuildRequires: colord-gtk-devel, accountsservice-devel, gnome-online-accounts-devel
257- add Patch0 (control-center-3.8.1-git20130424.patch)
258
259* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
260- new upstream release
261
262* Tue Oct 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
263- new upstream release
264
265* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
266- new upstream release
267
268* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
269- new upstream release
270- add BuildRequires: libpwquality-devel
271
272* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
273- new upstream release
274
275* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
276- new upstream release
277- remove BuildRequires: GConf2-devel, libbonobo-devel
278- add BuildRequires: libwacom-devel
279
280* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
281- new upstream release
282
283* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
284- new upstream release
285
286* Mon Oct 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-2
287- rebuild with NetworkManager-0.9
288- change BuildRequires: NetworkManager-gtk-devel instead of NetworkManager-glib-devel
289
290* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
291- new upstream release
292
293* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
294- new upstream release
295
296* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
297- new upstream release
298- remove Patch0
299
300* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
301- new upstream release
302- add BuildRequires: libnotify-devel
303- add Patch0 (control-center-3.1.5-crash-layout.patch)
304
305* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
306- new upstream release
307- change BuildRequires: gtk3-devel instead of gtk2-devel
308- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
309- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
310- change BuildRequires: unique3-devel instead of unique-devel
311- add BuildRequires: libXxf86misc-devel, libSM-devel, polkit-devel, libgtop2-devel, upower-devel,
312                     pulseaudio-libs-devel, cups-devel, cheese-devel, gstreamer-plugins-base-devel,
313                     gnome-online-accounts-devel, colord-devel, NetworkManager-glib-devel
314- add Requires: apg
315- drop all Patches
316- add Provides: and Obsoletes: gnome-volume-manager
317
318* Mon Mar 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
319- update desktop-effect-integration patch
320  - fix freeze on changing metacity to compiz
321  - run compiz directly instead of compiz-gtk
322  - drop use of jockey-gtk
323- update ja.po
324
325* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
326- new upstream release
327
328* Sat Nov 06 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-4
329- update translation.
330
331* Fri Nov 05 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-3
332- update translation.
333
334* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
335- update Source21(gnome-control-center-2.32.0-vine.ja.po)
336
337* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
338- new upstream release
339- drop Patch22, Patch30, Patch52
340- fix %files
341
342* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-4
343- rebuilt with rpm-4.8.1 for pkg-config (too)
344
345* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
346- rebuild with rpm-4.8.1 for pkg-config file
347- add Requires: %{name}=%{version}-%{release}
348
349* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
350- rebuild with evolution-data-server-2.30.2
351
352* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
353- new upstream release
354
355* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
356- new upstream release
357- drop Patch3, Patch46, Patch50, Patch51, Patch53, Patch54, Patch112
358- add BuildRequires: gnome-common, unique-devel
359
360* Thu Dec 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-2
361- enable Patch101,110-112 and 500
362
363* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
364- new upstream release
365- disabled Patch101, 110-112 and 500
366
367* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-9
368- update notification-theme.patch
369  - use vine theme if NotificationTheme is not set in meta-theme.
370
371* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-8
372- add Patch510: use Sans for font-properties sample font.
373- add BR: librsvg2-devel, libXScrnSaver-devel
374- remove BR: esound
375
376* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-7
377- add Patch37: Don't rely on _BACKUP property for xkb initialization
378
379* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-6
380- renumber patch10 to patch1010
381  - do not check gdm fprint plugin
382- add Patch101: show aspect in drop down menu
383- add Patch110: modify gnome-mouse-properties to fit smaller screen
384- add Patch111: modify gnome-about-me to fit smaller screen
385- add Patch112: modify gnome-display-properties to fit smaller screen
386
387* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-5
388- update Patch100 to use compiz-gtk instead of compiz
389
390* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
391- update ja.po
392
393* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
394- import upstream patchs (10,22,3[0-6])
395
396* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
397- add nautilus-devel to BR: not Requires:
398
399* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
400- new upstream release
401- update ja.po
402- add BR: nautilus-devel
403
404* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-3
405- drop Patch20 which need new XInput API
406- update Patch23
407
408* Sat Oct 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
409- add Patch20,22.23 from ubuntu
410  - patch20 to add touchpad configuration
411  - patch22 to add aspect setting in randr capplet
412  - patch23 to integrate desktop setting into appearance-properties
413
414* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
415- new upstream release
416
417* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
418- new upstream release
419
420* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-3
421- add gnome-typing-monitor to %%files
422
423* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
424- add Patch100 for new RandR capplet. (fc)
425
426* Sat Jun  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2.1-1
427- new upstream release
428- dropped Patch8 (merged into upstream)
429
430* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
431- new upstream release
432- added Patch7 and Patch8 from Fedora
433  * Mon Mar 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
434  - Fix warnings in the keybindings capplet when in non-UTF-8 locale
435  - Fix Esc/Backspace being bindable when CapsLock is on (#427123)
436  * Tue Apr  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-2
437  - Remove a nonfunctional button from the a11y preferences
438- added BuildRequires: gnome-settings-daemon, gnome-panel
439- added Requires: gnome-icon-theme, gnome-desktop, dbus-x11
440- removed Requires: xscreensaver
441
442* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
443- new upstream release based on Fedora
444- added BuildRequires: gnome-settings-daemon
445
446* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
447- new upstream release based on Fedora
448  * Wed Oct 24 2007  Matthias Clasen <mclasen@redhat.com> - 2.20.1-5
449  - Fix the orca command in the default applications capplet (#351471)
450
451* Sat Jul 14 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl4
452- add BuildReq: libgnomekbd-devel
453
454* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
455- rebuilt with evolution-data-server-devel-1.10.1
456
457* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl2
458- add BuildReq: evolution-data-server-devel
459
460* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
461- new upstream release
462- remove unneeded? patch10
463
464* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.2-0vl2
465- added Patch10 to supress /dev/pmu warning messages on some ppc models
466
467* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
468- new upstream release
469
470* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
471- new upstream release
472
473* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
474- run gtk-update-icon-cache in %%post script.
475
476* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
477- new upstream release
478- drop Patch10,it is merged in upstream
479
480* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl2
481- add Patch10 for correct textdomain name in
482  default-applications-properties(Bug332833)
483- add Patch100 for change default-applications settings for vine
484
485* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
486- new upstream release
487
488* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
489- new upstream release
490
491* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
492- new upstream release
493
494* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
495- new upstream release
496- enable alsa support
497
498* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
499- new upstream release
500
501* Thu Mar 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl4
502- fixed type in %%post script
503
504* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl3
505- clear the old defaults of xkb
506
507* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
508- remove bonobo-activation dependency
509
510* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
511- new upstream version
512
513* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
514- new upstream release
515- add Japanese summay to devel package
516
517* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
518- new upstream release
519
520* Sat Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
521- modify patch11 to use NeoVine theme instead of BeCool.
522
523* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
524- rebuild with new toolchain
525
526* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
527- new upstream release
528- remove obsolete ja.po
529
530* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 2.3.6-0vl2
531- change required version of metacity to 2.4.34 on alpha
532
533* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
534- new upstream release
535
536* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl1
537- new upstream release
538
539* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl3
540- add more missing files and schemas...
541
542* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
543- add missing file in %{_libdir}/gnome-vfs-2.0/
544
545* Sat May 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl1
546- new upstream release
547- this is experimental version
548- remove sr@Latn locale from desktop files to build with desktop-file-utils-0.3
549
550* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
551- new upstream release
552
553* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl3
554- import patch6 (upstream paches) from rawhide package.
555
556* Tue Feb 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl2
557- import patch1-5 (upstream paches) from rawhide package.
558
559* Sun Feb 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
560- new upstream release
561
562* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
563- rebuild
564
565* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
566- new upstream release
567
568* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
569- new upstream release
570
571* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
572- new upstream release
573
574* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl7
575- change default gtk1 theme from Raleigh to BeCool.
576
577* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl6
578- add BuildRequires/Requires.
579- fixed kanjicode of specfile
580
581* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
582- remove bogus message in %%post scripts.
583
584* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
585- add patch10 to modify some desktop files
586- update ja.po
587
588* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
589- update ja.po
590
591* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
592- update ja.po
593
594* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
595- new upstream release
596
597* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl3
598- add devel package
599- add window-manager-settings files.
600
601* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl2
602- modify dependancies.
603
604* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
605- build for Vine Linux
606- new upstream release from gnome-2.1.4
607
608* Thu Sep  5 2002 Jonathan Blandford <jrb@redhat.com>
609- Allow setting custom mime handlers
610
611* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
612- make desktop file symlinks absolute #71991
613- add po files from cvs.gnome.org
614
615* Fri Aug 23 2002 Jonathan Blandford <jrb@redhat.com>
616- Fix up keyboard handling
617
618* Wed Aug 21 2002 Jonathan Blandford <jrb@redhat.com>
619- Fixes for #68735
620
621* Wed Aug  7 2002 Jonathan Blandford <jrb@redhat.com>
622- New version.  Fix up metacity theme locations
623
624* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
625- Switch the gtk1 theme along with the gtk2 theme
626- Add the ability to switch the window manager theme through the theme capplet
627- Add two more font options to the font property dialog
628- Add a bunch of missing unrefs of the result of gconf_client_get_default()
629
630* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
631- fix desktop files more
632- copy icons to /usr/share/pixmaps
633
634* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
635- munge the desktop files correctly
636- obsolete control-center-devel, #69168
637- replace gnomecc.desktop with a file from redhat-menus
638
639* Tue Jul 23 2002 Owen Taylor <otaylor@redhat.com>
640- Fix crasher bug in xftprefs patch
641
642* Tue Jul 16 2002 Owen Taylor <otaylor@redhat.com>
643- Change the default rendering style to be "Best Shapes", not "Best Contrast"
644
645* Tue Jul  9 2002 Owen Taylor <otaylor@redhat.com>
646- Add Xft / XSETTINGS support
647
648* Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 2.0.0-2
649- fix %%post so schemas get installed
650 
651* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
652- 2.0.0
653- add new default editor schemas
654- fix find_lang
655
656* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
657- rebuild for new libraries
658- remove a no-longer-existing schemas file from post
659- use desktop-file-install
660
661* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
662- rebuild in different environment
663
664* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
665- rebuild with new dependent libs
666
667* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
668- rebuild in different environment
669
670* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
671- rebuild in different environment
672- build requires bonobo-activation
673
674* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
675- 1.99.10
676
677* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
678- 1.99.9
679
680* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
681- Move to GNOME 2 version
682
683* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
684- merge in translations
685
686* Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
687- Make the theme selector write fontsets, not fonts (#62413)
688
689* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
690- really put screensaver capplet back (I think)
691
692* Wed Mar 27 2002 Bill Nottingham <notting@redhat.com>
693- revert xscreensaver change
694
695* Wed Mar 27 2002 Havoc Pennington <hp@redhat.com>
696- init "Scaled" radio button correctly #61913
697
698* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
699- change path to windowmaker config tool again, #61824
700
701* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com>
702- rather than keep patching and patching it, use xscreensaver's own
703  capplet
704
705* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
706- rebuild in Hampton
707
708* Wed Jan 30 2002 Jonathan Blandford <jrb@redhat.com>
709- Rebuild package.
710
711* Thu Jan 24 2002 Tim Powers <timp@redhat.com>
712- rebuilt against new openssl
713
714* Fri Jan 18 2002 Havoc Pennington <hp@redhat.com>
715- automake14
716- don't run auto* again in ccsingle subdir, not sure why we did that
717
718* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
719- rebuild with new gnome-libs so that libcapplet has right cflags/libs
720- pixbufflags patch to make the rebuild work
721- compileflags patch to make control-center-single work
722
723* Wed Aug 29 2001 Havoc Pennington <hp@redhat.com>
724- fix #52831 (UI properties in Programs menu)
725
726* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
727- Add po files from sources.redhat.com
728
729* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
730- set the _XROOTCOLOR_PIXEL property, should fix
731  bug #52141
732
733* Wed Aug 22 2001 Yukihiro Nakai <ynakai@redhat.com>
734- Update translation.
735- Add CJK fontset patch
736
737* Thu Aug 16 2001 Jonathan Blandford <jrb@redhat.com>
738- New control-center-single to handle exiting, #51665
739
740* Wed Aug 01 2001 Havoc Pennington <hp@redhat.com>
741- remove .desktop file for gnomecc, so it won't appear
742  in panel menu, #49653
743
744* Mon Jul 30 2001 Jonathan Blandford <jrb@redhat.com>
745- allow to build without depending on control-center-devel
746
747* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
748- Add BuildRequires
749
750* Mon Jul 16 2001 Jonathan Blandford <jrb@redhat.com>
751- New version of control-center-single
752
753* Thu Jul 12 2001 Alexander Larsson <alexl@redhat.com>
754- Change default background to the same as the nautilus one
755
756* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
757- add hack to default to standalone control panels
758
759* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
760- Bump release + rebuild.
761
762* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
763- putting in tree for David
764
765* Tue May 22 2001 David Sainty <dsainty@redhat.com>
766- improve DPMS patch for the try case, and enable patch
767
768* Wed May  2 2001 Bill Nottingham <notting@redhat.com>
769- add patch to use xscreensaver's DPMS stuff, require that version
770
771* Fri Apr 20 2001  <jrb@redhat.com>
772- New Version (1.4.0.1)
773
774* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
775- kick the mixer once on startup if we aren't running esd
776
777* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
778- translations
779
780* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
781- Rebuild for GTK+-1.2.9 include paths
782
783* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
784- langify
785- don't define and use "ver" at the top of the file
786- move changelog to sane location
787
788* Thu Feb 08 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-4
789- Apply patch from bug #23782 to see how it works
790
791* Fri Feb 02 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-3
792- Include fvwm2.desktop in WM's
793
794* Sat Jan 27 2001 Akira TAGOH <tagoh@redhat.com>
795- Added Japanese patch.
796
797* Mon Dec 04 2000 Jonathan Blandford <jrb@redhat.com>
798- Update release.
799
800* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
801- Again, fix problem with solid backgrounds in bg-properties capplet
802  (patch got lost somewhere)
803
804* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
805- Up Epoch and release
806
807* Thu Aug 10 2000 Owen Taylor <otaylor@redhat.com>
808- Handle unreadable desktop files without crashing
809
810* Mon Aug 07 2000 Owen Taylor <otaylor@redhat.com>
811- Fix problem with backgrounds bigger than screen.
812
813* Tue Aug 01 2000 Owen Taylor <otaylor@redhat.com>
814- Fix problem when ~/.gtkrc does not already exist.
815- Fix problem with solid backgrounds in bg-properties capplet
816
817* Tue Jul 18 2000 Owen Taylor <otaylor@redhat.com>
818- Sort of fix problem with people hitting OK while the
819  "Save Session" dialog is still up. (Session won't be saved,
820  but at least the selected entry will be correctly kept.)
821- Fix history list in background properties capplet
822- Fix problems with temporary files in theme-selector capplet
823
824* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
825- automatic rebuild
826
827* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
828- Require redhat-logos
829- Some spec file and FHS fixes
830- reposition embedded logo a bit
831
832* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
833- Add big change to use gdk-pixbuf for backgrounds and add
834  the ability to emboss the background with a logo
835
836* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
837- revert .so strip
838
839* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
840- strip .so lib
841- use configure macro
842
843* Mon Sep 20 1999 Jonathan Blandford <jrb@redhat.com>
844- changed to work with 1.0.40
845
846* Fri Sep 17 1999 Jonathan Blandford <jrb@redhat.com>
847- Added fixrevert bug to fix bug in theme selector.
848
849* Sun Jun 13 1999 Jonathan Blandford <jrb@redhat.com>
850- updated RPM to use new control-center.
851
852* Wed Apr 07 1999 Michael Fulbright <drmike@redhat.com>
853- fixed sound-properties to only disable sound when run with --init-settings-..
854- removed debugging output from several capplets, fixed try behaviour of sm and
855  gnome-edit capplets
856- fixed bug in screensaver and background props
857- added new icons
858
859* Mon Apr 05 1999 Jonathan Blandford <jrb@redhat.com>
860- added a patch to fix the close dialog
861- added a patch to limit the number of bg's in the history.
862
863* Fri Apr 02 1999 Jonathan Blandford <jrb@redhat.com>
864- vesion 1.0.5
865- removed all patches >10 other then dontstartesd.
866
867* Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
868- removed UI props till it works better
869
870* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
871- make sure we DONT inadvertantly start esd by calling esd_open_...
872
873* Tue Mar 30 1999 Michael Fulbright <drmike@redhat.com>
874- changed default bg color to '#356390'
875
876* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
877- prime file selector path for browse in background-props if
878  "/usr/share/pixmaps/backgrounds/" exists.
879- fix behavior of file selector when you delete/cancel/ok it
880
881* Wed Mar 24 1999 Michael Fulbright <drmike@redhat.com>
882- added patch to fix trying in theme selector
883- disabled crystal screensaver, it does evil things to preview in capplet
884
885* Mon Mar 22 1999 Michael Fulbright <drmike@redhat.com>
886- version 1.0.4, fixes problems with sndprops and theme props among
887  other things.
888
889* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
890- fix sound-properties capplet so Try/Revert doesnt come on unless user
891  changes something
892- fixed theme-selector to not leave processes behind on Linux 2.2 kernels
893- strip binaries
894
895* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
896- version 1.0.3
897- added patch to make esd release after 30 sec of inactivity
898
899* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
900- version 1.0.2
901- turned off sound by default
902
903* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
904- version 1.0.1
905
906* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
907- version 0.99.8.1
908- added etc/CORBA/servers/* to file list
909
910* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
911- update to 0.99.8
912- added /usr/lib/cappletConf.sh
913
914* Mon Feb 08 1999 The Rasterman <raster@redhat.com>
915- update to 0.99.5.1
916
917* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
918- update to 0.99.5
919
920* Wed Jan 20 1999 Michael Fulbright <drmike@redhat.com>
921- update to 0.99.3.1
922
923* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
924- update to 0.99.3
925- seems like patch for non-standard xscreensaver placement was already in
926  prestine sources(?)
927
928* Wed Jan 06 1999 Jonathan Blandford <jrb@redhat.com>
929- updated to 0.99.1
930- temporary hack patch to get path to work to non-standard placement
931  of xscreensaver binaries in RH 5.2
932
933* Wed Dec 16 1998 Jonathan Blandford <jrb@redhat.com>
934- Created for the new control-center branch
935
Note: See TracBrowser for help on using the repository browser.