source: projects/specs/trunk/c/control-center/control-center-vl.spec @ 6201

Revision 6201, 30.4 KB checked in by Takemikaduchi, 12 years ago (diff)

gnome-themes: fix Vine theme
metacity: fix theme
others: new upstream release

Line 
1%define pango_version 1.30.0
2%define gtk3_version 3.4.0
3%define gnome_desktop3_version 3.4.0
4%define libgnomekbd_version 2.32.0
5%define gnome_vfs2_version 2.24.4
6%define desktop_file_utils_version 0.3
7%define startup_notification_version 0.7
8%define libxklavier_version 5.0
9%define gnome_doc_utils_version 0.20
10%define gnome_menus_version 2.30.0
11%define vine_menus_version 3.0
12%define metacity_version 2.30.3
13%define evolution_data_server_version 2.32.0
14%define libcanberra_version 0.9
15%define usermode_version 1.83
16%define libnotify_version 0.7.3
17%define nm_version 0.9.0
18
19Summary: GNOME Control Center.
20Summary(ja): GNOME コントロールセンター
21Name: control-center
22Version: 3.4.2
23Release: 1%{?_dist_release}
24License: GPLv2+ and GFDL+
25Group: User Interface/Desktops
26URL: http://www.gnome.org
27
28Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-control-center/3.4/gnome-control-center-%{version}.tar.xz
29
30Vendor: Project Vine
31Distribution: Vine Linux
32Packager: inagaki, daisuke, Takemikaduchi
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36Obsoletes: gnome, control-center-devel < 2.0
37Obsoletes: fontilus, themus
38
39Provides: gnome-volume-manager < 2.25
40Obsoletes: gnome-volume-manager < 2.25
41
42Requires: metacity >= %{metacity_version}
43Requires: usermode >= %{usermode_version}
44Requires: gnome-settings-daemon
45Requires: gnome-icon-theme
46Requires: gnome-desktop3 >= %{gnome_desktop_version}
47Requires: dbus-x11
48Requires: apg
49Requires(post,postun): desktop-file-utils shared-mime-info gtk3
50
51BuildRequires: gnome-common
52BuildRequires: pango-devel >= %{pango_version}
53BuildRequires: gtk3-devel >= %{gtk3_version}
54BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
55BuildRequires: libgnomekbd-devel >= %{libgnomekbd_version}
56BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
57BuildRequires: startup-notification-devel >= %{startup_notification_version}
58BuildRequires: libxklavier-devel >= %{libxklavier_version}
59BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
60BuildRequires: gnome-panel-devel
61BuildRequires: metacity-devel >= %{metacity_version}
62BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
63BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
64BuildRequires: gnome-settings-daemon-devel
65BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
66BuildRequires: nautilus-devel
67BuildRequires: alsa-lib-devel
68BuildRequires: autoconf
69BuildRequires: gettext-devel
70BuildRequires: librsvg2-devel
71BuildRequires: libXScrnSaver-devel
72BuildRequires: libXxf86misc-devel
73BuildRequires: libSM-devel
74BuildRequires: unique3-devel
75BuildRequires: polkit-devel
76BuildRequires: libgtop2-devel
77BuildRequires: upower-devel
78BuildRequires: pulseaudio-libs-devel
79BuildRequires: cups-devel
80BuildRequires: cheese-devel
81BuildRequires: gstreamer-plugins-base-devel
82BuildRequires: gnome-online-accounts-devel
83BuildRequires: colord-devel
84BuildRequires: NetworkManager-gtk-devel >= %{nm_version}
85BuildRequires: libnotify-devel >= %{libnotify_version}
86BuildRequires: libwacom-devel
87
88%description
89GNOME (the GNU Network Object Model Environment) is an attractive and
90easy-to-use GUI desktop environment. The control-center package
91provides the GNOME Control Center utilities that allow you to setup
92and configure your system's GNOME environment (things like the desktop
93background and theme, the screensaver, the window manager, system
94sounds, and mouse behavior).
95
96If you install GNOME, you need to install control-center.
97
98%description -l ja
99GNOME (the GNU Network Object Model Environment) は、魅力的で使いやすい
100GUI デスクトップ環境です。 control-center パッケージには、あなたの GNOME
101環境の設定に使う GNOME コントロールセンター・ユーティリティが含まれていま
102す。(これを使うと、デスクトップの壁紙や、テーマ、スクリーンセーバ、ウィン
103ドウマネージャ、サウンド、マウス、その他いろいろな設定を行えます。)
104
105%package devel
106Summary: Development files for GNOME Control Center
107Summary(ja): GNOME コントロールセンターの開発用ファイル
108Group: Development/Libraries
109Requires: %{name} = %{version}-%{release}
110
111%description devel
112Development tool for GNOME Control Center
113
114%descriotion -l ja devel
115GNOME コントロールセンターの開発用ファイルが含まれています。
116
117%prep
118%setup -q -n gnome-control-center-%{version}
119
120%build
121%configure --disable-static  \
122    --disable-scrollkeeper \
123    --disable-update-mimedb \
124    CFLAGS="$RPM_OPT_FLAGS -Wno-error"
125
126# drop unneeded direct library deps with --as-needed
127# libtool doesn't make this easy, so we do it the hard way
128sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/    if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/      func_append compile_command " -Wl,-O1,--as-needed"\n      func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
129
130make %{?_smp_mflags}
131
132%install
133rm -rf $RPM_BUILD_ROOT
134
135export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
136make install DESTDIR=$RPM_BUILD_ROOT
137unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
138
139for i in apps_gnome_settings_daemon_default_editor.schemas              \
140            apps_gnome_settings_daemon_keybindings.schemas              \
141            apps_gnome_settings_daemon_screensaver.schemas              \
142            desktop_gnome_font_rendering.schemas ; do                   \
143            rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/$i ;      \
144done
145
146#desktop-file-install --vendor gnome --delete-original                   \
147#  --dir $RPM_BUILD_ROOT%{_datadir}/applications                                \
148#  --add-only-show-in GNOME                                              \
149#  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
150
151# install visual effect icons
152# install -m644 visual-effects/*.svg $RPM_BUILD_ROOT%{_datadir}/gnome-control-center/pixmaps/
153
154# we do want this
155mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
156
157# We don't want these
158rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
159rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/cursor-fonts
160
161# remove useless libtool archive files
162find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
163
164# don't package mime caches
165rm -f $RPM_BUILD_ROOT%{_datadir}/mime/XMLnamespaces
166rm -f $RPM_BUILD_ROOT%{_datadir}/mime/aliases
167rm -f $RPM_BUILD_ROOT%{_datadir}/mime/application/x-gnome-theme-package.xml
168rm -f $RPM_BUILD_ROOT%{_datadir}/mime/globs
169rm -f $RPM_BUILD_ROOT%{_datadir}/mime/magic
170rm -f $RPM_BUILD_ROOT%{_datadir}/mime/subclasses
171rm -f $RPM_BUILD_ROOT%{_datadir}/mime/mime.cache
172rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
173
174rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/fdl
175rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/lgpl
176
177%find_lang gnome-control-center-2.0
178%find_lang gnome-control-center-2.0-timezones
179
180%clean
181rm -rf $RPM_BUILD_ROOT
182
183%post
184/sbin/ldconfig
185
186update-desktop-database %{_datadir}/applications >& /dev/null ||:
187update-mime-database %{_datadir}/mime > /dev/null
188touch --no-create %{_datadir}/icons/hicolor
189if [ -x /usr/bin/gtk-update-icon-cache ]; then
190  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
191fi
192
193%postun
194/sbin/ldconfig
195update-desktop-database %{_datadir}/applications >& /dev/null ||:
196update-mime-database %{_datadir}/mime > /dev/null
197touch --no-create %{_datadir}/icons/hicolor
198if [ -x /usr/bin/gtk-update-icon-cache ]; then
199  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
200fi
201
202%files -f gnome-control-center-2.0.lang -f gnome-control-center-2.0-timezones.lang
203%defattr(-, root, root)
204%doc AUTHORS COPYING ChangeLog NEWS README
205%dir %{_datadir}/gnome/wm-properties
206%dir %{_datadir}/gnome-control-center
207%{_datadir}/applications/*
208%{_datadir}/desktop-directories/*
209%{_datadir}/gnome-control-center/datetime
210%{_datadir}/gnome-control-center/icons
211%{_datadir}/gnome-control-center/keybindings
212%{_datadir}/gnome-control-center/pixmaps
213%{_datadir}/gnome-control-center/sounds
214%{_datadir}/gnome-control-center/ui
215%{_datadir}/icons/*
216%{_datadir}/pixmaps/*
217%{_datadir}/polkit-1/actions/org.gnome.controlcenter.datetime.policy
218%{_datadir}/sounds/*
219# list all binaries explicitly, so we notice if one goes missing
220%{_bindir}/gnome-control-center
221%{_bindir}/gnome-sound-applet
222%{_libdir}/control-center-1/panels/*.so
223#{_libexecdir}/*
224%{_sysconfdir}/xdg/menus/gnomecc.menu
225%{_sysconfdir}/xdg/autostart/gnome-sound-applet.desktop
226
227%files devel
228%defattr(-, root, root)
229%{_datadir}/pkgconfig/*
230
231
232%changelog
233* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
234- new upstream release
235
236* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
237- new upstream release
238- remove BuildRequires: GConf2-devel, libbonobo-devel
239- add BuildRequires: libwacom-devel
240
241* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
242- new upstream release
243
244* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
245- new upstream release
246
247* Mon Oct 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-2
248- rebuild with NetworkManager-0.9
249- change BuildRequires: NetworkManager-gtk-devel instead of NetworkManager-glib-devel
250
251* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
252- new upstream release
253
254* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
255- new upstream release
256
257* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
258- new upstream release
259- remove Patch0
260
261* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
262- new upstream release
263- add BuildRequires: libnotify-devel
264- add Patch0 (control-center-3.1.5-crash-layout.patch)
265
266* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
267- new upstream release
268- change BuildRequires: gtk3-devel instead of gtk2-devel
269- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
270- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
271- change BuildRequires: unique3-devel instead of unique-devel
272- add BuildRequires: libXxf86misc-devel, libSM-devel, polkit-devel, libgtop2-devel, upower-devel,
273                     pulseaudio-libs-devel, cups-devel, cheese-devel, gstreamer-plugins-base-devel,
274                     gnome-online-accounts-devel, colord-devel, NetworkManager-glib-devel
275- add Requires: apg
276- drop all Patches
277- add Provides: and Obsoletes: gnome-volume-manager
278
279* Sun Mar 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
280- update desktop-effect-integration patch
281  - fix freeze on changing metacity to compiz
282  - run compiz directly instead of compiz-gtk
283  - drop use of jockey-gtk
284- update ja.po
285
286* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
287- new upstream release
288
289* Sat Nov 06 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-4
290- update translation.
291
292* Fri Nov 05 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-3
293- update translation.
294
295* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
296- update Source21(gnome-control-center-2.32.0-vine.ja.po)
297
298* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
299- new upstream release
300- drop Patch22, Patch30, Patch52
301- fix %files
302
303* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-4
304- rebuilt with rpm-4.8.1 for pkg-config (too)
305
306* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
307- rebuild with rpm-4.8.1 for pkg-config file
308- add Requires: %{name}=%{version}-%{release}
309
310* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
311- rebuild with evolution-data-server-2.30.2
312
313* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
314- new upstream release
315
316* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
317- new upstream release
318- drop Patch3, Patch46, Patch50, Patch51, Patch53, Patch54, Patch112
319- add BuildRequires: gnome-common, unique-devel
320
321* Thu Dec 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-2
322- enable Patch101,110-112 and 500
323
324* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
325- new upstream release
326- disabled Patch101, 110-112 and 500
327
328* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-9
329- update notification-theme.patch
330  - use vine theme if NotificationTheme is not set in meta-theme.
331
332* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-8
333- add Patch510: use Sans for font-properties sample font.
334- add BR: librsvg2-devel, libXScrnSaver-devel
335- remove BR: esound
336
337* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-7
338- add Patch37: Don't rely on _BACKUP property for xkb initialization
339
340* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-6
341- renumber patch10 to patch1010
342  - do not check gdm fprint plugin
343- add Patch101: show aspect in drop down menu
344- add Patch110: modify gnome-mouse-properties to fit smaller screen
345- add Patch111: modify gnome-about-me to fit smaller screen
346- add Patch112: modify gnome-display-properties to fit smaller screen
347
348* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-5
349- update Patch100 to use compiz-gtk instead of compiz
350
351* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
352- update ja.po
353
354* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
355- import upstream patchs (10,22,3[0-6])
356
357* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
358- add nautilus-devel to BR: not Requires:
359
360* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
361- new upstream release
362- update ja.po
363- add BR: nautilus-devel
364
365* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-3
366- drop Patch20 which need new XInput API
367- update Patch23
368
369* Sat Oct 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
370- add Patch20,22.23 from ubuntu
371  - patch20 to add touchpad configuration
372  - patch22 to add aspect setting in randr capplet
373  - patch23 to integrate desktop setting into appearance-properties
374
375* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
376- new upstream release
377
378* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
379- new upstream release
380
381* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-3
382- add gnome-typing-monitor to %%files
383
384* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
385- add Patch100 for new RandR capplet. (fc)
386
387* Sat Jun  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2.1-1
388- new upstream release
389- dropped Patch8 (merged into upstream)
390
391* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
392- new upstream release
393- added Patch7 and Patch8 from Fedora
394  * Mon Mar 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
395  - Fix warnings in the keybindings capplet when in non-UTF-8 locale
396  - Fix Esc/Backspace being bindable when CapsLock is on (#427123)
397  * Tue Apr  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-2
398  - Remove a nonfunctional button from the a11y preferences
399- added BuildRequires: gnome-settings-daemon, gnome-panel
400- added Requires: gnome-icon-theme, gnome-desktop, dbus-x11
401- removed Requires: xscreensaver
402
403* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
404- new upstream release based on Fedora
405- added BuildRequires: gnome-settings-daemon
406
407* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
408- new upstream release based on Fedora
409  * Wed Oct 24 2007  Matthias Clasen <mclasen@redhat.com> - 2.20.1-5
410  - Fix the orca command in the default applications capplet (#351471)
411
412* Sat Jul 14 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl4
413- add BuildReq: libgnomekbd-devel
414
415* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
416- rebuilt with evolution-data-server-devel-1.10.1
417
418* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl2
419- add BuildReq: evolution-data-server-devel
420
421* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
422- new upstream release
423- remove unneeded? patch10
424
425* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.2-0vl2
426- added Patch10 to supress /dev/pmu warning messages on some ppc models
427
428* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
429- new upstream release
430
431* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
432- new upstream release
433
434* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
435- run gtk-update-icon-cache in %%post script.
436
437* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
438- new upstream release
439- drop Patch10,it is merged in upstream
440
441* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl2
442- add Patch10 for correct textdomain name in
443  default-applications-properties(Bug332833)
444- add Patch100 for change default-applications settings for vine
445
446* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
447- new upstream release
448
449* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
450- new upstream release
451
452* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
453- new upstream release
454
455* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
456- new upstream release
457- enable alsa support
458
459* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
460- new upstream release
461
462* Thu Mar 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl4
463- fixed type in %%post script
464
465* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl3
466- clear the old defaults of xkb
467
468* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
469- remove bonobo-activation dependency
470
471* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
472- new upstream version
473
474* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
475- new upstream release
476- add Japanese summay to devel package
477
478* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
479- new upstream release
480
481* Sat Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
482- modify patch11 to use NeoVine theme instead of BeCool.
483
484* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
485- rebuild with new toolchain
486
487* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
488- new upstream release
489- remove obsolete ja.po
490
491* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 2.3.6-0vl2
492- change required version of metacity to 2.4.34 on alpha
493
494* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
495- new upstream release
496
497* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl1
498- new upstream release
499
500* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl3
501- add more missing files and schemas...
502
503* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
504- add missing file in %{_libdir}/gnome-vfs-2.0/
505
506* Sat May 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl1
507- new upstream release
508- this is experimental version
509- remove sr@Latn locale from desktop files to build with desktop-file-utils-0.3
510
511* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
512- new upstream release
513
514* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl3
515- import patch6 (upstream paches) from rawhide package.
516
517* Tue Feb 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl2
518- import patch1-5 (upstream paches) from rawhide package.
519
520* Sun Feb 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
521- new upstream release
522
523* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
524- rebuild
525
526* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
527- new upstream release
528
529* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
530- new upstream release
531
532* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
533- new upstream release
534
535* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl7
536- change default gtk1 theme from Raleigh to BeCool.
537
538* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl6
539- add BuildRequires/Requires.
540- fixed kanjicode of specfile
541
542* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
543- remove bogus message in %%post scripts.
544
545* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
546- add patch10 to modify some desktop files
547- update ja.po
548
549* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
550- update ja.po
551
552* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
553- update ja.po
554
555* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
556- new upstream release
557
558* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl3
559- add devel package
560- add window-manager-settings files.
561
562* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl2
563- modify dependancies.
564
565* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
566- build for Vine Linux
567- new upstream release from gnome-2.1.4
568
569* Thu Sep  5 2002 Jonathan Blandford <jrb@redhat.com>
570- Allow setting custom mime handlers
571
572* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
573- make desktop file symlinks absolute #71991
574- add po files from cvs.gnome.org
575
576* Fri Aug 23 2002 Jonathan Blandford <jrb@redhat.com>
577- Fix up keyboard handling
578
579* Wed Aug 21 2002 Jonathan Blandford <jrb@redhat.com>
580- Fixes for #68735
581
582* Wed Aug  7 2002 Jonathan Blandford <jrb@redhat.com>
583- New version.  Fix up metacity theme locations
584
585* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
586- Switch the gtk1 theme along with the gtk2 theme
587- Add the ability to switch the window manager theme through the theme capplet
588- Add two more font options to the font property dialog
589- Add a bunch of missing unrefs of the result of gconf_client_get_default()
590
591* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
592- fix desktop files more
593- copy icons to /usr/share/pixmaps
594
595* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
596- munge the desktop files correctly
597- obsolete control-center-devel, #69168
598- replace gnomecc.desktop with a file from redhat-menus
599
600* Tue Jul 23 2002 Owen Taylor <otaylor@redhat.com>
601- Fix crasher bug in xftprefs patch
602
603* Tue Jul 16 2002 Owen Taylor <otaylor@redhat.com>
604- Change the default rendering style to be "Best Shapes", not "Best Contrast"
605
606* Tue Jul  9 2002 Owen Taylor <otaylor@redhat.com>
607- Add Xft / XSETTINGS support
608
609* Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 2.0.0-2
610- fix %%post so schemas get installed
611 
612* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
613- 2.0.0
614- add new default editor schemas
615- fix find_lang
616
617* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
618- rebuild for new libraries
619- remove a no-longer-existing schemas file from post
620- use desktop-file-install
621
622* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
623- rebuild in different environment
624
625* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
626- rebuild with new dependent libs
627
628* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
629- rebuild in different environment
630
631* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
632- rebuild in different environment
633- build requires bonobo-activation
634
635* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
636- 1.99.10
637
638* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
639- 1.99.9
640
641* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
642- Move to GNOME 2 version
643
644* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
645- merge in translations
646
647* Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
648- Make the theme selector write fontsets, not fonts (#62413)
649
650* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
651- really put screensaver capplet back (I think)
652
653* Wed Mar 27 2002 Bill Nottingham <notting@redhat.com>
654- revert xscreensaver change
655
656* Wed Mar 27 2002 Havoc Pennington <hp@redhat.com>
657- init "Scaled" radio button correctly #61913
658
659* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
660- change path to windowmaker config tool again, #61824
661
662* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com>
663- rather than keep patching and patching it, use xscreensaver's own
664  capplet
665
666* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
667- rebuild in Hampton
668
669* Wed Jan 30 2002 Jonathan Blandford <jrb@redhat.com>
670- Rebuild package.
671
672* Thu Jan 24 2002 Tim Powers <timp@redhat.com>
673- rebuilt against new openssl
674
675* Fri Jan 18 2002 Havoc Pennington <hp@redhat.com>
676- automake14
677- don't run auto* again in ccsingle subdir, not sure why we did that
678
679* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
680- rebuild with new gnome-libs so that libcapplet has right cflags/libs
681- pixbufflags patch to make the rebuild work
682- compileflags patch to make control-center-single work
683
684* Wed Aug 29 2001 Havoc Pennington <hp@redhat.com>
685- fix #52831 (UI properties in Programs menu)
686
687* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
688- Add po files from sources.redhat.com
689
690* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
691- set the _XROOTCOLOR_PIXEL property, should fix
692  bug #52141
693
694* Wed Aug 22 2001 Yukihiro Nakai <ynakai@redhat.com>
695- Update translation.
696- Add CJK fontset patch
697
698* Thu Aug 16 2001 Jonathan Blandford <jrb@redhat.com>
699- New control-center-single to handle exiting, #51665
700
701* Wed Aug 01 2001 Havoc Pennington <hp@redhat.com>
702- remove .desktop file for gnomecc, so it won't appear
703  in panel menu, #49653
704
705* Mon Jul 30 2001 Jonathan Blandford <jrb@redhat.com>
706- allow to build without depending on control-center-devel
707
708* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
709- Add BuildRequires
710
711* Mon Jul 16 2001 Jonathan Blandford <jrb@redhat.com>
712- New version of control-center-single
713
714* Thu Jul 12 2001 Alexander Larsson <alexl@redhat.com>
715- Change default background to the same as the nautilus one
716
717* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
718- add hack to default to standalone control panels
719
720* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
721- Bump release + rebuild.
722
723* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
724- putting in tree for David
725
726* Tue May 22 2001 David Sainty <dsainty@redhat.com>
727- improve DPMS patch for the try case, and enable patch
728
729* Wed May  2 2001 Bill Nottingham <notting@redhat.com>
730- add patch to use xscreensaver's DPMS stuff, require that version
731
732* Fri Apr 20 2001  <jrb@redhat.com>
733- New Version (1.4.0.1)
734
735* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
736- kick the mixer once on startup if we aren't running esd
737
738* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
739- translations
740
741* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
742- Rebuild for GTK+-1.2.9 include paths
743
744* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
745- langify
746- don't define and use "ver" at the top of the file
747- move changelog to sane location
748
749* Thu Feb 08 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-4
750- Apply patch from bug #23782 to see how it works
751
752* Fri Feb 02 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-3
753- Include fvwm2.desktop in WM's
754
755* Sat Jan 27 2001 Akira TAGOH <tagoh@redhat.com>
756- Added Japanese patch.
757
758* Mon Dec 04 2000 Jonathan Blandford <jrb@redhat.com>
759- Update release.
760
761* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
762- Again, fix problem with solid backgrounds in bg-properties capplet
763  (patch got lost somewhere)
764
765* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
766- Up Epoch and release
767
768* Thu Aug 10 2000 Owen Taylor <otaylor@redhat.com>
769- Handle unreadable desktop files without crashing
770
771* Mon Aug 07 2000 Owen Taylor <otaylor@redhat.com>
772- Fix problem with backgrounds bigger than screen.
773
774* Tue Aug 01 2000 Owen Taylor <otaylor@redhat.com>
775- Fix problem when ~/.gtkrc does not already exist.
776- Fix problem with solid backgrounds in bg-properties capplet
777
778* Tue Jul 18 2000 Owen Taylor <otaylor@redhat.com>
779- Sort of fix problem with people hitting OK while the
780  "Save Session" dialog is still up. (Session won't be saved,
781  but at least the selected entry will be correctly kept.)
782- Fix history list in background properties capplet
783- Fix problems with temporary files in theme-selector capplet
784
785* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
786- automatic rebuild
787
788* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
789- Require redhat-logos
790- Some spec file and FHS fixes
791- reposition embedded logo a bit
792
793* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
794- Add big change to use gdk-pixbuf for backgrounds and add
795  the ability to emboss the background with a logo
796
797* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
798- revert .so strip
799
800* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
801- strip .so lib
802- use configure macro
803
804* Mon Sep 20 1999 Jonathan Blandford <jrb@redhat.com>
805- changed to work with 1.0.40
806
807* Fri Sep 17 1999 Jonathan Blandford <jrb@redhat.com>
808- Added fixrevert bug to fix bug in theme selector.
809
810* Sun Jun 13 1999 Jonathan Blandford <jrb@redhat.com>
811- updated RPM to use new control-center.
812
813* Wed Apr 07 1999 Michael Fulbright <drmike@redhat.com>
814- fixed sound-properties to only disable sound when run with --init-settings-..
815- removed debugging output from several capplets, fixed try behaviour of sm and
816  gnome-edit capplets
817- fixed bug in screensaver and background props
818- added new icons
819
820* Mon Apr 05 1999 Jonathan Blandford <jrb@redhat.com>
821- added a patch to fix the close dialog
822- added a patch to limit the number of bg's in the history.
823
824* Fri Apr 02 1999 Jonathan Blandford <jrb@redhat.com>
825- vesion 1.0.5
826- removed all patches >10 other then dontstartesd.
827
828* Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
829- removed UI props till it works better
830
831* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
832- make sure we DONT inadvertantly start esd by calling esd_open_...
833
834* Tue Mar 30 1999 Michael Fulbright <drmike@redhat.com>
835- changed default bg color to '#356390'
836
837* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
838- prime file selector path for browse in background-props if
839  "/usr/share/pixmaps/backgrounds/" exists.
840- fix behavior of file selector when you delete/cancel/ok it
841
842* Wed Mar 24 1999 Michael Fulbright <drmike@redhat.com>
843- added patch to fix trying in theme selector
844- disabled crystal screensaver, it does evil things to preview in capplet
845
846* Mon Mar 22 1999 Michael Fulbright <drmike@redhat.com>
847- version 1.0.4, fixes problems with sndprops and theme props among
848  other things.
849
850* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
851- fix sound-properties capplet so Try/Revert doesnt come on unless user
852  changes something
853- fixed theme-selector to not leave processes behind on Linux 2.2 kernels
854- strip binaries
855
856* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
857- version 1.0.3
858- added patch to make esd release after 30 sec of inactivity
859
860* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
861- version 1.0.2
862- turned off sound by default
863
864* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
865- version 1.0.1
866
867* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
868- version 0.99.8.1
869- added etc/CORBA/servers/* to file list
870
871* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
872- update to 0.99.8
873- added /usr/lib/cappletConf.sh
874
875* Mon Feb 08 1999 The Rasterman <raster@redhat.com>
876- update to 0.99.5.1
877
878* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
879- update to 0.99.5
880
881* Mon Jan 20 1999 Michael Fulbright <drmike@redhat.com>
882- update to 0.99.3.1
883
884* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
885- update to 0.99.3
886- seems like patch for non-standard xscreensaver placement was already in
887  prestine sources(?)
888
889* Wed Jan 06 1999 Jonathan Blandford <jrb@redhat.com>
890- updated to 0.99.1
891- temporary hack patch to get path to work to non-standard placement
892  of xscreensaver binaries in RH 5.2
893
894* Wed Dec 16 1998 Jonathan Blandford <jrb@redhat.com>
895- Created for the new control-center branch
896
Note: See TracBrowser for help on using the repository browser.