source: projects/specs/trunk/c/control-center/control-center-vl.spec @ 6890

Revision 6890, 29.9 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1%define pango_version 1.32.0
2%define gtk3_version 3.6.0
3%define gnome_desktop3_version 3.6.0
4%define libgnomekbd_version 3.6.0
5%define desktop_file_utils_version 0.3
6%define startup_notification_version 0.7
7%define libxklavier_version 5.0
8%define gnome_doc_utils_version 0.20
9%define gnome_menus_version 2.30.0
10%define vine_menus_version 3.0
11%define metacity_version 2.30.3
12%define evolution_data_server_version 2.32.0
13%define libcanberra_version 0.9
14%define usermode_version 1.83
15%define libnotify_version 0.7.3
16%define nm_version 0.9.0
17
18Summary: GNOME Control Center.
19Summary(ja): GNOME コントロールセンター
20Name: control-center
21Version: 3.6.0
22Release: 1%{?_dist_release}
23License: GPLv2+ and GFDL+
24Group: User Interface/Desktops
25URL: http://www.gnome.org
26
27Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-control-center/3.6/gnome-control-center-%{version}.tar.xz
28
29Vendor: Project Vine
30Distribution: Vine Linux
31Packager: inagaki, daisuke, Takemikaduchi
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-root
34
35Obsoletes: gnome, control-center-devel < 2.0
36Obsoletes: fontilus, themus
37
38Provides: gnome-volume-manager < 2.25
39Obsoletes: gnome-volume-manager < 2.25
40
41Requires: metacity >= %{metacity_version}
42Requires: usermode >= %{usermode_version}
43Requires: gnome-settings-daemon
44Requires: gnome-icon-theme
45Requires: gnome-desktop3 >= %{gnome_desktop_version}
46Requires: dbus-x11
47Requires: apg
48Requires(post,postun): desktop-file-utils shared-mime-info gtk3
49
50BuildRequires: gnome-common
51BuildRequires: pango-devel >= %{pango_version}
52BuildRequires: gtk3-devel >= %{gtk3_version}
53BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
54BuildRequires: libgnomekbd-devel >= %{libgnomekbd_version}
55BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
56BuildRequires: startup-notification-devel >= %{startup_notification_version}
57BuildRequires: libxklavier-devel >= %{libxklavier_version}
58BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
59BuildRequires: gnome-panel-devel
60BuildRequires: metacity-devel >= %{metacity_version}
61BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
62BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
63BuildRequires: gnome-settings-daemon-devel
64BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
65BuildRequires: nautilus-devel
66BuildRequires: alsa-lib-devel
67BuildRequires: autoconf
68BuildRequires: gettext-devel
69BuildRequires: librsvg2-devel
70BuildRequires: libXScrnSaver-devel
71BuildRequires: libXxf86misc-devel
72BuildRequires: libSM-devel
73BuildRequires: unique3-devel
74BuildRequires: polkit-devel
75BuildRequires: libgtop2-devel
76BuildRequires: upower-devel
77BuildRequires: pulseaudio-libs-devel
78BuildRequires: cups-devel
79BuildRequires: cheese-devel
80BuildRequires: gstreamer-plugins-base-devel
81BuildRequires: gnome-online-accounts-devel
82BuildRequires: colord-devel
83BuildRequires: NetworkManager-gtk-devel >= %{nm_version}
84BuildRequires: libnotify-devel >= %{libnotify_version}
85BuildRequires: libwacom-devel
86BuildRequires: libpwquality-devel
87BuildRequires: ibus-devel
88
89%description
90GNOME (the GNU Network Object Model Environment) is an attractive and
91easy-to-use GUI desktop environment. The control-center package
92provides the GNOME Control Center utilities that allow you to setup
93and configure your system's GNOME environment (things like the desktop
94background and theme, the screensaver, the window manager, system
95sounds, and mouse behavior).
96
97If you install GNOME, you need to install control-center.
98
99%description -l ja
100GNOME (the GNU Network Object Model Environment) は、魅力的で使いやすい
101GUI デスクトップ環境です。 control-center パッケージには、あなたの GNOME
102環境の設定に使う GNOME コントロールセンター・ユーティリティが含まれていま
103す。(これを使うと、デスクトップの壁紙や、テーマ、スクリーンセーバ、ウィン
104ドウマネージャ、サウンド、マウス、その他いろいろな設定を行えます。)
105
106%package devel
107Summary: Development files for GNOME Control Center
108Summary(ja): GNOME コントロールセンターの開発用ファイル
109Group: Development/Libraries
110Requires: %{name} = %{version}-%{release}
111
112%description devel
113Development tool for GNOME Control Center
114
115%descriotion -l ja devel
116GNOME コントロールセンターの開発用ファイルが含まれています。
117
118%prep
119%setup -q -n gnome-control-center-%{version}
120
121%build
122%configure --disable-static  \
123    --disable-update-mimedb \
124    --enable-ibus
125    CFLAGS="$RPM_OPT_FLAGS -Wno-error"
126
127# drop unneeded direct library deps with --as-needed
128# libtool doesn't make this easy, so we do it the hard way
129sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/    if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/      func_append compile_command " -Wl,-O1,--as-needed"\n      func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
130
131make %{?_smp_mflags}
132
133%install
134rm -rf $RPM_BUILD_ROOT
135
136make install DESTDIR=$RPM_BUILD_ROOT
137
138# we do want this
139mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
140
141# We don't want these
142rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
143rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/cursor-fonts
144
145# remove useless libtool archive files
146find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
147
148# don't package mime caches
149rm -f $RPM_BUILD_ROOT%{_datadir}/mime/XMLnamespaces
150rm -f $RPM_BUILD_ROOT%{_datadir}/mime/aliases
151rm -f $RPM_BUILD_ROOT%{_datadir}/mime/application/x-gnome-theme-package.xml
152rm -f $RPM_BUILD_ROOT%{_datadir}/mime/globs
153rm -f $RPM_BUILD_ROOT%{_datadir}/mime/magic
154rm -f $RPM_BUILD_ROOT%{_datadir}/mime/subclasses
155rm -f $RPM_BUILD_ROOT%{_datadir}/mime/mime.cache
156rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
157
158rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/fdl
159rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/lgpl
160
161%find_lang gnome-control-center-2.0
162%find_lang gnome-control-center-2.0-timezones
163
164%clean
165rm -rf $RPM_BUILD_ROOT
166
167%post
168/sbin/ldconfig
169
170update-desktop-database %{_datadir}/applications >& /dev/null ||:
171update-mime-database %{_datadir}/mime > /dev/null
172touch --no-create %{_datadir}/icons/hicolor
173if [ -x /usr/bin/gtk-update-icon-cache ]; then
174  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
175fi
176
177%postun
178/sbin/ldconfig
179update-desktop-database %{_datadir}/applications >& /dev/null ||:
180update-mime-database %{_datadir}/mime > /dev/null
181touch --no-create %{_datadir}/icons/hicolor
182if [ -x /usr/bin/gtk-update-icon-cache ]; then
183  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
184fi
185
186%files -f gnome-control-center-2.0.lang -f gnome-control-center-2.0-timezones.lang
187%defattr(-, root, root)
188%doc AUTHORS COPYING ChangeLog NEWS README
189%{_sysconfdir}/xdg/menus/gnomecc.menu
190%{_sysconfdir}/xdg/autostart/gnome-sound-applet.desktop
191%{_bindir}/gnome-control-center
192%{_bindir}/gnome-sound-applet
193%{_libdir}/control-center-1/panels/*.so
194%dir %{_datadir}/gnome/wm-properties
195%dir %{_datadir}/gnome-control-center
196%{_datadir}/applications/*
197%{_datadir}/desktop-directories/*
198%{_datadir}/gnome-control-center/datetime
199%{_datadir}/gnome-control-center/icons
200%{_datadir}/gnome-control-center/keybindings
201%{_datadir}/gnome-control-center/pixmaps
202%{_datadir}/gnome-control-center/sounds
203%{_datadir}/gnome-control-center/ui
204%{_datadir}/icons/*
205%{_datadir}/pixmaps/*
206%{_datadir}/polkit-1/actions/org.gnome.controlcenter.datetime.policy
207%{_datadir}/polkit-1/actions/org.gnome.controlcenter.user-accounts.policy
208%{_datadir}/polkit-1/rules.d/gnome-control-center.rules
209%{_datadir}/sounds/*
210%{_mandir}/man1/gnome-control-center.1.gz
211
212%files devel
213%defattr(-, root, root)
214%{_datadir}/pkgconfig/*
215
216
217%changelog
218* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
219- new upstream release
220- add BuildRequires: libpwquality-devel
221
222* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
223- new upstream release
224
225* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
226- new upstream release
227- remove BuildRequires: GConf2-devel, libbonobo-devel
228- add BuildRequires: libwacom-devel
229
230* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
231- new upstream release
232
233* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
234- new upstream release
235
236* Mon Oct 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-2
237- rebuild with NetworkManager-0.9
238- change BuildRequires: NetworkManager-gtk-devel instead of NetworkManager-glib-devel
239
240* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
241- new upstream release
242
243* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
244- new upstream release
245
246* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
247- new upstream release
248- remove Patch0
249
250* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
251- new upstream release
252- add BuildRequires: libnotify-devel
253- add Patch0 (control-center-3.1.5-crash-layout.patch)
254
255* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
256- new upstream release
257- change BuildRequires: gtk3-devel instead of gtk2-devel
258- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
259- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
260- change BuildRequires: unique3-devel instead of unique-devel
261- add BuildRequires: libXxf86misc-devel, libSM-devel, polkit-devel, libgtop2-devel, upower-devel,
262                     pulseaudio-libs-devel, cups-devel, cheese-devel, gstreamer-plugins-base-devel,
263                     gnome-online-accounts-devel, colord-devel, NetworkManager-glib-devel
264- add Requires: apg
265- drop all Patches
266- add Provides: and Obsoletes: gnome-volume-manager
267
268* Sun Mar 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
269- update desktop-effect-integration patch
270  - fix freeze on changing metacity to compiz
271  - run compiz directly instead of compiz-gtk
272  - drop use of jockey-gtk
273- update ja.po
274
275* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
276- new upstream release
277
278* Sat Nov 06 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-4
279- update translation.
280
281* Fri Nov 05 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-3
282- update translation.
283
284* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
285- update Source21(gnome-control-center-2.32.0-vine.ja.po)
286
287* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
288- new upstream release
289- drop Patch22, Patch30, Patch52
290- fix %files
291
292* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-4
293- rebuilt with rpm-4.8.1 for pkg-config (too)
294
295* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
296- rebuild with rpm-4.8.1 for pkg-config file
297- add Requires: %{name}=%{version}-%{release}
298
299* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
300- rebuild with evolution-data-server-2.30.2
301
302* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
303- new upstream release
304
305* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
306- new upstream release
307- drop Patch3, Patch46, Patch50, Patch51, Patch53, Patch54, Patch112
308- add BuildRequires: gnome-common, unique-devel
309
310* Thu Dec 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-2
311- enable Patch101,110-112 and 500
312
313* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
314- new upstream release
315- disabled Patch101, 110-112 and 500
316
317* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-9
318- update notification-theme.patch
319  - use vine theme if NotificationTheme is not set in meta-theme.
320
321* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-8
322- add Patch510: use Sans for font-properties sample font.
323- add BR: librsvg2-devel, libXScrnSaver-devel
324- remove BR: esound
325
326* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-7
327- add Patch37: Don't rely on _BACKUP property for xkb initialization
328
329* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-6
330- renumber patch10 to patch1010
331  - do not check gdm fprint plugin
332- add Patch101: show aspect in drop down menu
333- add Patch110: modify gnome-mouse-properties to fit smaller screen
334- add Patch111: modify gnome-about-me to fit smaller screen
335- add Patch112: modify gnome-display-properties to fit smaller screen
336
337* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-5
338- update Patch100 to use compiz-gtk instead of compiz
339
340* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
341- update ja.po
342
343* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
344- import upstream patchs (10,22,3[0-6])
345
346* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
347- add nautilus-devel to BR: not Requires:
348
349* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
350- new upstream release
351- update ja.po
352- add BR: nautilus-devel
353
354* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-3
355- drop Patch20 which need new XInput API
356- update Patch23
357
358* Sat Oct 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
359- add Patch20,22.23 from ubuntu
360  - patch20 to add touchpad configuration
361  - patch22 to add aspect setting in randr capplet
362  - patch23 to integrate desktop setting into appearance-properties
363
364* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
365- new upstream release
366
367* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
368- new upstream release
369
370* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-3
371- add gnome-typing-monitor to %%files
372
373* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
374- add Patch100 for new RandR capplet. (fc)
375
376* Sat Jun  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2.1-1
377- new upstream release
378- dropped Patch8 (merged into upstream)
379
380* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
381- new upstream release
382- added Patch7 and Patch8 from Fedora
383  * Mon Mar 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
384  - Fix warnings in the keybindings capplet when in non-UTF-8 locale
385  - Fix Esc/Backspace being bindable when CapsLock is on (#427123)
386  * Tue Apr  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-2
387  - Remove a nonfunctional button from the a11y preferences
388- added BuildRequires: gnome-settings-daemon, gnome-panel
389- added Requires: gnome-icon-theme, gnome-desktop, dbus-x11
390- removed Requires: xscreensaver
391
392* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
393- new upstream release based on Fedora
394- added BuildRequires: gnome-settings-daemon
395
396* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
397- new upstream release based on Fedora
398  * Wed Oct 24 2007  Matthias Clasen <mclasen@redhat.com> - 2.20.1-5
399  - Fix the orca command in the default applications capplet (#351471)
400
401* Sat Jul 14 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl4
402- add BuildReq: libgnomekbd-devel
403
404* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
405- rebuilt with evolution-data-server-devel-1.10.1
406
407* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl2
408- add BuildReq: evolution-data-server-devel
409
410* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
411- new upstream release
412- remove unneeded? patch10
413
414* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.2-0vl2
415- added Patch10 to supress /dev/pmu warning messages on some ppc models
416
417* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
418- new upstream release
419
420* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
421- new upstream release
422
423* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
424- run gtk-update-icon-cache in %%post script.
425
426* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
427- new upstream release
428- drop Patch10,it is merged in upstream
429
430* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl2
431- add Patch10 for correct textdomain name in
432  default-applications-properties(Bug332833)
433- add Patch100 for change default-applications settings for vine
434
435* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
436- new upstream release
437
438* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
439- new upstream release
440
441* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
442- new upstream release
443
444* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
445- new upstream release
446- enable alsa support
447
448* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
449- new upstream release
450
451* Thu Mar 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl4
452- fixed type in %%post script
453
454* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl3
455- clear the old defaults of xkb
456
457* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
458- remove bonobo-activation dependency
459
460* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
461- new upstream version
462
463* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
464- new upstream release
465- add Japanese summay to devel package
466
467* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
468- new upstream release
469
470* Sat Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
471- modify patch11 to use NeoVine theme instead of BeCool.
472
473* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
474- rebuild with new toolchain
475
476* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
477- new upstream release
478- remove obsolete ja.po
479
480* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 2.3.6-0vl2
481- change required version of metacity to 2.4.34 on alpha
482
483* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
484- new upstream release
485
486* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl1
487- new upstream release
488
489* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl3
490- add more missing files and schemas...
491
492* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
493- add missing file in %{_libdir}/gnome-vfs-2.0/
494
495* Sat May 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl1
496- new upstream release
497- this is experimental version
498- remove sr@Latn locale from desktop files to build with desktop-file-utils-0.3
499
500* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
501- new upstream release
502
503* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl3
504- import patch6 (upstream paches) from rawhide package.
505
506* Tue Feb 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl2
507- import patch1-5 (upstream paches) from rawhide package.
508
509* Sun Feb 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
510- new upstream release
511
512* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
513- rebuild
514
515* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
516- new upstream release
517
518* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
519- new upstream release
520
521* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
522- new upstream release
523
524* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl7
525- change default gtk1 theme from Raleigh to BeCool.
526
527* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl6
528- add BuildRequires/Requires.
529- fixed kanjicode of specfile
530
531* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
532- remove bogus message in %%post scripts.
533
534* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
535- add patch10 to modify some desktop files
536- update ja.po
537
538* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
539- update ja.po
540
541* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
542- update ja.po
543
544* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
545- new upstream release
546
547* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl3
548- add devel package
549- add window-manager-settings files.
550
551* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl2
552- modify dependancies.
553
554* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
555- build for Vine Linux
556- new upstream release from gnome-2.1.4
557
558* Thu Sep  5 2002 Jonathan Blandford <jrb@redhat.com>
559- Allow setting custom mime handlers
560
561* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
562- make desktop file symlinks absolute #71991
563- add po files from cvs.gnome.org
564
565* Fri Aug 23 2002 Jonathan Blandford <jrb@redhat.com>
566- Fix up keyboard handling
567
568* Wed Aug 21 2002 Jonathan Blandford <jrb@redhat.com>
569- Fixes for #68735
570
571* Wed Aug  7 2002 Jonathan Blandford <jrb@redhat.com>
572- New version.  Fix up metacity theme locations
573
574* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
575- Switch the gtk1 theme along with the gtk2 theme
576- Add the ability to switch the window manager theme through the theme capplet
577- Add two more font options to the font property dialog
578- Add a bunch of missing unrefs of the result of gconf_client_get_default()
579
580* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
581- fix desktop files more
582- copy icons to /usr/share/pixmaps
583
584* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
585- munge the desktop files correctly
586- obsolete control-center-devel, #69168
587- replace gnomecc.desktop with a file from redhat-menus
588
589* Tue Jul 23 2002 Owen Taylor <otaylor@redhat.com>
590- Fix crasher bug in xftprefs patch
591
592* Tue Jul 16 2002 Owen Taylor <otaylor@redhat.com>
593- Change the default rendering style to be "Best Shapes", not "Best Contrast"
594
595* Tue Jul  9 2002 Owen Taylor <otaylor@redhat.com>
596- Add Xft / XSETTINGS support
597
598* Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 2.0.0-2
599- fix %%post so schemas get installed
600 
601* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
602- 2.0.0
603- add new default editor schemas
604- fix find_lang
605
606* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
607- rebuild for new libraries
608- remove a no-longer-existing schemas file from post
609- use desktop-file-install
610
611* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
612- rebuild in different environment
613
614* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
615- rebuild with new dependent libs
616
617* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
618- rebuild in different environment
619
620* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
621- rebuild in different environment
622- build requires bonobo-activation
623
624* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
625- 1.99.10
626
627* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
628- 1.99.9
629
630* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
631- Move to GNOME 2 version
632
633* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
634- merge in translations
635
636* Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
637- Make the theme selector write fontsets, not fonts (#62413)
638
639* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
640- really put screensaver capplet back (I think)
641
642* Wed Mar 27 2002 Bill Nottingham <notting@redhat.com>
643- revert xscreensaver change
644
645* Wed Mar 27 2002 Havoc Pennington <hp@redhat.com>
646- init "Scaled" radio button correctly #61913
647
648* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
649- change path to windowmaker config tool again, #61824
650
651* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com>
652- rather than keep patching and patching it, use xscreensaver's own
653  capplet
654
655* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
656- rebuild in Hampton
657
658* Wed Jan 30 2002 Jonathan Blandford <jrb@redhat.com>
659- Rebuild package.
660
661* Thu Jan 24 2002 Tim Powers <timp@redhat.com>
662- rebuilt against new openssl
663
664* Fri Jan 18 2002 Havoc Pennington <hp@redhat.com>
665- automake14
666- don't run auto* again in ccsingle subdir, not sure why we did that
667
668* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
669- rebuild with new gnome-libs so that libcapplet has right cflags/libs
670- pixbufflags patch to make the rebuild work
671- compileflags patch to make control-center-single work
672
673* Wed Aug 29 2001 Havoc Pennington <hp@redhat.com>
674- fix #52831 (UI properties in Programs menu)
675
676* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
677- Add po files from sources.redhat.com
678
679* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
680- set the _XROOTCOLOR_PIXEL property, should fix
681  bug #52141
682
683* Wed Aug 22 2001 Yukihiro Nakai <ynakai@redhat.com>
684- Update translation.
685- Add CJK fontset patch
686
687* Thu Aug 16 2001 Jonathan Blandford <jrb@redhat.com>
688- New control-center-single to handle exiting, #51665
689
690* Wed Aug 01 2001 Havoc Pennington <hp@redhat.com>
691- remove .desktop file for gnomecc, so it won't appear
692  in panel menu, #49653
693
694* Mon Jul 30 2001 Jonathan Blandford <jrb@redhat.com>
695- allow to build without depending on control-center-devel
696
697* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
698- Add BuildRequires
699
700* Mon Jul 16 2001 Jonathan Blandford <jrb@redhat.com>
701- New version of control-center-single
702
703* Thu Jul 12 2001 Alexander Larsson <alexl@redhat.com>
704- Change default background to the same as the nautilus one
705
706* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
707- add hack to default to standalone control panels
708
709* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
710- Bump release + rebuild.
711
712* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
713- putting in tree for David
714
715* Tue May 22 2001 David Sainty <dsainty@redhat.com>
716- improve DPMS patch for the try case, and enable patch
717
718* Wed May  2 2001 Bill Nottingham <notting@redhat.com>
719- add patch to use xscreensaver's DPMS stuff, require that version
720
721* Fri Apr 20 2001  <jrb@redhat.com>
722- New Version (1.4.0.1)
723
724* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
725- kick the mixer once on startup if we aren't running esd
726
727* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
728- translations
729
730* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
731- Rebuild for GTK+-1.2.9 include paths
732
733* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
734- langify
735- don't define and use "ver" at the top of the file
736- move changelog to sane location
737
738* Thu Feb 08 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-4
739- Apply patch from bug #23782 to see how it works
740
741* Fri Feb 02 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-3
742- Include fvwm2.desktop in WM's
743
744* Sat Jan 27 2001 Akira TAGOH <tagoh@redhat.com>
745- Added Japanese patch.
746
747* Mon Dec 04 2000 Jonathan Blandford <jrb@redhat.com>
748- Update release.
749
750* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
751- Again, fix problem with solid backgrounds in bg-properties capplet
752  (patch got lost somewhere)
753
754* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
755- Up Epoch and release
756
757* Thu Aug 10 2000 Owen Taylor <otaylor@redhat.com>
758- Handle unreadable desktop files without crashing
759
760* Mon Aug 07 2000 Owen Taylor <otaylor@redhat.com>
761- Fix problem with backgrounds bigger than screen.
762
763* Tue Aug 01 2000 Owen Taylor <otaylor@redhat.com>
764- Fix problem when ~/.gtkrc does not already exist.
765- Fix problem with solid backgrounds in bg-properties capplet
766
767* Tue Jul 18 2000 Owen Taylor <otaylor@redhat.com>
768- Sort of fix problem with people hitting OK while the
769  "Save Session" dialog is still up. (Session won't be saved,
770  but at least the selected entry will be correctly kept.)
771- Fix history list in background properties capplet
772- Fix problems with temporary files in theme-selector capplet
773
774* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
775- automatic rebuild
776
777* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
778- Require redhat-logos
779- Some spec file and FHS fixes
780- reposition embedded logo a bit
781
782* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
783- Add big change to use gdk-pixbuf for backgrounds and add
784  the ability to emboss the background with a logo
785
786* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
787- revert .so strip
788
789* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
790- strip .so lib
791- use configure macro
792
793* Mon Sep 20 1999 Jonathan Blandford <jrb@redhat.com>
794- changed to work with 1.0.40
795
796* Fri Sep 17 1999 Jonathan Blandford <jrb@redhat.com>
797- Added fixrevert bug to fix bug in theme selector.
798
799* Sun Jun 13 1999 Jonathan Blandford <jrb@redhat.com>
800- updated RPM to use new control-center.
801
802* Wed Apr 07 1999 Michael Fulbright <drmike@redhat.com>
803- fixed sound-properties to only disable sound when run with --init-settings-..
804- removed debugging output from several capplets, fixed try behaviour of sm and
805  gnome-edit capplets
806- fixed bug in screensaver and background props
807- added new icons
808
809* Mon Apr 05 1999 Jonathan Blandford <jrb@redhat.com>
810- added a patch to fix the close dialog
811- added a patch to limit the number of bg's in the history.
812
813* Fri Apr 02 1999 Jonathan Blandford <jrb@redhat.com>
814- vesion 1.0.5
815- removed all patches >10 other then dontstartesd.
816
817* Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
818- removed UI props till it works better
819
820* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
821- make sure we DONT inadvertantly start esd by calling esd_open_...
822
823* Tue Mar 30 1999 Michael Fulbright <drmike@redhat.com>
824- changed default bg color to '#356390'
825
826* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
827- prime file selector path for browse in background-props if
828  "/usr/share/pixmaps/backgrounds/" exists.
829- fix behavior of file selector when you delete/cancel/ok it
830
831* Wed Mar 24 1999 Michael Fulbright <drmike@redhat.com>
832- added patch to fix trying in theme selector
833- disabled crystal screensaver, it does evil things to preview in capplet
834
835* Mon Mar 22 1999 Michael Fulbright <drmike@redhat.com>
836- version 1.0.4, fixes problems with sndprops and theme props among
837  other things.
838
839* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
840- fix sound-properties capplet so Try/Revert doesnt come on unless user
841  changes something
842- fixed theme-selector to not leave processes behind on Linux 2.2 kernels
843- strip binaries
844
845* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
846- version 1.0.3
847- added patch to make esd release after 30 sec of inactivity
848
849* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
850- version 1.0.2
851- turned off sound by default
852
853* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
854- version 1.0.1
855
856* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
857- version 0.99.8.1
858- added etc/CORBA/servers/* to file list
859
860* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
861- update to 0.99.8
862- added /usr/lib/cappletConf.sh
863
864* Mon Feb 08 1999 The Rasterman <raster@redhat.com>
865- update to 0.99.5.1
866
867* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
868- update to 0.99.5
869
870* Mon Jan 20 1999 Michael Fulbright <drmike@redhat.com>
871- update to 0.99.3.1
872
873* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
874- update to 0.99.3
875- seems like patch for non-standard xscreensaver placement was already in
876  prestine sources(?)
877
878* Wed Jan 06 1999 Jonathan Blandford <jrb@redhat.com>
879- updated to 0.99.1
880- temporary hack patch to get path to work to non-standard placement
881  of xscreensaver binaries in RH 5.2
882
883* Wed Dec 16 1998 Jonathan Blandford <jrb@redhat.com>
884- Created for the new control-center branch
885
Note: See TracBrowser for help on using the repository browser.