source: projects/specs/trunk/c/control-center/control-center-vl.spec @ 6924

Revision 6924, 30.0 KB checked in by Takemikaduchi, 12 years ago (diff)

libunistring: add Requires,
others: new upstream release

Line 
1%define pango_version 1.32.0
2%define gtk3_version 3.6.0
3%define gnome_desktop3_version 3.6.0
4%define libgnomekbd_version 3.6.0
5%define desktop_file_utils_version 0.3
6%define startup_notification_version 0.7
7%define libxklavier_version 5.0
8%define gnome_doc_utils_version 0.20
9%define gnome_menus_version 2.30.0
10%define vine_menus_version 3.0
11%define metacity_version 2.30.3
12%define evolution_data_server_version 2.32.0
13%define libcanberra_version 0.9
14%define usermode_version 1.83
15%define libnotify_version 0.7.3
16%define nm_version 0.9.0
17
18Summary: GNOME Control Center.
19Summary(ja): GNOME コントロールセンター
20Name: control-center
21Version: 3.6.1
22Release: 1%{?_dist_release}
23License: GPLv2+ and GFDL+
24Group: User Interface/Desktops
25URL: http://www.gnome.org
26
27Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-control-center/3.6/gnome-control-center-%{version}.tar.xz
28
29Vendor: Project Vine
30Distribution: Vine Linux
31Packager: inagaki, daisuke, Takemikaduchi
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-root
34
35Obsoletes: gnome, control-center-devel < 2.0
36Obsoletes: fontilus, themus
37
38Provides: gnome-volume-manager < 2.25
39Obsoletes: gnome-volume-manager < 2.25
40
41Requires: metacity >= %{metacity_version}
42Requires: usermode >= %{usermode_version}
43Requires: gnome-settings-daemon
44Requires: gnome-icon-theme
45Requires: gnome-desktop3 >= %{gnome_desktop_version}
46Requires: dbus-x11
47Requires: apg
48Requires(post,postun): desktop-file-utils shared-mime-info gtk3
49
50BuildRequires: gnome-common
51BuildRequires: pango-devel >= %{pango_version}
52BuildRequires: gtk3-devel >= %{gtk3_version}
53BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
54BuildRequires: libgnomekbd-devel >= %{libgnomekbd_version}
55BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
56BuildRequires: startup-notification-devel >= %{startup_notification_version}
57BuildRequires: libxklavier-devel >= %{libxklavier_version}
58BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
59BuildRequires: gnome-panel-devel
60BuildRequires: metacity-devel >= %{metacity_version}
61BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
62BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
63BuildRequires: gnome-settings-daemon-devel
64BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
65BuildRequires: nautilus-devel
66BuildRequires: alsa-lib-devel
67BuildRequires: autoconf
68BuildRequires: gettext-devel
69BuildRequires: librsvg2-devel
70BuildRequires: libXScrnSaver-devel
71BuildRequires: libXxf86misc-devel
72BuildRequires: libSM-devel
73BuildRequires: unique3-devel
74BuildRequires: polkit-devel
75BuildRequires: libgtop2-devel
76BuildRequires: upower-devel
77BuildRequires: pulseaudio-libs-devel
78BuildRequires: cups-devel
79BuildRequires: cheese-devel
80BuildRequires: gstreamer-plugins-base-devel
81BuildRequires: gnome-online-accounts-devel
82BuildRequires: colord-devel
83BuildRequires: NetworkManager-gtk-devel >= %{nm_version}
84BuildRequires: libnotify-devel >= %{libnotify_version}
85BuildRequires: libwacom-devel
86BuildRequires: libpwquality-devel
87BuildRequires: ibus-devel
88
89%description
90GNOME (the GNU Network Object Model Environment) is an attractive and
91easy-to-use GUI desktop environment. The control-center package
92provides the GNOME Control Center utilities that allow you to setup
93and configure your system's GNOME environment (things like the desktop
94background and theme, the screensaver, the window manager, system
95sounds, and mouse behavior).
96
97If you install GNOME, you need to install control-center.
98
99%description -l ja
100GNOME (the GNU Network Object Model Environment) は、魅力的で使いやすい
101GUI デスクトップ環境です。 control-center パッケージには、あなたの GNOME
102環境の設定に使う GNOME コントロールセンター・ユーティリティが含まれていま
103す。(これを使うと、デスクトップの壁紙や、テーマ、スクリーンセーバ、ウィン
104ドウマネージャ、サウンド、マウス、その他いろいろな設定を行えます。)
105
106%package devel
107Summary: Development files for GNOME Control Center
108Summary(ja): GNOME コントロールセンターの開発用ファイル
109Group: Development/Libraries
110Requires: %{name} = %{version}-%{release}
111
112%description devel
113Development tool for GNOME Control Center
114
115%descriotion -l ja devel
116GNOME コントロールセンターの開発用ファイルが含まれています。
117
118%prep
119%setup -q -n gnome-control-center-%{version}
120
121%build
122%configure --disable-static  \
123    --disable-update-mimedb \
124    --enable-ibus
125    CFLAGS="$RPM_OPT_FLAGS -Wno-error"
126
127# drop unneeded direct library deps with --as-needed
128# libtool doesn't make this easy, so we do it the hard way
129sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/    if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/      func_append compile_command " -Wl,-O1,--as-needed"\n      func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
130
131make %{?_smp_mflags}
132
133%install
134rm -rf $RPM_BUILD_ROOT
135
136make install DESTDIR=$RPM_BUILD_ROOT
137
138# we do want this
139mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
140
141# We don't want these
142rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
143rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/cursor-fonts
144
145# remove useless libtool archive files
146find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
147
148# don't package mime caches
149rm -f $RPM_BUILD_ROOT%{_datadir}/mime/XMLnamespaces
150rm -f $RPM_BUILD_ROOT%{_datadir}/mime/aliases
151rm -f $RPM_BUILD_ROOT%{_datadir}/mime/application/x-gnome-theme-package.xml
152rm -f $RPM_BUILD_ROOT%{_datadir}/mime/globs
153rm -f $RPM_BUILD_ROOT%{_datadir}/mime/magic
154rm -f $RPM_BUILD_ROOT%{_datadir}/mime/subclasses
155rm -f $RPM_BUILD_ROOT%{_datadir}/mime/mime.cache
156rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
157
158rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/fdl
159rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/lgpl
160
161%find_lang gnome-control-center-2.0
162%find_lang gnome-control-center-2.0-timezones
163
164%clean
165rm -rf $RPM_BUILD_ROOT
166
167%post
168/sbin/ldconfig
169
170update-desktop-database %{_datadir}/applications >& /dev/null ||:
171update-mime-database %{_datadir}/mime > /dev/null
172touch --no-create %{_datadir}/icons/hicolor
173if [ -x /usr/bin/gtk-update-icon-cache ]; then
174  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
175fi
176
177%postun
178/sbin/ldconfig
179update-desktop-database %{_datadir}/applications >& /dev/null ||:
180update-mime-database %{_datadir}/mime > /dev/null
181touch --no-create %{_datadir}/icons/hicolor
182if [ -x /usr/bin/gtk-update-icon-cache ]; then
183  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
184fi
185
186%files -f gnome-control-center-2.0.lang -f gnome-control-center-2.0-timezones.lang
187%defattr(-, root, root)
188%doc AUTHORS COPYING ChangeLog NEWS README
189%{_sysconfdir}/xdg/menus/gnomecc.menu
190%{_sysconfdir}/xdg/autostart/gnome-sound-applet.desktop
191%{_bindir}/gnome-control-center
192%{_bindir}/gnome-sound-applet
193%{_libdir}/control-center-1/panels/*.so
194%dir %{_datadir}/gnome/wm-properties
195%dir %{_datadir}/gnome-control-center
196%{_datadir}/applications/*
197%{_datadir}/desktop-directories/*
198%{_datadir}/gnome-control-center/datetime
199%{_datadir}/gnome-control-center/icons
200%{_datadir}/gnome-control-center/keybindings
201%{_datadir}/gnome-control-center/pixmaps
202%{_datadir}/gnome-control-center/sounds
203%{_datadir}/gnome-control-center/ui
204%{_datadir}/icons/*
205%{_datadir}/pixmaps/*
206%{_datadir}/polkit-1/actions/org.gnome.controlcenter.datetime.policy
207%{_datadir}/polkit-1/actions/org.gnome.controlcenter.user-accounts.policy
208%{_datadir}/polkit-1/rules.d/gnome-control-center.rules
209%{_datadir}/sounds/*
210%{_mandir}/man1/gnome-control-center.1.gz
211
212%files devel
213%defattr(-, root, root)
214%{_datadir}/pkgconfig/*
215
216
217%changelog
218* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
219- new upstream release
220
221* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
222- new upstream release
223- add BuildRequires: libpwquality-devel
224
225* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
226- new upstream release
227
228* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
229- new upstream release
230- remove BuildRequires: GConf2-devel, libbonobo-devel
231- add BuildRequires: libwacom-devel
232
233* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
234- new upstream release
235
236* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
237- new upstream release
238
239* Mon Oct 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-2
240- rebuild with NetworkManager-0.9
241- change BuildRequires: NetworkManager-gtk-devel instead of NetworkManager-glib-devel
242
243* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
244- new upstream release
245
246* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
247- new upstream release
248
249* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
250- new upstream release
251- remove Patch0
252
253* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
254- new upstream release
255- add BuildRequires: libnotify-devel
256- add Patch0 (control-center-3.1.5-crash-layout.patch)
257
258* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
259- new upstream release
260- change BuildRequires: gtk3-devel instead of gtk2-devel
261- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
262- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
263- change BuildRequires: unique3-devel instead of unique-devel
264- add BuildRequires: libXxf86misc-devel, libSM-devel, polkit-devel, libgtop2-devel, upower-devel,
265                     pulseaudio-libs-devel, cups-devel, cheese-devel, gstreamer-plugins-base-devel,
266                     gnome-online-accounts-devel, colord-devel, NetworkManager-glib-devel
267- add Requires: apg
268- drop all Patches
269- add Provides: and Obsoletes: gnome-volume-manager
270
271* Sun Mar 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
272- update desktop-effect-integration patch
273  - fix freeze on changing metacity to compiz
274  - run compiz directly instead of compiz-gtk
275  - drop use of jockey-gtk
276- update ja.po
277
278* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
279- new upstream release
280
281* Sat Nov 06 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-4
282- update translation.
283
284* Fri Nov 05 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-3
285- update translation.
286
287* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
288- update Source21(gnome-control-center-2.32.0-vine.ja.po)
289
290* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
291- new upstream release
292- drop Patch22, Patch30, Patch52
293- fix %files
294
295* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-4
296- rebuilt with rpm-4.8.1 for pkg-config (too)
297
298* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
299- rebuild with rpm-4.8.1 for pkg-config file
300- add Requires: %{name}=%{version}-%{release}
301
302* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
303- rebuild with evolution-data-server-2.30.2
304
305* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
306- new upstream release
307
308* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
309- new upstream release
310- drop Patch3, Patch46, Patch50, Patch51, Patch53, Patch54, Patch112
311- add BuildRequires: gnome-common, unique-devel
312
313* Thu Dec 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-2
314- enable Patch101,110-112 and 500
315
316* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
317- new upstream release
318- disabled Patch101, 110-112 and 500
319
320* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-9
321- update notification-theme.patch
322  - use vine theme if NotificationTheme is not set in meta-theme.
323
324* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-8
325- add Patch510: use Sans for font-properties sample font.
326- add BR: librsvg2-devel, libXScrnSaver-devel
327- remove BR: esound
328
329* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-7
330- add Patch37: Don't rely on _BACKUP property for xkb initialization
331
332* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-6
333- renumber patch10 to patch1010
334  - do not check gdm fprint plugin
335- add Patch101: show aspect in drop down menu
336- add Patch110: modify gnome-mouse-properties to fit smaller screen
337- add Patch111: modify gnome-about-me to fit smaller screen
338- add Patch112: modify gnome-display-properties to fit smaller screen
339
340* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-5
341- update Patch100 to use compiz-gtk instead of compiz
342
343* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
344- update ja.po
345
346* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
347- import upstream patchs (10,22,3[0-6])
348
349* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
350- add nautilus-devel to BR: not Requires:
351
352* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
353- new upstream release
354- update ja.po
355- add BR: nautilus-devel
356
357* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-3
358- drop Patch20 which need new XInput API
359- update Patch23
360
361* Sat Oct 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
362- add Patch20,22.23 from ubuntu
363  - patch20 to add touchpad configuration
364  - patch22 to add aspect setting in randr capplet
365  - patch23 to integrate desktop setting into appearance-properties
366
367* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
368- new upstream release
369
370* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
371- new upstream release
372
373* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-3
374- add gnome-typing-monitor to %%files
375
376* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
377- add Patch100 for new RandR capplet. (fc)
378
379* Sat Jun  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2.1-1
380- new upstream release
381- dropped Patch8 (merged into upstream)
382
383* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
384- new upstream release
385- added Patch7 and Patch8 from Fedora
386  * Mon Mar 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
387  - Fix warnings in the keybindings capplet when in non-UTF-8 locale
388  - Fix Esc/Backspace being bindable when CapsLock is on (#427123)
389  * Tue Apr  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-2
390  - Remove a nonfunctional button from the a11y preferences
391- added BuildRequires: gnome-settings-daemon, gnome-panel
392- added Requires: gnome-icon-theme, gnome-desktop, dbus-x11
393- removed Requires: xscreensaver
394
395* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
396- new upstream release based on Fedora
397- added BuildRequires: gnome-settings-daemon
398
399* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
400- new upstream release based on Fedora
401  * Wed Oct 24 2007  Matthias Clasen <mclasen@redhat.com> - 2.20.1-5
402  - Fix the orca command in the default applications capplet (#351471)
403
404* Sat Jul 14 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl4
405- add BuildReq: libgnomekbd-devel
406
407* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
408- rebuilt with evolution-data-server-devel-1.10.1
409
410* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl2
411- add BuildReq: evolution-data-server-devel
412
413* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
414- new upstream release
415- remove unneeded? patch10
416
417* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.2-0vl2
418- added Patch10 to supress /dev/pmu warning messages on some ppc models
419
420* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
421- new upstream release
422
423* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
424- new upstream release
425
426* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
427- run gtk-update-icon-cache in %%post script.
428
429* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
430- new upstream release
431- drop Patch10,it is merged in upstream
432
433* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl2
434- add Patch10 for correct textdomain name in
435  default-applications-properties(Bug332833)
436- add Patch100 for change default-applications settings for vine
437
438* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
439- new upstream release
440
441* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
442- new upstream release
443
444* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
445- new upstream release
446
447* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
448- new upstream release
449- enable alsa support
450
451* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
452- new upstream release
453
454* Thu Mar 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl4
455- fixed type in %%post script
456
457* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl3
458- clear the old defaults of xkb
459
460* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
461- remove bonobo-activation dependency
462
463* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
464- new upstream version
465
466* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
467- new upstream release
468- add Japanese summay to devel package
469
470* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
471- new upstream release
472
473* Sat Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
474- modify patch11 to use NeoVine theme instead of BeCool.
475
476* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
477- rebuild with new toolchain
478
479* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
480- new upstream release
481- remove obsolete ja.po
482
483* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 2.3.6-0vl2
484- change required version of metacity to 2.4.34 on alpha
485
486* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
487- new upstream release
488
489* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl1
490- new upstream release
491
492* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl3
493- add more missing files and schemas...
494
495* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
496- add missing file in %{_libdir}/gnome-vfs-2.0/
497
498* Sat May 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl1
499- new upstream release
500- this is experimental version
501- remove sr@Latn locale from desktop files to build with desktop-file-utils-0.3
502
503* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
504- new upstream release
505
506* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl3
507- import patch6 (upstream paches) from rawhide package.
508
509* Tue Feb 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl2
510- import patch1-5 (upstream paches) from rawhide package.
511
512* Sun Feb 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
513- new upstream release
514
515* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
516- rebuild
517
518* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
519- new upstream release
520
521* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
522- new upstream release
523
524* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
525- new upstream release
526
527* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl7
528- change default gtk1 theme from Raleigh to BeCool.
529
530* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl6
531- add BuildRequires/Requires.
532- fixed kanjicode of specfile
533
534* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
535- remove bogus message in %%post scripts.
536
537* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
538- add patch10 to modify some desktop files
539- update ja.po
540
541* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
542- update ja.po
543
544* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
545- update ja.po
546
547* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
548- new upstream release
549
550* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl3
551- add devel package
552- add window-manager-settings files.
553
554* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl2
555- modify dependancies.
556
557* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
558- build for Vine Linux
559- new upstream release from gnome-2.1.4
560
561* Thu Sep  5 2002 Jonathan Blandford <jrb@redhat.com>
562- Allow setting custom mime handlers
563
564* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
565- make desktop file symlinks absolute #71991
566- add po files from cvs.gnome.org
567
568* Fri Aug 23 2002 Jonathan Blandford <jrb@redhat.com>
569- Fix up keyboard handling
570
571* Wed Aug 21 2002 Jonathan Blandford <jrb@redhat.com>
572- Fixes for #68735
573
574* Wed Aug  7 2002 Jonathan Blandford <jrb@redhat.com>
575- New version.  Fix up metacity theme locations
576
577* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
578- Switch the gtk1 theme along with the gtk2 theme
579- Add the ability to switch the window manager theme through the theme capplet
580- Add two more font options to the font property dialog
581- Add a bunch of missing unrefs of the result of gconf_client_get_default()
582
583* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
584- fix desktop files more
585- copy icons to /usr/share/pixmaps
586
587* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
588- munge the desktop files correctly
589- obsolete control-center-devel, #69168
590- replace gnomecc.desktop with a file from redhat-menus
591
592* Tue Jul 23 2002 Owen Taylor <otaylor@redhat.com>
593- Fix crasher bug in xftprefs patch
594
595* Tue Jul 16 2002 Owen Taylor <otaylor@redhat.com>
596- Change the default rendering style to be "Best Shapes", not "Best Contrast"
597
598* Tue Jul  9 2002 Owen Taylor <otaylor@redhat.com>
599- Add Xft / XSETTINGS support
600
601* Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 2.0.0-2
602- fix %%post so schemas get installed
603 
604* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
605- 2.0.0
606- add new default editor schemas
607- fix find_lang
608
609* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
610- rebuild for new libraries
611- remove a no-longer-existing schemas file from post
612- use desktop-file-install
613
614* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
615- rebuild in different environment
616
617* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
618- rebuild with new dependent libs
619
620* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
621- rebuild in different environment
622
623* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
624- rebuild in different environment
625- build requires bonobo-activation
626
627* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
628- 1.99.10
629
630* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
631- 1.99.9
632
633* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
634- Move to GNOME 2 version
635
636* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
637- merge in translations
638
639* Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
640- Make the theme selector write fontsets, not fonts (#62413)
641
642* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
643- really put screensaver capplet back (I think)
644
645* Wed Mar 27 2002 Bill Nottingham <notting@redhat.com>
646- revert xscreensaver change
647
648* Wed Mar 27 2002 Havoc Pennington <hp@redhat.com>
649- init "Scaled" radio button correctly #61913
650
651* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
652- change path to windowmaker config tool again, #61824
653
654* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com>
655- rather than keep patching and patching it, use xscreensaver's own
656  capplet
657
658* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
659- rebuild in Hampton
660
661* Wed Jan 30 2002 Jonathan Blandford <jrb@redhat.com>
662- Rebuild package.
663
664* Thu Jan 24 2002 Tim Powers <timp@redhat.com>
665- rebuilt against new openssl
666
667* Fri Jan 18 2002 Havoc Pennington <hp@redhat.com>
668- automake14
669- don't run auto* again in ccsingle subdir, not sure why we did that
670
671* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
672- rebuild with new gnome-libs so that libcapplet has right cflags/libs
673- pixbufflags patch to make the rebuild work
674- compileflags patch to make control-center-single work
675
676* Wed Aug 29 2001 Havoc Pennington <hp@redhat.com>
677- fix #52831 (UI properties in Programs menu)
678
679* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
680- Add po files from sources.redhat.com
681
682* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
683- set the _XROOTCOLOR_PIXEL property, should fix
684  bug #52141
685
686* Wed Aug 22 2001 Yukihiro Nakai <ynakai@redhat.com>
687- Update translation.
688- Add CJK fontset patch
689
690* Thu Aug 16 2001 Jonathan Blandford <jrb@redhat.com>
691- New control-center-single to handle exiting, #51665
692
693* Wed Aug 01 2001 Havoc Pennington <hp@redhat.com>
694- remove .desktop file for gnomecc, so it won't appear
695  in panel menu, #49653
696
697* Mon Jul 30 2001 Jonathan Blandford <jrb@redhat.com>
698- allow to build without depending on control-center-devel
699
700* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
701- Add BuildRequires
702
703* Mon Jul 16 2001 Jonathan Blandford <jrb@redhat.com>
704- New version of control-center-single
705
706* Thu Jul 12 2001 Alexander Larsson <alexl@redhat.com>
707- Change default background to the same as the nautilus one
708
709* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
710- add hack to default to standalone control panels
711
712* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
713- Bump release + rebuild.
714
715* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
716- putting in tree for David
717
718* Tue May 22 2001 David Sainty <dsainty@redhat.com>
719- improve DPMS patch for the try case, and enable patch
720
721* Wed May  2 2001 Bill Nottingham <notting@redhat.com>
722- add patch to use xscreensaver's DPMS stuff, require that version
723
724* Fri Apr 20 2001  <jrb@redhat.com>
725- New Version (1.4.0.1)
726
727* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
728- kick the mixer once on startup if we aren't running esd
729
730* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
731- translations
732
733* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
734- Rebuild for GTK+-1.2.9 include paths
735
736* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
737- langify
738- don't define and use "ver" at the top of the file
739- move changelog to sane location
740
741* Thu Feb 08 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-4
742- Apply patch from bug #23782 to see how it works
743
744* Fri Feb 02 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-3
745- Include fvwm2.desktop in WM's
746
747* Sat Jan 27 2001 Akira TAGOH <tagoh@redhat.com>
748- Added Japanese patch.
749
750* Mon Dec 04 2000 Jonathan Blandford <jrb@redhat.com>
751- Update release.
752
753* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
754- Again, fix problem with solid backgrounds in bg-properties capplet
755  (patch got lost somewhere)
756
757* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
758- Up Epoch and release
759
760* Thu Aug 10 2000 Owen Taylor <otaylor@redhat.com>
761- Handle unreadable desktop files without crashing
762
763* Mon Aug 07 2000 Owen Taylor <otaylor@redhat.com>
764- Fix problem with backgrounds bigger than screen.
765
766* Tue Aug 01 2000 Owen Taylor <otaylor@redhat.com>
767- Fix problem when ~/.gtkrc does not already exist.
768- Fix problem with solid backgrounds in bg-properties capplet
769
770* Tue Jul 18 2000 Owen Taylor <otaylor@redhat.com>
771- Sort of fix problem with people hitting OK while the
772  "Save Session" dialog is still up. (Session won't be saved,
773  but at least the selected entry will be correctly kept.)
774- Fix history list in background properties capplet
775- Fix problems with temporary files in theme-selector capplet
776
777* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
778- automatic rebuild
779
780* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
781- Require redhat-logos
782- Some spec file and FHS fixes
783- reposition embedded logo a bit
784
785* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
786- Add big change to use gdk-pixbuf for backgrounds and add
787  the ability to emboss the background with a logo
788
789* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
790- revert .so strip
791
792* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
793- strip .so lib
794- use configure macro
795
796* Mon Sep 20 1999 Jonathan Blandford <jrb@redhat.com>
797- changed to work with 1.0.40
798
799* Fri Sep 17 1999 Jonathan Blandford <jrb@redhat.com>
800- Added fixrevert bug to fix bug in theme selector.
801
802* Sun Jun 13 1999 Jonathan Blandford <jrb@redhat.com>
803- updated RPM to use new control-center.
804
805* Wed Apr 07 1999 Michael Fulbright <drmike@redhat.com>
806- fixed sound-properties to only disable sound when run with --init-settings-..
807- removed debugging output from several capplets, fixed try behaviour of sm and
808  gnome-edit capplets
809- fixed bug in screensaver and background props
810- added new icons
811
812* Mon Apr 05 1999 Jonathan Blandford <jrb@redhat.com>
813- added a patch to fix the close dialog
814- added a patch to limit the number of bg's in the history.
815
816* Fri Apr 02 1999 Jonathan Blandford <jrb@redhat.com>
817- vesion 1.0.5
818- removed all patches >10 other then dontstartesd.
819
820* Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
821- removed UI props till it works better
822
823* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
824- make sure we DONT inadvertantly start esd by calling esd_open_...
825
826* Tue Mar 30 1999 Michael Fulbright <drmike@redhat.com>
827- changed default bg color to '#356390'
828
829* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
830- prime file selector path for browse in background-props if
831  "/usr/share/pixmaps/backgrounds/" exists.
832- fix behavior of file selector when you delete/cancel/ok it
833
834* Wed Mar 24 1999 Michael Fulbright <drmike@redhat.com>
835- added patch to fix trying in theme selector
836- disabled crystal screensaver, it does evil things to preview in capplet
837
838* Mon Mar 22 1999 Michael Fulbright <drmike@redhat.com>
839- version 1.0.4, fixes problems with sndprops and theme props among
840  other things.
841
842* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
843- fix sound-properties capplet so Try/Revert doesnt come on unless user
844  changes something
845- fixed theme-selector to not leave processes behind on Linux 2.2 kernels
846- strip binaries
847
848* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
849- version 1.0.3
850- added patch to make esd release after 30 sec of inactivity
851
852* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
853- version 1.0.2
854- turned off sound by default
855
856* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
857- version 1.0.1
858
859* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
860- version 0.99.8.1
861- added etc/CORBA/servers/* to file list
862
863* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
864- update to 0.99.8
865- added /usr/lib/cappletConf.sh
866
867* Mon Feb 08 1999 The Rasterman <raster@redhat.com>
868- update to 0.99.5.1
869
870* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
871- update to 0.99.5
872
873* Mon Jan 20 1999 Michael Fulbright <drmike@redhat.com>
874- update to 0.99.3.1
875
876* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
877- update to 0.99.3
878- seems like patch for non-standard xscreensaver placement was already in
879  prestine sources(?)
880
881* Wed Jan 06 1999 Jonathan Blandford <jrb@redhat.com>
882- updated to 0.99.1
883- temporary hack patch to get path to work to non-standard placement
884  of xscreensaver binaries in RH 5.2
885
886* Wed Dec 16 1998 Jonathan Blandford <jrb@redhat.com>
887- Created for the new control-center branch
888
Note: See TracBrowser for help on using the repository browser.