source: projects/specs/trunk/c/conky/conky-vl.spec @ 521

Revision 521, 5.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# TODO: make libXNVCtrl-devel
2
3%define with_alsa 0
4%define with_audacious 0
5%define with_imlib 1
6%define with_lua 0
7%define with_moc 1
8%define with_mpd 0
9%define with_nvidia 0
10%define with_rss 1
11%define with_smapi 0
12%define with_ibm 0
13%define with_wlan 0
14
15Name:           conky
16Version:        1.7.1.1
17Release:        1%{?_dist_release}
18Summary:        A lightweight system monitor for X
19Summary(ja):    X 用軽量システムモニタ
20Group:          User Interface/X
21License:        GPLv3+
22URL:            http://conky.sf.net/
23Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
24Patch0:         conky-1.7.1.1-nonxft.patch
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26
27BuildRequires:  libXft-devel
28BuildRequires:  libXt-devel
29BuildRequires:  libXdamage-devel
30BuildRequires:  libXext-devel
31%if %{with_alsa}
32BuildRequires: alsa-lib-devel
33%endif
34%if %{with_imlib}
35BuildRequires: imlib2-devel
36%endif
37%if %{with_lua}
38BuildRequires: lua-devel
39%endif
40%if %{with_audacious}
41BuildRequires:  audacious-devel
42BuildRequires:  dbus-glib-devel
43%endif
44%if %{with_nvidia}
45BuildRequires: libXNVCtrl-devel
46%endif
47%if %{with_rss}
48BuildRequires: curl-devel
49%endif
50%if %{with_wlan}
51BuildRequires: wireless-tools-devel
52%endif
53
54%description
55A system monitor for X originally based on the torsmo code. but more kickass.
56It just keeps on given'er. Yeah.
57#'
58
59%description -l ja
60torsmo をベースにした X 用のシステムモニタです。
61
62%prep
63%setup -q
64%patch0 -p1 -b .nonxft
65
66for i in AUTHORS ChangeLog; do
67    iconv -f iso8859-1 -t utf8 -o ${i}{_,} && touch -r ${i}{,_} && mv -f ${i}{_,}
68done
69
70%build
71#sh autogen.sh
72%configure \
73    --disable-rpath \
74    %if !%{with_alsa}
75    --disable-alsa \
76    %if %{with_audacious}
77    --enable-audacious=yes \
78    %endif
79    %if %{with_imlib}
80    --enable-imlib2 \
81    %endif
82    %if !%{with_lua}
83    --disable-lua \
84    %endif
85    %if !%{with_moc}
86    --disable-moc \
87    %endif
88    %if !%{with_mpd}
89    --disable-mpd \
90    %endif
91    %if %{with_nvidia}
92    --enable-nvidia \
93    %endif
94    %if %{with_rss}
95    --enable-rss \
96    %endif
97    %if %{with_ibm}
98    --enable-ibm \
99    %endif
100    %if %{with_smapi}
101    --enable-smapi \
102    %endif
103    %if %{with_wlan}
104    --enable-wlan \
105    %endif
106    ;
107
108%__make %{?_smp_mflags}
109
110
111%install
112%__rm -rf $RPM_BUILD_ROOT
113%__make install DESTDIR=$RPM_BUILD_ROOT
114
115%clean
116%__rm -rf $RPM_BUILD_ROOT
117
118
119%files
120%defattr(-,root,root,-)
121%doc AUTHORS ChangeLog COPYING TODO README NEWS extras/* doc/docs.html
122%dir %{_sysconfdir}/%{name}
123%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
124%{_bindir}/%{name}
125%{_mandir}/man1/*
126
127
128%changelog
129* Thu Jul 30 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.7.1.1-1
130- new upstream release
131
132* Sat Nov 15 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.6.1-1
133- initial build based on Fedora package
134 - applied conky-1.6.0-rdtsc.patch, conky-1.6.1-ifaddrs.patch
135
136* Tue Aug 26 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.6.1-1
137- Update to 1.6.1
138- Fix buffer overflow when reading interface addresses
139
140* Tue Jul 22 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.6.0-1
141- Update to 1.6.0
142- Fix freq_dyn on x86_64
143
144* Tue Apr 01 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.5.1-1
145- Update to 1.5.1
146
147* Sun Mar 23 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.5.0-1
148- Update to 1.5.0
149- Convert doc files to UTF-8
150
151* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.9-2
152- Autorebuild for GCC 4.3
153
154* Tue Nov 27 2007 Miroslav Lichvar <mlichvar@redhat.com> - 1.4.9-1
155- Update to 1.4.9
156- Enable support for Audacious 1.4.0
157
158* Sun Oct 21 2007 Miroslav Lichvar <mlichvar@redhat.com> - 1.4.8-1
159- Update to 1.4.8
160- Enable mpd, rss and wireless support
161- Update license tag
162
163* Wed Apr 18 2007 Michael Rice <errr[AT]errr-online.com> - 1.4.5-4
164- Rebuild to match audacious lib in fc6 bug: 236989
165
166* Mon Apr 09 2007 Michael Rice <errr[AT]errr-online.com> - 1.4.5-3
167- Rebuild for devel
168
169* Thu Dec 14 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.5-2
170- Ship NEWS
171- Add patch for license of timed_thread and NEWS
172
173* Tue Dec 12 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.5-1
174- version bump
175- change group
176 
177* Wed Dec 06 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-3
178- rebuild for new audacious lib version
179
180* Thu Nov 30 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-2
181- Move nano and vim files into docs
182- remove unneeded BR's
183
184* Tue Nov 21 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-1
185- Version bump
186- Add vim and nano syntax files to package
187
188* Thu Oct 05 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.3-1
189- Version bump
190- Remove Install file from docs
191
192* Mon Oct 02 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-4
193- moved to configure macro from ./configure
194- clean up changelog and make more informative entrys
195- Fixed sumary in spec file
196- remove NEWS file since it was empty
197- remove xmms support due to possible security issue
198- remove bmp support due to possible security issue
199- add missing BR for libXext-devel and remove unneeded libX11-devel 
200
201* Thu Sep 28 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-3
202- use the GPL as licence since the whole package is GPL
203
204* Thu Sep 28 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-2
205- remove unneeded deps
206
207* Tue Sep 26 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-1
208- Initial RPM release
Note: See TracBrowser for help on using the repository browser.