source: projects/specs/trunk/c/conky/conky-vl.spec @ 10815

Revision 10815, 6.6 KB checked in by ara_t, 7 years ago (diff)

rebuild for VineSeed (add Patch)

Line 
1# TODO: - make libXNVCtrl-devel
2#       - with --enable-lua-imlib2
3
4%define with_alsa 0
5%define with_audacious 0
6%define with_imlib 1
7%define with_lua 1
8%define with_lua_cairo 1
9%define with_lua_imlib 1
10%define with_moc 1
11%define with_mpd 0
12%define with_nvidia 0
13%define with_rss 1
14%define with_smapi 0
15%define with_ibm 0
16%define with_wlan 0
17
18Name:           conky
19Version:        1.8.1
20Release:        2%{?_dist_release}
21Summary:        A lightweight system monitor for X
22Summary(ja):    X 用軽量システムモニタ
23Group:          User Interface/X
24License:        GPLv3+
25URL:            http://conky.sf.net/
26Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
27Patch0:         conky-1.8.1-delete-curl_types.h.patch
28BuildRoot:      %{_tmppath}/%{name}-%{version}-root
29
30BuildRequires:  glib2-devel
31BuildRequires:  libxml2-devel
32BuildRequires:  libXft-devel
33BuildRequires:  libXt-devel
34BuildRequires:  libXdamage-devel
35BuildRequires:  libXext-devel
36%if %{with_alsa}
37BuildRequires: alsa-lib-devel
38%endif
39%if %{with_imlib}
40BuildRequires: imlib2-devel
41%endif
42%if %{with_lua}
43BuildRequires: lua-devel
44%endif
45%if %{with_lua_cairo}
46BuildRequires: cairo-devel tolua++-devel
47%endif
48%if %{with_lua_imlib}
49BuildRequires: imlib2-devel tolua++-devel
50%endif
51%if %{with_audacious}
52BuildRequires:  audacious-devel
53BuildRequires:  dbus-glib-devel
54%endif
55%if %{with_nvidia}
56BuildRequires: libXNVCtrl-devel
57%endif
58%if %{with_rss}
59BuildRequires: curl-devel
60%endif
61%if %{with_wlan}
62BuildRequires: wireless-tools-devel
63%endif
64
65Vendor: Project Vine
66Distribution: Vine Linux
67
68%description
69A system monitor for X originally based on the torsmo code. but more kickass.
70It just keeps on given'er. Yeah.
71#'
72
73%description -l ja
74torsmo をベースにした X 用のシステムモニタです。
75
76%prep
77%setup -q
78%if %{?_dist_release} >= "vl7"
79%patch0
80%endif
81
82for i in AUTHORS ChangeLog; do
83    iconv -f iso8859-1 -t utf8 -o ${i}{_,} && touch -r ${i}{,_} && mv -f ${i}{_,}
84done
85
86%build
87#sh autogen.sh
88%configure \
89    --disable-rpath \
90    %if !%{with_alsa}
91    --disable-alsa \
92    %endif
93    %if %{with_audacious}
94    --enable-audacious=yes \
95    %endif
96    %if %{with_imlib}
97    --enable-imlib2 \
98    %endif
99    %if !%{with_lua}
100    --disable-lua \
101    %endif
102    %if %{with_lua_cairo}
103    --enable-lua-cairo \
104    %endif
105    %if %{with_lua_imlib}
106    --enable-lua-imlib2 \
107    %endif
108    %if !%{with_moc}
109    --disable-moc \
110    %endif
111    %if !%{with_mpd}
112    --disable-mpd \
113    %endif
114    %if %{with_nvidia}
115    --enable-nvidia \
116    %endif
117    %if %{with_rss}
118    --enable-rss \
119    %endif
120    %if %{with_ibm}
121    --enable-ibm \
122    %endif
123    %if %{with_smapi}
124    --enable-smapi \
125    %endif
126    %if %{with_wlan}
127    --enable-wlan \
128    %endif
129    ;
130
131# don't use rpath
132%__sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
133%__sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
134
135%__make %{?_smp_mflags}
136
137
138%install
139%__rm -rf $RPM_BUILD_ROOT
140%__make install DESTDIR=$RPM_BUILD_ROOT
141
142%__rm -f $RPM_BUILD_ROOT%{_sysconfdir}/conky/conky_no_x11.conf
143%__rm -f $RPM_BUILD_ROOT%{_libdir}/conky/*.{la,a}
144
145%clean
146%__rm -rf $RPM_BUILD_ROOT
147
148
149%files
150%defattr(-,root,root,-)
151%doc AUTHORS ChangeLog COPYING TODO README NEWS extras/* doc/docs.html
152%dir %{_sysconfdir}/%{name}
153%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
154%{_bindir}/%{name}
155%if %{with_lua_cairo} || %{with_lua_imlib}
156%{_libdir}/conky
157%endif
158%{_mandir}/man1/*
159
160
161%changelog
162* Wed Nov 16 2016 Toshiaki Ara <ara_t@384.jp> 1.10.4-1
163- new upstream release
164- add Vendor and Distribution
165
166* Sun Jun 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.8.1-1
167- new upstream release
168
169* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.7.2-1
170- new upstream release
171- enable lua, lua-cairo
172- added BuildRequires: glib2-devel
173
174* Mon Feb 15 2010 Miroslav Lichvar <mlichvar@redhat.com> - 1.7.2-2
175- fix building with new audacious (#556317)
176
177* Tue Aug 25 2009 Miroslav Lichvar <mlichvar@redhat.com> - 1.7.2-1
178- Update to 1.7.2
179
180* Thu Jul 30 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.7.1.1-1
181- new upstream release
182
183* Sat Nov 15 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.6.1-1
184- initial build based on Fedora package
185 - applied conky-1.6.0-rdtsc.patch, conky-1.6.1-ifaddrs.patch
186
187* Tue Aug 26 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.6.1-1
188- Update to 1.6.1
189- Fix buffer overflow when reading interface addresses
190
191* Tue Jul 22 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.6.0-1
192- Update to 1.6.0
193- Fix freq_dyn on x86_64
194
195* Tue Apr 01 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.5.1-1
196- Update to 1.5.1
197
198* Sun Mar 23 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.5.0-1
199- Update to 1.5.0
200- Convert doc files to UTF-8
201
202* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.9-2
203- Autorebuild for GCC 4.3
204
205* Tue Nov 27 2007 Miroslav Lichvar <mlichvar@redhat.com> - 1.4.9-1
206- Update to 1.4.9
207- Enable support for Audacious 1.4.0
208
209* Sun Oct 21 2007 Miroslav Lichvar <mlichvar@redhat.com> - 1.4.8-1
210- Update to 1.4.8
211- Enable mpd, rss and wireless support
212- Update license tag
213
214* Wed Apr 18 2007 Michael Rice <errr[AT]errr-online.com> - 1.4.5-4
215- Rebuild to match audacious lib in fc6 bug: 236989
216
217* Mon Apr 09 2007 Michael Rice <errr[AT]errr-online.com> - 1.4.5-3
218- Rebuild for devel
219
220* Thu Dec 14 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.5-2
221- Ship NEWS
222- Add patch for license of timed_thread and NEWS
223
224* Tue Dec 12 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.5-1
225- version bump
226- change group
227 
228* Wed Dec 06 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-3
229- rebuild for new audacious lib version
230
231* Thu Nov 30 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-2
232- Move nano and vim files into docs
233- remove unneeded BR's
234
235* Tue Nov 21 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-1
236- Version bump
237- Add vim and nano syntax files to package
238
239* Thu Oct 05 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.3-1
240- Version bump
241- Remove Install file from docs
242
243* Mon Oct 02 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-4
244- moved to configure macro from ./configure
245- clean up changelog and make more informative entrys
246- Fixed sumary in spec file
247- remove NEWS file since it was empty
248- remove xmms support due to possible security issue
249- remove bmp support due to possible security issue
250- add missing BR for libXext-devel and remove unneeded libX11-devel 
251
252* Thu Sep 28 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-3
253- use the GPL as licence since the whole package is GPL
254
255* Thu Sep 28 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-2
256- remove unneeded deps
257
258* Tue Sep 26 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-1
259- Initial RPM release
Note: See TracBrowser for help on using the repository browser.