source: projects/specs/trunk/c/compiz/compiz-vl.spec @ 521

Revision 521, 26.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# build with kde4
2%bcond_with kde
3
4%define         dialogversion   0.7.18
5%define         kde_dialogversion 0.0.5
6
7%define         core_plugins    blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
8
9%define         gnome_plugins   annotate gconf glib svg gnomecompat
10
11# List of plugins passed to ./configure.  The order is important
12
13%define         plugins         core,glib,gconf,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
14
15Summary:        OpenGL window and compositing manager
16Summary(ja):    OpenGL ウィンドウ・コンポジットマネージャ
17Name:           compiz
18URL:            http://www.go-compiz.org
19License:        X11/MIT/GPL
20Group:          User Interface/Desktops
21Version:        0.8.2
22Release:        4%{?_dist_release}
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26# libdrm is not available on these arches
27ExcludeArch:    s390 s390x ppc64
28
29Requires:       xorg-x11-server-Xorg
30Requires:       mesa-libGL
31
32Requires(post): desktop-file-utils
33
34BuildRequires:  libX11-devel, libdrm-devel, libwnck-devel
35BuildRequires:  libXfixes-devel, libXrandr-devel, libXrender-devel
36BuildRequires:  libXcomposite-devel, libXdamage-devel, libXext-devel
37BuildRequires:  libXt-devel, libXmu-devel, libICE-devel, libSM-devel
38BuildRequires:  control-center-devel, GConf2-devel
39BuildRequires:  gnome-desktop-devel >= 2.26.0
40BuildRequires:  metacity-devel
41BuildRequires:  desktop-file-utils
42BuildRequires:  intltool >= 0.35
43BuildRequires:  gettext
44BuildRequires:  dbus-devel
45BuildRequires:  librsvg2-devel
46BuildRequires:  mesa-libGLU-devel
47BuildRequires:  fuse-devel
48%if %{with kde}
49BuildRequires:  kdebase-workspace-devel
50BUildRequires:  dbus-qt-devel
51%endif
52
53Source0:        http://releases.compiz-fusion.org/compiz/%{version}/%{name}-%{version}.tar.bz2
54Source1:        desktop-effects-%{dialogversion}.tar.bz2
55Source2:        kde-desktop-effects-%{kde_dialogversion}.tar.bz2
56
57Source3:        compiz-gtk
58Source4:        compiz-gtk.desktop
59
60# Make sure that former beryl users still have bling
61Obsoletes: beryl-core
62
63# Patches from fedora
64Patch102: desktop-effects-0.7.17-wall-plugin.patch
65Patch103: composite-cube-logo.patch
66Patch111: gconf-core-plugin-loopfix.patch
67
68# Make sure configuration plugins never get unloaded
69Patch123: compiz-0.7.8-pin-initial-plugins.patch
70
71# Patches from ubuntu
72Patch200: 014-fix-gtk-window-decorator-no-argb-crash.patch
73Patch210: 049-damage-report-non-empty.patch
74
75# build fix
76Patch300: compiz-0.8.2-gconf-buildfix.patch
77
78%description
79Compiz is one of the first OpenGL-accelerated compositing window
80managers for the X Window System. The integration allows it to perform
81compositing effects in window management, such as a minimization
82effect and a cube workspace.  Compiz is an OpenGL compositing manager
83that use Compiz use EXT_texture_from_pixmap OpenGL extension for
84binding redirected top-level windows to texture objects.
85
86%package devel
87Summary: Development packages for compiz
88Summary(ja): compiz の開発パッケージ
89Group: Development/Libraries
90Requires: compiz = %{version}-%{release}
91Requires: pkgconfig
92Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
93Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
94Requires: libxslt-devel startup-notification-devel
95
96%description devel
97The compiz-devel package includes the header files,
98and developer docs for the compiz package.
99
100Install compiz-devel if you want to develop plugins for the compiz
101windows and compositing manager.
102
103%package gnome
104Summary: Compiz gnome integration bits
105Summary(ja): Compiz gnome integration bits
106Group: User Interface/Desktops
107Requires: gnome-session
108Requires: metacity
109Requires: libwnck
110Requires: glx-utils
111Requires: %{name} = %{version}
112Requires(pre): GConf2
113Requires(post): GConf2
114Requires(preun): GConf2
115Obsoletes: compiz < 0.5.2-8
116Obsoletes: beryl-gnome
117
118%description gnome
119The compiz-gnome package contains gtk-window-decorator,
120and other gnome integration related stuff.
121
122%if %{with kde}
123%package kde
124Summary: Compiz kde integration bits
125Summary(ja): Compiz kde integration bits
126Group: User Interface/Desktops
127Requires: %{name} = %{version}
128Requires: compiz-manager
129Obsoletes: beryl-kde
130
131%description kde
132The compiz-kde package contains kde-window-decorator,
133and other kde integration related stuff.
134%endif
135
136%prep
137%setup -q -T -b1 -n desktop-effects-%{dialogversion}
138#%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
139%setup -q
140
141pushd ../desktop-effects-%{dialogversion}
142%patch102 -p1 -b .wall-plugin
143popd
144
145%patch103 -p1 -b .composite-cube-logo
146%patch111 -p1 -b .gconf-core-loop
147
148%patch123 -p1 -b .initial-plugins
149
150%patch200 -p1 -b .fix-gtk-window-decorator-no-argb-crash
151%patch210 -p1 -b .damage-report-non-empty
152
153%patch300 -p1 -b .gconf-buildfix
154
155%build
156rm -rf $RPM_BUILD_ROOT
157
158CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
159export CPPFLAGS
160
161#needed to find kde4 libs
162#LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
163#export LDFLAGS
164
165libtoolize
166autoreconf
167%configure                                      \
168%{?with_kde: --enable-kde4 }                    \
169%{!?with_kde: --disable-kde4 }                  \
170        --disable-kde                           \
171        --enable-gconf                          \
172        --enable-dbus                           \
173        --enable-place                          \
174        --enable-librsvg                        \
175        --enable-gtk                            \
176        --enable-metacity                       \
177        --enable-gnome                          \
178        --with-default-plugins=%{plugins}       \
179        --enable-gnome-keybindings           
180
181
182make %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
183
184# desktop-effects
185cd ../desktop-effects-%{dialogversion}
186%configure
187
188
189%install
190rm -rf $RPM_BUILD_ROOT
191export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
192make DESTDIR=$RPM_BUILD_ROOT install || exit 1
193unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
194
195echo INSTALLING DESKTOP EFFECTS
196pushd ../desktop-effects-%{dialogversion}
197make DESTDIR=$RPM_BUILD_ROOT install || exit 1
198#desktop-file-install --vendor vine --delete-original      \
199#  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
200#  $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
201rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
202popd
203
204# install compiz-gtk/compiz-gtk.desktop
205install %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}
206
207desktop-file-install --vendor="" \
208  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
209  %{SOURCE4}
210   
211
212%if %{with kde}
213# kde-desktop-effects
214echo INSTALLING KDE DESKTOP EFFECTS
215pushd ../kde-desktop-effects-%{kde_dialogversion}
216cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
217mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
218cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
219
220iconlist="16 24 32 36 48 96"
221for i in $iconlist; do
222 mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
223 cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
224done
225
226desktop-file-install --vendor=""           \
227  --dir=%{buildroot}%{_datadir}/applications/kde       \
228  kde-desktop-effects.desktop
229popd
230%endif
231
232%if !%{with kde}
233rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
234%endif
235
236
237find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
238find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
239
240
241%find_lang compiz
242%find_lang desktop-effects
243
244cat compiz.lang > core-files.txt
245cat desktop-effects.lang > gnome-files.txt
246
247for f in %{core_plugins}; do
248  echo %{_libdir}/compiz/lib$f.so
249  echo %{_datadir}/compiz/$f.xml
250done >> core-files.txt
251
252for f in %{gnome_plugins}; do
253  echo %{_libdir}/compiz/lib$f.so
254  echo %{_datadir}/compiz/$f.xml
255done >> gnome-files.txt
256
257
258%post -p /sbin/ldconfig
259
260%postun -p /sbin/ldconfig
261
262%post gnome
263update-desktop-database -q %{_datadir}/applications
264
265export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`
266for f in %{core_plugins} %{gnome_plugins} core; do
267  echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
268  | xargs gconftool-2 --makefile-install-rule >& /dev/null || :
269
270gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
271
272touch --no-create %{_datadir}/icons/hicolor
273if [ -x /usr/bin/gtk-update-icon-cache ]; then
274        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
275fi
276
277
278%pre gnome
279if [ "$1" -gt 1 ]; then
280  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
281  for f in %{core_plugins} %{gnome_plugins} core; do
282    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
283    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
284
285  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
286fi
287
288
289%preun gnome
290if [ "$1" -eq 0 ]; then
291  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
292  for f in %{core_plugins} %{gnome_plugins} core; do
293    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
294    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
295
296  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
297fi
298
299
300%postun gnome
301touch --no-create %{_datadir}/icons/hicolor
302if [ -x /usr/bin/gtk-update-icon-cache ]; then
303        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
304fi
305
306%if %{with kde}
307%post kde
308update-desktop-database -q %{_datadir}/applications/kde
309touch --no-create %{_datadir}/icons/hicolor
310
311%postun kde
312touch --no-create %{_datadir}/icons/hicolor
313%endif
314
315%clean
316rm -rf $RPM_BUILD_ROOT
317
318
319%files -f core-files.txt
320%defattr(-, root, root)
321%doc AUTHORS ChangeLog COPYING* README TODO
322%{_bindir}/compiz
323%{_libdir}/libdecoration.so.*
324%dir %{_libdir}/compiz
325%dir %{_datadir}/compiz
326%{_datadir}/compiz/*.png
327%{_datadir}/compiz/core.xml
328
329
330%files gnome -f gnome-files.txt
331%defattr(-, root, root)
332%{_bindir}/gtk-window-decorator
333%{_bindir}/compiz-gtk
334%{_bindir}/desktop-effects
335%{_libdir}/window-manager-settings/libcompiz.so
336%{_datadir}/gnome/wm-properties/compiz-wm.desktop
337%{_datadir}/applications/compiz.desktop
338%{_datadir}/gnome-control-center/keybindings/50-compiz-desktop-key.xml
339%{_datadir}/gnome-control-center/keybindings/50-compiz-key.xml
340%{_datadir}/compiz/desktop-effects.glade
341%{_datadir}/applications/compiz-gtk.desktop
342#{_datadir}/applications/vine-desktop-effects.desktop
343%{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
344%{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
345%{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
346%{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
347%{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
348%{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
349%{_sysconfdir}/gconf/schemas/*.schemas
350
351%if %{with kde}
352%files kde
353%defattr(-, root, root)
354%{_bindir}/kde4-window-decorator
355%{_docdir}/compiz-kde-%{version}
356%{_bindir}/kde-desktop-effects.sh
357%{_datadir}/applications/kde/kde-desktop-effects.desktop
358%{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
359%{_datadir}/compiz/kconfig.xml
360%endif
361
362%files devel
363%defattr(-, root, root)
364%{_libdir}/pkgconfig/compiz.pc
365%{_libdir}/pkgconfig/libdecoration.pc
366%{_libdir}/pkgconfig/compiz-cube.pc
367%{_libdir}/pkgconfig/compiz-gconf.pc
368%{_libdir}/pkgconfig/compiz-scale.pc
369%{_datadir}/compiz/schemas.xslt
370%{_includedir}/compiz
371%{_libdir}/libdecoration.so
372
373
374%changelog
375* Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
376- rebuild with mesa-7.6
377- add Patch300 to build with gconf-2.28
378
379* Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
380- disable glib plugin in compiz-gtk
381- use direct rendering on virtualbox video adaptor.
382
383* Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
384- add Requires: glx-utils to compiz-gnome
385
386* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
387- new upstream release
388
389* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
390- re-enable metacity decoration on gtk-window-decorator
391  - BR: metacity-devel instead of metacity
392
393* Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
394- fix pre/post scripts for speeding up gconf schema installation
395
396* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
397- add ccp compiz option to compiz-gtk
398
399* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
400- remove desktop-effect.desktop
401  - we use gnome-appearance-properties integrated version.
402
403* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
404- add Patch121,122 from upstream fix.
405- add Patch123: make sure configuration plugins never get unloaded
406- add Patch124: memleak fix from upstream
407- add Patch125: make the terminal keybind work
408- add Patch120,126,127 for kde42
409- add Patch128: gwd fix from upstream
410
411* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
412- rebuild with gnome-desktop-2.26.0
413
414* Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
415- add compiz-gtk scripts and desktop file from fedora
416
417* Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
418- new upstream release
419
420* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
421- rebuild with gnome-desktop-2.24.0
422
423* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
424- new upstream release
425
426* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
427- new upstream release
428
429* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
430- initial build for Vine Linux
431
432* Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
433- Fix gconf plugin loop RH #438794, patch based on
434  older one from Guillaume Seguin
435- Add core to default plugin list
436
437* Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
438- Reword kde-desktop-effects messages to mention Compiz by name (#438883)
439
440* Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
441- Update to 0.7.2
442
443* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
444- Autorebuild for GCC 4.3
445
446* Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
447- Update to desktop-effects version 0.7.17 which include more
448  translations and move desktop-effects translations to compiz-gnome.
449- Fix spelling in beryl-core obsoletes.
450
451* Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
452- Update buildrequires (kwd uses the kde3 api)
453
454* Tue Nov  6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
455- Fix a typo in description of the main package.
456- All descriptions should end with a dot (unlike the summary line)
457
458* Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
459- Include kde-desktop-effects in kde subpackage
460
461* Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
462- Obsolete berly-core
463
464* Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
465- 0.6.2
466
467* Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
468- Disable scale corner initiate and install a GNOME key config entry.
469
470* Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
471- 0.6.0 final
472- always-restack-windows-on-map
473
474* Tue Oct  9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
475- Make compiz behave with gnome-terminal (#304051)
476
477* Fri Oct  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
478- Also install gwd.schemas (#319621)
479
480* Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
481- Update to more recent 0.6 branch snapshot (fixes #253575).
482
483* Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
484- compiz-gnome: install core schema so it actually works
485- remove unnecessary gconf stuff from %%install
486
487* Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
488- Make compiz-gnome Obsolete the older compiz package so yum/anaconda
489  will pull it in (thans to Adel Gadllah).
490
491* Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
492- Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
493  up dialog.
494- Fix broken gconf install and uninstall rules.
495- Pick up shadowman logo for RHEL builds (#232398).
496
497* Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
498- Add more-sm-junk.patch so we set SM restart style to
499  SmRestartIfRunning on exit (#247163, #245971).
500- Add Requires to compiz-devel (#253407).
501- Update to desktop-effects 0.7.6, which terminates decorator when
502  switching to metacity or on compiz failure (#215247, #215032).
503
504* Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
505- Split into gnome and kde subpackages
506- Minor cleanups
507
508* Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
509- Reorder plugin list to avoid 'place' getting removed on startup.
510- Add run-command-key.patch to put the run command key in the GNOME
511  keyboard shortcut dialog (#213576).
512- Drop a bunch of obsolete patches.
513- Bump mesa-libGL and X server requires to fix TFP bugs for
514  power-of-two textures (#251935).
515- Rebase fedora-logo and composite-cube-logo patch.
516
517* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
518- Build with desktop-effects so we don't pick up metacity work spaces.
519  Fixes #250568.
520
521* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
522- Build git snapshot from fedora branch at
523  git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
524  branch.
525- Fixes #237486.
526
527* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
528- Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
529  'glib' on the command line too.
530
531* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
532- Move xml meta data files to main package.
533
534* Thu Aug  9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
535- Update to 0.5.2.
536- Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
537  with LIBGL_ALWAYS_INDIRECT set.
538
539* Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
540- Update to 0.5.0
541
542* Tue Jun  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
543- Update to 0.4.0
544
545* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
546- Rebuild against new libwnck
547
548* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
549- Don't install INSTALL
550
551* Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
552- Update metacity build requires to metacity-devel.
553
554* Wed Apr  4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
555- Fix typo in ./configure option.
556
557* Wed Apr  4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
558- Add place and clone plugins to default plugin list.
559
560* Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
561- Update URL (#208214).
562- Require at least metacity 2.18 (#232831).
563- Add close-session.patch to deregister from SM when replaced (#229113).
564
565* Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
566- Explicitly disable KDE parts (#234128).
567
568* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
569- Fix some directory ownership issues (#233825)
570- Small spec cleanups
571
572* Tue Feb  6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
573- Require gnome-session > 2.16 so it starts gtk-window-decorator.
574- Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
575
576* Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
577- Update to 0.3.6, update patches.
578- Drop autotool build requires.
579- Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
580- Add libdecoration.so
581- Update to desktop-effects-0.7.0, which spawns the right decorator
582  and plays nicely with unknown plugins.
583
584* Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
585- Update the fedora logo patch (#217224)
586
587* Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
588- Update to 0.3.4
589
590* Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
591- Use cow by default, bug 208044
592
593* Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
594- Update to 0.3.2
595- Drop upstreamed patches
596- Work with new metacity theme api
597
598* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
599- Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
600
601* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
602- Add buildrequires on intltool
603
604* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
605- Build
606
607* Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
608- Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
609
610* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
611- Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
612
613* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
614- Change default plugin list to not include the plane plugin. (Bug 208448).
615- Change default keybinding for shrink to be Pause (Bug 206187).
616
617* Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
618- Add patch to show a menu when the window icon is clicked. (Bug 201629).
619
620* Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
621- Add restart.patch to make compiz ask the session manager to restart it
622  if it crashes (bug 200280).
623
624* Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
625- Change plane.patch to not do cyclical window movement in dimensions
626  where the desktop has size 1 (bug 207263).
627
628* Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
629- Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
630
631* Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
632- Change .plane patch to
633  (a) not set the background color to pink in the plane plugin.
634  (b) allow workspaces with horizontal sizes less then 4.
635
636* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
637- Change plane patch to correctly initialize the screen size to the
638  defaults (bug 206088).
639
640* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
641- Run update-desktop-database and gtk-update-icon-cache in post. Add icons
642  to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
643  directories before attempting to install to them).
644
645* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
646- Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
647  that the new version has icons.
648
649* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
650- Add patch to fix mispositioning of window decorator event windows (bug 201624)
651
652* Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
653- Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
654
655* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
656- Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
657
658* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
659- Add patch to fix thumbnail sorting (bug 201605)
660
661* Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
662- Add patch to fix double clicking (bug 201783).
663
664* Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
665- Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
666
667* Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
668- Fix plane.patch to draw correctly when no timeout is running. (206088).
669
670* Wed Sep  6 2006 Kristian H淡gsberg <krh@redhat.com>
671- Update fbconfig-depth-fix.patch to also skip fbconfigs without
672  corresponding visuals.
673
674* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
675- Make number of vertical size configurable
676
677* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
678- Fix vertical viewport support in the plane patch.
679
680* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
681- Upgrade to 0.6.61 of the dialog
682
683* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
684- Add libtool to BuildRequires
685
686* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
687- Add automake and autoconf to BuildRequires
688
689* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
690- Add a patch to put viewports on a plane.
691
692* Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
693- Drop gl-include-inferiors.patch now that compiz uses COW and the X
694  server evicts offscreen pixmaps automatically on
695  GLX_EXT_texture_from_pixmap usage.
696
697* Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
698- Add cow.patch to make compiz use the composite overlay window.
699
700* Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
701- Rebase to desktop-effects 0.6.41
702
703* Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
704- Rebase to desktop-effects 0.6.19 and drop
705  desktop-effects-0.6.1-delete-session.patch
706
707* Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
708- Add patch from upstream to also use sync protocol for override
709  redirect windows (sync-override-redirect-windows.patch).
710
711* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
712- Rebase to latest upstream changes which has the rest of the bindings
713  rewrite.  Add resize-move-keybindings.patch to make move and resize
714  bindings work like metacity.
715- Add back scale plugin.
716
717* Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
718- Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
719- unlink session file on changing wms (bug 201473)
720
721* Thu Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
722- Add Requires: gnome-session 2.15.4-3
723
724* Wed Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
725- New version of dialog box. Macro the version number.
726
727* Wed Aug  2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
728- Add 'desktop effects' dialog box.
729
730* Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
731- Add libwnck requires.
732
733* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
734- Bump and build for fc5 AIGLX repo.
735
736* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
737- Fix gconf hooks.
738
739* Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
740- Require system-logos instead.
741
742* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
743- Bump version to work around tagging weirdness.
744
745* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
746- Add devel package and require redhat-logos instead of fedora-logos (#199757).
747
748* Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
749- Add workaround for AIGLX throttling problem.
750
751* Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
752- Drop scale plugin from snapshot.
753
754* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
755- Don't build on s390
756
757* Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
758- Do some changes forced upon us by package review
759
760* Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
761- Use sane numbering scheme.
762
763* Fri Jul  7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
764- Drop the fullscreen hardcode patch and require X server that has
765  GLX_MESA_copy_sub_buffer.
766
767* Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
768- Unbreak --replace.
769
770* Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
771- Add Requires, fix start-compiz.sh.
772
773* Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
774- Spec file for compiz, borrowing bits and pieces from Alphonse Van
775  Assches spec file (#192432).
Note: See TracBrowser for help on using the repository browser.