source: projects/specs/trunk/c/compiz/compiz-vl.spec @ 805

Revision 805, 26.9 KB checked in by Takemikaduchi, 14 years ago (diff)

change spec file of gnome-2.30

Line 
1# build with kde4
2%bcond_with kde
3
4%define         dialogversion   0.7.18
5%define         kde_dialogversion 0.0.5
6
7%define         core_plugins    blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
8
9%define         gnome_plugins   annotate gconf glib svg gnomecompat
10
11# List of plugins passed to ./configure.  The order is important
12
13%define         plugins         core,glib,gconf,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
14
15Summary:        OpenGL window and compositing manager
16Summary(ja):    OpenGL ウィンドウ・コンポジットマネージャ
17Name:           compiz
18URL:            http://www.go-compiz.org
19License:        X11/MIT/GPL
20Group:          User Interface/Desktops
21Version:        0.8.6
22Release:        1%{?_dist_release}
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26# libdrm is not available on these arches
27ExcludeArch:    s390 s390x ppc64
28
29Requires:       xorg-x11-server-Xorg
30Requires:       mesa-libGL
31
32Requires(post): desktop-file-utils
33
34BuildRequires:  libX11-devel, libdrm-devel, libwnck-devel
35BuildRequires:  libXfixes-devel, libXrandr-devel, libXrender-devel
36BuildRequires:  libXcomposite-devel, libXdamage-devel, libXext-devel
37BuildRequires:  libXt-devel, libXmu-devel, libICE-devel, libSM-devel
38BuildRequires:  control-center-devel, GConf2-devel
39BuildRequires:  gnome-desktop-devel >= 2.30.0
40BuildRequires:  metacity-devel
41BuildRequires:  desktop-file-utils
42BuildRequires:  intltool >= 0.35
43BuildRequires:  gettext
44BuildRequires:  dbus-devel
45BuildRequires:  librsvg2-devel
46BuildRequires:  mesa-libGLU-devel
47BuildRequires:  fuse-devel
48%if %{with kde}
49BuildRequires:  kdebase-workspace-devel
50BUildRequires:  dbus-qt-devel
51%endif
52
53Source0:        http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
54Source1:        desktop-effects-%{dialogversion}.tar.bz2
55Source2:        kde-desktop-effects-%{kde_dialogversion}.tar.bz2
56
57Source3:        compiz-gtk
58Source4:        compiz-gtk.desktop
59
60# Make sure that former beryl users still have bling
61Obsoletes: beryl-core
62
63# Patches from fedora
64Patch102: desktop-effects-0.7.17-wall-plugin.patch
65Patch103: composite-cube-logo.patch
66Patch111: gconf-core-plugin-loopfix.patch
67
68# Make sure configuration plugins never get unloaded
69Patch123: compiz-0.7.8-pin-initial-plugins.patch
70
71# Patches from ubuntu
72Patch200: 014-fix-gtk-window-decorator-no-argb-crash.patch
73Patch210: 049-damage-report-non-empty.patch
74
75# build fix
76Patch300: compiz-0.8.2-gconf-buildfix.patch
77
78%description
79Compiz is one of the first OpenGL-accelerated compositing window
80managers for the X Window System. The integration allows it to perform
81compositing effects in window management, such as a minimization
82effect and a cube workspace.  Compiz is an OpenGL compositing manager
83that use Compiz use EXT_texture_from_pixmap OpenGL extension for
84binding redirected top-level windows to texture objects.
85
86%package devel
87Summary: Development packages for compiz
88Summary(ja): compiz の開発パッケージ
89Group: Development/Libraries
90Requires: compiz = %{version}-%{release}
91Requires: pkgconfig
92Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
93Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
94Requires: libxslt-devel startup-notification-devel
95
96%description devel
97The compiz-devel package includes the header files,
98and developer docs for the compiz package.
99
100Install compiz-devel if you want to develop plugins for the compiz
101windows and compositing manager.
102
103%package gnome
104Summary: Compiz gnome integration bits
105Summary(ja): Compiz gnome integration bits
106Group: User Interface/Desktops
107Requires: gnome-session
108Requires: metacity
109Requires: libwnck
110Requires: glx-utils
111Requires: %{name} = %{version}
112Requires(pre): GConf2
113Requires(post): GConf2
114Requires(preun): GConf2
115Obsoletes: compiz < 0.5.2-8
116Obsoletes: beryl-gnome
117
118%description gnome
119The compiz-gnome package contains gtk-window-decorator,
120and other gnome integration related stuff.
121
122%if %{with kde}
123%package kde
124Summary: Compiz kde integration bits
125Summary(ja): Compiz kde integration bits
126Group: User Interface/Desktops
127Requires: %{name} = %{version}
128Requires: compiz-manager
129Obsoletes: beryl-kde
130
131%description kde
132The compiz-kde package contains kde-window-decorator,
133and other kde integration related stuff.
134%endif
135
136%prep
137%setup -q -T -b1 -n desktop-effects-%{dialogversion}
138#%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
139%setup -q
140
141pushd ../desktop-effects-%{dialogversion}
142%patch102 -p1 -b .wall-plugin
143popd
144
145%patch103 -p1 -b .composite-cube-logo
146%patch111 -p1 -b .gconf-core-loop
147
148## %patch123 -p1 -b .initial-plugins
149
150%patch200 -p1 -b .fix-gtk-window-decorator-no-argb-crash
151%patch210 -p1 -b .damage-report-non-empty
152
153## %patch300 -p1 -b .gconf-buildfix
154
155%build
156rm -rf $RPM_BUILD_ROOT
157
158CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
159export CPPFLAGS
160
161#needed to find kde4 libs
162#LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
163#export LDFLAGS
164
165libtoolize
166autoreconf
167%configure                                      \
168%{?with_kde: --enable-kde4 }                    \
169%{!?with_kde: --disable-kde4 }                  \
170        --disable-kde                           \
171        --enable-gconf                          \
172        --enable-dbus                           \
173        --enable-place                          \
174        --enable-librsvg                        \
175        --enable-gtk                            \
176        --enable-metacity                       \
177        --enable-gnome                          \
178        --with-default-plugins=%{plugins}       \
179        --enable-gnome-keybindings           
180
181
182make %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
183
184# desktop-effects
185cd ../desktop-effects-%{dialogversion}
186%configure
187
188
189%install
190rm -rf $RPM_BUILD_ROOT
191export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
192make DESTDIR=$RPM_BUILD_ROOT install || exit 1
193unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
194
195echo INSTALLING DESKTOP EFFECTS
196pushd ../desktop-effects-%{dialogversion}
197make DESTDIR=$RPM_BUILD_ROOT install || exit 1
198#desktop-file-install --vendor vine --delete-original      \
199#  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
200#  $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
201rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
202popd
203
204# install compiz-gtk/compiz-gtk.desktop
205install %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}
206
207desktop-file-install --vendor="" \
208  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
209  %{SOURCE4}
210   
211
212%if %{with kde}
213# kde-desktop-effects
214echo INSTALLING KDE DESKTOP EFFECTS
215pushd ../kde-desktop-effects-%{kde_dialogversion}
216cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
217mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
218cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
219
220iconlist="16 24 32 36 48 96"
221for i in $iconlist; do
222 mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
223 cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
224done
225
226desktop-file-install --vendor=""           \
227  --dir=%{buildroot}%{_datadir}/applications/kde       \
228  kde-desktop-effects.desktop
229popd
230%endif
231
232%if !%{with kde}
233rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
234%endif
235
236
237find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
238find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
239
240
241%find_lang compiz
242%find_lang desktop-effects
243
244cat compiz.lang > core-files.txt
245cat desktop-effects.lang > gnome-files.txt
246
247for f in %{core_plugins}; do
248  echo %{_libdir}/compiz/lib$f.so
249  echo %{_datadir}/compiz/$f.xml
250done >> core-files.txt
251
252for f in %{gnome_plugins}; do
253  echo %{_libdir}/compiz/lib$f.so
254  echo %{_datadir}/compiz/$f.xml
255done >> gnome-files.txt
256
257
258%post -p /sbin/ldconfig
259
260%postun -p /sbin/ldconfig
261
262%post gnome
263update-desktop-database -q %{_datadir}/applications
264
265export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`
266for f in %{core_plugins} %{gnome_plugins} core; do
267  echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
268  | xargs gconftool-2 --makefile-install-rule >& /dev/null || :
269
270gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
271
272touch --no-create %{_datadir}/icons/hicolor
273if [ -x /usr/bin/gtk-update-icon-cache ]; then
274        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
275fi
276
277
278%pre gnome
279if [ "$1" -gt 1 ]; then
280  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
281  for f in %{core_plugins} %{gnome_plugins} core; do
282    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
283    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
284
285  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
286fi
287
288
289%preun gnome
290if [ "$1" -eq 0 ]; then
291  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
292  for f in %{core_plugins} %{gnome_plugins} core; do
293    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
294    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
295
296  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
297fi
298
299
300%postun gnome
301touch --no-create %{_datadir}/icons/hicolor
302if [ -x /usr/bin/gtk-update-icon-cache ]; then
303        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
304fi
305
306%if %{with kde}
307%post kde
308update-desktop-database -q %{_datadir}/applications/kde
309touch --no-create %{_datadir}/icons/hicolor
310
311%postun kde
312touch --no-create %{_datadir}/icons/hicolor
313%endif
314
315%clean
316rm -rf $RPM_BUILD_ROOT
317
318
319%files -f core-files.txt
320%defattr(-, root, root)
321%doc AUTHORS ChangeLog COPYING* README TODO
322%{_bindir}/compiz
323%{_libdir}/libdecoration.so.*
324%dir %{_libdir}/compiz
325%dir %{_datadir}/compiz
326%{_datadir}/compiz/*.png
327%{_datadir}/compiz/core.xml
328
329
330%files gnome -f gnome-files.txt
331%defattr(-, root, root)
332%{_bindir}/gtk-window-decorator
333%{_bindir}/compiz-gtk
334%{_bindir}/desktop-effects
335%{_libdir}/window-manager-settings/libcompiz.so
336%{_datadir}/gnome/wm-properties/compiz-wm.desktop
337%{_datadir}/applications/compiz.desktop
338%{_datadir}/gnome-control-center/keybindings/50-compiz-desktop-key.xml
339%{_datadir}/gnome-control-center/keybindings/50-compiz-key.xml
340%{_datadir}/compiz/desktop-effects.glade
341%{_datadir}/applications/compiz-gtk.desktop
342#{_datadir}/applications/vine-desktop-effects.desktop
343%{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
344%{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
345%{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
346%{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
347%{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
348%{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
349%{_sysconfdir}/gconf/schemas/*.schemas
350
351%if %{with kde}
352%files kde
353%defattr(-, root, root)
354%{_bindir}/kde4-window-decorator
355%{_docdir}/compiz-kde-%{version}
356%{_bindir}/kde-desktop-effects.sh
357%{_datadir}/applications/kde/kde-desktop-effects.desktop
358%{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
359%{_datadir}/compiz/kconfig.xml
360%endif
361
362%files devel
363%defattr(-, root, root)
364%{_libdir}/pkgconfig/compiz.pc
365%{_libdir}/pkgconfig/libdecoration.pc
366%{_libdir}/pkgconfig/compiz-cube.pc
367%{_libdir}/pkgconfig/compiz-gconf.pc
368%{_libdir}/pkgconfig/compiz-scale.pc
369%{_datadir}/compiz/schemas.xslt
370%{_includedir}/compiz
371%{_libdir}/libdecoration.so
372
373
374%changelog
375* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
376- new upstream release (build on GNOME-2.30)
377- drop Patch123, Patch300
378
379* Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
380- rebuild with mesa-7.6
381- add Patch300 to build with gconf-2.28
382
383* Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
384- disable glib plugin in compiz-gtk
385- use direct rendering on virtualbox video adaptor.
386
387* Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
388- add Requires: glx-utils to compiz-gnome
389
390* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
391- new upstream release
392
393* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
394- re-enable metacity decoration on gtk-window-decorator
395  - BR: metacity-devel instead of metacity
396
397* Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
398- fix pre/post scripts for speeding up gconf schema installation
399
400* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
401- add ccp compiz option to compiz-gtk
402
403* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
404- remove desktop-effect.desktop
405  - we use gnome-appearance-properties integrated version.
406
407* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
408- add Patch121,122 from upstream fix.
409- add Patch123: make sure configuration plugins never get unloaded
410- add Patch124: memleak fix from upstream
411- add Patch125: make the terminal keybind work
412- add Patch120,126,127 for kde42
413- add Patch128: gwd fix from upstream
414
415* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
416- rebuild with gnome-desktop-2.26.0
417
418* Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
419- add compiz-gtk scripts and desktop file from fedora
420
421* Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
422- new upstream release
423
424* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
425- rebuild with gnome-desktop-2.24.0
426
427* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
428- new upstream release
429
430* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
431- new upstream release
432
433* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
434- initial build for Vine Linux
435
436* Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
437- Fix gconf plugin loop RH #438794, patch based on
438  older one from Guillaume Seguin
439- Add core to default plugin list
440
441* Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
442- Reword kde-desktop-effects messages to mention Compiz by name (#438883)
443
444* Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
445- Update to 0.7.2
446
447* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
448- Autorebuild for GCC 4.3
449
450* Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
451- Update to desktop-effects version 0.7.17 which include more
452  translations and move desktop-effects translations to compiz-gnome.
453- Fix spelling in beryl-core obsoletes.
454
455* Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
456- Update buildrequires (kwd uses the kde3 api)
457
458* Tue Nov  6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
459- Fix a typo in description of the main package.
460- All descriptions should end with a dot (unlike the summary line)
461
462* Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
463- Include kde-desktop-effects in kde subpackage
464
465* Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
466- Obsolete berly-core
467
468* Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
469- 0.6.2
470
471* Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
472- Disable scale corner initiate and install a GNOME key config entry.
473
474* Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
475- 0.6.0 final
476- always-restack-windows-on-map
477
478* Tue Oct  9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
479- Make compiz behave with gnome-terminal (#304051)
480
481* Fri Oct  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
482- Also install gwd.schemas (#319621)
483
484* Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
485- Update to more recent 0.6 branch snapshot (fixes #253575).
486
487* Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
488- compiz-gnome: install core schema so it actually works
489- remove unnecessary gconf stuff from %%install
490
491* Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
492- Make compiz-gnome Obsolete the older compiz package so yum/anaconda
493  will pull it in (thans to Adel Gadllah).
494
495* Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
496- Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
497  up dialog.
498- Fix broken gconf install and uninstall rules.
499- Pick up shadowman logo for RHEL builds (#232398).
500
501* Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
502- Add more-sm-junk.patch so we set SM restart style to
503  SmRestartIfRunning on exit (#247163, #245971).
504- Add Requires to compiz-devel (#253407).
505- Update to desktop-effects 0.7.6, which terminates decorator when
506  switching to metacity or on compiz failure (#215247, #215032).
507
508* Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
509- Split into gnome and kde subpackages
510- Minor cleanups
511
512* Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
513- Reorder plugin list to avoid 'place' getting removed on startup.
514- Add run-command-key.patch to put the run command key in the GNOME
515  keyboard shortcut dialog (#213576).
516- Drop a bunch of obsolete patches.
517- Bump mesa-libGL and X server requires to fix TFP bugs for
518  power-of-two textures (#251935).
519- Rebase fedora-logo and composite-cube-logo patch.
520
521* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
522- Build with desktop-effects so we don't pick up metacity work spaces.
523  Fixes #250568.
524
525* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
526- Build git snapshot from fedora branch at
527  git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
528  branch.
529- Fixes #237486.
530
531* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
532- Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
533  'glib' on the command line too.
534
535* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
536- Move xml meta data files to main package.
537
538* Thu Aug  9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
539- Update to 0.5.2.
540- Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
541  with LIBGL_ALWAYS_INDIRECT set.
542
543* Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
544- Update to 0.5.0
545
546* Tue Jun  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
547- Update to 0.4.0
548
549* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
550- Rebuild against new libwnck
551
552* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
553- Don't install INSTALL
554
555* Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
556- Update metacity build requires to metacity-devel.
557
558* Wed Apr  4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
559- Fix typo in ./configure option.
560
561* Wed Apr  4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
562- Add place and clone plugins to default plugin list.
563
564* Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
565- Update URL (#208214).
566- Require at least metacity 2.18 (#232831).
567- Add close-session.patch to deregister from SM when replaced (#229113).
568
569* Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
570- Explicitly disable KDE parts (#234128).
571
572* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
573- Fix some directory ownership issues (#233825)
574- Small spec cleanups
575
576* Tue Feb  6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
577- Require gnome-session > 2.16 so it starts gtk-window-decorator.
578- Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
579
580* Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
581- Update to 0.3.6, update patches.
582- Drop autotool build requires.
583- Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
584- Add libdecoration.so
585- Update to desktop-effects-0.7.0, which spawns the right decorator
586  and plays nicely with unknown plugins.
587
588* Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
589- Update the fedora logo patch (#217224)
590
591* Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
592- Update to 0.3.4
593
594* Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
595- Use cow by default, bug 208044
596
597* Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
598- Update to 0.3.2
599- Drop upstreamed patches
600- Work with new metacity theme api
601
602* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
603- Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
604
605* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
606- Add buildrequires on intltool
607
608* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
609- Build
610
611* Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
612- Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
613
614* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
615- Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
616
617* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
618- Change default plugin list to not include the plane plugin. (Bug 208448).
619- Change default keybinding for shrink to be Pause (Bug 206187).
620
621* Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
622- Add patch to show a menu when the window icon is clicked. (Bug 201629).
623
624* Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
625- Add restart.patch to make compiz ask the session manager to restart it
626  if it crashes (bug 200280).
627
628* Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
629- Change plane.patch to not do cyclical window movement in dimensions
630  where the desktop has size 1 (bug 207263).
631
632* Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
633- Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
634
635* Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
636- Change .plane patch to
637  (a) not set the background color to pink in the plane plugin.
638  (b) allow workspaces with horizontal sizes less then 4.
639
640* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
641- Change plane patch to correctly initialize the screen size to the
642  defaults (bug 206088).
643
644* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
645- Run update-desktop-database and gtk-update-icon-cache in post. Add icons
646  to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
647  directories before attempting to install to them).
648
649* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
650- Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
651  that the new version has icons.
652
653* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
654- Add patch to fix mispositioning of window decorator event windows (bug 201624)
655
656* Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
657- Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
658
659* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
660- Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
661
662* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
663- Add patch to fix thumbnail sorting (bug 201605)
664
665* Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
666- Add patch to fix double clicking (bug 201783).
667
668* Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
669- Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
670
671* Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
672- Fix plane.patch to draw correctly when no timeout is running. (206088).
673
674* Wed Sep  6 2006 Kristian H淡gsberg <krh@redhat.com>
675- Update fbconfig-depth-fix.patch to also skip fbconfigs without
676  corresponding visuals.
677
678* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
679- Make number of vertical size configurable
680
681* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
682- Fix vertical viewport support in the plane patch.
683
684* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
685- Upgrade to 0.6.61 of the dialog
686
687* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
688- Add libtool to BuildRequires
689
690* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
691- Add automake and autoconf to BuildRequires
692
693* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
694- Add a patch to put viewports on a plane.
695
696* Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
697- Drop gl-include-inferiors.patch now that compiz uses COW and the X
698  server evicts offscreen pixmaps automatically on
699  GLX_EXT_texture_from_pixmap usage.
700
701* Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
702- Add cow.patch to make compiz use the composite overlay window.
703
704* Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
705- Rebase to desktop-effects 0.6.41
706
707* Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
708- Rebase to desktop-effects 0.6.19 and drop
709  desktop-effects-0.6.1-delete-session.patch
710
711* Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
712- Add patch from upstream to also use sync protocol for override
713  redirect windows (sync-override-redirect-windows.patch).
714
715* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
716- Rebase to latest upstream changes which has the rest of the bindings
717  rewrite.  Add resize-move-keybindings.patch to make move and resize
718  bindings work like metacity.
719- Add back scale plugin.
720
721* Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
722- Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
723- unlink session file on changing wms (bug 201473)
724
725* Thu Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
726- Add Requires: gnome-session 2.15.4-3
727
728* Wed Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
729- New version of dialog box. Macro the version number.
730
731* Wed Aug  2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
732- Add 'desktop effects' dialog box.
733
734* Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
735- Add libwnck requires.
736
737* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
738- Bump and build for fc5 AIGLX repo.
739
740* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
741- Fix gconf hooks.
742
743* Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
744- Require system-logos instead.
745
746* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
747- Bump version to work around tagging weirdness.
748
749* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
750- Add devel package and require redhat-logos instead of fedora-logos (#199757).
751
752* Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
753- Add workaround for AIGLX throttling problem.
754
755* Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
756- Drop scale plugin from snapshot.
757
758* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
759- Don't build on s390
760
761* Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
762- Do some changes forced upon us by package review
763
764* Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
765- Use sane numbering scheme.
766
767* Fri Jul  7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
768- Drop the fullscreen hardcode patch and require X server that has
769  GLX_MESA_copy_sub_buffer.
770
771* Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
772- Unbreak --replace.
773
774* Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
775- Add Requires, fix start-compiz.sh.
776
777* Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
778- Spec file for compiz, borrowing bits and pieces from Alphonse Van
779  Assches spec file (#192432).
Note: See TracBrowser for help on using the repository browser.