source: projects/specs/trunk/c/cogl/cogl-vl.spec @ 9073

Revision 9073, 4.9 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME 3.14.1

Line 
1%define         cogl_version 1.18.2
2%define         cogl_release 1%{?_dist_release}
3
4Name:           cogl
5Version:        %{cogl_version}
6Release:        %{cogl_release}
7Summary:        A small open source library for using 3D graphics hardware to draw pretty pictures
8
9Group:          System Environment/Libraries
10License:        LGPLv2+
11URL:            http://www.clutter-project.org/
12Source0:        http://www.clutter-project.org/sources/%{name}/1.18/%{name}-%{version}.tar.xz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  gobject-introspection-devel
17BuildRequires:  libXcomposite-devel
18BuildRequires:  libXrandr-devel
19BuildRequires:  mesa-libGL-devel
20BuildRequires:  mesa-libEGL-devel
21BuildRequires:  pango-devel
22BuildRequires:  gdk-pixbuf2-devel
23BuildRequires:  gstreamer1-plugins-base-devel
24BuildRequires:  gtk-doc
25
26Vendor:         Project Vine
27Distribution:   Vine Linux
28Packager:       Takemikaduchi
29
30%description
31Cogl is a small open source library for using 3D graphics hardware to draw
32pretty pictures. The API departs from the flat state machine style of
33OpenGL and is designed to make it easy to write orthogonal components that
34can render without stepping on each others toes.
35
36
37%package                devel
38Summary:        Development tools for cogl
39Summary(ja):    cogl の開発環境
40Group:          Development/Libraries
41Requires:       %{name} = %{version}-%{release}
42Requires:       pkgconfig
43
44%description    devel
45Header files and libraries for building a extension library for the
46cogl.
47
48
49%package                gstreamer
50Summary:        Cogl GStreamer library
51Summary(ja):    cogl gstreamer ライブラリ
52Group:          System Environment/Libraries
53Requires:       %{name} = %{version}-%{release}
54
55%description    gstreamer
56%{summary}
57
58
59%package        docs
60Summary:        Documentation for cogl
61Summary(ja):    cogl 用のドキュメント
62Group:          Documentation
63Provides:       %{name}-doc = %{version}-%{release}
64BuildArch:              noarch
65Requires:       %{name} = %{version}-%{release}
66
67
68%description    docs
69This package contains documentation for cogl.
70
71
72%prep
73%setup -q
74
75for i in `grep -rl "<note>" ./`;
76do
77  sed -i 's/<note>//' $i
78done
79
80for i in `grep -rl "<\/note>" ./`;
81do
82  sed -i 's/<\/note>//' $i
83done
84
85%build
86
87%configure \
88        --enable-gtk-doc \
89        --disable-static \
90        --enable-cairo=yes \
91        --enable-gdk-pixbuf=yes \
92        --enable-cogl-gst=yes \
93        --enable-cogl-pango=yes \
94        --enable-glx=yes \
95        --enable-introspection=yes \
96        --enable-xlib-egl-platform=yes
97
98make V=1
99
100%install
101rm -rf $RPM_BUILD_ROOT
102#make DESTDIR=$RPM_BUILD_ROOT install
103make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
104
105find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
106
107%find_lang %{name}
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%post -p /sbin/ldconfig
113%postun -p /sbin/ldconfig
114
115%files -f %{name}.lang
116%defattr(-,root,root,-)
117%doc ChangeLog AUTHORS COPYING NEWS README
118%{_libdir}/*.so.*
119%{_libdir}/girepository-1.0/*.typelib
120%{_datadir}/%{name}/examples-data/crate.jpg
121
122%files devel
123%defattr(-,root,root,-)
124%{_includedir}/cogl
125%{_libdir}/*.so
126%{_libdir}/pkgconfig/*.pc
127%{_datadir}/gir-1.0/*.gir
128
129%files gstreamer
130%defattr(-,root,root,-)
131%{_libdir}/gstreamer-1.0/libgstcogl.so
132
133%files docs
134%defattr(-,root,root,-)
135%{_datadir}/gtk-doc/html/cogl
136%{_datadir}/gtk-doc/html/cogl-gst
137%{_datadir}/gtk-doc/html/cogl-2.0-experimental
138
139%changelog
140* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
141- new upstream release
142- add BuildRequires: mesa-libEGL-devel
143
144* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
145- new upstream release
146
147* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
148- new upstream release
149
150* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-2
151- rebuild with VineSeed environment
152
153* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
154- new upstream release
155- add BuildRequire: gstreamer1-plugins-base-devel
156
157* Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
158- new upstream release
159- add BuildRequires: libXrandr-devel
160
161* Sun Jan 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
162- new upstream release
163
164* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
165- new upstream release
166- remove Patch0 (04_fix_crash_on_free.patch)
167
168* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
169- new upstream release
170
171* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-2
172- add Patch0 (04_fix_crash_on_free.patch)
173
174* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
175- new upstream release
176
177* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
178- new upstream release
179
180* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
181- new upstream release
182
183* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.8-1
184- new upstream release
185- remove Patch0
186
187* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
188- new upstream release
189- add Patch0 (cogl-1.7.6-configure.patch)
190
191* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.4-1
192- initial build for Vine Linux
193
Note: See TracBrowser for help on using the repository browser.