source: projects/specs/trunk/c/cogl/cogl-vl.spec @ 8353

Revision 8353, 4.7 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.0

Line 
1%define         cogl_version 1.18.0
2%define         cogl_release 1%{?_dist_release}
3
4Name:           cogl
5Version:        %{cogl_version}
6Release:        %{cogl_release}
7Summary:        A small open source library for using 3D graphics hardware to draw pretty pictures
8
9Group:          System Environment/Libraries
10License:        LGPLv2+
11URL:            http://www.clutter-project.org/
12Source0:        http://www.clutter-project.org/sources/%{name}/1.18/%{name}-%{version}.tar.xz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  gobject-introspection-devel
17BuildRequires:  libXcomposite-devel
18BuildRequires:  libXrandr-devel
19BuildRequires:  mesa-libGL-devel
20BuildRequires:  pango-devel
21BuildRequires:  gdk-pixbuf2-devel
22BuildRequires:  gstreamer1-plugins-base-devel
23BuildRequires:  gtk-doc
24
25Vendor:         Project Vine
26Distribution:   Vine Linux
27Packager:       Takemikaduchi
28
29%description
30Cogl is a small open source library for using 3D graphics hardware to draw
31pretty pictures. The API departs from the flat state machine style of
32OpenGL and is designed to make it easy to write orthogonal components that
33can render without stepping on each others toes.
34
35
36%package                devel
37Summary:        Development tools for cogl
38Summary(ja):    cogl の開発環境
39Group:          Development/Libraries
40Requires:       %{name} = %{version}-%{release}
41Requires:       pkgconfig
42
43%description    devel
44Header files and libraries for building a extension library for the
45cogl.
46
47
48%package                gstreamer
49Summary:        Cogl GStreamer library
50Summary(ja):    cogl gstreamer ライブラリ
51Group:          System Environment/Libraries
52Requires:       %{name} = %{version}-%{release}
53
54%description    gstreamer
55%{summary}
56
57
58%package        docs
59Summary:        Documentation for cogl
60Summary(ja):    cogl 用のドキュメント
61Group:          Documentation
62Provides:       %{name}-doc = %{version}-%{release}
63BuildArch:              noarch
64Requires:       %{name} = %{version}-%{release}
65
66
67%description    docs
68This package contains documentation for cogl.
69
70
71%prep
72%setup -q
73
74for i in `grep -rl "<note>" ./`;
75do
76  sed -i 's/<note>//' $i
77done
78
79for i in `grep -rl "<\/note>" ./`;
80do
81  sed -i 's/<\/note>//' $i
82done
83
84%build
85
86%configure \
87        --enable-gtk-doc \
88        --disable-static \
89        --enable-cairo=yes \
90        --enable-gdk-pixbuf=yes \
91        --enable-cogl-gst=yes \
92        --enable-cogl-pango=yes \
93        --enable-glx=yes \
94        --enable-introspection=yes
95
96make V=1
97
98%install
99rm -rf $RPM_BUILD_ROOT
100#make DESTDIR=$RPM_BUILD_ROOT install
101make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
102
103find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
104
105%find_lang %{name}
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%post -p /sbin/ldconfig
111%postun -p /sbin/ldconfig
112
113%files -f %{name}.lang
114%defattr(-,root,root,-)
115%doc ChangeLog AUTHORS COPYING NEWS README
116%{_libdir}/*.so.*
117%{_libdir}/girepository-1.0/*.typelib
118%{_datadir}/%{name}/examples-data/crate.jpg
119
120%files devel
121%defattr(-,root,root,-)
122%{_includedir}/cogl
123%{_libdir}/*.so
124%{_libdir}/pkgconfig/*.pc
125%{_datadir}/gir-1.0/*.gir
126
127%files gstreamer
128%defattr(-,root,root,-)
129%{_libdir}/gstreamer-1.0/libgstcogl.so
130
131%files docs
132%defattr(-,root,root,-)
133%{_datadir}/gtk-doc/html/cogl
134%{_datadir}/gtk-doc/html/cogl-gst
135%{_datadir}/gtk-doc/html/cogl-2.0-experimental
136
137%changelog
138* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
139- new upstream release
140
141* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
142- new upstream release
143
144* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-2
145- rebuild with VineSeed environment
146
147* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
148- new upstream release
149- add BuildRequire: gstreamer1-plugins-base-devel
150
151* Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
152- new upstream release
153- add BuildRequires: libXrandr-devel
154
155* Sun Jan 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
156- new upstream release
157
158* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
159- new upstream release
160- remove Patch0 (04_fix_crash_on_free.patch)
161
162* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
163- new upstream release
164
165* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-2
166- add Patch0 (04_fix_crash_on_free.patch)
167
168* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
169- new upstream release
170
171* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
172- new upstream release
173
174* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
175- new upstream release
176
177* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.8-1
178- new upstream release
179- remove Patch0
180
181* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
182- new upstream release
183- add Patch0 (cogl-1.7.6-configure.patch)
184
185* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.4-1
186- initial build for Vine Linux
187
Note: See TracBrowser for help on using the repository browser.