source: projects/specs/trunk/c/cmake/cmake-vl.spec @ 7639

Revision 7639, 6.1 KB checked in by kudoh, 11 years ago (diff)

--force-log

Line 
1# Set to bcond_without or use --with bootstrap if bootstrapping a new release
2# or architecture
3%bcond_with bootstrap
4# Set to bcond_with or use --without gui to disable qt4 gui build
5%bcond_without gui
6
7Name: cmake
8Summary: Cross-platform make system
9Summary(ja): クロスプラットフォームな Make システム
10Version: 2.8.10.2
11Release: 1%{?_dist_release}
12
13Group: Development/Tools
14License: BSD
15URL: http://www.cmake.org/
16
17Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
18Source1: macros.cmake
19
20# Patch to find DCMTK in Fedora (bug #720140)
21Patch0:         cmake-dcmtk.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: curl-devel
25BuildRequires: expat-devel
26BuildRequires: gcc-gfortran
27BuildRequires: libarchive-devel
28BuildRequires: libidn-devel
29BuildRequires: ncurses-devel
30BuildRequires: openssl-devel
31BuildRequires: zlib-devel
32%if %{with gui}
33BuildRequires: qt4-devel, desktop-file-utils
34%define qt_gui --qt-gui
35%else
36%define qt_gui --no-qt-gui
37%endif
38
39Vendor: Project Vine
40Distribution: Vine Linux
41
42%description
43CMake is used to control the software compilation process using simple
44platform and compiler independent configuration files. CMake generates
45native makefiles and workspaces that can be used in the compiler
46environment of your choice. CMake is quite sophisticated: it is possible
47to support complex environments requiring system configuration, pre-processor
48generation, code generation, and template instantiation.
49
50%package        gui
51Summary:        Qt GUI for %{name}
52Group:          Development/Tools
53Requires:       %{name} = %{version}-%{release}
54Requires(post): desktop-file-utils, shared-mime-info
55Requires(postun): desktop-file-utils, shared-mime-info
56
57%description    gui
58The %{name}-gui package contains the Qt based GUI for CMake.
59
60
61%prep
62%setup -q
63%patch0 -p1 -b .dcmtk
64
65# Fixup permissions
66#find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
67
68#fix desktop file warning
69sed -i 's:\(Icon=\)\(CMakeSetup32.png\):\1/usr/share/pixmaps/\2:' Source/QtDialog/CMake.desktop
70
71%build
72./bootstrap \
73    --prefix=%{_prefix} \
74    --datadir=/share/%{name} \
75    --mandir=/share/man \
76    --%{?with_bootstrap:no-}system-libs \
77    %{?qt_gui}
78
79sed -i 's/-lcurses/-lcurses -ltinfo/' Source/CMakeFiles/ccmake.dir/link.txt
80%if %{?_dist_release} == "vl5"
81sed -i 's/HAVE_SYS_WAIT_H:INTERNAL=/HAVE_SYS_WAIT_H:INTERNAL=1/' CMakeCache.txt
82%endif
83
84make VERBOSE=1 %{?_smp_mflags}
85
86%install
87rm -rf $RPM_BUILD_ROOT
88make install DESTDIR=$RPM_BUILD_ROOT
89
90find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
91rm -rf $RPM_BUILD_ROOT/usr/doc
92
93# RPM macros
94install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
95sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
96touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
97
98%if %{with gui}
99# Desktop file
100desktop-file-install --delete-original \
101  --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
102  $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
103%endif
104
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%if %{with gui}
110%post gui
111update-desktop-database &> /dev/null || :
112update-mime-database %{_datadir}/mime &> /dev/null || :
113
114%postun gui
115update-desktop-database &> /dev/null || :
116update-mime-database %{_datadir}/mime &> /dev/null || :
117%endif
118
119
120%files
121%defattr(-,root,root)
122%doc CMakeLogo.gif ChangeLog.* Copyright.txt
123%doc Docs/*
124%doc Example/
125%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
126%{_bindir}/ccmake
127%{_bindir}/cmake
128%{_bindir}/cpack
129%{_bindir}/ctest
130%{_datadir}/%{name}/
131%{_datadir}/aclocal/cmake.m4
132%{_mandir}/man1/*
133
134%if %{with gui}
135%files gui
136%defattr(-,root,root,-)
137%{_bindir}/cmake-gui
138%{_datadir}/applications/CMake.desktop
139%{_datadir}/mime/packages/cmakecache.xml
140%{_datadir}/pixmaps/CMakeSetup32.png
141%endif
142
143
144%changelog
145* Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10.2-1
146- new upstream release
147- fixed desktop file warning
148
149* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
150- rebuild with libarchive-3.0.4
151
152* Sat Nov 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.6-1
153- new upstream release
154- forced to link with libtinfo.so (ccmake)
155- used --system-libs again
156
157* Sat Jan  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
158- new upstream release
159- used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
160
161* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
162- fixed typo (not --with-system-libs, but --system-libs)
163- added BR: curl-devel, expat-devel, zlib-devel
164
165* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
166- add BuildRequires: ncurses-devel
167
168* Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
169- generate gui package
170- renamed module directory
171
172* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
173- new upstream release
174
175* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
176- rebuilt with new toolchain
177
178* Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
179- imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
180
181* Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
182- new upstream release
183- added Vendor/Distribution tag
184
185* Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
186- new upstream release
187
188* Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
189- new upstream release
190
191* Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
192- new upstream release
193
194* Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
195- new upstream release
196
197* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
198- new upstream release
199- drop Patch100
200- use bootstrap script instead of configure
201- delete caches from %%doc
202
203* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
204- rebuilt with new toolchain
205
206* Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
207- new upstream release
208- delete duped docs
209
210* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
211- added Patch100 (especially for ppc to solve ppc/powerpc issue)
212
213* Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
214- source version up
215
216* Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
217- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.