source: projects/specs/trunk/c/cmake/cmake-vl.spec @ 5159

Revision 5159, 5.8 KB checked in by inagaki, 12 years ago (diff)

update: cmake

Line 
1# Set to bcond_without or use --with bootstrap if bootstrapping a new release
2# or architecture
3%bcond_with bootstrap
4# Set to bcond_with or use --without gui to disable qt4 gui build
5%bcond_without gui
6
7Name: cmake
8Summary: Cross-platform make system
9Summary(ja): クロスプラットフォームな Make システム
10Version: 2.8.6
11Release: 1%{?_dist_release}
12
13Group: Development/Tools
14License: BSD
15URL: http://www.cmake.org/
16
17Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
18Source1: macros.cmake
19
20# Patch to find DCMTK in Fedora (bug #720140)
21Patch0:         cmake-dcmtk.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: curl-devel
25BuildRequires: expat-devel
26BuildRequires: gcc-gfortran
27BuildRequires: libarchive-devel
28BuildRequires: libidn-devel
29BuildRequires: ncurses-devel
30BuildRequires: openssl-devel
31BuildRequires: zlib-devel
32%if %{with gui}
33BuildRequires: qt4-devel, desktop-file-utils
34%define qt_gui --qt-gui
35%else
36%define qt_gui --no-qt-gui
37%endif
38
39Vendor: Project Vine
40Distribution: Vine Linux
41
42%description
43CMake is used to control the software compilation process using simple
44platform and compiler independent configuration files. CMake generates
45native makefiles and workspaces that can be used in the compiler
46environment of your choice. CMake is quite sophisticated: it is possible
47to support complex environments requiring system configuration, pre-processor
48generation, code generation, and template instantiation.
49
50%package        gui
51Summary:        Qt GUI for %{name}
52Group:          Development/Tools
53Requires:       %{name} = %{version}-%{release}
54Requires(post): desktop-file-utils, shared-mime-info
55Requires(postun): desktop-file-utils, shared-mime-info
56
57%description    gui
58The %{name}-gui package contains the Qt based GUI for CMake.
59
60
61%prep
62%setup -q
63%patch0 -p1 -b .dcmtk
64
65# Fixup permissions
66#find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
67
68%build
69./bootstrap \
70    --prefix=%{_prefix} \
71    --datadir=/share/%{name} \
72    --mandir=/share/man \
73    --%{?with_bootstrap:no-}system-libs \
74    %{?qt_gui}
75
76sed -i 's/-lcurses/-lcurses -ltinfo/' Source/CMakeFiles/ccmake.dir/link.txt
77%if %{?_dist_release} == "vl5"
78sed -i 's/HAVE_SYS_WAIT_H:INTERNAL=/HAVE_SYS_WAIT_H:INTERNAL=1/' CMakeCache.txt
79%endif
80
81make VERBOSE=1 %{?_smp_mflags}
82
83%install
84rm -rf $RPM_BUILD_ROOT
85make install DESTDIR=$RPM_BUILD_ROOT
86
87find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
88rm -rf $RPM_BUILD_ROOT/usr/doc
89
90# RPM macros
91install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
92sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
93touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
94
95%if %{with gui}
96# Desktop file
97desktop-file-install --delete-original \
98  --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
99  $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
100%endif
101
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%if %{with gui}
107%post gui
108update-desktop-database &> /dev/null || :
109update-mime-database %{_datadir}/mime &> /dev/null || :
110
111%postun gui
112update-desktop-database &> /dev/null || :
113update-mime-database %{_datadir}/mime &> /dev/null || :
114%endif
115
116
117%files
118%defattr(-,root,root)
119%doc CMakeLogo.gif ChangeLog.* Copyright.txt
120%doc Docs/*
121%doc Example/
122%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
123%{_bindir}/ccmake
124%{_bindir}/cmake
125%{_bindir}/cpack
126%{_bindir}/ctest
127%{_datadir}/%{name}/
128%{_datadir}/aclocal/cmake.m4
129%{_mandir}/man1/*
130
131%if %{with gui}
132%files gui
133%defattr(-,root,root,-)
134%{_bindir}/cmake-gui
135%{_datadir}/applications/CMake.desktop
136%{_datadir}/mime/packages/cmakecache.xml
137%{_datadir}/pixmaps/CMakeSetup32.png
138%endif
139
140
141%changelog
142* Sat Nov 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.6-1
143- new upstream release
144- forced to link with libtinfo.so (ccmake)
145- used --system-libs again
146
147* Sat Jan  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
148- new upstream release
149- used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
150
151* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
152- fixed typo (not --with-system-libs, but --system-libs)
153- added BR: curl-devel, expat-devel, zlib-devel
154
155* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
156- add BuildRequires: ncurses-devel
157
158* Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
159- generate gui package
160- renamed module directory
161
162* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
163- new upstream release
164
165* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
166- rebuilt with new toolchain
167
168* Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
169- imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
170
171* Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
172- new upstream release
173- added Vendor/Distribution tag
174
175* Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
176- new upstream release
177
178* Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
179- new upstream release
180
181* Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
182- new upstream release
183
184* Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
185- new upstream release
186
187* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
188- new upstream release
189- drop Patch100
190- use bootstrap script instead of configure
191- delete caches from %%doc
192
193* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
194- rebuilt with new toolchain
195
196* Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
197- new upstream release
198- delete duped docs
199
200* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
201- added Patch100 (especially for ppc to solve ppc/powerpc issue)
202
203* Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
204- source version up
205
206* Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
207- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.