source: projects/specs/trunk/c/cmake/cmake-vl.spec @ 12428

Revision 12428, 7.6 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

cmake-3.18.0-1

jsoncpp-1.9.3-1

libarchive-3.4.3-1

libzip-1.7.3-1

xz-5.2.5-1

Line 
1# Set to bcond_without or use --with bootstrap if bootstrapping a new release
2# or architecture
3%bcond_with bootstrap
4# Set to bcond_with or use --without gui to disable qt4 gui build
5%bcond_with gui
6
7%global major_version 3
8%global minor_version 18
9
10Name: cmake
11Summary: Cross-platform make system
12Summary(ja): クロスプラットフォームな Make システム
13Version: 3.18.0
14Release: 1%{?_dist_release}
15Group: Development/Tools
16
17License: BSD
18URL: http://www.cmake.org/
19Source0: https://github.com/Kitware/CMake/releases/download/v%{version}/cmake-%{version}.tar.gz
20Source1: macros.cmake
21Vendor: Project Vine
22Distribution: Vine Linux
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: curl-devel
26BuildRequires: expat-devel
27BuildRequires: gcc-gfortran
28BuildRequires: libarchive-devel
29#BuildRequires: libidn-devel
30BuildRequires: ncurses-devel
31BuildRequires: openssl-devel
32BuildRequires: zlib-devel
33BuildRequires: xz-devel
34BuildRequires: jsoncpp-devel
35%if %{with gui}
36BuildRequires: qt4-devel, desktop-file-utils
37%define qt_gui --qt-gui
38%else
39%define qt_gui --no-qt-gui
40%endif
41
42%description
43CMake is used to control the software compilation process using simple
44platform and compiler independent configuration files. CMake generates
45native makefiles and workspaces that can be used in the compiler
46environment of your choice. CMake is quite sophisticated: it is possible
47to support complex environments requiring system configuration, pre-processor
48generation, code generation, and template instantiation.
49
50%package        gui
51Summary:        Qt GUI for %{name}
52Group:          Development/Tools
53Requires:       %{name} = %{version}-%{release}
54Requires(post): desktop-file-utils, shared-mime-info
55Requires(postun): desktop-file-utils, shared-mime-info
56
57%description    gui
58The %{name}-gui package contains the Qt based GUI for CMake.
59
60
61%debug_package
62
63
64%prep
65%setup -q
66
67
68%build
69./bootstrap \
70    --prefix=%{_prefix} \
71    --datadir=/share/%{name} \
72    --docdir=/share/doc/%{name} \
73    --mandir=/share/man \
74%if 0%{?with_bootstrap}
75    --no-system-libs \
76%else
77    --system-curl \
78    --system-expat \
79    --system-jsoncpp \
80    --system-zlib \
81    --system-bzip2 \
82    --system-liblzma \
83    --system-libarchive \
84    --no-system-librhash \
85%endif
86    --parallel=`/usr/bin/getconf _NPROCESSORS_ONLN` \
87    %{?qt_gui} \
88    -- -DCMAKE_USE_SYSTEM_LIBUV=OFF
89
90# sed -i 's/-lcurses/-lcurses -ltinfo/' Source/CMakeFiles/ccmake.dir/link.txt
91
92make VERBOSE=1 %{?_smp_mflags}
93
94%install
95rm -rf $RPM_BUILD_ROOT
96make install DESTDIR=$RPM_BUILD_ROOT
97
98find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
99rm -rf $RPM_BUILD_ROOT/usr/doc
100
101# RPM macros
102install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
103sed -i -e "s|@@CMAKE_MAJOR_VERSION@@|%{major_version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
104touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
105
106%if %{with gui}
107# Desktop file
108desktop-file-install --delete-original \
109  --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
110  $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
111%endif
112
113rm -rf doc
114mv -f %{buildroot}%{_docdir}/%{name} ./doc
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%if %{with gui}
120%post gui
121update-desktop-database &> /dev/null || :
122update-mime-database %{_datadir}/mime &> /dev/null || :
123
124%postun gui
125update-desktop-database &> /dev/null || :
126update-mime-database %{_datadir}/mime &> /dev/null || :
127%endif
128
129
130%files
131%defattr(-,root,root)
132%doc CMakeLogo.gif README.* doc
133%doc Help
134%license Copyright.txt Licenses/*
135%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
136%{_bindir}/ccmake
137%{_bindir}/cmake
138%{_bindir}/cpack
139%{_bindir}/ctest
140%{_datadir}/%{name}/
141%{_datadir}/aclocal/cmake.m4
142%dir %{_datadir}/bash-completion
143%dir %{_datadir}/bash-completion/completions
144%{_datadir}/bash-completion/completions/*
145%exclude /usr/share/vim
146%exclude /usr/share/emacs
147
148%if %{with gui}
149%files gui
150%defattr(-,root,root,-)
151%{_bindir}/cmake-gui
152%{_datadir}/applications/CMake.desktop
153%{_datadir}/mime/packages/cmakecache.xml
154%{_datadir}/icons/hicolor/*/*/*
155%endif
156
157
158%changelog
159* Thu Jul 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.18.0-1
160- updated to 3.18.0.
161
162* Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.15.3-1
163- updated to 3.15.3.
164
165* Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.10.1-1
166- updated to 3.10.1.
167- updated macros.cmake.
168- disabled gui.
169
170* Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-2
171- rebuild with gcc-5.4.0
172
173* Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-1
174- update to 3.5.2
175- add BuildRequires: xz-devel, jsoncpp-devel
176- remove old patches
177
178* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
179- update to 2.8.12.2
180
181* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
182- update to 2.8.12.2
183- add Patch2 (cmake-2.8.12.2-ruby-2.2.x.patch)
184
185* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-2
186- rebuild with libarchive-3.1.2
187
188* Mon Dec 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-1
189- new upstream release
190- add Patch1 (cmake-2.8.12.1-FindFreetype.patch)
191
192* Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11.2-1
193- new upstream release
194
195* Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11-1
196- new upstream release
197
198* Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10.2-1
199- new upstream release
200- fixed desktop file warning
201
202* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
203- rebuild with libarchive-3.0.4
204
205* Sat Nov 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.6-1
206- new upstream release
207- forced to link with libtinfo.so (ccmake)
208- used --system-libs again
209
210* Sat Jan  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
211- new upstream release
212- used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
213
214* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
215- fixed typo (not --with-system-libs, but --system-libs)
216- added BR: curl-devel, expat-devel, zlib-devel
217
218* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
219- add BuildRequires: ncurses-devel
220
221* Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
222- generate gui package
223- renamed module directory
224
225* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
226- new upstream release
227
228* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
229- rebuilt with new toolchain
230
231* Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
232- imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
233
234* Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
235- new upstream release
236- added Vendor/Distribution tag
237
238* Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
239- new upstream release
240
241* Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
242- new upstream release
243
244* Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
245- new upstream release
246
247* Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
248- new upstream release
249
250* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
251- new upstream release
252- drop Patch100
253- use bootstrap script instead of configure
254- delete caches from %%doc
255
256* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
257- rebuilt with new toolchain
258
259* Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
260- new upstream release
261- delete duped docs
262
263* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
264- added Patch100 (especially for ppc to solve ppc/powerpc issue)
265
266* Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
267- source version up
268
269* Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
270- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.