source: projects/specs/trunk/c/cmake/cmake-vl.spec @ 12222

Revision 12222, 7.3 KB checked in by tomop, 5 years ago (diff)

updated 5 packages

bubblewrap-0.3.3-4

cmake-3.15.3-1

jsoncpp-1.9.1-1

webkitgtk4-2.26.0-1

xdg-dbus-proxy-0.1.2-1

Line 
1# Set to bcond_without or use --with bootstrap if bootstrapping a new release
2# or architecture
3%bcond_with bootstrap
4# Set to bcond_with or use --without gui to disable qt4 gui build
5%bcond_with gui
6
7%global major_version 3
8%global minor_version 15
9
10Name: cmake
11Summary: Cross-platform make system
12Summary(ja): クロスプラットフォームな Make システム
13Version: 3.15.3
14Release: 1%{?_dist_release}
15
16Group: Development/Tools
17License: BSD
18URL: http://www.cmake.org/
19
20Source0: https://github.com/Kitware/CMake/releases/download/v%{version}/cmake-%{version}.tar.gz
21Source1: macros.cmake
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: curl-devel
25BuildRequires: expat-devel
26BuildRequires: gcc-gfortran
27BuildRequires: libarchive-devel
28BuildRequires: libidn-devel
29BuildRequires: ncurses-devel
30BuildRequires: openssl-devel
31BuildRequires: zlib-devel
32BuildRequires: xz-devel
33BuildRequires: jsoncpp-devel
34%if %{with gui}
35BuildRequires: qt4-devel, desktop-file-utils
36%define qt_gui --qt-gui
37%else
38%define qt_gui --no-qt-gui
39%endif
40
41Vendor: Project Vine
42Distribution: Vine Linux
43
44%description
45CMake is used to control the software compilation process using simple
46platform and compiler independent configuration files. CMake generates
47native makefiles and workspaces that can be used in the compiler
48environment of your choice. CMake is quite sophisticated: it is possible
49to support complex environments requiring system configuration, pre-processor
50generation, code generation, and template instantiation.
51
52%package        gui
53Summary:        Qt GUI for %{name}
54Group:          Development/Tools
55Requires:       %{name} = %{version}-%{release}
56Requires(post): desktop-file-utils, shared-mime-info
57Requires(postun): desktop-file-utils, shared-mime-info
58
59%description    gui
60The %{name}-gui package contains the Qt based GUI for CMake.
61
62
63%prep
64%setup -q
65
66
67%build
68./bootstrap \
69    --prefix=%{_prefix} \
70    --datadir=/share/%{name} \
71    --docdir=/share/doc/%{name} \
72    --mandir=/share/man \
73%if 0%{?with_bootstrap}
74    --no-system-libs \
75%else
76    --system-curl \
77    --system-expat \
78    --system-jsoncpp \
79    --system-zlib \
80    --system-bzip2 \
81    --system-liblzma \
82    --system-libarchive \
83    --no-system-librhash \
84%endif
85    --parallel=`/usr/bin/getconf _NPROCESSORS_ONLN` \
86    %{?qt_gui} \
87    -- -DCMAKE_USE_SYSTEM_LIBUV=OFF
88
89sed -i 's/-lcurses/-lcurses -ltinfo/' Source/CMakeFiles/ccmake.dir/link.txt
90
91make VERBOSE=1 %{?_smp_mflags}
92
93%install
94rm -rf $RPM_BUILD_ROOT
95make install DESTDIR=$RPM_BUILD_ROOT
96
97find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
98rm -rf $RPM_BUILD_ROOT/usr/doc
99
100# RPM macros
101install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
102sed -i -e "s|@@CMAKE_MAJOR_VERSION@@|%{major_version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
103touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
104
105%if %{with gui}
106# Desktop file
107desktop-file-install --delete-original \
108  --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
109  $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
110%endif
111
112rm -rf doc
113mv -f %{buildroot}%{_docdir}/%{name} ./doc
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%if %{with gui}
119%post gui
120update-desktop-database &> /dev/null || :
121update-mime-database %{_datadir}/mime &> /dev/null || :
122
123%postun gui
124update-desktop-database &> /dev/null || :
125update-mime-database %{_datadir}/mime &> /dev/null || :
126%endif
127
128
129%files
130%defattr(-,root,root)
131%doc CMakeLogo.gif README.* doc
132%doc Help
133%doc Licenses
134%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
135%{_bindir}/ccmake
136%{_bindir}/cmake
137%{_bindir}/cpack
138%{_bindir}/ctest
139%{_datadir}/%{name}/
140%{_datadir}/aclocal/cmake.m4
141
142%if %{with gui}
143%files gui
144%defattr(-,root,root,-)
145%{_bindir}/cmake-gui
146%{_datadir}/applications/CMake.desktop
147%{_datadir}/mime/packages/cmakecache.xml
148%{_datadir}/icons/hicolor/*/*/*
149%endif
150
151
152%changelog
153* Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.15.3-1
154- updated to 3.15.3.
155
156* Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.10.1-1
157- updated to 3.10.1.
158- updated macros.cmake.
159- disabled gui.
160
161* Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-2
162- rebuild with gcc-5.4.0
163
164* Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-1
165- update to 3.5.2
166- add BuildRequires: xz-devel, jsoncpp-devel
167- remove old patches
168
169* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
170- update to 2.8.12.2
171
172* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
173- update to 2.8.12.2
174- add Patch2 (cmake-2.8.12.2-ruby-2.2.x.patch)
175
176* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-2
177- rebuild with libarchive-3.1.2
178
179* Mon Dec 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-1
180- new upstream release
181- add Patch1 (cmake-2.8.12.1-FindFreetype.patch)
182
183* Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11.2-1
184- new upstream release
185
186* Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11-1
187- new upstream release
188
189* Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10.2-1
190- new upstream release
191- fixed desktop file warning
192
193* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
194- rebuild with libarchive-3.0.4
195
196* Sat Nov 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.6-1
197- new upstream release
198- forced to link with libtinfo.so (ccmake)
199- used --system-libs again
200
201* Sat Jan  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
202- new upstream release
203- used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
204
205* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
206- fixed typo (not --with-system-libs, but --system-libs)
207- added BR: curl-devel, expat-devel, zlib-devel
208
209* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
210- add BuildRequires: ncurses-devel
211
212* Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
213- generate gui package
214- renamed module directory
215
216* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
217- new upstream release
218
219* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
220- rebuilt with new toolchain
221
222* Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
223- imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
224
225* Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
226- new upstream release
227- added Vendor/Distribution tag
228
229* Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
230- new upstream release
231
232* Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
233- new upstream release
234
235* Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
236- new upstream release
237
238* Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
239- new upstream release
240
241* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
242- new upstream release
243- drop Patch100
244- use bootstrap script instead of configure
245- delete caches from %%doc
246
247* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
248- rebuilt with new toolchain
249
250* Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
251- new upstream release
252- delete duped docs
253
254* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
255- added Patch100 (especially for ppc to solve ppc/powerpc issue)
256
257* Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
258- source version up
259
260* Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
261- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.