source: projects/specs/trunk/c/cmake/cmake-vl.spec @ 10245

Revision 10245, 6.8 KB checked in by Takemikaduchi, 8 years ago (diff)

OpenImageIO,cmake: new upstream release
others: rebuild

Line 
1# Set to bcond_without or use --with bootstrap if bootstrapping a new release
2# or architecture
3%bcond_with bootstrap
4# Set to bcond_with or use --without gui to disable qt4 gui build
5%bcond_without gui
6
7Name: cmake
8Summary: Cross-platform make system
9Summary(ja): クロスプラットフォームな Make システム
10Version: 3.5.2
11Release: 1%{?_dist_release}
12
13Group: Development/Tools
14License: BSD
15URL: http://www.cmake.org/
16
17Source0: http://www.cmake.org/files/v3.5/%{name}-%{version}.tar.gz
18Source1: macros.cmake
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: curl-devel
22BuildRequires: expat-devel
23BuildRequires: gcc-gfortran
24BuildRequires: libarchive-devel
25BuildRequires: libidn-devel
26BuildRequires: ncurses-devel
27BuildRequires: openssl-devel
28BuildRequires: zlib-devel
29BuildRequires: xz-devel
30BuildRequires: jsoncpp-devel
31%if %{with gui}
32BuildRequires: qt4-devel, desktop-file-utils
33%define qt_gui --qt-gui
34%else
35%define qt_gui --no-qt-gui
36%endif
37
38Vendor: Project Vine
39Distribution: Vine Linux
40
41%description
42CMake is used to control the software compilation process using simple
43platform and compiler independent configuration files. CMake generates
44native makefiles and workspaces that can be used in the compiler
45environment of your choice. CMake is quite sophisticated: it is possible
46to support complex environments requiring system configuration, pre-processor
47generation, code generation, and template instantiation.
48
49%package        gui
50Summary:        Qt GUI for %{name}
51Group:          Development/Tools
52Requires:       %{name} = %{version}-%{release}
53Requires(post): desktop-file-utils, shared-mime-info
54Requires(postun): desktop-file-utils, shared-mime-info
55
56%description    gui
57The %{name}-gui package contains the Qt based GUI for CMake.
58
59
60%prep
61%setup -q
62
63# Fixup permissions
64#find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
65
66#fix desktop file warning
67sed -i 's:\(Icon=\)\(CMakeSetup32.png\):\1/usr/share/pixmaps/\2:' Source/QtDialog/CMake.desktop
68
69%build
70./bootstrap \
71    --prefix=%{_prefix} \
72    --datadir=/share/%{name} \
73    --mandir=/share/man \
74    --%{?with_bootstrap:no-}system-libs \
75    %{?qt_gui}
76
77sed -i 's/-lcurses/-lcurses -ltinfo/' Source/CMakeFiles/ccmake.dir/link.txt
78%if %{?_dist_release} == "vl5"
79sed -i 's/HAVE_SYS_WAIT_H:INTERNAL=/HAVE_SYS_WAIT_H:INTERNAL=1/' CMakeCache.txt
80%endif
81
82make VERBOSE=1 %{?_smp_mflags}
83
84%install
85rm -rf $RPM_BUILD_ROOT
86make install DESTDIR=$RPM_BUILD_ROOT
87
88find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
89rm -rf $RPM_BUILD_ROOT/usr/doc
90
91# RPM macros
92install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
93sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
94touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
95
96%if %{with gui}
97# Desktop file
98desktop-file-install --delete-original \
99  --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
100  $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
101%endif
102
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%if %{with gui}
108%post gui
109update-desktop-database &> /dev/null || :
110update-mime-database %{_datadir}/mime &> /dev/null || :
111
112%postun gui
113update-desktop-database &> /dev/null || :
114update-mime-database %{_datadir}/mime &> /dev/null || :
115%endif
116
117
118%files
119%defattr(-,root,root)
120%doc CMakeLogo.gif ChangeLog.* Copyright.txt
121%doc Docs/*
122%doc Example/
123%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
124%{_bindir}/ccmake
125%{_bindir}/cmake
126%{_bindir}/cpack
127%{_bindir}/ctest
128%{_datadir}/%{name}/
129%{_datadir}/aclocal/cmake.m4
130
131%if %{with gui}
132%files gui
133%defattr(-,root,root,-)
134%{_bindir}/cmake-gui
135%{_datadir}/applications/CMake.desktop
136%{_datadir}/mime/packages/cmakecache.xml
137%{_datadir}/icons/hicolor/*/*/*
138%endif
139
140
141%changelog
142* Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-1
143- update to 3.5.2
144- add BuildRequires: xz-devel, jsoncpp-devel
145- remove old patches
146
147* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
148- update to 2.8.12.2
149
150* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
151- update to 2.8.12.2
152- add Patch2 (cmake-2.8.12.2-ruby-2.2.x.patch)
153
154* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-2
155- rebuild with libarchive-3.1.2
156
157* Mon Dec 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-1
158- new upstream release
159- add Patch1 (cmake-2.8.12.1-FindFreetype.patch)
160
161* Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11.2-1
162- new upstream release
163
164* Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11-1
165- new upstream release
166
167* Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10.2-1
168- new upstream release
169- fixed desktop file warning
170
171* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
172- rebuild with libarchive-3.0.4
173
174* Sat Nov 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.6-1
175- new upstream release
176- forced to link with libtinfo.so (ccmake)
177- used --system-libs again
178
179* Sat Jan  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
180- new upstream release
181- used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
182
183* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
184- fixed typo (not --with-system-libs, but --system-libs)
185- added BR: curl-devel, expat-devel, zlib-devel
186
187* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
188- add BuildRequires: ncurses-devel
189
190* Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
191- generate gui package
192- renamed module directory
193
194* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
195- new upstream release
196
197* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
198- rebuilt with new toolchain
199
200* Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
201- imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
202
203* Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
204- new upstream release
205- added Vendor/Distribution tag
206
207* Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
208- new upstream release
209
210* Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
211- new upstream release
212
213* Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
214- new upstream release
215
216* Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
217- new upstream release
218
219* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
220- new upstream release
221- drop Patch100
222- use bootstrap script instead of configure
223- delete caches from %%doc
224
225* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
226- rebuilt with new toolchain
227
228* Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
229- new upstream release
230- delete duped docs
231
232* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
233- added Patch100 (especially for ppc to solve ppc/powerpc issue)
234
235* Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
236- source version up
237
238* Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
239- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.