source: projects/specs/trunk/c/cmake/cmake-vl.spec @ 8056

Revision 8056, 6.5 KB checked in by Takemikaduchi, 10 years ago (diff)

KDE-4.11.4
exiv2-0.24
wireshark-1.10.5, etc...

RevLine 
[5159]1# Set to bcond_without or use --with bootstrap if bootstrapping a new release
2# or architecture
3%bcond_with bootstrap
[1640]4# Set to bcond_with or use --without gui to disable qt4 gui build
5%bcond_without gui
6
[1442]7Name: cmake
[521]8Summary: Cross-platform make system
[1640]9Summary(ja): クロスプラットフォームな Make システム
[8056]10Version: 2.8.12.1
[7639]11Release: 1%{?_dist_release}
[521]12
13Group: Development/Tools
[1640]14License: BSD
[521]15URL: http://www.cmake.org/
16
[1442]17Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
18Source1: macros.cmake
19
[5159]20# Patch to find DCMTK in Fedora (bug #720140)
21Patch0:         cmake-dcmtk.patch
22
[8056]23Patch1:                 cmake-2.8.12.1-FindFreetype.patch
24
[521]25BuildRoot: %{_tmppath}/%{name}-%{version}-root
[5159]26BuildRequires: curl-devel
27BuildRequires: expat-devel
28BuildRequires: gcc-gfortran
29BuildRequires: libarchive-devel
[2604]30BuildRequires: libidn-devel
[1643]31BuildRequires: ncurses-devel
[2604]32BuildRequires: openssl-devel
[5159]33BuildRequires: zlib-devel
[1640]34%if %{with gui}
35BuildRequires: qt4-devel, desktop-file-utils
36%define qt_gui --qt-gui
[1777]37%else
38%define qt_gui --no-qt-gui
[1640]39%endif
[521]40
41Vendor: Project Vine
42Distribution: Vine Linux
43
44%description
45CMake is used to control the software compilation process using simple
46platform and compiler independent configuration files. CMake generates
47native makefiles and workspaces that can be used in the compiler
48environment of your choice. CMake is quite sophisticated: it is possible
49to support complex environments requiring system configuration, pre-processor
50generation, code generation, and template instantiation.
51
[1640]52%package        gui
53Summary:        Qt GUI for %{name}
54Group:          Development/Tools
55Requires:       %{name} = %{version}-%{release}
56Requires(post): desktop-file-utils, shared-mime-info
57Requires(postun): desktop-file-utils, shared-mime-info
58
59%description    gui
60The %{name}-gui package contains the Qt based GUI for CMake.
61
62
[521]63%prep
64%setup -q
[5159]65%patch0 -p1 -b .dcmtk
[8056]66%patch1 -p1 -b .freetype2
[5159]67
[1640]68# Fixup permissions
[5159]69#find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
[521]70
[7639]71#fix desktop file warning
72sed -i 's:\(Icon=\)\(CMakeSetup32.png\):\1/usr/share/pixmaps/\2:' Source/QtDialog/CMake.desktop
73
[521]74%build
[1777]75./bootstrap \
76    --prefix=%{_prefix} \
77    --datadir=/share/%{name} \
78    --mandir=/share/man \
[5159]79    --%{?with_bootstrap:no-}system-libs \
[1777]80    %{?qt_gui}
81
[5159]82sed -i 's/-lcurses/-lcurses -ltinfo/' Source/CMakeFiles/ccmake.dir/link.txt
[2604]83%if %{?_dist_release} == "vl5"
84sed -i 's/HAVE_SYS_WAIT_H:INTERNAL=/HAVE_SYS_WAIT_H:INTERNAL=1/' CMakeCache.txt
85%endif
86
[1640]87make VERBOSE=1 %{?_smp_mflags}
[521]88
89%install
90rm -rf $RPM_BUILD_ROOT
[1640]91make install DESTDIR=$RPM_BUILD_ROOT
[521]92
[1640]93find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
[521]94rm -rf $RPM_BUILD_ROOT/usr/doc
95
96# RPM macros
97install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
98sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
99touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
100
[1640]101%if %{with gui}
102# Desktop file
103desktop-file-install --delete-original \
104  --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
105  $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
106%endif
107
108
[521]109%clean
110rm -rf $RPM_BUILD_ROOT
111
[1640]112%if %{with gui}
113%post gui
114update-desktop-database &> /dev/null || :
115update-mime-database %{_datadir}/mime &> /dev/null || :
116
117%postun gui
118update-desktop-database &> /dev/null || :
119update-mime-database %{_datadir}/mime &> /dev/null || :
120%endif
121
122
[521]123%files
124%defattr(-,root,root)
125%doc CMakeLogo.gif ChangeLog.* Copyright.txt
126%doc Docs/*
127%doc Example/
128%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
[1640]129%{_bindir}/ccmake
130%{_bindir}/cmake
131%{_bindir}/cpack
132%{_bindir}/ctest
133%{_datadir}/%{name}/
[5159]134%{_datadir}/aclocal/cmake.m4
[521]135%{_mandir}/man1/*
136
[1640]137%if %{with gui}
138%files gui
139%defattr(-,root,root,-)
140%{_bindir}/cmake-gui
141%{_datadir}/applications/CMake.desktop
142%{_datadir}/mime/packages/cmakecache.xml
143%{_datadir}/pixmaps/CMakeSetup32.png
144%endif
145
146
[521]147%changelog
[8056]148* Mon Dec 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-1
149- new upstream release
150- add Patch1 (cmake-2.8.12.1-FindFreetype.patch)
151
[7728]152* Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11.2-1
153- new upstream release
154
[7712]155* Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11-1
156- new upstream release
157
[7639]158* Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10.2-1
159- new upstream release
160- fixed desktop file warning
161
[6304]162* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
[6305]163- rebuild with libarchive-3.0.4
[6304]164
[5159]165* Sat Nov 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.6-1
166- new upstream release
167- forced to link with libtinfo.so (ccmake)
168- used --system-libs again
169
[2604]170* Sat Jan  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
171- new upstream release
172- used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
173
[1777]174* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
175- fixed typo (not --with-system-libs, but --system-libs)
176- added BR: curl-devel, expat-devel, zlib-devel
177
[1643]178* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
179- add BuildRequires: ncurses-devel
180
[1640]181* Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
182- generate gui package
183- renamed module directory
184
[1442]185* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
186- new upstream release
187
[521]188* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
189- rebuilt with new toolchain
190
191* Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
192- imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
193
194* Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
195- new upstream release
196- added Vendor/Distribution tag
197
198* Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
199- new upstream release
200
201* Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
202- new upstream release
203
204* Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
205- new upstream release
206
207* Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
208- new upstream release
209
210* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
211- new upstream release
212- drop Patch100
213- use bootstrap script instead of configure
214- delete caches from %%doc
215
216* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
217- rebuilt with new toolchain
218
219* Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
220- new upstream release
221- delete duped docs
222
223* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
224- added Patch100 (especially for ppc to solve ppc/powerpc issue)
225
226* Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
227- source version up
228
229* Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
230- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.