source: projects/specs/trunk/c/cmake/cmake-vl.spec @ 7728

Revision 7728, 6.3 KB checked in by Takemikaduchi, 11 years ago (diff)

KDE-4.10.5

RevLine 
[5159]1# Set to bcond_without or use --with bootstrap if bootstrapping a new release
2# or architecture
3%bcond_with bootstrap
[1640]4# Set to bcond_with or use --without gui to disable qt4 gui build
5%bcond_without gui
6
[1442]7Name: cmake
[521]8Summary: Cross-platform make system
[1640]9Summary(ja): クロスプラットフォームな Make システム
[7728]10Version: 2.8.11.2
[7639]11Release: 1%{?_dist_release}
[521]12
13Group: Development/Tools
[1640]14License: BSD
[521]15URL: http://www.cmake.org/
16
[1442]17Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
18Source1: macros.cmake
19
[5159]20# Patch to find DCMTK in Fedora (bug #720140)
21Patch0:         cmake-dcmtk.patch
22
[521]23BuildRoot: %{_tmppath}/%{name}-%{version}-root
[5159]24BuildRequires: curl-devel
25BuildRequires: expat-devel
26BuildRequires: gcc-gfortran
27BuildRequires: libarchive-devel
[2604]28BuildRequires: libidn-devel
[1643]29BuildRequires: ncurses-devel
[2604]30BuildRequires: openssl-devel
[5159]31BuildRequires: zlib-devel
[1640]32%if %{with gui}
33BuildRequires: qt4-devel, desktop-file-utils
34%define qt_gui --qt-gui
[1777]35%else
36%define qt_gui --no-qt-gui
[1640]37%endif
[521]38
39Vendor: Project Vine
40Distribution: Vine Linux
41
42%description
43CMake is used to control the software compilation process using simple
44platform and compiler independent configuration files. CMake generates
45native makefiles and workspaces that can be used in the compiler
46environment of your choice. CMake is quite sophisticated: it is possible
47to support complex environments requiring system configuration, pre-processor
48generation, code generation, and template instantiation.
49
[1640]50%package        gui
51Summary:        Qt GUI for %{name}
52Group:          Development/Tools
53Requires:       %{name} = %{version}-%{release}
54Requires(post): desktop-file-utils, shared-mime-info
55Requires(postun): desktop-file-utils, shared-mime-info
56
57%description    gui
58The %{name}-gui package contains the Qt based GUI for CMake.
59
60
[521]61%prep
62%setup -q
[5159]63%patch0 -p1 -b .dcmtk
64
[1640]65# Fixup permissions
[5159]66#find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
[521]67
[7639]68#fix desktop file warning
69sed -i 's:\(Icon=\)\(CMakeSetup32.png\):\1/usr/share/pixmaps/\2:' Source/QtDialog/CMake.desktop
70
[521]71%build
[1777]72./bootstrap \
73    --prefix=%{_prefix} \
74    --datadir=/share/%{name} \
75    --mandir=/share/man \
[5159]76    --%{?with_bootstrap:no-}system-libs \
[1777]77    %{?qt_gui}
78
[5159]79sed -i 's/-lcurses/-lcurses -ltinfo/' Source/CMakeFiles/ccmake.dir/link.txt
[2604]80%if %{?_dist_release} == "vl5"
81sed -i 's/HAVE_SYS_WAIT_H:INTERNAL=/HAVE_SYS_WAIT_H:INTERNAL=1/' CMakeCache.txt
82%endif
83
[1640]84make VERBOSE=1 %{?_smp_mflags}
[521]85
86%install
87rm -rf $RPM_BUILD_ROOT
[1640]88make install DESTDIR=$RPM_BUILD_ROOT
[521]89
[1640]90find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
[521]91rm -rf $RPM_BUILD_ROOT/usr/doc
92
93# RPM macros
94install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
95sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
96touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
97
[1640]98%if %{with gui}
99# Desktop file
100desktop-file-install --delete-original \
101  --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
102  $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
103%endif
104
105
[521]106%clean
107rm -rf $RPM_BUILD_ROOT
108
[1640]109%if %{with gui}
110%post gui
111update-desktop-database &> /dev/null || :
112update-mime-database %{_datadir}/mime &> /dev/null || :
113
114%postun gui
115update-desktop-database &> /dev/null || :
116update-mime-database %{_datadir}/mime &> /dev/null || :
117%endif
118
119
[521]120%files
121%defattr(-,root,root)
122%doc CMakeLogo.gif ChangeLog.* Copyright.txt
123%doc Docs/*
124%doc Example/
125%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
[1640]126%{_bindir}/ccmake
127%{_bindir}/cmake
128%{_bindir}/cpack
129%{_bindir}/ctest
130%{_datadir}/%{name}/
[5159]131%{_datadir}/aclocal/cmake.m4
[521]132%{_mandir}/man1/*
133
[1640]134%if %{with gui}
135%files gui
136%defattr(-,root,root,-)
137%{_bindir}/cmake-gui
138%{_datadir}/applications/CMake.desktop
139%{_datadir}/mime/packages/cmakecache.xml
140%{_datadir}/pixmaps/CMakeSetup32.png
141%endif
142
143
[521]144%changelog
[7728]145* Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11.2-1
146- new upstream release
147
[7712]148* Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11-1
149- new upstream release
150
[7639]151* Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10.2-1
152- new upstream release
153- fixed desktop file warning
154
[6304]155* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
[6305]156- rebuild with libarchive-3.0.4
[6304]157
[5159]158* Sat Nov 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.6-1
159- new upstream release
160- forced to link with libtinfo.so (ccmake)
161- used --system-libs again
162
[2604]163* Sat Jan  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
164- new upstream release
165- used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
166
[1777]167* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
168- fixed typo (not --with-system-libs, but --system-libs)
169- added BR: curl-devel, expat-devel, zlib-devel
170
[1643]171* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
172- add BuildRequires: ncurses-devel
173
[1640]174* Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
175- generate gui package
176- renamed module directory
177
[1442]178* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
179- new upstream release
180
[521]181* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
182- rebuilt with new toolchain
183
184* Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
185- imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
186
187* Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
188- new upstream release
189- added Vendor/Distribution tag
190
191* Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
192- new upstream release
193
194* Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
195- new upstream release
196
197* Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
198- new upstream release
199
200* Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
201- new upstream release
202
203* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
204- new upstream release
205- drop Patch100
206- use bootstrap script instead of configure
207- delete caches from %%doc
208
209* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
210- rebuilt with new toolchain
211
212* Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
213- new upstream release
214- delete duped docs
215
216* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
217- added Patch100 (especially for ppc to solve ppc/powerpc issue)
218
219* Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
220- source version up
221
222* Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
223- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.