source: projects/specs/trunk/c/cmake/cmake-vl.spec @ 9748

Revision 9748, 6.9 KB checked in by Takemikaduchi, 9 years ago (diff)

rebuild with ruby-2.2.3

RevLine 
[5159]1# Set to bcond_without or use --with bootstrap if bootstrapping a new release
2# or architecture
3%bcond_with bootstrap
[1640]4# Set to bcond_with or use --without gui to disable qt4 gui build
5%bcond_without gui
6
[1442]7Name: cmake
[521]8Summary: Cross-platform make system
[1640]9Summary(ja): クロスプラットフォームな Make システム
[9748]10Version: 2.8.12.2
11Release: 1%{?_dist_release}
[521]12
13Group: Development/Tools
[1640]14License: BSD
[521]15URL: http://www.cmake.org/
16
[1442]17Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
18Source1: macros.cmake
19
[5159]20# Patch to find DCMTK in Fedora (bug #720140)
21Patch0:         cmake-dcmtk.patch
22
[8056]23Patch1:                 cmake-2.8.12.1-FindFreetype.patch
24
[9748]25# http://public.kitware.com/pipermail/cmake-developers/2014-December/024044.html
26Patch2:                 cmake-2.8.12.2-ruby-2.2.x.patch
27
[521]28BuildRoot: %{_tmppath}/%{name}-%{version}-root
[5159]29BuildRequires: curl-devel
30BuildRequires: expat-devel
31BuildRequires: gcc-gfortran
32BuildRequires: libarchive-devel
[2604]33BuildRequires: libidn-devel
[1643]34BuildRequires: ncurses-devel
[2604]35BuildRequires: openssl-devel
[5159]36BuildRequires: zlib-devel
[1640]37%if %{with gui}
38BuildRequires: qt4-devel, desktop-file-utils
39%define qt_gui --qt-gui
[1777]40%else
41%define qt_gui --no-qt-gui
[1640]42%endif
[521]43
44Vendor: Project Vine
45Distribution: Vine Linux
46
47%description
48CMake is used to control the software compilation process using simple
49platform and compiler independent configuration files. CMake generates
50native makefiles and workspaces that can be used in the compiler
51environment of your choice. CMake is quite sophisticated: it is possible
52to support complex environments requiring system configuration, pre-processor
53generation, code generation, and template instantiation.
54
[1640]55%package        gui
56Summary:        Qt GUI for %{name}
57Group:          Development/Tools
58Requires:       %{name} = %{version}-%{release}
59Requires(post): desktop-file-utils, shared-mime-info
60Requires(postun): desktop-file-utils, shared-mime-info
61
62%description    gui
63The %{name}-gui package contains the Qt based GUI for CMake.
64
65
[521]66%prep
67%setup -q
[5159]68%patch0 -p1 -b .dcmtk
[8056]69%patch1 -p1 -b .freetype2
[9748]70%patch2 -p1 -b .ruby
[5159]71
[1640]72# Fixup permissions
[5159]73#find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
[521]74
[7639]75#fix desktop file warning
76sed -i 's:\(Icon=\)\(CMakeSetup32.png\):\1/usr/share/pixmaps/\2:' Source/QtDialog/CMake.desktop
77
[521]78%build
[1777]79./bootstrap \
80    --prefix=%{_prefix} \
81    --datadir=/share/%{name} \
82    --mandir=/share/man \
[5159]83    --%{?with_bootstrap:no-}system-libs \
[1777]84    %{?qt_gui}
85
[5159]86sed -i 's/-lcurses/-lcurses -ltinfo/' Source/CMakeFiles/ccmake.dir/link.txt
[2604]87%if %{?_dist_release} == "vl5"
88sed -i 's/HAVE_SYS_WAIT_H:INTERNAL=/HAVE_SYS_WAIT_H:INTERNAL=1/' CMakeCache.txt
89%endif
90
[1640]91make VERBOSE=1 %{?_smp_mflags}
[521]92
93%install
94rm -rf $RPM_BUILD_ROOT
[1640]95make install DESTDIR=$RPM_BUILD_ROOT
[521]96
[1640]97find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
[521]98rm -rf $RPM_BUILD_ROOT/usr/doc
99
100# RPM macros
101install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
102sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
103touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
104
[1640]105%if %{with gui}
106# Desktop file
107desktop-file-install --delete-original \
108  --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
109  $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
110%endif
111
112
[521]113%clean
114rm -rf $RPM_BUILD_ROOT
115
[1640]116%if %{with gui}
117%post gui
118update-desktop-database &> /dev/null || :
119update-mime-database %{_datadir}/mime &> /dev/null || :
120
121%postun gui
122update-desktop-database &> /dev/null || :
123update-mime-database %{_datadir}/mime &> /dev/null || :
124%endif
125
126
[521]127%files
128%defattr(-,root,root)
129%doc CMakeLogo.gif ChangeLog.* Copyright.txt
130%doc Docs/*
131%doc Example/
132%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
[1640]133%{_bindir}/ccmake
134%{_bindir}/cmake
135%{_bindir}/cpack
136%{_bindir}/ctest
137%{_datadir}/%{name}/
[5159]138%{_datadir}/aclocal/cmake.m4
[521]139%{_mandir}/man1/*
140
[1640]141%if %{with gui}
142%files gui
143%defattr(-,root,root,-)
144%{_bindir}/cmake-gui
145%{_datadir}/applications/CMake.desktop
146%{_datadir}/mime/packages/cmakecache.xml
147%{_datadir}/pixmaps/CMakeSetup32.png
148%endif
149
150
[521]151%changelog
[9748]152* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
153- update to 2.8.12.2
154- add Patch2 (cmake-2.8.12.2-ruby-2.2.x.patch)
155
[8758]156* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-2
157- rebuild with libarchive-3.1.2
158
[8056]159* Mon Dec 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-1
160- new upstream release
161- add Patch1 (cmake-2.8.12.1-FindFreetype.patch)
162
[7728]163* Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11.2-1
164- new upstream release
165
[7712]166* Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11-1
167- new upstream release
168
[7639]169* Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10.2-1
170- new upstream release
171- fixed desktop file warning
172
[6304]173* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
[6305]174- rebuild with libarchive-3.0.4
[6304]175
[5159]176* Sat Nov 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.6-1
177- new upstream release
178- forced to link with libtinfo.so (ccmake)
179- used --system-libs again
180
[2604]181* Sat Jan  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
182- new upstream release
183- used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
184
[1777]185* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
186- fixed typo (not --with-system-libs, but --system-libs)
187- added BR: curl-devel, expat-devel, zlib-devel
188
[1643]189* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
190- add BuildRequires: ncurses-devel
191
[1640]192* Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
193- generate gui package
194- renamed module directory
195
[1442]196* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
197- new upstream release
198
[521]199* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
200- rebuilt with new toolchain
201
202* Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
203- imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
204
205* Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
206- new upstream release
207- added Vendor/Distribution tag
208
209* Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
210- new upstream release
211
212* Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
213- new upstream release
214
215* Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
216- new upstream release
217
218* Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
219- new upstream release
220
221* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
222- new upstream release
223- drop Patch100
224- use bootstrap script instead of configure
225- delete caches from %%doc
226
227* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
228- rebuilt with new toolchain
229
230* Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
231- new upstream release
232- delete duped docs
233
234* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
235- added Patch100 (especially for ppc to solve ppc/powerpc issue)
236
237* Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
238- source version up
239
240* Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
241- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.