source: projects/specs/trunk/c/clutter/clutter-vl.spec @ 9073

Revision 9073, 11.3 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME 3.14.1

Line 
1%define         clutter_version 1.20.0
2%define         clutter_release 1%{?_dist_release}
3
4Name:           clutter
5Version:        %{clutter_version}
6Release:        %{clutter_release}
7Summary:        Open Source software library for creating rich graphical user interfaces
8Summary(ja):    リッチなGUIを作成するためのオープンソースライブラリ
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.clutter-project.org/
13Source0:        http://www.clutter-project.org/sources/%{name}/1.20/%{name}-%{version}.tar.xz
14
15Patch0:         clutter-fixdso.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Requires:       gobject-introspection
20# FIXME to remove when all the bits have been merged into their
21# libraries
22
23BuildRequires:  glib2-devel
24BuildRequires:  mesa-libGL-devel
25BuildRequires:  mesa-libEGL-devel
26BuildRequires:  gdk-pixbuf2-devel
27BuildRequires:  atk-devel
28BuildRequires:  pkgconfig
29BuildRequires:  pango-devel
30BuildRequires:  libXdamage-devel
31BuildRequires:  libXcomposite-devel
32BuildRequires:  libXi-devel
33BuildRequires:  gettext
34BuildRequires:  gtk-doc
35BuildRequires:  gobject-introspection-devel >= 0.9.5
36BuildRequires:  json-glib-devel
37BuildRequires:  cogl-devel >= 1.18.0
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41Packager:       Takemikaduchi
42
43%description
44Clutter is an open source software library for creating fast,
45visually rich graphical user interfaces. The most obvious example
46of potential usage is in media center type applications.
47We hope however it can be used for a lot more.
48
49%description -l ja
50Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
51最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
52しかしながら、我々はいろいろな分野で使用されることを願っています。
53
54%package                devel
55Summary:        Clutter development environment
56Summary(ja):    Clutterの開発環境
57Group:          Development/Libraries
58Requires:       %{name} = %{version}-%{release}
59Requires:       pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
60Requires:       mesa-libGL-devel
61Requires:       mesa-libEGL-devel
62Requires:       gobject-introspection-devel
63Requires:               json-glib-devel
64Requires:               libXcomposite-devel
65Requires:               libXi-devel
66
67%description    devel
68Header files and libraries for building a extension library for the
69clutter
70
71
72%package        docs
73Summary:        Documentation for %{name}
74Summary(ja):    %{name}用のドキュメント
75Group:          Documentation
76Provides:               %{name}-doc = %{version}-%{release}
77BuildArch:              noarch
78Requires:       %{name} = %{version}-%{release}
79
80%description    docs
81Clutter is an open source software library for creating fast,
82visually rich graphical user interfaces. The most obvious example
83of potential usage is in media center type applications.
84We hope however it can be used for a lot more.
85
86This package contains documentation for clutter.
87
88
89%prep
90%setup -q
91%patch0 -p1 -b .dso
92
93
94%build
95#%configure --enable-gtk-doc \
96#       --enable-introspection=yes \
97#       --disable-silent-rules \
98#       --enable-xinput \
99#       --disable-static
100(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
101 %configure $CONFIGFLAGS \
102        --enable-introspection=yes \
103        --disable-silent-rules \
104        --enable-xinput \
105        --disable-static \
106        --enable-egl-backend=yes
107 # clutter git ships with some magic to put the git log in shipped tarballs
108 # which gets listed in files; don't blow up if it's missing
109 if ! test -f ChangeLog; then
110   echo "Created from snapshot" > ChangeLog
111 fi
112)
113
114make V=0
115
116%install
117rm -rf $RPM_BUILD_ROOT
118#make DESTDIR=$RPM_BUILD_ROOT install
119make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
120
121rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
122
123%find_lang %{name}-1.0
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%post -p /sbin/ldconfig
129%postun -p /sbin/ldconfig
130
131%files -f %{name}-1.0.lang
132%defattr(-,root,root,-)
133%doc AUTHORS COPYING NEWS README
134%{_libdir}/*.so.*
135%{_libdir}/girepository-1.0/*.typelib
136
137%files devel
138%defattr(-, root, root)
139%doc ChangeLog
140%{_includedir}/clutter-1.0
141%{_libdir}/*.so
142%{_libdir}/pkgconfig/*.pc
143%{_datadir}/gir-1.0/*.gir
144
145%files docs
146%defattr(-, root, root)
147%{_datadir}/gtk-doc/html/clutter
148%{_datadir}/gtk-doc/html/cally
149
150
151%changelog
152* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-1
153- new upstream release
154- add BuildRequires: mesa-libEGL-devel
155
156* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.4-1
157- new upstream release
158
159* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
160- new upstream release
161
162* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
163- new upstream release
164
165* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.4-1
166- new upstream release
167
168* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
169- new upstream release
170
171* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
172- new upstream release
173
174* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-1
175- new upstream release
176
177* Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
178- new upstream release
179
180* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
181- new upstream release
182
183* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
184- new upstream release
185
186* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
187- new upstream release
188
189* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
190- new upstream release
191
192* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
193- new upstream release
194
195* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
196- new upstream release
197
198* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
199- new upstream release
200
201* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
202- new upstream release
203
204* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
205- new upstream release
206- add Requires: libXcomposite-devel, libXi-devel (-devel package)
207
208* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
209- new upstream release
210
211* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
212- new upstream release
213
214* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
215- new upstream release
216
217* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
218- new upstream release
219- add BuildRequires: cogl-devel
220- add "BuildArch: noarch" to doc sub package
221- add Patch0 (clutter-fixdso.patch)
222
223* Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
224- new upstream release
225
226* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
227- new upstream release
228
229* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
230- new upstream release
231
232* Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
233- new upstream release
234
235* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
236- new upstream release
237- change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
238- add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
239- drop Patch0
240
241* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
242- new upstream release
243- drop Patch1
244
245* Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
246- new upstream release
247- add BuildRequires: json-glib-devel
248- delete Requires: gir-repository
249- delete BuildRequires: gir-repository-devel
250- add Requires: json-glib-devel (devel package)
251- add Patch0, Patch1
252- fix %build
253
254* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
255- rebuild with rpm-4.8.1 for pkg-config file
256
257* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
258- new upstream release
259
260* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
261- new upstream release
262
263* Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
264- new upstream release
265- add configure option (--enable-xinput)
266
267* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
268- new upstream release
269
270* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
271- new upstream release
272
273* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
274- new upstream release
275
276* Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
277- new upstream release
278
279* Tue Dec  1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
280- new upstream release
281- build for Vine Linux
282- add Summary(ja)
283- fix BuildRoot
284- remove Obsolete and Provides
285
286* Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
287- Update to 1.0.6
288
289* Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
290- Update to 1.0.4, update gobject-introspection requirement
291
292* Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
293- Update to 1.0.2
294
295* Sat Aug  1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
296- Move ChangeLog to -devel to save some space
297
298* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
299- Drop the gir-repository-devel dep, which pulls a bunch of -devel
300  onto the live cd
301
302* Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
303- Update to 1.0.0
304
305* Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
306- fix bz #507389
307
308* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
309- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
310
311* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
312- Update to 0.9.8
313
314* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
315- Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
316  introspection support to clutter (#512260)
317
318* Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
319- Update to 0.9.6
320
321* Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
322- Update to 0.9.4
323
324* Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
325- Update to 0.9.2
326
327* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
328- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
329
330
331* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
332- Remove noarch from doc subpackage
333
334* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
335- Added gtk-doc for cogl
336- Created doc subpackage
337
338* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
339- Update to 0.8.6
340
341* Mon Oct  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
342- Update to 0.8.2
343- Removed clutter-0.8.0-clutter-fixed.patch
344
345* Sat Sep  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
346- Update to 0.8.0
347- Added clutter-0.8.0-clutter-fixed.patch
348
349* Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
350- Update to 0.6.4
351
352* Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
353- Update to 0.6.2
354
355* Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
356- Update to 0.6.0
357
358* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
359- Autorebuild for GCC 4.3
360
361* Wed Oct  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
362- Update to 0.4.2
363
364* Mon Sep  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
365- Update to 0.4.1
366
367* Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
368- Update to 0.3.1
369
370* Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
371- Update to 0.2.3
372
373* Wed Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
374- Changed buildrequires and requires
375
376* Tue Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
377- Fix .spec
378
379* Sat Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
380- Fix .spec
381
382* Fri Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
383- Initial RPM release
Note: See TracBrowser for help on using the repository browser.