source: projects/specs/trunk/c/clutter/clutter-vl.spec @ 9475

Revision 9475, 11.4 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME-3.16.0

Line 
1%define         clutter_version 1.22.0
2%define         clutter_release 1%{?_dist_release}
3
4Name:           clutter
5Version:        %{clutter_version}
6Release:        %{clutter_release}
7Summary:        Open Source software library for creating rich graphical user interfaces
8Summary(ja):    リッチなGUIを作成するためのオープンソースライブラリ
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.clutter-project.org/
13Source0:        http://www.clutter-project.org/sources/%{name}/1.22/%{name}-%{version}.tar.xz
14
15Patch0:         clutter-fixdso.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Requires:       gobject-introspection
20# FIXME to remove when all the bits have been merged into their
21# libraries
22
23BuildRequires:  glib2-devel
24BuildRequires:  mesa-libGL-devel
25BuildRequires:  mesa-libEGL-devel
26BuildRequires:  gdk-pixbuf2-devel
27BuildRequires:  atk-devel
28BuildRequires:  pkgconfig
29BuildRequires:  pango-devel
30BuildRequires:  libXdamage-devel
31BuildRequires:  libXcomposite-devel
32BuildRequires:  libXi-devel
33BuildRequires:  gettext
34BuildRequires:  gtk-doc
35BuildRequires:  gobject-introspection-devel >= 0.9.5
36BuildRequires:  json-glib-devel
37BuildRequires:  cogl-devel >= 1.20.0
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41Packager:       Takemikaduchi
42
43%description
44Clutter is an open source software library for creating fast,
45visually rich graphical user interfaces. The most obvious example
46of potential usage is in media center type applications.
47We hope however it can be used for a lot more.
48
49%description -l ja
50Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
51最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
52しかしながら、我々はいろいろな分野で使用されることを願っています。
53
54%package                devel
55Summary:        Clutter development environment
56Summary(ja):    Clutterの開発環境
57Group:          Development/Libraries
58Requires:       %{name} = %{version}-%{release}
59Requires:       pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
60Requires:       mesa-libGL-devel
61Requires:       mesa-libEGL-devel
62Requires:       gobject-introspection-devel
63Requires:               json-glib-devel
64Requires:               libXcomposite-devel
65Requires:               libXi-devel
66
67%description    devel
68Header files and libraries for building a extension library for the
69clutter
70
71
72%package        docs
73Summary:        Documentation for %{name}
74Summary(ja):    %{name}用のドキュメント
75Group:          Documentation
76Provides:               %{name}-doc = %{version}-%{release}
77BuildArch:              noarch
78
79%description    docs
80Clutter is an open source software library for creating fast,
81visually rich graphical user interfaces. The most obvious example
82of potential usage is in media center type applications.
83We hope however it can be used for a lot more.
84
85This package contains documentation for clutter.
86
87
88%prep
89%setup -q
90%patch0 -p1 -b .dso
91
92
93%build
94#%configure --enable-gtk-doc \
95#       --enable-introspection=yes \
96#       --disable-silent-rules \
97#       --enable-xinput \
98#       --disable-static
99(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
100 %configure $CONFIGFLAGS \
101        --enable-introspection=yes \
102        --disable-silent-rules \
103        --enable-xinput \
104        --disable-static \
105        --enable-egl-backend=yes
106 # clutter git ships with some magic to put the git log in shipped tarballs
107 # which gets listed in files; don't blow up if it's missing
108 if ! test -f ChangeLog; then
109   echo "Created from snapshot" > ChangeLog
110 fi
111)
112
113make V=0
114
115%install
116rm -rf $RPM_BUILD_ROOT
117#make DESTDIR=$RPM_BUILD_ROOT install
118make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
119
120rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
121
122%find_lang %{name}-1.0
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%post -p /sbin/ldconfig
128%postun -p /sbin/ldconfig
129
130%files -f %{name}-1.0.lang
131%defattr(-,root,root,-)
132%doc AUTHORS COPYING NEWS README
133%{_libdir}/*.so.*
134%{_libdir}/girepository-1.0/*.typelib
135
136%files devel
137%defattr(-, root, root)
138%doc ChangeLog
139%{_includedir}/clutter-1.0
140%{_libdir}/*.so
141%{_libdir}/pkgconfig/*.pc
142%{_datadir}/gir-1.0/*.gir
143
144%files docs
145%defattr(-, root, root)
146%{_datadir}/gtk-doc/html/clutter
147%{_datadir}/gtk-doc/html/cally
148
149
150%changelog
151* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.0-1
152- new upstream release
153
154* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-1
155- new upstream release
156- add BuildRequires: mesa-libEGL-devel
157
158* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.4-1
159- new upstream release
160
161* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
162- new upstream release
163
164* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
165- new upstream release
166
167* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.4-1
168- new upstream release
169
170* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
171- new upstream release
172
173* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
174- new upstream release
175
176* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-1
177- new upstream release
178
179* Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
180- new upstream release
181
182* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
183- new upstream release
184
185* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
186- new upstream release
187
188* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
189- new upstream release
190
191* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
192- new upstream release
193
194* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
195- new upstream release
196
197* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
198- new upstream release
199
200* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
201- new upstream release
202
203* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
204- new upstream release
205
206* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
207- new upstream release
208- add Requires: libXcomposite-devel, libXi-devel (-devel package)
209
210* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
211- new upstream release
212
213* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
214- new upstream release
215
216* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
217- new upstream release
218
219* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
220- new upstream release
221- add BuildRequires: cogl-devel
222- add "BuildArch: noarch" to doc sub package
223- add Patch0 (clutter-fixdso.patch)
224
225* Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
226- new upstream release
227
228* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
229- new upstream release
230
231* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
232- new upstream release
233
234* Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
235- new upstream release
236
237* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
238- new upstream release
239- change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
240- add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
241- drop Patch0
242
243* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
244- new upstream release
245- drop Patch1
246
247* Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
248- new upstream release
249- add BuildRequires: json-glib-devel
250- delete Requires: gir-repository
251- delete BuildRequires: gir-repository-devel
252- add Requires: json-glib-devel (devel package)
253- add Patch0, Patch1
254- fix %build
255
256* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
257- rebuild with rpm-4.8.1 for pkg-config file
258
259* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
260- new upstream release
261
262* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
263- new upstream release
264
265* Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
266- new upstream release
267- add configure option (--enable-xinput)
268
269* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
270- new upstream release
271
272* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
273- new upstream release
274
275* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
276- new upstream release
277
278* Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
279- new upstream release
280
281* Tue Dec  1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
282- new upstream release
283- build for Vine Linux
284- add Summary(ja)
285- fix BuildRoot
286- remove Obsolete and Provides
287
288* Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
289- Update to 1.0.6
290
291* Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
292- Update to 1.0.4, update gobject-introspection requirement
293
294* Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
295- Update to 1.0.2
296
297* Sat Aug  1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
298- Move ChangeLog to -devel to save some space
299
300* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
301- Drop the gir-repository-devel dep, which pulls a bunch of -devel
302  onto the live cd
303
304* Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
305- Update to 1.0.0
306
307* Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
308- fix bz #507389
309
310* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
311- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
312
313* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
314- Update to 0.9.8
315
316* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
317- Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
318  introspection support to clutter (#512260)
319
320* Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
321- Update to 0.9.6
322
323* Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
324- Update to 0.9.4
325
326* Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
327- Update to 0.9.2
328
329* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
330- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
331
332
333* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
334- Remove noarch from doc subpackage
335
336* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
337- Added gtk-doc for cogl
338- Created doc subpackage
339
340* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
341- Update to 0.8.6
342
343* Mon Oct  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
344- Update to 0.8.2
345- Removed clutter-0.8.0-clutter-fixed.patch
346
347* Sat Sep  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
348- Update to 0.8.0
349- Added clutter-0.8.0-clutter-fixed.patch
350
351* Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
352- Update to 0.6.4
353
354* Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
355- Update to 0.6.2
356
357* Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
358- Update to 0.6.0
359
360* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
361- Autorebuild for GCC 4.3
362
363* Wed Oct  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
364- Update to 0.4.2
365
366* Mon Sep  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
367- Update to 0.4.1
368
369* Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
370- Update to 0.3.1
371
372* Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
373- Update to 0.2.3
374
375* Wed Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
376- Changed buildrequires and requires
377
378* Tue Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
379- Fix .spec
380
381* Sat Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
382- Fix .spec
383
384* Fri Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
385- Initial RPM release
Note: See TracBrowser for help on using the repository browser.