source: projects/specs/trunk/c/clutter/clutter-vl.spec @ 4732

Revision 4732, 9.4 KB checked in by Takemikaduchi, 13 years ago (diff)

gimp: fix security issue, others: new upstream release

Line 
1%define         clutter_version 1.7.14
2%define         clutter_release 1%{?_dist_release}
3
4Name:           clutter
5Version:        %{clutter_version}
6Release:        %{clutter_release}
7Summary:        Open Source software library for creating rich graphical user interfaces
8Summary(ja):    リッチなGUIを作成するためのオープンソースライブラリ
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.clutter-project.org/
13Source0:        http://www.clutter-project.org/sources/%{name}/1.7/%{name}-%{version}.tar.xz
14
15Patch0:         clutter-fixdso.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Requires:       gobject-introspection
20# FIXME to remove when all the bits have been merged into their
21# libraries
22
23BuildRequires:  glib2-devel
24BuildRequires:  mesa-libGL-devel
25BuildRequires:  gdk-pixbuf2-devel
26BuildRequires:  atk-devel
27BuildRequires:  pkgconfig
28BuildRequires:  pango-devel
29BuildRequires:  libXdamage-devel
30BuildRequires:  libXcomposite-devel
31BuildRequires:  libXi-devel
32BuildRequires:  gettext
33BuildRequires:  gtk-doc
34BuildRequires:  gobject-introspection-devel >= 0.9.5
35BuildRequires:  json-glib-devel
36BuildRequires:  cogl-devel >= 1.7.4
37
38Vendor:         Project Vine
39Distribution:   Vine Linux
40Packager:       Takemikaduchi
41
42%description
43Clutter is an open source software library for creating fast,
44visually rich graphical user interfaces. The most obvious example
45of potential usage is in media center type applications.
46We hope however it can be used for a lot more.
47
48%description -l ja
49Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
50最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
51しかしながら、我々はいろいろな分野で使用されることを願っています。
52
53%package devel
54Summary:        Clutter development environment
55Summary(ja):    Clutterの開発環境
56Group:          Development/Libraries
57Requires:       %{name} = %{version}-%{release}
58Requires:       pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
59Requires:       mesa-libGL-devel
60Requires:       gobject-introspection-devel
61Requires:       json-glib-devel
62
63%description devel
64Header files and libraries for building a extension library for the
65clutter
66
67
68%package        doc
69Summary:        Documentation for %{name}
70Summary(ja):    %{name}用のドキュメント
71Group:          Documentation
72Requires:       %{name} = %{version}-%{release}
73BuildArch:      noarch
74
75%description    doc
76Clutter is an open source software library for creating fast,
77visually rich graphical user interfaces. The most obvious example
78of potential usage is in media center type applications.
79We hope however it can be used for a lot more.
80
81This package contains documentation for clutter.
82
83
84%prep
85%setup -q
86%patch0 -p1 -b .dso
87
88
89%build
90#%configure --enable-gtk-doc \
91#       --enable-introspection=yes \
92#       --disable-silent-rules \
93#       --enable-xinput \
94#       --disable-static
95(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
96 %configure $CONFIGFLAGS \
97        --enable-introspection=yes \
98        --disable-silent-rules \
99        --enable-xinput \
100        --disable-static
101 # clutter git ships with some magic to put the git log in shipped tarballs
102 # which gets listed in files; don't blow up if it's missing
103 if ! test -f ChangeLog; then
104   echo "Created from snapshot" > ChangeLog
105 fi
106)
107
108make V=0
109
110%install
111rm -rf $RPM_BUILD_ROOT
112#make DESTDIR=$RPM_BUILD_ROOT install
113make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
114
115rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
116
117%find_lang %{name}-1.0
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post -p /sbin/ldconfig
123%postun -p /sbin/ldconfig
124
125%files -f %{name}-1.0.lang
126%defattr(-,root,root,-)
127%doc AUTHORS COPYING NEWS README
128%{_libdir}/*.so.*
129%{_libdir}/girepository-1.0/*.typelib
130
131%files devel
132%defattr(-, root, root)
133%doc ChangeLog
134%{_includedir}/clutter-1.0
135%{_libdir}/*.so
136%{_libdir}/pkgconfig/*.pc
137%{_datadir}/gir-1.0/*.gir
138
139%files doc
140%defattr(-, root, root)
141%{_datadir}/gtk-doc/html/clutter
142%{_datadir}/gtk-doc/html/cally
143
144
145%changelog
146* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
147- new upstream release
148
149* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
150- new upstream release
151
152* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
153- new upstream release
154
155* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
156- new upstream release
157- add BuildRequires: cogl-devel
158- add "BuildArch: noarch" to doc sub package
159- add Patch0 (clutter-fixdso.patch)
160
161* Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
162- new upstream release
163
164* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
165- new upstream release
166
167* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
168- new upstream release
169
170* Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
171- new upstream release
172
173* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
174- new upstream release
175- change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
176- add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
177- drop Patch0
178
179* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
180- new upstream release
181- drop Patch1
182
183* Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
184- new upstream release
185- add BuildRequires: json-glib-devel
186- delete Requires: gir-repository
187- delete BuildRequires: gir-repository-devel
188- add Requires: json-glib-devel (devel package)
189- add Patch0, Patch1
190- fix %build
191
192* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
193- rebuild with rpm-4.8.1 for pkg-config file
194
195* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
196- new upstream release
197
198* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
199- new upstream release
200
201* Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
202- new upstream release
203- add configure option (--enable-xinput)
204
205* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
206- new upstream release
207
208* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
209- new upstream release
210
211* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
212- new upstream release
213
214* Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
215- new upstream release
216
217* Tue Dec  1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
218- new upstream release
219- build for Vine Linux
220- add Summary(ja)
221- fix BuildRoot
222- remove Obsolete and Provides
223
224* Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
225- Update to 1.0.6
226
227* Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
228- Update to 1.0.4, update gobject-introspection requirement
229
230* Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
231- Update to 1.0.2
232
233* Sun Aug  1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
234- Move ChangeLog to -devel to save some space
235
236* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
237- Drop the gir-repository-devel dep, which pulls a bunch of -devel
238  onto the live cd
239
240* Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
241- Update to 1.0.0
242
243* Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
244- fix bz #507389
245
246* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
247- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
248
249* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
250- Update to 0.9.8
251
252* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
253- Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
254  introspection support to clutter (#512260)
255
256* Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
257- Update to 0.9.6
258
259* Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
260- Update to 0.9.4
261
262* Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
263- Update to 0.9.2
264
265* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
266- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
267
268
269* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
270- Remove noarch from doc subpackage
271
272* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
273- Added gtk-doc for cogl
274- Created doc subpackage
275
276* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
277- Update to 0.8.6
278
279* Mon Oct  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
280- Update to 0.8.2
281- Removed clutter-0.8.0-clutter-fixed.patch
282
283* Sat Sep  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
284- Update to 0.8.0
285- Added clutter-0.8.0-clutter-fixed.patch
286
287* Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
288- Update to 0.6.4
289
290* Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
291- Update to 0.6.2
292
293* Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
294- Update to 0.6.0
295
296* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
297- Autorebuild for GCC 4.3
298
299* Wed Oct  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
300- Update to 0.4.2
301
302* Mon Sep  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
303- Update to 0.4.1
304
305* Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
306- Update to 0.3.1
307
308* Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
309- Update to 0.2.3
310
311* Sun Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
312- Changed buildrequires and requires
313
314* Sun Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
315- Fix .spec
316
317* Sun Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
318- Fix .spec
319
320* Sun Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
321- Initial RPM release
Note: See TracBrowser for help on using the repository browser.