source: projects/specs/trunk/c/clutter/clutter-vl.spec @ 4812

Revision 4812, 9.6 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.1.92

Line 
1%define         clutter_version 1.8.0
2%define         clutter_release 1%{?_dist_release}
3
4Name:           clutter
5Version:        %{clutter_version}
6Release:        %{clutter_release}
7Summary:        Open Source software library for creating rich graphical user interfaces
8Summary(ja):    リッチなGUIを作成するためのオープンソースライブラリ
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.clutter-project.org/
13Source0:        http://www.clutter-project.org/sources/%{name}/1.8/%{name}-%{version}.tar.xz
14
15Patch0:         clutter-fixdso.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Requires:       gobject-introspection
20# FIXME to remove when all the bits have been merged into their
21# libraries
22
23BuildRequires:  glib2-devel
24BuildRequires:  mesa-libGL-devel
25BuildRequires:  gdk-pixbuf2-devel
26BuildRequires:  atk-devel
27BuildRequires:  pkgconfig
28BuildRequires:  pango-devel
29BuildRequires:  libXdamage-devel
30BuildRequires:  libXcomposite-devel
31BuildRequires:  libXi-devel
32BuildRequires:  gettext
33BuildRequires:  gtk-doc
34BuildRequires:  gobject-introspection-devel >= 0.9.5
35BuildRequires:  json-glib-devel
36BuildRequires:  cogl-devel >= 1.8.0
37
38Vendor:         Project Vine
39Distribution:   Vine Linux
40Packager:       Takemikaduchi
41
42%description
43Clutter is an open source software library for creating fast,
44visually rich graphical user interfaces. The most obvious example
45of potential usage is in media center type applications.
46We hope however it can be used for a lot more.
47
48%description -l ja
49Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
50最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
51しかしながら、我々はいろいろな分野で使用されることを願っています。
52
53%package devel
54Summary:        Clutter development environment
55Summary(ja):    Clutterの開発環境
56Group:          Development/Libraries
57Requires:       %{name} = %{version}-%{release}
58Requires:       pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
59Requires:       mesa-libGL-devel
60Requires:       gobject-introspection-devel
61Requires:       json-glib-devel
62Requires:       libXcomposite-devel
63Requires:       libXi-devel
64
65%description devel
66Header files and libraries for building a extension library for the
67clutter
68
69
70%package        doc
71Summary:        Documentation for %{name}
72Summary(ja):    %{name}用のドキュメント
73Group:          Documentation
74Requires:       %{name} = %{version}-%{release}
75BuildArch:      noarch
76
77%description    doc
78Clutter is an open source software library for creating fast,
79visually rich graphical user interfaces. The most obvious example
80of potential usage is in media center type applications.
81We hope however it can be used for a lot more.
82
83This package contains documentation for clutter.
84
85
86%prep
87%setup -q
88%patch0 -p1 -b .dso
89
90
91%build
92#%configure --enable-gtk-doc \
93#       --enable-introspection=yes \
94#       --disable-silent-rules \
95#       --enable-xinput \
96#       --disable-static
97(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
98 %configure $CONFIGFLAGS \
99        --enable-introspection=yes \
100        --disable-silent-rules \
101        --enable-xinput \
102        --disable-static
103 # clutter git ships with some magic to put the git log in shipped tarballs
104 # which gets listed in files; don't blow up if it's missing
105 if ! test -f ChangeLog; then
106   echo "Created from snapshot" > ChangeLog
107 fi
108)
109
110make V=0
111
112%install
113rm -rf $RPM_BUILD_ROOT
114#make DESTDIR=$RPM_BUILD_ROOT install
115make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
116
117rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
118
119%find_lang %{name}-1.0
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
127%files -f %{name}-1.0.lang
128%defattr(-,root,root,-)
129%doc AUTHORS COPYING NEWS README
130%{_libdir}/*.so.*
131%{_libdir}/girepository-1.0/*.typelib
132
133%files devel
134%defattr(-, root, root)
135%doc ChangeLog
136%{_includedir}/clutter-1.0
137%{_libdir}/*.so
138%{_libdir}/pkgconfig/*.pc
139%{_datadir}/gir-1.0/*.gir
140
141%files doc
142%defattr(-, root, root)
143%{_datadir}/gtk-doc/html/clutter
144%{_datadir}/gtk-doc/html/cally
145
146
147%changelog
148* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
149- new upstream release
150- add Requires: libXcomposite-devel, libXi-devel (-devel package)
151
152* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
153- new upstream release
154
155* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
156- new upstream release
157
158* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
159- new upstream release
160
161* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
162- new upstream release
163- add BuildRequires: cogl-devel
164- add "BuildArch: noarch" to doc sub package
165- add Patch0 (clutter-fixdso.patch)
166
167* Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
168- new upstream release
169
170* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
171- new upstream release
172
173* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
174- new upstream release
175
176* Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
177- new upstream release
178
179* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
180- new upstream release
181- change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
182- add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
183- drop Patch0
184
185* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
186- new upstream release
187- drop Patch1
188
189* Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
190- new upstream release
191- add BuildRequires: json-glib-devel
192- delete Requires: gir-repository
193- delete BuildRequires: gir-repository-devel
194- add Requires: json-glib-devel (devel package)
195- add Patch0, Patch1
196- fix %build
197
198* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
199- rebuild with rpm-4.8.1 for pkg-config file
200
201* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
202- new upstream release
203
204* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
205- new upstream release
206
207* Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
208- new upstream release
209- add configure option (--enable-xinput)
210
211* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
212- new upstream release
213
214* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
215- new upstream release
216
217* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
218- new upstream release
219
220* Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
221- new upstream release
222
223* Tue Dec  1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
224- new upstream release
225- build for Vine Linux
226- add Summary(ja)
227- fix BuildRoot
228- remove Obsolete and Provides
229
230* Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
231- Update to 1.0.6
232
233* Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
234- Update to 1.0.4, update gobject-introspection requirement
235
236* Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
237- Update to 1.0.2
238
239* Sun Aug  1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
240- Move ChangeLog to -devel to save some space
241
242* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
243- Drop the gir-repository-devel dep, which pulls a bunch of -devel
244  onto the live cd
245
246* Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
247- Update to 1.0.0
248
249* Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
250- fix bz #507389
251
252* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
253- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
254
255* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
256- Update to 0.9.8
257
258* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
259- Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
260  introspection support to clutter (#512260)
261
262* Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
263- Update to 0.9.6
264
265* Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
266- Update to 0.9.4
267
268* Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
269- Update to 0.9.2
270
271* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
272- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
273
274
275* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
276- Remove noarch from doc subpackage
277
278* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
279- Added gtk-doc for cogl
280- Created doc subpackage
281
282* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
283- Update to 0.8.6
284
285* Mon Oct  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
286- Update to 0.8.2
287- Removed clutter-0.8.0-clutter-fixed.patch
288
289* Sat Sep  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
290- Update to 0.8.0
291- Added clutter-0.8.0-clutter-fixed.patch
292
293* Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
294- Update to 0.6.4
295
296* Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
297- Update to 0.6.2
298
299* Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
300- Update to 0.6.0
301
302* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
303- Autorebuild for GCC 4.3
304
305* Wed Oct  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
306- Update to 0.4.2
307
308* Mon Sep  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
309- Update to 0.4.1
310
311* Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
312- Update to 0.3.1
313
314* Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
315- Update to 0.2.3
316
317* Sun Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
318- Changed buildrequires and requires
319
320* Sun Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
321- Fix .spec
322
323* Sun Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
324- Fix .spec
325
326* Sun Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
327- Initial RPM release
Note: See TracBrowser for help on using the repository browser.