source: projects/specs/trunk/c/clutter/clutter-vl.spec @ 7681

Revision 7681, 10.5 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME 3.8.2

RevLine 
[7681]1%define         clutter_version 1.14.4
[2041]2%define         clutter_release 1%{?_dist_release}
[521]3
4Name:           clutter
5Version:        %{clutter_version}
6Release:        %{clutter_release}
7Summary:        Open Source software library for creating rich graphical user interfaces
8Summary(ja):    リッチなGUIを作成するためのオープンソースライブラリ
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.clutter-project.org/
[7633]13Source0:        http://www.clutter-project.org/sources/%{name}/1.14/%{name}-%{version}.tar.xz
[2041]14
[4616]15Patch0:         clutter-fixdso.patch
[2041]16
[521]17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Requires:       gobject-introspection
20# FIXME to remove when all the bits have been merged into their
21# libraries
22
23BuildRequires:  glib2-devel
24BuildRequires:  mesa-libGL-devel
[2721]25BuildRequires:  gdk-pixbuf2-devel
26BuildRequires:  atk-devel
[521]27BuildRequires:  pkgconfig
28BuildRequires:  pango-devel
29BuildRequires:  libXdamage-devel
[2721]30BuildRequires:  libXcomposite-devel
31BuildRequires:  libXi-devel
[521]32BuildRequires:  gettext
33BuildRequires:  gtk-doc
[2041]34BuildRequires:  gobject-introspection-devel >= 0.9.5
35BuildRequires:  json-glib-devel
[6890]36BuildRequires:  cogl-devel >= 1.12.0
[521]37
[4732]38Vendor:         Project Vine
39Distribution:   Vine Linux
40Packager:       Takemikaduchi
[4616]41
[521]42%description
43Clutter is an open source software library for creating fast,
44visually rich graphical user interfaces. The most obvious example
45of potential usage is in media center type applications.
46We hope however it can be used for a lot more.
47
48%description -l ja
49Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
50最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
51しかしながら、我々はいろいろな分野で使用されることを願っています。
52
53%package devel
54Summary:        Clutter development environment
55Summary(ja):    Clutterの開発環境
56Group:          Development/Libraries
57Requires:       %{name} = %{version}-%{release}
[2721]58Requires:       pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
[521]59Requires:       mesa-libGL-devel
60Requires:       gobject-introspection-devel
[2041]61Requires:       json-glib-devel
[4812]62Requires:       libXcomposite-devel
63Requires:       libXi-devel
[521]64
65%description devel
66Header files and libraries for building a extension library for the
67clutter
68
69
70%package        doc
71Summary:        Documentation for %{name}
72Summary(ja):    %{name}用のドキュメント
73Group:          Documentation
74Requires:       %{name} = %{version}-%{release}
[4616]75BuildArch:      noarch
[521]76
77%description    doc
78Clutter is an open source software library for creating fast,
79visually rich graphical user interfaces. The most obvious example
80of potential usage is in media center type applications.
81We hope however it can be used for a lot more.
82
83This package contains documentation for clutter.
84
85
86%prep
87%setup -q
[4616]88%patch0 -p1 -b .dso
[521]89
[2041]90
[521]91%build
[2041]92#%configure --enable-gtk-doc \
93#       --enable-introspection=yes \
94#       --disable-silent-rules \
95#       --enable-xinput \
96#       --disable-static
97(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
98 %configure $CONFIGFLAGS \
99        --enable-introspection=yes \
100        --disable-silent-rules \
101        --enable-xinput \
102        --disable-static
103 # clutter git ships with some magic to put the git log in shipped tarballs
104 # which gets listed in files; don't blow up if it's missing
105 if ! test -f ChangeLog; then
106   echo "Created from snapshot" > ChangeLog
107 fi
108)
[521]109
[2041]110make V=0
111
[521]112%install
113rm -rf $RPM_BUILD_ROOT
114#make DESTDIR=$RPM_BUILD_ROOT install
115make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
116
[4616]117rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
118
119%find_lang %{name}-1.0
120
[521]121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
[4616]127%files -f %{name}-1.0.lang
[521]128%defattr(-,root,root,-)
129%doc AUTHORS COPYING NEWS README
[4616]130%{_libdir}/*.so.*
[521]131%{_libdir}/girepository-1.0/*.typelib
132
133%files devel
134%defattr(-, root, root)
135%doc ChangeLog
[4616]136%{_includedir}/clutter-1.0
[521]137%{_libdir}/*.so
138%{_libdir}/pkgconfig/*.pc
139%{_datadir}/gir-1.0/*.gir
140
141%files doc
142%defattr(-, root, root)
143%{_datadir}/gtk-doc/html/clutter
[2041]144%{_datadir}/gtk-doc/html/cally
[521]145
146
147%changelog
[7681]148* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-1
149- new upstream release
150
[7633]151* Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
152- new upstream release
153
[6951]154* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
155- new upstream release
156
[6890]157* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
158- new upstream release
159
[6401]160* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
161- new upstream release
162
[6256]163* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
164- new upstream release
165
[6123]166* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
167- new upstream release
168
[6078]169* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
[6011]170- new upstream release
171
[5651]172* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
173- new upstream release
174
[5038]175* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
176- new upstream release
177
[4812]178* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
179- new upstream release
180- add Requires: libXcomposite-devel, libXi-devel (-devel package)
181
[4732]182* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
183- new upstream release
184
[4704]185* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
186- new upstream release
187
[4650]188* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
189- new upstream release
190
[4616]191* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
192- new upstream release
193- add BuildRequires: cogl-devel
194- add "BuildArch: noarch" to doc sub package
195- add Patch0 (clutter-fixdso.patch)
196
[3735]197* Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
198- new upstream release
199
[3079]200* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
201- new upstream release
202
[3003]203* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
204- new upstream release
205
[2739]206* Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
207- new upstream release
208
[2721]209* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
210- new upstream release
211- change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
212- add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
213- drop Patch0
214
[2415]215* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
216- new upstream release
217- drop Patch1
218
[2041]219* Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
220- new upstream release
221- add BuildRequires: json-glib-devel
222- delete Requires: gir-repository
223- delete BuildRequires: gir-repository-devel
224- add Requires: json-glib-devel (devel package)
225- add Patch0, Patch1
226- fix %build
227
[1883]228* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
229- rebuild with rpm-4.8.1 for pkg-config file
230
[1401]231* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
232- new upstream release
233
[1270]234* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
235- new upstream release
236
[1044]237* Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
238- new upstream release
239- add configure option (--enable-xinput)
240
[914]241* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
242- new upstream release
243
[805]244* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
[521]245- new upstream release
246
[805]247* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
[521]248- new upstream release
249
[805]250* Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
[521]251- new upstream release
[805]252
253* Tue Dec  1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
254- new upstream release
[521]255- build for Vine Linux
256- add Summary(ja)
257- fix BuildRoot
258- remove Obsolete and Provides
259
260* Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
261- Update to 1.0.6
262
263* Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
264- Update to 1.0.4, update gobject-introspection requirement
265
266* Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
267- Update to 1.0.2
268
[7633]269* Sat Aug  1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
[521]270- Move ChangeLog to -devel to save some space
271
272* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
273- Drop the gir-repository-devel dep, which pulls a bunch of -devel
274  onto the live cd
275
276* Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
277- Update to 1.0.0
278
279* Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
280- fix bz #507389
281
282* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
283- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
284
285* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
286- Update to 0.9.8
287
288* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
289- Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
290  introspection support to clutter (#512260)
291
292* Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
293- Update to 0.9.6
294
295* Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
296- Update to 0.9.4
297
298* Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
299- Update to 0.9.2
300
301* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
302- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
303
304
305* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
306- Remove noarch from doc subpackage
307
308* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
309- Added gtk-doc for cogl
310- Created doc subpackage
311
312* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
313- Update to 0.8.6
314
315* Mon Oct  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
316- Update to 0.8.2
317- Removed clutter-0.8.0-clutter-fixed.patch
318
319* Sat Sep  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
320- Update to 0.8.0
321- Added clutter-0.8.0-clutter-fixed.patch
322
323* Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
324- Update to 0.6.4
325
326* Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
327- Update to 0.6.2
328
329* Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
330- Update to 0.6.0
331
332* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
333- Autorebuild for GCC 4.3
334
335* Wed Oct  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
336- Update to 0.4.2
337
338* Mon Sep  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
339- Update to 0.4.1
340
341* Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
342- Update to 0.3.1
343
344* Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
345- Update to 0.2.3
346
[7633]347* Wed Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
[521]348- Changed buildrequires and requires
349
[7633]350* Tue Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
[521]351- Fix .spec
352
[7633]353* Sat Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
[521]354- Fix .spec
355
[7633]356* Fri Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
[521]357- Initial RPM release
Note: See TracBrowser for help on using the repository browser.