source: projects/specs/trunk/c/clutter/clutter-vl.spec @ 7938

Revision 7938, 10.7 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.10.1

Line 
1%define         clutter_version 1.16.0
2%define         clutter_release 1%{?_dist_release}
3
4Name:           clutter
5Version:        %{clutter_version}
6Release:        %{clutter_release}
7Summary:        Open Source software library for creating rich graphical user interfaces
8Summary(ja):    リッチなGUIを作成するためのオープンソースライブラリ
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.clutter-project.org/
13Source0:        http://www.clutter-project.org/sources/%{name}/1.16/%{name}-%{version}.tar.xz
14
15Patch0:         clutter-fixdso.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Requires:       gobject-introspection
20# FIXME to remove when all the bits have been merged into their
21# libraries
22
23BuildRequires:  glib2-devel
24BuildRequires:  mesa-libGL-devel
25BuildRequires:  gdk-pixbuf2-devel
26BuildRequires:  atk-devel
27BuildRequires:  pkgconfig
28BuildRequires:  pango-devel
29BuildRequires:  libXdamage-devel
30BuildRequires:  libXcomposite-devel
31BuildRequires:  libXi-devel
32BuildRequires:  gettext
33BuildRequires:  gtk-doc
34BuildRequires:  gobject-introspection-devel >= 0.9.5
35BuildRequires:  json-glib-devel
36BuildRequires:  cogl-devel >= 1.16.0
37
38Vendor:         Project Vine
39Distribution:   Vine Linux
40Packager:       Takemikaduchi
41
42%description
43Clutter is an open source software library for creating fast,
44visually rich graphical user interfaces. The most obvious example
45of potential usage is in media center type applications.
46We hope however it can be used for a lot more.
47
48%description -l ja
49Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
50最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
51しかしながら、我々はいろいろな分野で使用されることを願っています。
52
53%package                devel
54Summary:        Clutter development environment
55Summary(ja):    Clutterの開発環境
56Group:          Development/Libraries
57Requires:       %{name} = %{version}-%{release}
58Requires:       pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
59Requires:       mesa-libGL-devel
60Requires:       gobject-introspection-devel
61Requires:               json-glib-devel
62Requires:               libXcomposite-devel
63Requires:               libXi-devel
64
65%description    devel
66Header files and libraries for building a extension library for the
67clutter
68
69
70%package        docs
71Summary:        Documentation for %{name}
72Summary(ja):    %{name}用のドキュメント
73Group:          Documentation
74Provides:               %{name}-doc = %{version}-%{release}
75BuildArch:              noarch
76Requires:       %{name} = %{version}-%{release}
77
78%description    docs
79Clutter is an open source software library for creating fast,
80visually rich graphical user interfaces. The most obvious example
81of potential usage is in media center type applications.
82We hope however it can be used for a lot more.
83
84This package contains documentation for clutter.
85
86
87%prep
88%setup -q
89%patch0 -p1 -b .dso
90
91
92%build
93#%configure --enable-gtk-doc \
94#       --enable-introspection=yes \
95#       --disable-silent-rules \
96#       --enable-xinput \
97#       --disable-static
98(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
99 %configure $CONFIGFLAGS \
100        --enable-introspection=yes \
101        --disable-silent-rules \
102        --enable-xinput \
103        --disable-static
104 # clutter git ships with some magic to put the git log in shipped tarballs
105 # which gets listed in files; don't blow up if it's missing
106 if ! test -f ChangeLog; then
107   echo "Created from snapshot" > ChangeLog
108 fi
109)
110
111make V=0
112
113%install
114rm -rf $RPM_BUILD_ROOT
115#make DESTDIR=$RPM_BUILD_ROOT install
116make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
117
118rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
119
120%find_lang %{name}-1.0
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%post -p /sbin/ldconfig
126%postun -p /sbin/ldconfig
127
128%files -f %{name}-1.0.lang
129%defattr(-,root,root,-)
130%doc AUTHORS COPYING NEWS README
131%{_libdir}/*.so.*
132%{_libdir}/girepository-1.0/*.typelib
133
134%files devel
135%defattr(-, root, root)
136%doc ChangeLog
137%{_includedir}/clutter-1.0
138%{_libdir}/*.so
139%{_libdir}/pkgconfig/*.pc
140%{_datadir}/gir-1.0/*.gir
141
142%files docs
143%defattr(-, root, root)
144%{_datadir}/gtk-doc/html/clutter
145%{_datadir}/gtk-doc/html/cally
146
147
148%changelog
149* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
150- new upstream release
151
152* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-1
153- new upstream release
154
155* Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
156- new upstream release
157
158* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
159- new upstream release
160
161* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
162- new upstream release
163
164* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
165- new upstream release
166
167* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
168- new upstream release
169
170* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
171- new upstream release
172
173* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
174- new upstream release
175
176* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
177- new upstream release
178
179* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
180- new upstream release
181
182* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
183- new upstream release
184- add Requires: libXcomposite-devel, libXi-devel (-devel package)
185
186* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
187- new upstream release
188
189* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
190- new upstream release
191
192* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
193- new upstream release
194
195* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
196- new upstream release
197- add BuildRequires: cogl-devel
198- add "BuildArch: noarch" to doc sub package
199- add Patch0 (clutter-fixdso.patch)
200
201* Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
202- new upstream release
203
204* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
205- new upstream release
206
207* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
208- new upstream release
209
210* Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
211- new upstream release
212
213* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
214- new upstream release
215- change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
216- add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
217- drop Patch0
218
219* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
220- new upstream release
221- drop Patch1
222
223* Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
224- new upstream release
225- add BuildRequires: json-glib-devel
226- delete Requires: gir-repository
227- delete BuildRequires: gir-repository-devel
228- add Requires: json-glib-devel (devel package)
229- add Patch0, Patch1
230- fix %build
231
232* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
233- rebuild with rpm-4.8.1 for pkg-config file
234
235* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
236- new upstream release
237
238* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
239- new upstream release
240
241* Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
242- new upstream release
243- add configure option (--enable-xinput)
244
245* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
246- new upstream release
247
248* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
249- new upstream release
250
251* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
252- new upstream release
253
254* Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
255- new upstream release
256
257* Tue Dec  1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
258- new upstream release
259- build for Vine Linux
260- add Summary(ja)
261- fix BuildRoot
262- remove Obsolete and Provides
263
264* Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
265- Update to 1.0.6
266
267* Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
268- Update to 1.0.4, update gobject-introspection requirement
269
270* Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
271- Update to 1.0.2
272
273* Sat Aug  1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
274- Move ChangeLog to -devel to save some space
275
276* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
277- Drop the gir-repository-devel dep, which pulls a bunch of -devel
278  onto the live cd
279
280* Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
281- Update to 1.0.0
282
283* Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
284- fix bz #507389
285
286* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
287- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
288
289* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
290- Update to 0.9.8
291
292* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
293- Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
294  introspection support to clutter (#512260)
295
296* Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
297- Update to 0.9.6
298
299* Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
300- Update to 0.9.4
301
302* Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
303- Update to 0.9.2
304
305* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
306- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
307
308
309* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
310- Remove noarch from doc subpackage
311
312* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
313- Added gtk-doc for cogl
314- Created doc subpackage
315
316* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
317- Update to 0.8.6
318
319* Mon Oct  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
320- Update to 0.8.2
321- Removed clutter-0.8.0-clutter-fixed.patch
322
323* Sat Sep  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
324- Update to 0.8.0
325- Added clutter-0.8.0-clutter-fixed.patch
326
327* Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
328- Update to 0.6.4
329
330* Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
331- Update to 0.6.2
332
333* Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
334- Update to 0.6.0
335
336* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
337- Autorebuild for GCC 4.3
338
339* Wed Oct  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
340- Update to 0.4.2
341
342* Mon Sep  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
343- Update to 0.4.1
344
345* Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
346- Update to 0.3.1
347
348* Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
349- Update to 0.2.3
350
351* Wed Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
352- Changed buildrequires and requires
353
354* Tue Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
355- Fix .spec
356
357* Sat Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
358- Fix .spec
359
360* Fri Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
361- Initial RPM release
Note: See TracBrowser for help on using the repository browser.