source: projects/specs/trunk/c/clearsilver/clearsilver-vl.spec @ 7014

Revision 7014, 3.2 KB checked in by daisuke, 12 years ago (diff)

rebuild with ruby-1.9, add patch to build with ruby-1.9

Line 
1%define name clearsilver
2%define version 0.10.5
3%define release 7%{_dist_release}
4%define python_sitelib %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')
5
6Summary: A fast, powerful, and language-neutral HTML template system.
7Summary(ja): 高速、パワフルで言語中立なHTMLテンプレートシステム
8Name: %{name}
9Version: %{version}
10Release: %{release}
11Source0: http://clearsilver.net/downloads/%{name}-%{version}.tar.gz
12Patch0: clearsilver-0.10.5-conf.patch
13Patch1: clearsilver-0.10.5-regression.patch
14Patch2: clearsilver-0.10.5-CVE-2011-4357.patch
15Patch3: clearsilver-ruby-1.9.patch
16License: Neotonic ClearSilver Software License
17Group: Applications/Documentation
18URL: http://clearsilver.net/
19
20BuildRequires: perl
21BuildRequires: ruby, ruby-devel >= 1.9.3
22BuildRequires: python-devel, zlib-devel
23Provides: ruby(clearsilver)
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29%description
30ClearSilver is a fast, powerful, and language-neutral template system.
31It is designed to make it easy to create template driven static or
32dynamic websites.
33
34%description -l ja
35Clearsilver は高速、強力で言語中立なテンプレートシステムです。
36テンプレート駆動の静的あるいは動的な Web サイトの構築を
37容易にすることを目指して設計されています。
38
39%prep
40%setup -q
41%patch0 -p1 -b .conf
42%patch1 -p1
43%patch2 -p1
44%patch3 -p1
45
46perl -pi -e 's/python_versions="2\.5/python_versions="2.7 2.6 2.5/' configure
47
48%build
49%configure --disable-csharp
50
51%ifarch x86_64
52perl -pi -e 's/^(TARGETS =.+) test/$1/' cs/Makefile
53%endif
54
55%__make %{_smp_mflags}
56
57%install
58rm -rf $RPM_BUILD_ROOT
59cd ruby
60%ruby install.rb config --rb-dir=${RPM_BUILD_ROOT}%{ruby_vendorlibdir} --so-dir=${RPM_BUILD_ROOT}%{ruby_vendorarchdir}
61cd ..
62make DESTDIR=${RPM_BUILD_ROOT} install
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(-,root,root)
69%doc CS_LICENSE INSTALL LICENSE README README.python
70%{_bindir}/*
71%{_includedir}/ClearSilver/
72%{perl_sitearch}/*.pm
73%{perl_sitearch}/auto/ClearSilver/
74%{ruby_vendorarchdir}/*.so
75%{ruby_vendorlibdir}/*.rb
76%{python_sitelib}/*.so
77%{_libdir}/*.a
78%{_mandir}/man*/*.gz
79
80%changelog
81* Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.5-7
82- rebuild with ruby-1.9.3
83- add patch3 to build with ruby-1.9
84- add patch2 for CVE-2011-4357
85
86* Sat Feb 25 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-6
87- rebuilt with python-2.7.
88
89* Sun May 15 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-5
90- rebuilt with perl-5.12.3 and python-2.6.
91
92* Mon Jun 22 2009 Shu KONNO <owa@bg.wakwak.com> 0.10.5-4
93- applied new versioning policy, spec in utf-8
94
95* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.10.5-3
96- rebuilt with python-2.5.2
97- added clearsilver-0.10.5-conf.patch
98
99* Tue Apr 29 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.10.5-2
100- rebuilt with perl-5.10.0.
101
102* Mon Apr 28 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.10.5-1
103- x86_64: make to skip testing.
104
105* Fri Nov 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.5-0vl4
106- add --disable-csharp for configure script
107
108* Tue Aug 28 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.10.5-0vl2
109- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.