source: projects/specs/trunk/c/clearsilver/clearsilver-vl.spec @ 12120

Revision 12120, 4.6 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%bcond_with ruby
2
3%define name clearsilver
4%define version 0.10.5
5%define release 12%{_dist_release}
6
7Summary: A fast, powerful, and language-neutral HTML template system.
8Summary(ja): 高速、パワフルで言語中立なHTMLテンプレートシステム
9Name: %{name}
10Version: %{version}
11Release: %{release}
12
13License: Neotonic ClearSilver Software License
14Group: Applications/Text
15URL: http://clearsilver.net/
16
17Source0: http://clearsilver.net/downloads/%{name}-%{version}.tar.gz
18Patch0: clearsilver-0.10.5-conf.patch
19Patch1: clearsilver-0.10.5-regression.patch
20Patch2: clearsilver-0.10.5-CVE-2011-4357.patch
21Patch3: clearsilver-ruby-1.9.patch
22Patch4: clearsilver-ruby-2.2.patch
23# GCC 5 compatibility, bug #1190760
24Patch5: clearsilver-0.10.5-gcc5.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: perl
28BuildRequires: python-devel
29%if %{with ruby}
30BuildRequires: ruby
31BuildRequires: ruby-devel >= 1.9.3
32%endif
33BuildRequires: zlib-devel
34BuildRequires: libxcrypt-devel
35Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
36Provides: ruby(clearsilver)
37
38Vendor: Project Vine
39Distribution: Vine Linux
40
41%description
42ClearSilver is a fast, powerful, and language-neutral template system.
43It is designed to make it easy to create template driven static or
44dynamic websites.
45
46%description -l ja
47Clearsilver は高速、強力で言語中立なテンプレートシステムです。
48テンプレート駆動の静的あるいは動的な Web サイトの構築を
49容易にすることを目指して設計されています。
50
51%prep
52%setup -q
53%patch0 -p1 -b .conf
54%patch1 -p1
55%patch2 -p1
56%if %{with ruby}
57%patch3 -p1
58%patch4 -p1
59%endif
60%patch5 -p2
61
62touch configure
63perl -pi -e 's/python_versions="2\.5/python_versions="2.7 2.6 2.5/' configure
64sed -i 's|/neo/opt/bin/python|%{__python}|' python/examples/*/*.py
65sed -i 's|PYTHON_SITE = @PYTHON_SITE@|PYTHON_SITE = %{python_sitearch}|' rules.mk.in
66sed -i -r 's|(\$\(RUBY\) install.rb config) (--.*)|\1 --rb-dir="$(DESTDIR)%{ruby_vendorlibdir}" --so-dir="$(DESTDIR)%{ruby_vendorarchdir}" \2|' ruby/Makefile
67find python/examples -type f | xargs chmod -x
68
69%build
70%configure \
71%if ! %{with ruby}
72 --disable-ruby \
73%endif
74 --disable-csharp
75
76%ifarch x86_64
77perl -pi -e 's/^(TARGETS =.+) test/$1/' cs/Makefile
78%endif
79
80%__make %{_smp_mflags}
81
82%install
83rm -rf $RPM_BUILD_ROOT
84make DESTDIR=${RPM_BUILD_ROOT} install
85
86find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
87find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
88find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
89find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
90chmod -R u+w $RPM_BUILD_ROOT/*
91
92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%files
97%defattr(-,root,root)
98%doc CS_LICENSE INSTALL LICENSE README README.python
99%{_bindir}/*
100%{_includedir}/ClearSilver/
101%{perl_sitearch}/*.pm
102%{perl_sitearch}/auto/ClearSilver/
103%{python_sitearch}/*.so
104%if %{with ruby}
105%{ruby_vendorarchdir}/*.so
106%{ruby_vendorlibdir}/*.rb
107%endif
108%{_libdir}/*.a
109%{_mandir}/man*/*.gz
110
111%changelog
112* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-12
113- rebuilt with perl-5.26.
114- added BR:libxcrypt-devel.
115
116* Tue Dec 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-11
117- added Patch5 for gcc5.
118- disabled ruby stuff.
119
120* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.5-10
121- rebuild with ruby-2.2.3
122- add Patch4 (clearsilver-ruby-2.2.patch) from fedora
123
124* Wed Dec 17 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.10.5-9
125- rebuilt with perl 5.16.3 and ruby 2.1.5
126
127* Sun Dec 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-8
128- rebuilt with ruby-2.0.0.353.
129
130* Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.5-7
131- rebuild with ruby-1.9.3
132- add patch3 to build with ruby-1.9
133- add patch2 for CVE-2011-4357
134
135* Sat Feb 25 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-6
136- rebuilt with python-2.7.
137
138* Sun May 15 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-5
139- rebuilt with perl-5.12.3 and python-2.6.
140
141* Mon Jun 22 2009 Shu KONNO <owa@bg.wakwak.com> 0.10.5-4
142- applied new versioning policy, spec in utf-8
143
144* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.10.5-3
145- rebuilt with python-2.5.2
146- added clearsilver-0.10.5-conf.patch
147
148* Tue Apr 29 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.10.5-2
149- rebuilt with perl-5.10.0.
150
151* Mon Apr 28 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.10.5-1
152- x86_64: make to skip testing.
153
154* Fri Nov 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.5-0vl4
155- add --disable-csharp for configure script
156
157* Tue Aug 28 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.10.5-0vl2
158- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.